totem-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555
  1. # build browser plugins
  2. %define build_plugin %{!?_without_mozilla:1}%{?_without_mozilla:0}
  3. # define versions
  4. %define _glib_ver 2.32.0
  5. %define _gtk_ver 3.4.0
  6. %define _gnomeicon_ver 3.4.0
  7. %define _gnome_doc_utils_ver 0.20.0
  8. %define _dbus_ver 1.4.0
  9. %define _gst_ver 0.10.30
  10. %define _gstpb_ver 0.10.30
  11. %define _gstpg_ver 0.10.24
  12. %define _xulrunner_ver 1.9
  13. %define _nautilus_ver 3.4.0
  14. %define _shared_mime_info_ver 0.17
  15. %define _unique_ver 1.0
  16. %define _vala_ver 0.11.1
  17. %define _totem_pl_parser_ver 2.32.0
  18. %define nautilus_extdir %{_libdir}/nautilus/extensions-3.0
  19. %define mozplug_dir %{_libdir}/mozilla/plugins
  20. Summary: Movie player for GNOME 3
  21. Summary(ja): GNOME3 用動画プレイヤー
  22. Name: totem
  23. Version: 3.4.2
  24. Release: 1%{?_dist_release}
  25. License: GPL
  26. Group: Applications/Multimedia
  27. URL: http://www.gnome.org/projects/totem/
  28. Source0: http://ftp.gnome.org/pub/GNOME/sources/totem/3.4/totem-%{version}.tar.xz
  29. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  30. Vendor: Project Vine
  31. Distribution: Vine Linux
  32. BuildRequires: gtk3-devel >= %{_gtk_ver}, glib2-devel >= %{_glib_ver}
  33. BuildRequires: gnome-icon-theme >= %{_gnomeicon_ver}
  34. BuildRequires: gnome-doc-utils >= %{_gnome_doc_utils_ver}
  35. BuildRequires: dbus-devel >= %{_dbus_ver}
  36. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  37. BuildRequires: gettext, scrollkeeper
  38. BuildRequires: perl-XML-Parser
  39. BuildRequires: iso-codes
  40. BuildRequires: totem-pl-parser-devel >= %{_totem_pl_parser_ver}
  41. BuildRequires: bluez-libs-devel >= 4.15
  42. BuildRequires: lirc
  43. BuildRequires: unique-devel >= %{_unique_ver}
  44. BuildRequires: vala-devel >= %{_vala_ver}
  45. BuildRequires: python-devel
  46. BuildRequires: pylint
  47. BuildRequires: pygobject3-devel
  48. BuildRequires: libpeas-devel
  49. BuildRequires: libXtst-devel
  50. BuildRequires: gstreamer-devel >= %{_gst_ver}
  51. BuildRequires: gstreamer-plugins-base-devel >= %{_gstpb_ver}
  52. BuildRequires: gstreamer-plugins-good >= %{_gstpg_ver}
  53. BuildRequires: clutter-gtk-devel
  54. BuildRequires: clutter-gst-devel
  55. BuildRequires: libmx-devel
  56. %if %{build_plugin}
  57. BuildRequires: xulrunner-devel >= %{_xulrunner_ver}
  58. BuildRequires: nautilus-devel >= %{_nautilus_ver}
  59. BuildRequires: shared-mime-info >= %{_shared_mime_info_ver}
  60. %endif
  61. Requires: gstreamer >= %{_gst_ver}
  62. Requires: gstreamer-plugins-base >= %{_gstpb_ver}
  63. Requires: gstreamer-plugins-good >= %{_gstpg_ver}
  64. Requires: iso-codes
  65. # for opensubtitles plugin
  66. Requires: pyxdg
  67. # for python plugins
  68. Requires: pygtk2
  69. # for coherence plugins
  70. # Requires: python-Coherence >= 0.6.6.2
  71. Obsoletes: nautilus-media
  72. Obsoletes: %{name}-gstreamer < 2.30.1-2
  73. Obsoletes: %{name}-xine < 2.30.1-2
  74. Obsoletes: %{name}-common < 2.30.1-3
  75. Provides: nautilus-media
  76. Provides: %{name}-common = %{version}-%{release}
  77. Requires(post): ldconfig, scrollkeeper, desktop-file-utils, GConf2
  78. Requires(postun): ldconfig, scrollkeeper, desktop-file-utils
  79. Requires(preun): GConf2
  80. %description
  81. Totem is simple movie player for the Gnome desktop. It features a
  82. simple playlist, a full-screen mode, seek and volume controls, as well as
  83. a pretty complete keyboard navigation.
  84. %if %{build_plugin}
  85. %package mozilla
  86. Summary: Totem movie plugin for Mozilla
  87. Summary(ja): Mozilla 用 Totem 動画プラグイン
  88. Group: Applications/Internet
  89. Requires: %{name} = %{version}-%{release}
  90. Obsoletes: %{name}-mozilla-common
  91. Obsoletes: %{name}-mozilla-gstreamer
  92. Obsoletes: %{name}-mozilla-xine
  93. %description mozilla
  94. Totem is simple movie player for the Gnome desktop. It features a
  95. simple playlist, a full-screen mode, seek and volume controls, as well as
  96. a pretty complete keyboard navigation.
  97. This package contains a Totem video plugin for Mozilla. It allows Totem
  98. movie player to be embedded into a web browser.
  99. %endif
  100. %package devel
  101. Summary: Plugin writer's documentation for totem
  102. Group: Development/Libraries
  103. Requires: %{name} = %{version}-%{release}
  104. %description devel
  105. The %{name}-devel package contains API documentation for
  106. developing developing plugins for %{name}.
  107. %prep
  108. %setup -q
  109. %build
  110. DBUS_FATAL_WARNINGS=0 /usr/bin/gst-inspect-0.10 --print-all > /dev/null
  111. export MOZILLA_PLUGINDIR=%{mozplug_dir}
  112. %configure \
  113. --disable-scrollkeeper \
  114. --enable-python \
  115. --disable-vala \
  116. --enable-nautilus \
  117. --enable-gmp-plugin \
  118. --enable-narrowspace-plugin \
  119. --enable-mully-plugin \
  120. %if %{build_plugin}
  121. --enable-browser-plugins
  122. %else
  123. --disable-browser-plugins
  124. %endif
  125. make %{?_smp_mflags}
  126. %install
  127. rm -rf $RPM_BUILD_ROOT
  128. export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
  129. make install DESTDIR=$RPM_BUILD_ROOT
  130. # remove unneeded files
  131. %__rm -f %{buildroot}%{_libdir}/totem/plugins/*/*.{a,la}
  132. %__rm -f %{buildroot}%{_libdir}/*.{a,la}
  133. %__rm -f %{buildroot}%{_datadir}/pixmaps/vanity.png
  134. %__rm -f %{buildroot}%{nautilus_extdir}/*.{a,la}
  135. %__rm -f %{buildroot}%{mozplug_dir}/*.{a,la}
  136. %__rm -f %{buildroot}%{_datadir}/icons/hicolor/icon-theme.cache
  137. %__rm -rf %{buildroot}%{_libdir}/totem/plugins/bemused/
  138. # remove unused file
  139. %__rm -f %{buildroot}%{_datadir}/GConf/gsettings/pythonconsole.convert
  140. %find_lang %{name} --with-gnome
  141. # save space by linking identical images in translated docs
  142. helpdir=$RPM_BUILD_ROOT%{_datadir}/gnome/help/%{name}
  143. for f in $helpdir/C/figures/*.png; do
  144. b="$(basename $f)"
  145. for d in $helpdir/*; do
  146. if [ -d "$d" -a "$d" != "$helpdir/C" ]; then
  147. g="$d/figures/$b"
  148. if [ -f "$g" ]; then
  149. if cmp -s $f $g; then
  150. rm "$g"; ln -s "../../C/figures/$b" "$g"
  151. fi
  152. fi
  153. fi
  154. done
  155. done
  156. %clean
  157. %__rm -rf %{buildroot}
  158. %post
  159. %{_bindir}/scrollkeeper-update -q
  160. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  161. touch %{_datadir}/icons/hicolor
  162. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  163. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  164. fi
  165. %postun
  166. %{_bindir}/scrollkeeper-update -q
  167. %{_bindir}/update-desktop-database %{_datadir}/applications >& /dev/null ||:
  168. touch %{_datadir}/icons/hicolor
  169. if [ -x /usr/bin/gtk-update-icon-cache ]; then
  170. /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor
  171. fi
  172. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  173. %posttrans
  174. glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
  175. %files -f %{name}.lang
  176. %defattr(-,root,root,-)
  177. %doc AUTHORS COPYING ChangeLog NEWS README TODO
  178. %{_bindir}/totem
  179. %{_bindir}/totem-audio-preview
  180. %{_bindir}/totem-video-thumbnailer
  181. %{_datadir}/GConf/gsettings/opensubtitles.convert
  182. #%{_datadir}/GConf/gsettings/pythonconsole.convert
  183. %{_datadir}/GConf/gsettings/totem.convert
  184. %{_datadir}/applications/%{name}.desktop
  185. %{_datadir}/glib-2.0/schemas/*.xml
  186. %{_datadir}/icons/*/*/*/*
  187. %{_datadir}/thumbnailers/totem.thumbnailer
  188. %{_datadir}/%{name}
  189. %{_datadir}/gtk-doc/html/totem
  190. %{_libdir}/libtotem.so.*
  191. %{_libdir}/girepository-1.0/*.typelib
  192. %dir %{_libdir}/totem
  193. %dir %{_libdir}/totem/plugins
  194. %{_libdir}/totem/plugins/brasero-disc-recorder
  195. %{_libdir}/totem/plugins/chapters
  196. %{_libdir}/totem/plugins/dbus
  197. %{_libdir}/totem/plugins/gromit
  198. %{_libdir}/totem/plugins/iplayer
  199. %{_libdir}/totem/plugins/lirc
  200. %{_libdir}/totem/plugins/media-player-keys
  201. %{_libdir}/totem/plugins/ontop
  202. %{_libdir}/totem/plugins/opensubtitles
  203. %{_libdir}/totem/plugins/properties
  204. %{_libdir}/totem/plugins/pythonconsole
  205. %{_libdir}/totem/plugins/screensaver
  206. %{_libdir}/totem/plugins/screenshot
  207. %{_libdir}/totem/plugins/skipto
  208. %{_libdir}/totem/plugins/im-status/libtotem-im-status.so
  209. %{_libdir}/totem/plugins/im-status/totem-im-status.plugin
  210. %{_libdir}/totem/plugins/save-file/libsave-file.so
  211. %{_libdir}/totem/plugins/save-file/save-file.plugin
  212. %if %{build_plugin}
  213. %{_libdir}/nautilus/extensions-3.0/*.so*
  214. %endif
  215. %{_libexecdir}/%{name}/totem-bugreport.py
  216. %{_mandir}/man1/*
  217. %if %{build_plugin}
  218. %files mozilla
  219. %defattr(-,root,root,-)
  220. %{mozplug_dir}/*
  221. %{_libexecdir}/totem-plugin-viewer
  222. %endif
  223. %files devel
  224. %defattr(-, root, root,-)
  225. %{_includedir}/totem
  226. %{_libdir}/libtotem.so
  227. %{_libdir}/pkgconfig/totem.pc
  228. %{_datadir}/gir-1.0/Totem-1.0.gir
  229. %{_datadir}/gtk-doc/html/totem
  230. %changelog
  231. * Sun May 20 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.2-1
  232. - new upstream release
  233. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.4.1-1
  234. - new upstream release
  235. - add BuildRequires: pylint
  236. - remove BuildRequires: libgdata-devel
  237. * Sat Oct 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.1-1
  238. - new upstream release
  239. * Fri Sep 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.0-1
  240. - new upstream release
  241. * Fri Sep 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.92-1
  242. - new upstream release
  243. - change BuildRequires: pygobject3-devel instead of pygobject-devel
  244. * Wed Aug 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.4-1
  245. - new upstream release
  246. - change BuildRequires: gtk3-devel instead of gtk2-devel
  247. - add BuildRequires: libpeas-devel, libXtst-devel, pygobject-devel, clutter-gtk-devel,
  248. clutter-gst-devel, libmx-devel
  249. - change configure option (--disable-vala)
  250. * Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.0-1
  251. - new upstream release
  252. - fix %files
  253. * Tue Jun 29 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  254. - new upstream release
  255. * Mon May 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.1-3
  256. - clean up spec file
  257. - remove totem-common and merged to totem main package.
  258. - add Obsoletes: totem-common
  259. - remove unneeded BR: and R:
  260. - gnome-vfs2, libgnomeui, libgnome, gnome-desktop-libs
  261. - libmusicbrainz, alternatives
  262. - remove explicit dependency
  263. - gtk2, glib2, dbus
  264. - add R: pygtk2, pyxdg, python-Coherence for python plugins
  265. - add R: gstreamer-plugins-good
  266. * Sun May 09 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-2
  267. - rebuild with libgdata (add youtube plugin)
  268. - add BuildRequires: libgdata-devel, python-devel, pygtk2-devel
  269. - add Obsolete: totem-gstreamer, totem-xine)
  270. * Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  271. - new upstream release
  272. - chagnge _gst_ver from 0.10.19 to 0.10.29
  273. * Wed Apr 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  274. - new upstream release
  275. - drop totem-tracker package
  276. - add BuildRequires: unique-devel
  277. - remove BuildRequires: hal-devel
  278. - remove unrecognized options (--disable-lirc, --disable-vanity, --disable-nvtv, --enable-xine, --disable-xine, --enable-gstreamer, --disable-gstreamer, --enable-mozilla, --with-mozilla, --disable-mozilla, --enable-basic-plugin, --enable-complex-plugin)
  279. * Mon Jul 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-2
  280. - remove unneeded autoreconf
  281. - add BR: lirc
  282. * Thu Jul 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.3-1
  283. - new upstream release
  284. * Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-2
  285. - remove bemused plugin
  286. * Thu May 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.2-1
  287. - new upstream release
  288. * Thu Apr 30 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.26.1-2
  289. - added tracker video search sub-package
  290. * Sat Apr 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.1-1
  291. - new upstream release
  292. * Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
  293. - new upstream release
  294. * Fri Mar 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.3-2
  295. - remove libxine dependency from totem-common
  296. - build xine backend with minimum dependency
  297. * Thu Oct 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-3
  298. - add BR: bluez-libs-devel >= 4.15
  299. - fix typo in %%postun xine
  300. * Thu Oct 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.24.2-2
  301. - rebuild with bluez-libs-devel-4.15
  302. * Sat Oct 11 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.2-1
  303. - new upstream release
  304. * Wed Sep 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
  305. - new upstream release
  306. * Mon Jul 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.2-1
  307. - new upstream release
  308. - add patch1 to build with xulrunner-1.9
  309. * Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
  310. - new upstream release
  311. * Mon Apr 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
  312. - new upstream release
  313. - disabled devel package (replaced by totem-pl-parser-devel)
  314. * Sat Aug 11 2007 KAZUKI SHIMURA <ksh753@y5.dion.ne.jp> 2.18.2-0vl1
  315. - new upstream release
  316. - update version macros
  317. - enable browser plugins on x86_64
  318. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
  319. - new upstream release
  320. * Sun Mar 25 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.6-0vl1
  321. - upstream release
  322. - drop obsolete ja.po.patch (patch0)
  323. - revert change of 1.4.4-0vl2
  324. * Wed Jan 31 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.5-0vl1
  325. - upstream release
  326. - enable browser plugins (exclude x86_64 arch)
  327. * Fri Dec 01 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.4-0vl1
  328. - upstream release
  329. * Mon Nov 27 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl3
  330. - update configure options
  331. - add -mozilla-{gstreamer,xine,common} sub-packages (disabled by default)
  332. * Sat Nov 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl2
  333. - fix mistranslation (patch0)
  334. - add icon symlink
  335. - add BuildRequires: gstreamer-plugins-good
  336. * Fri Nov 24 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 2.16.3-0vl1
  337. - upstream release
  338. - update %%_glib_ver, %%_xine_ver
  339. - add BuildRequires: hal
  340. - update %%configure options
  341. - update %%files
  342. * Wed Sep 13 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.5-0vl1
  343. - upstream release
  344. * Fri Sep 08 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl2
  345. - fix macro name (%%gnome_desktop_ver -> %%gnomedesktop_ver)
  346. * Mon Aug 07 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.4-0vl1
  347. - upstream release
  348. - drop obsolete patch0
  349. * Sun Jul 16 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.3-0vl1
  350. - upstream release
  351. - add patch0 to build with intltool-0.35
  352. * Sun Jun 25 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.2-0vl1
  353. - upstream release
  354. * Thu May 18 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.1-0vl1
  355. - upstream release
  356. - update alternatives entry
  357. * Tue Mar 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.0-0vl1
  358. - upstream release
  359. - drop fix-sort-function.patch (was merged to upstream, #331426)
  360. * Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.3.91-0vl2
  361. - rebuild with gnome-2.14rc
  362. * Tue Feb 14 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.91-0vl1
  363. - upstream release
  364. - add macros
  365. - _gtk_ver, _glib_ver
  366. - _gnomevfs_ver, _gnomeui_ver, _gnomeicon_ver, _gnome_desktop_ver
  367. - _dbus_ver
  368. - _gst_ver, gstpb_ver, _xine_ver
  369. - add fix-sort-function.patch to build with glib < 2.9.1
  370. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.3.1-0vl1
  371. - upstream release
  372. - add BuildRequires:
  373. - gtk2-devel >= 2.5.6, glib2-devel >= 2.6.3
  374. - gnome-vfs2-devel >= 2.9.92
  375. - dbus-devel >= 0.35
  376. - use gstreamer-0.10 as backend for totem-gstreamer
  377. * Sat Jan 21 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl2
  378. - use gstreamer08 instead of gstreamer
  379. * Sat Dec 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.1-0vl1
  380. - upstream release
  381. * Sun Oct 09 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl2
  382. - fix missing links
  383. - update file list
  384. - update update-alternatives scripts
  385. - fix totem-gstreamer's %%postun script
  386. * Wed Sep 21 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.2.0-0vl1
  387. - upstream release
  388. - add BuildRequires: iso-codes, libmusicbrainz-devel
  389. - add Requires: iso-codes, libmusicbrains to -common package
  390. - remove BuildRequires: nautilus-cd-burner
  391. - remove Requires: nautilus-cd-burner from -common package
  392. * Wed Aug 03 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl2
  393. - totem-gstreamer obsoletes nautilus-media
  394. * Thu Jun 23 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.4-0vl1
  395. - upstream release
  396. - add Requires(post,postun): alternatives for gstreamer,xine
  397. - add Requires(postun,triggers): alternatives for common
  398. * Mon May 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.3-0vl1
  399. - upstream release
  400. * Sun May 08 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl2
  401. - build xine backend
  402. - move common files to common package
  403. - move GStreamer related files to gstreamer package
  404. - install xine related files to xine package
  405. - fix scripts
  406. * Sun May 01 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.2-0vl1
  407. - upstream release
  408. - update URL
  409. - move *.{a,la} to devel package
  410. * Mon Apr 04 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.0.1-1vl1
  411. - fix %%{post,preun} script (video-thumbnail.schemas)
  412. - sync with Fedora Core's 1.0.1-1
  413. * Tue Feb 29 2005 John (J5) Palmieri <johnp@redhat.com> - 1.0.1-1
  414. - Update to upstream version 1.0.1
  415. - Break out devel package
  416. * Thu Mar 31 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl2
  417. - add %%{post,pre}un script
  418. * Wed Mar 30 2005 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.101-4uvl1
  419. - initial build for Vine Linux
  420. * Mon Feb 21 2005 Bill Nottingham <notting@redhat.com> - 0.101-4
  421. - fix %%post
  422. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-3
  423. - Obsolete nautilus-media
  424. - Install property page and thumbnailer
  425. * Wed Feb 2 2005 Matthias Clasen <mclasen@redhat.com> - 0.101-2
  426. - Update to 0.101
  427. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-2
  428. - Grab patch totem-0.100-desktopfile.patch from CVS to fix
  429. missing menu entry (144088)
  430. - Remove workaround for desktop file being misinstalled, fixed
  431. by above patch
  432. * Mon Jan 03 2005 Colin Walters <walters@redhat.com> - 0.100-1
  433. - New upstream version 0.100
  434. * Sun Dec 5 2004 Bill Nottingham <notting@redhat.com> - 0.99.22-1
  435. - update to 0.99.22
  436. * Thu Oct 28 2004 Colin Walters <walters@redhat.com> - 0.99.19-2
  437. - Add patch to remove removed items from package from help
  438. * Thu Oct 14 2004 Colin Walters <walters@redhat.com> - 0.99.19-1
  439. - New upstream 0.99.19
  440. - Fixes crasher with CD playback (see NEWS)
  441. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-2
  442. - Call update-desktop-database in post
  443. * Tue Oct 12 2004 Alexander Larsson <alexl@redhat.com> - 0.99.18-1
  444. - update to 0.99.18
  445. * Wed Oct 6 2004 Alexander Larsson <alexl@redhat.com> -
  446. - Initial version, based on specfile by Matthias Saou <http://freshrpms.net/>