lftp-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356
  1. %define name lftp
  2. %define version 4.4.14
  3. %define release 1%{?_dist_release}
  4. Summary: The lftp command line ftp/http client
  5. Summary(ja): lftp - コマンドライン ftp/http クライアント
  6. Name: %{name}
  7. Version: %{version}
  8. Release: %{release}
  9. License: GPL3
  10. Group: Applications/Internet
  11. # Source: http://ftp.yars.free.net/pub/source/lftp/lftp-%{version}.tar.bz2
  12. Source: http://ftp.yars.free.net/pub/source/lftp/lftp-%{version}.tar.xz
  13. # Source10: lftp-3.0.9-0vl1-ja.po
  14. # Source10: lftp-3.7.4-ja.po
  15. URL: http://lftp.yar.ru/
  16. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  17. BuildRequires: ncurses-devel, openssl-devel, pkgconfig, readline-devel
  18. BuildRequires: expat-devel
  19. BuildRequires: zlib-devel
  20. Packager: iwamoto
  21. Vendor: Project Vine
  22. Distribution: Vine Linux
  23. %description
  24. LFTP is a shell-like command line ftp client. It is
  25. reliable: can retry operations and does reget automatically.
  26. It can do several transfers simultaneously in background.
  27. You can start a transfer in background and continue browsing
  28. the ftp site or another one. This all is done in one process.
  29. Background jobs will be completed in nohup mode if you exit
  30. or close modem connection. Lftp has reput, mirror, reverse
  31. mirror among its features. Since version 2.0 it also supports
  32. http protocol.
  33. %description -l ja
  34. LFTP は、shell ライクなコマンドライン ftp クライアントです。
  35. リトライ機能の実装や自動的な再取得を行うため信頼性が高いです。
  36. バックグラウンドで複数の転送を同時に行うことができます。
  37. バックグラウンドでの転送を開始し、その ftp サイトや別の ftp
  38. サイトを閲覧し続けることができます。これらは全て 1 つのプロセス
  39. で実行されます。
  40. もし、モデムの接続が exit や close された場合、バックグラウンド
  41. ジョブは、nohup モードで終了します。lftp の特徴は、reput やミラー、
  42. 逆ミラーなどです。バージョン 2.0 以降では、HTTP もサポートしています。
  43. %package scripts
  44. Summary: Scripts for lftp
  45. Summary(ja): lftp のユーティリティスクリプト
  46. Group: Applications/Internet
  47. Requires: lftp = %{version}-%{release}
  48. Requires: perl(DBD::SQLite)
  49. BuildArch: noarch
  50. %description scripts
  51. Utility scripts for use with lftp.
  52. %description scripts -l ja
  53. lftp のユーティリティスクリプトです。
  54. %prep
  55. %setup -q
  56. # cp po/ja.po po/ja.po.orig
  57. # msgmerge -v %{SOURCE10} po/ja.po.orig -o po/ja.po
  58. %build
  59. if pkg-config openssl ; then
  60. CPPFLAGS=`pkg-config --cflags openssl`; export CPPFLAGS
  61. LDFLAGS=`pkg-config --libs-only-L openssl`; export LDFLAGS
  62. fi
  63. LDFLAGS="-L`pwd`/src/.libs $LDFLAGS"; export LDFLAGS
  64. %configure --with-modules --disable-static --with-openssl
  65. export tagname=CC
  66. make %{?_smp_mflags}
  67. %install
  68. rm -rf $RPM_BUILD_ROOT
  69. %makeinstall sysconfdir=$RPM_BUILD_ROOT%{_sysconfdir}
  70. rm -f $RPM_BUILD_ROOT%{_libdir}/lftp/%{version}/*.la
  71. chmod 0755 $RPM_BUILD_ROOT%{_libdir}/lftp/*
  72. chmod 0755 $RPM_BUILD_ROOT%{_libdir}/lftp/%{version}/*.so
  73. # Remove files from $RPM_BUILD_ROOT that we aren't shipping.
  74. rm -f $RPM_BUILD_ROOT%{_libdir}/lftp/%{version}/*.a
  75. rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
  76. %find_lang %{name}
  77. %clean
  78. rm -rf $RPM_BUILD_ROOT
  79. %files -f %{name}.lang
  80. %defattr(-,root,root)
  81. %doc README README.modules FAQ THANKS COPYING
  82. %doc TODO lftp.lsm NEWS INSTALL FEATURES
  83. %config(noreplace) %{_sysconfdir}/lftp.conf
  84. %{_bindir}/*
  85. %{_mandir}/*/*
  86. # %{_datadir}/lftp
  87. %{_libdir}/*.so*
  88. %dir %{_libdir}/lftp
  89. %dir %{_libdir}/lftp/%{version}
  90. %{_libdir}/lftp/%{version}/cmd-*.so
  91. %{_libdir}/lftp/%{version}/liblftp-network.so
  92. # %{_libdir}/lftp/%{version}/liblftp-getdate.so
  93. %{_libdir}/lftp/%{version}/liblftp-pty.so
  94. %{_libdir}/lftp/%{version}/proto-*.so
  95. %files scripts
  96. %defattr(-,root,root,-)
  97. %{_datadir}/lftp
  98. %changelog
  99. * Thu Jan 9 2014 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.4.14-1
  100. - new upstream release
  101. - add BR: zlib-devel
  102. - fix changelog date
  103. * Sun Sep 30 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.4.0-1
  104. - new upstream release
  105. - use upstream ja.po instead of old local ja.po (source10)
  106. * Sat Jun 2 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.3.7-1
  107. - new upstream release
  108. - built with openssl 1.0.1
  109. * Mon May 2 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.2.3-1
  110. - new upstream release
  111. * Sun Jan 9 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.1.2-3
  112. - rebuilt with openssl 1.0.0c
  113. * Wed Jan 5 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.1.2-2
  114. - separated scripts to script package
  115. * Mon Jan 3 2011 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.1.2-1
  116. - new upstream release
  117. - change source tarball format (bz2 -> xz)
  118. * Sat Aug 7 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.9-1
  119. - new upstream release with security fix (CVE-2010-2251)
  120. * Thu Jan 21 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 4.0.5-1
  121. - new upstream release
  122. - update ja.po file (Thanks to Tadashi Jokagi <elf@elf.no-ip.org>)
  123. - update %files section to fit new release
  124. * Tue Jul 28 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.15-1
  125. - new upstream release
  126. * Tue May 19 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.14-1
  127. - new upstream release
  128. * Wed May 06 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.13-1
  129. - new upstream release
  130. * Wed Mar 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.11-1
  131. - new upstream release
  132. * Wed Mar 04 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.9-1vl5
  133. - new upstream release
  134. * Sun Feb 01 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.8-1vl5
  135. - new upstream release
  136. - fix License tag
  137. * Mon Jan 12 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.7-1vl5
  138. - new upstream release
  139. * Mon Dec 01 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.6-1vl5
  140. - new upstream release
  141. * Mon Oct 20 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.4-1vl5
  142. - new upstream release
  143. - del liblftp-getdate.so from files list (upstream change)
  144. * Sat Jul 12 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.3-1vl5
  145. - new upstream release
  146. - spec in UTF8
  147. * Sat May 03 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.1-2vl5
  148. - add BuildPrereq expat-devel
  149. * Sat May 03 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.1-1vl5
  150. - new upstream release
  151. - new versioning policy
  152. * Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.7.0-0vl1
  153. - new upstream release
  154. * Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 3.6.1-0vl2
  155. - rebuild with expat-2.0.1
  156. * Mon Jan 07 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.6.1-0vl1
  157. - new upstream release
  158. * Sat Oct 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 3.5.15-0vl1
  159. - new upstream release
  160. * Tue Aug 28 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.5.13-0vl1
  161. - new upstream release
  162. * Mon Jul 30 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.5.12-0vl1
  163. - new upstream release
  164. * Sat May 19 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.5.10-0vl1
  165. - new upstream release
  166. - rebuilt with new toolchain and openssl-0.9.8
  167. * Fri Jan 12 2007 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.5.9-0vl1
  168. - new upstream release
  169. * Sat Nov 11 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.5.6-0vl3
  170. - fix configure option to use openssl
  171. * Sun Oct 29 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 3.5.6-0vl2
  172. - rebuild with gnutls-1.4.1
  173. * Fri Oct 27 2006 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 3.5.6-0vl1
  174. - new upstream release
  175. * Mon Aug 21 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.5.4-0vl1
  176. - new upstream release
  177. * Fri Jul 07 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.4.7-0vl2
  178. - changed Group to Applications/Internet
  179. * Fri Jun 09 2006 KOBAYASHI Taizo <tkoba@vinelinux.org> 3.4.7-0vl1
  180. - new upstream release
  181. * Sun Mar 19 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.4.2-0vl2
  182. - rebuild with readline-5.1
  183. * Wed Feb 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 3.4.2-0vl1
  184. - new upstream release
  185. * Fri Oct 22 2004 IWAI, Masaharu <iwai@alib.jp> 3.0.9-0vl1
  186. - new upstream release
  187. - update ja.po ( Source10 )
  188. - add Japanese description
  189. - lftp.conf: noreplace
  190. * Sun Jun 13 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.6-0vl1
  191. - new upstream release
  192. * Thu Jun 3 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.5-0vl1
  193. - new upstream release
  194. * Fri Apr 30 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.3-0vl1
  195. - new upstream release
  196. * Sun Apr 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.2-0vl2
  197. - update ja.po (more work needed...)
  198. * Sun Apr 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.2-0vl1
  199. - new upstream release
  200. * Sun Apr 4 2004 HAYASHI Kentarou <linjian@gigo-ice.org> 3.0.0-0vl1
  201. - new upstream release
  202. * Mon Mar 1 2004 HAYASHI Kentarou <linjian@gigo-ice.org> 2.6.12-0vl1
  203. - new upstream release
  204. * Mon Dec 29 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.11-0vl1
  205. - new upstream release
  206. * Thu Dec 18 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.10-0vl1
  207. - new upstream release
  208. * Sat Aug 30 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.7-0vl1
  209. - new upstream release
  210. * Tue Jun 10 2003 Jun NISHII <jun@vinelinux.org> 2.6.5-2vl1
  211. - synced with RawHide 2.6.5-2
  212. * Thu Mar 27 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 2.6.3-4vl1
  213. - synced with RawHide 2.6.3-4
  214. * Wed Jan 23 2002 Jun Nishii <jun@vinelinux.org> 2.4.8-0vl1
  215. - ver.up
  216. - fix COPYRIGHT(GPL->GPL2)
  217. * Tue Sep 25 2001 Kazuhisa TAKEI <takei@vinelinux.org>
  218. - 2.4.4
  219. - major version update
  220. * Mon Jul 16 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
  221. - 2.3.10-0vl5
  222. - rebuilt with openssl-0.9.6b
  223. * Thu May 24 2001 <sagami@vinelinux.org>
  224. - 2.3.10-0vl4: fix so as not to own %%{_bindir} itself
  225. * Thu May 24 2001 Kazuhisa TAKEI<takei@vinelinux.org> 2.3.10-0vl3
  226. - remove configurei's --with-modules option.
  227. * Sat May 19 2001 <takei@vinelinux.org> 2.3.10-0vl2
  228. - fixed spec bug( sevaral lftp modules lack)
  229. * Fri May 11 2001 <sagami@vinelinux.org>
  230. - 2.3.10-0vl1: use more macros
  231. * Tue Jan 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 2.3.7-0vl2
  232. - enable ssl
  233. * Tue Jan 23 2001 Kazuhisa TAKEI <takei@vinelinux.org> 2.3.7-0vl1
  234. - 2.3.7-0vl1
  235. * Wed Dec 13 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  236. - 2.3.3-0vl4
  237. - rebuilt with readline-4
  238. * Thu Oct 12 2000 Kazuhisa TAKEI<takei@vinelinux.org> 2.3.3-0vl3
  239. - add lftpget
  240. * Mon Oct 9 2000 Kazuhisa TAKEI<takei@vinelinux.org> 2.3.3-0vl1
  241. - upstream merge ja.po
  242. - %doc /usr/man -> %{_mandir}
  243. - several .spec file's bug fixed.
  244. * Sun Oct 1 2000 Kazuhisa TAKEI<takei@vinelinux.org> 2.3.0-0vl5
  245. - fixed ja.po
  246. * Mon Sep 11 2000 Kazuhisa TAKEI<takei@vinelinux.org>
  247. - 2.2.6-1vl0
  248. - remove noroot.patch
  249. * Mon Sep 11 2000 Kazuhisa TAKEI<takei@vinelinux.org>
  250. - 2.2.2-1vl3
  251. - added Japanese message catalog file
  252. * Thu Jul 27 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  253. - 2.2.2-1vl2
  254. - cleaned up noroot.patch
  255. - added %build tag (why forgotten?)
  256. - added Japanese Summary
  257. - modified %files section to handle compressed man pages
  258. * Thu May 4 2000 Kazuhisa TAKEI <takei@vinelinux.org>
  259. - change spec file for Vine Linux
  260. * Sat Oct 02 1999 Alexander Lukyanov <lav@yars.free.net>
  261. - 2.1.1 release
  262. - removed ChangeLog from doc.
  263. * Mon Sep 27 1999 Alexander Lukyanov <lav@yars.free.net>
  264. - 2.1.0 release
  265. * Tue Sep 14 1999 Alexander Lukyanov <lav@yars.free.net>
  266. - add lftpget
  267. * Tue Jul 27 1999 Adrian Likins <alikins@redhat.com>
  268. -initial release