libcdio-vl.spec 5.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219
  1. Summary: CD-ROM input and control library
  2. Summary(ja): CD-ROM 入力・制御ライブラリ
  3. Name: libcdio
  4. Version: 0.82
  5. Release: 1%{?_dist_release}
  6. Group: System Environment/Libraries
  7. License: GPLv2+
  8. URL: http://www.gnu.org/software/libcdio/
  9. Source0: http://ftp.gnu.org/gnu/libcdio/libcdio-%{version}.tar.bz2
  10. Source1: http://ftp.gnu.org/gnu/libcdio/libcdio-%{version}.tar.bz2.sig
  11. Source2: libcdio-no_date_footer.hml
  12. Patch1: libcdio-0.80-paranoia-fix.patch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  14. BuildRequires: pkgconfig doxygen
  15. BuildRequires: ncurses-devel
  16. BuildRequires: help2man
  17. BuildRequires: gcc-c++
  18. Requires(post): /sbin/install-info
  19. Requires(preun): /sbin/install-info
  20. %description
  21. This library provides an interface for CD-ROM access. It can be used
  22. by applications that need OS- and device-independent access to CD-ROM
  23. devices.
  24. %package devel
  25. Summary: Development files for %{name}
  26. Summary(ja): %{name} の開発用ファイル
  27. Group: Development/Libraries
  28. Requires: %{name} = %{version}-%{release}
  29. Requires: pkgconfig
  30. %description devel
  31. This package contains development files for %{name}.
  32. %prep
  33. %setup -q
  34. #patch1 -p1 -b .paranoia_pc
  35. f=src/cd-paranoia/doc/ja/cd-paranoia.1.in
  36. iconv -f euc-jp -t utf-8 -o $f.utf8 $f && mv $f.utf8 $f
  37. %build
  38. #libtoolize --force || :
  39. #aclocal || :
  40. #autoheader || :
  41. #automake || :
  42. #autoconf || :
  43. %configure \
  44. --disable-vcd-info \
  45. --disable-dependency-tracking \
  46. --disable-cddb \
  47. --disable-rpath \
  48. --disable-static
  49. make %{?_smp_mflags}
  50. cd doc/doxygen
  51. sed -i -e "s,HTML_FOOTER.*$,HTML_FOOTER = libcdio-no_date_footer.hml,g" Doxyfile
  52. cp %{SOURCE2} .
  53. ./run_doxygen
  54. %install
  55. rm -rf $RPM_BUILD_ROOT
  56. make install DESTDIR=$RPM_BUILD_ROOT
  57. rm -f $RPM_BUILD_ROOT%{_infodir}/dir
  58. find $RPM_BUILD_ROOT -type f -name "*.la" -exec rm -f {} ';'
  59. mv $RPM_BUILD_ROOT%{_mandir}/{jp,ja}
  60. rm -rf examples
  61. mkdir -p examples/C++
  62. cp -a example/{*.c,README} examples
  63. cp -a example/C++/{*.cpp,README} examples/C++
  64. %check
  65. # disable test using local CDROM
  66. %{__sed} -i -e "s,testiso9660\$(EXEEXT),,g" \
  67. -e "s,check_paranoia.sh check_opts.sh, check_opts.sh,g" \
  68. test/Makefile
  69. make check
  70. %clean
  71. rm -rf $RPM_BUILD_ROOT
  72. %post
  73. /sbin/ldconfig
  74. /sbin/install-info %{_infodir}/%{name}.info %{_infodir}/dir 2>/dev/null || :
  75. %preun
  76. if [ $1 = 0 ]; then
  77. /sbin/install-info --delete %{_infodir}/%{name}.info \
  78. %{_infodir}/dir 2>/dev/null || :
  79. fi
  80. %postun -p /sbin/ldconfig
  81. %files
  82. %defattr(-,root,root,-)
  83. %doc AUTHORS COPYING NEWS README README.libcdio THANKS TODO
  84. %{_bindir}/*
  85. %{_libdir}/*.so.*
  86. %{_infodir}/*
  87. %{_mandir}/man1/*
  88. %lang(ja) %{_mandir}/ja/man1/*
  89. %files devel
  90. %defattr(-,root,root,-)
  91. %doc doc/doxygen/html examples
  92. %{_includedir}/cdio
  93. %{_includedir}/cdio++
  94. %{_libdir}/*.so
  95. %{_libdir}/pkgconfig/*.pc
  96. %changelog
  97. * Fri May 21 2010 Ryoichi INAGAKI <ryo1@bc.wakwa.com> 0.82-1
  98. - new upstream release
  99. - dropt Patch1
  100. - removed static libraries from devel package
  101. * Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.80-1
  102. - initial build for Vine Linux
  103. * Wed Jun 4 2008 Tomas Bzatek <tbzatek@redhat.com> - 0.80-2
  104. - added patch enabling libcdio_paranoia.pc
  105. * Thu May 29 2008 Adrian Reber <adrian@lisas.de> - 0.80-1
  106. - updated to 0.80
  107. - removed upstreamed patches
  108. - last GPLv2+ release
  109. * Thu Feb 14 2008 Adrian Reber <adrian@lisas.de> - 0.79-3
  110. - added patch to compile with gcc43
  111. * Fri Jan 04 2008 Adrian Reber <adrian@lisas.de> - 0.79-2
  112. - fixed security fix (was off by two)
  113. * Wed Jan 02 2008 Adrian Reber <adrian@lisas.de> - 0.79-1
  114. - updated to 0.79
  115. - fixes #427197 (Long Joliet file name overflows cdio's buffer)
  116. - fixes #341981 (multiarch conflicts in libcdio)
  117. * Fri Aug 24 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-3
  118. - rebuilt
  119. * Mon Jul 23 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-2
  120. - updated to 0.78.2 (#221359) (this time for real)
  121. * Thu Jan 04 2007 Adrian Reber <adrian@lisas.de> - 0.78.2-1
  122. - updated to 0.78.2 (#221359)
  123. * Thu Oct 05 2006 Adrian Reber <adrian@lisas.de> - 0.77-3
  124. - disabled iso9660 test case (fails for some reason with date problems)
  125. this seems to be a known problem according to the ChangeLog
  126. * Thu Oct 05 2006 Christian Iseli <Christian.Iseli@licr.org> 0.77-2
  127. - rebuilt for unwind info generation, broken in gcc-4.1.1-21
  128. * Fri Sep 22 2006 Adrian Reber <adrian@lisas.de> - 0.77-1
  129. - Updated to 0.77
  130. * Mon Sep 18 2006 Adrian Reber <adrian@lisas.de> - 0.76-3
  131. - Rebuilt
  132. * Mon Sep 26 2005 Adrian Reber <adrian@lisas.de> - 0.76-2
  133. - Rebuilt
  134. * Mon Sep 26 2005 Adrian Reber <adrian@lisas.de> - 0.76-1
  135. - Updated to 0.76.
  136. - Included doxygen generated documentation into -devel
  137. - Included examples into -devel
  138. * Mon Aug 01 2005 Adrian Reber <adrian@lisas.de> - 0.75-4
  139. - disable test accessing local CDROM drive (#164266)
  140. * Wed Jul 27 2005 Adrian Reber <adrian@lisas.de> - 0.75-3
  141. - Rebuilt without libcddb dependency (#164270)
  142. * Tue Jul 26 2005 Adrian Reber <adrian@lisas.de> - 0.75-2
  143. - Rebuilt
  144. * Thu Jul 14 2005 Adrian Reber <adrian@lisas.de> - 0.75-1
  145. - Updated to 0.75.
  146. * Fri Jun 03 2005 Adrian Reber <adrian@lisas.de> - 0.74-2
  147. - Updated to 0.74.
  148. * Sun Apr 24 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.73-2
  149. - BuildRequire ncurses-devel (for cdda-player and cd-paranoia).
  150. - Run test suite during build.
  151. - Install Japanese man pages.
  152. * Sun Apr 24 2005 Adrian Reber <adrian@lisas.de> - 0.73-1
  153. - Updated to 0.73.
  154. * Fri Mar 18 2005 Ville Skyttä <ville.skytta at iki.fi> - 0.70-2
  155. - Fix FC4 build (#151468).
  156. - Build with dependency tracking disabled.
  157. * Sun Sep 5 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.70-0.fdr.1
  158. - Updated to 0.70.
  159. * Sat Jul 17 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.69-0.fdr.1
  160. - Updated to 0.69.
  161. - Removed broken iso-read.
  162. - Split Requires(pre,post).
  163. - Added BuildReq pkgconfig.
  164. * Mon Mar 29 2004 Marius L. Jøhndal <mariuslj at ifi.uio.no> - 0:0.68-0.fdr.1
  165. - Initial RPM release.