R-vl.spec 21 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675
  1. %define pkg_name R
  2. %define pkg_version 3.6.1
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: A language for data analysis and graphics
  5. Summary(ja): データ解析・グラフィック化の言語
  6. Name: %{pkg_name}
  7. Version: %{pkg_version}
  8. Release: %{pkg_release}
  9. License: GPLv2
  10. Group: Applications/Edutainment
  11. URL: http://www.r-project.org
  12. Source0: https://cran.r-project.org/src/base/R-3/%{name}-%{version}.tar.gz
  13. Source1: Rprofile.site
  14. # Patch0: R-release.diff.gz
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. %if %{?_dist_release} >= "vl7"
  17. %ifarch x86_64
  18. BuildRequires: clang
  19. %endif
  20. %endif
  21. BuildRequires: gcc-gfortran libgfortran
  22. BuildRequires: texinfo
  23. %if %{?_dist_release} == "vl6"
  24. BuildRequires: R-pcre-devel
  25. BuildRequires: tcl85-devel tk85-devel
  26. %endif
  27. %if %{?_dist_release} >= "vl7"
  28. BuildRequires: pcre2-devel
  29. BuildRequires: tcl-devel tk-devel
  30. %endif
  31. BuildRequires: libpng-devel libjpeg-turbo-devel libtiff-devel
  32. BuildRequires: readline-devel ncurses-devel
  33. BuildRequires: zlib-devel bzip2-devel xz-devel
  34. BuildRequires: libSM-devel libX11-devel libICE-devel libXt-devel libXmu-devel
  35. BuildRequires: cairo-devel pango-devel
  36. BuildRequires: libicu-devel
  37. BuildRequires: curl-devel
  38. BuildRequires: blas-devel
  39. BuildRequires: texlive-common
  40. BuildRequires: texlive-collection-basic
  41. BuildRequires: texlive-collection-latexextra
  42. BuildRequires: texlive-collection-fontsextra
  43. %if %{?_dist_release} == "vl6"
  44. BuildRequires: texlive-collection-texinfo
  45. %endif
  46. %if %{?_dist_release} >= "vl7"
  47. BuildRequires: texlive-collection-plaingeneric
  48. BuildRequires: texlive-collection-fontsrecommended
  49. %endif
  50. BuildRequires: java-devel
  51. %if %{?_dist_release} >= "vl7"
  52. %ifarch x86_64
  53. Requires: clang
  54. %endif
  55. %endif
  56. Requires: gcc-gfortran
  57. Requires: libgfortran
  58. Requires: libicu
  59. %if %{?_dist_release} == "vl6"
  60. Requires: tcl85 tk85
  61. Requires: R-pcre
  62. %endif
  63. %if %{?_dist_release} >= "vl7"
  64. Requires: tcl tk
  65. Requires: pcre2
  66. Obsoletes: tcl85 tk85
  67. Obsoletes: R-pcre
  68. %endif
  69. Requires: blas
  70. Requires: openblas-Rblas
  71. Obsoletes: R-devel < %{version}-%{release}
  72. Vendor: Project Vine
  73. Distribution: Vine Linux
  74. Packager: ara_t
  75. %description
  76. 'GNU S' - A language and environment for statistical computing and
  77. graphics. R is similar to the award-winning S system, which was
  78. developed at Bell Laboratories by John Chambers et al. It provides
  79. a wide variety of statistical and graphical techniques (linear and
  80. nonlinear modelling, statistical tests, time series analysis,
  81. classification, clustering, ...).
  82. R is designed as a true computer language with control-flow
  83. constructions for iteration and alternation, and it allows users to
  84. add additional functionality by defining new functions.
  85. For computationally intensive tasks, C, C++ and Fortran code
  86. can be linked and called at run time.
  87. %description -l ja
  88. 'GNU S' - 統計解析とグラフィックスのプログラミング言語と環境。
  89. Rは、ベル研究所のJohn Chambersらが開発した輝けるS言語に似ており、
  90. 線形・非線型モデル、統計検定、時系列分析、クラスター分析など
  91. 幅広い統計解析・視覚化手法を提供する。
  92. Rは、条件分岐や反復計算などの制御構造を持つ正真正銘のコンピュータ言語
  93. として設計されており、ユーザが新たに関数を組み込むことが可能である。
  94. また、計算量が多いときにはC、 C++、Fortranなどのコードとリンクさせて
  95. 使用することができる。
  96. %package -n libRmath
  97. Summary: standalone math library from the R project
  98. Summary(ja): 単独で動作するRプロジェクトの数理ライブラリ
  99. Group: System Environment/Libraries
  100. %description -n libRmath
  101. A standalone library of mathematical and statistical functions derived
  102. from the R project. This packages provides the shared libRmath library.
  103. %description -l ja -n libRmath
  104. 単独で動作するRプロジェクトの数理統計ライブラリで、libRmath.soという
  105. 共有ライブラリを提供する。
  106. %package -n libRmath-devel
  107. Summary: standalone math library from the R project
  108. Summary(ja): libRmathの開発ライブラリ
  109. Group: Development/Libraries
  110. Requires: libRmath = %{version}-%{release}
  111. %description -n libRmath-devel
  112. A standalone library of mathematical and statistical functions derived
  113. from the R project. This packages provides the header files.
  114. %description -l ja -n libRmath-devel
  115. libRmathのヘッダファイル(Rmath.h)
  116. %package -n libRmath-static
  117. Summary: Static R Standalone math library
  118. Summary(ja): libRmath の静的ライブラリ
  119. Group: Development/Libraries
  120. Requires: libRmath-devel = %{version}-%{release}
  121. %description -n libRmath-static
  122. A standalone library of mathematical and statistical functions derived
  123. from the R project. This package provides the static libRmath library.
  124. %prep
  125. %{__rm} -rf ${RPM_BUILD_ROOT}
  126. %setup -q
  127. # %patch0 -p1
  128. cat > R.desktop <<EOF
  129. [Desktop Entry]
  130. Name=GNU R
  131. Comment=A language for data analysis and graphics
  132. TryExec=/usr/bin/R
  133. Exec=/usr/bin/R
  134. Icon=/usr/share/icons/logo.jpg
  135. Terminal=true
  136. Type=Application
  137. Categories=Education;Science;
  138. StartupNotify=false
  139. EOF
  140. %build
  141. export R_PDFVIEWER="%{_bindir}/xdg-open"
  142. export R_PRINTCMD="lpr"
  143. export R_BROWSER="%{_bindir}/xdg-open"
  144. %if %{?_dist_release} == "vl6"
  145. export LD_LIBRARY_PATH=%{_libdir}/R/lib
  146. %endif
  147. %if %{?_dist_release} >= "vl7"
  148. %ifarch x86_64
  149. export CFLAGS="-O2 -m64 -mtune=generic -fno-strict-aliasing"
  150. export CXXFLAGS="-O2 -m64 -mtune=generic -fno-strict-aliasing"
  151. %endif
  152. %endif
  153. # Add PATHS to Renviron for R_LIBS_SITE
  154. echo 'R_LIBS_SITE=${R_LIBS_SITE-'"'/usr/local/lib/R/site-library:%{_libdir}/R/site-library:%{_libdir}/R/library'"'}' \
  155. >> etc/Renviron.in
  156. %{configure} --enable-R-shlib --with-tcltk \
  157. --with-blas="-lblas" \
  158. %if %{?_dist_release} >= "vl7"
  159. %ifarch x86_64
  160. CC=clang CXX=clang++ \
  161. %endif
  162. %endif
  163. %if %{?_dist_release} == "vl6"
  164. --with-tcl-config=%{_libdir}/tclConfig85.sh \
  165. --with-tk-config=%{_libdir}/tkConfig85.sh \
  166. CPPFLAGS="-I%{_libdir}/R/include" \
  167. LDFLAGS="-L%{_libdir}/R/lib"
  168. %endif
  169. %{__make} %{?_smp_mflags}
  170. pushd src/nmath/standalone
  171. %{__make} %{?_smp_mflags}
  172. popd
  173. %{__make} pdf
  174. %install
  175. %{make_install}
  176. %{__make} install-pdf DESTDIR=${RPM_BUILD_ROOT}
  177. %{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir
  178. %{__rm} -f ${RPM_BUILD_ROOT}%{_infodir}/dir.old
  179. # Remove libRblas.so
  180. %{__rm} -f ${RPM_BUILD_ROOT}%{_libdir}/R/lib/libRblas.so
  181. # Install libRmath files
  182. pushd src/nmath/standalone
  183. %{make_install}
  184. popd
  185. %{__mkdir_p} ${RPM_BUILD_ROOT}/etc/ld.so.conf.d
  186. echo "%{_libdir}/R/lib" > \
  187. ${RPM_BUILD_ROOT}/etc/ld.so.conf.d/%{name}-%{_arch}.conf
  188. # Fix lication of R_HOME_DIR in shell wrapper
  189. %{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
  190. > ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
  191. %{__chmod} 755 ${RPM_BUILD_ROOT}%{_libdir}/R/bin/R
  192. %{__sed} -e "s@R_HOME_DIR=.*@R_HOME_DIR=%{_libdir}/R@" bin/R \
  193. > ${RPM_BUILD_ROOT}%{_bindir}/R
  194. %{__chmod} 755 ${RPM_BUILD_ROOT}%{_bindir}/R
  195. # add R into menu
  196. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/applications
  197. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_datadir}/icons
  198. %{__cp} -a R.desktop ${RPM_BUILD_ROOT}%{_datadir}/applications/
  199. %{__cp} -a doc/html/logo.jpg ${RPM_BUILD_ROOT}%{_datadir}/icons/
  200. # move manuals
  201. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}
  202. %{__cp} -r ${RPM_BUILD_ROOT}%{_libdir}/%{name}/doc/* \
  203. ${RPM_BUILD_ROOT}%{_docdir}/%{name}-%{version}/
  204. # make symlink for libblas.so.3 (No need to use blas-devel)
  205. pushd ${RPM_BUILD_ROOT}%{_libdir}/R/lib
  206. %{__ln_s} %{_libdir}/libblas.so.3 libblas.so
  207. popd
  208. # Add folders for R_LIBS_SITE
  209. %{__mkdir_p} ${RPM_BUILD_ROOT}%{_libdir}/R/site-library
  210. # install Rprofile.site
  211. %{__install} %{SOURCE1} ${RPM_BUILD_ROOT}%{_libdir}/R/etc
  212. %check
  213. %{__make} check
  214. %clean
  215. %{__rm} -rf ${RPM_BUILD_ROOT}
  216. %post
  217. %{_syssbindir}/ldconfig
  218. %{__mkdir_p} %{_prefix}/local/lib/R/site-library
  219. %preun
  220. if [ "$1" = "0" ]
  221. then
  222. %{__rm} -f %{_libdir}/R/lib/libblas*.so.*
  223. %{__rm} -f %{_libdir}/R/lib/libopenblas*.so.*
  224. fi
  225. %postun -p %{_syssbindir}/ldconfig
  226. %post -n libRmath -p %{_syssbindir}/ldconfig
  227. %postun -n libRmath -p %{_syssbindir}/ldconfig
  228. %files
  229. %defattr(-, root, root)
  230. %{_bindir}/R
  231. %{_bindir}/Rscript
  232. %{_libdir}/R
  233. %{_datadir}/applications/*
  234. %{_datadir}/icons/*
  235. %{_mandir}/man1/*
  236. %{_docdir}/%{name}-%{version}
  237. %{_sysconfdir}/ld.so.conf.d/*
  238. %files -n libRmath
  239. %defattr(-, root, root)
  240. %{_libdir}/libRmath.so
  241. %files -n libRmath-devel
  242. %defattr(-, root, root)
  243. %{_libdir}/pkgconfig/*.pc
  244. %{_includedir}/Rmath.h
  245. %files -n libRmath-static
  246. %defattr(-, root, root)
  247. %{_libdir}/libRmath.a
  248. %changelog
  249. * Sat Jul 06 2019 Toshiaki Ara <ara_t@384.jp> 3.6.1-1
  250. - update to 3.6.1
  251. * Thu May 09 2019 Toshiaki Ara <ara_t@384.jp> 3.6.0-2
  252. - drop "-fno-schedule-insns2" option for clang/clang++ in VineSeed (x86_64)
  253. * Fri Apr 26 2019 Toshiaki Ara <ara_t@384.jp> 3.6.0-1
  254. - update to 3.6.0
  255. - build using clang/clang++ for VineSeed (x86_64)
  256. - change install path for external library
  257. - add PATHS to Renviron for R_LIBS_SITE
  258. - set default CRAN mirror
  259. * Mon Mar 11 2019 Toshiaki Ara <ara_t@384.jp> 3.5.3-1
  260. - update to 3.5.3
  261. * Fri Jan 25 2019 Toshiaki Ara <ara_t@384.jp> 3.5.2-2
  262. - rebuild with gfortran-8.2.0
  263. * Thu Dec 20 2018 Toshiaki Ara <ara_t@384.jp> 3.5.2-1
  264. - update to 3.5.2
  265. * Mon Jul 02 2018 Toshiaki Ara <ara_t@384.jp> 3.5.1-1
  266. - update to 3.5.1
  267. * Fri Jun 29 2018 Toshiaki Ara <ara_t@384.jp> 3.5.0-2
  268. - add Requires: openblas-Rblas
  269. - change using system blas
  270. * Mon Apr 23 2018 Toshiaki Ara <ara_t@384.jp> 3.5.0-1
  271. - update to 3.5.0
  272. - drop Patch 1 and 2
  273. * Thu Mar 15 2018 Toshiaki Ara <ara_t@384.jp> 3.4.4-1
  274. - updated to 3.4.4
  275. - add Obsoletes: tcl85 tk85 R-pcre for VineSeed
  276. * Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 3.4.3-2
  277. - rebuild under icu-60.2
  278. * Thu Nov 30 2017 Toshiaki Ara <ara_t@384.jp> 3.4.3-1
  279. - Updated to 3.4.3
  280. * Thu Sep 28 2017 Toshiaki Ara <ara_t@384.jp> 3.4.2-1
  281. - Updated to 3.4.2
  282. - change download URL
  283. * Mon Jul 03 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-2
  284. - left %%{_libdir}/R/doc
  285. * Sat Jul 01 2017 Toshiaki Ara <ara_t@384.jp> 3.4.1-1
  286. - Updated to 3.4.1
  287. - rebuild under R-pcre (pcre-8.39) for Vine6
  288. - add Requires: gcc-gfortran
  289. - change to BuildRequires: texlive-collection-plaingeneric
  290. - delete unnecessary descriptions
  291. * Tue May 02 2017 Toshiaki Ara <ara_t@384.jp> 3.4.0-1
  292. - Updated to 3.4.0
  293. - add Patch1 and Patch2 to avoid 'make check' error
  294. - add export TZ="Asia/Tokyo" to avoid 'make check' error
  295. - delete descrption about info
  296. * Tue Apr 11 2017 Toshiaki Ara <ara_t@384.jp> 3.3.3-1
  297. - Updated to 3.3.3
  298. * Thu Nov 17 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-3
  299. - use tcl-8.5/tk-8.5 for Vine6.5
  300. - BuildRequires to tcl85-devel/tk85-devel
  301. - Requires to tcl85/tk85
  302. * Tue Nov 15 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-2
  303. - merge SPEC file for Vine6
  304. - drop devel package
  305. - move PDF manuals to /usr/share/doc/R-%%{version}
  306. - revert logo of menu item to logo.jpg
  307. * Mon Oct 31 2016 Toshiaki Ara <ara_t@384.jp> 3.3.2-1
  308. - Updated to 3.3.2
  309. * Wed Jun 22 2016 Toshiaki Ara <ara_t@384.jp> 3.3.1-1vl7
  310. - Updated to 3.3.1
  311. - delete BuildRequires: texlive-collection-lang*
  312. * Sat May 14 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-2vl7
  313. - add BuildRequires: texlive-collection-lang*
  314. * Tue May 03 2016 Toshiaki Ara <ara_t@384.jp> 3.3.0-1vl7
  315. - Updated to 3.3.0
  316. - add BuildRequires: pcre-devel xz-devel
  317. - change logo of menu item to Rlogo.svg
  318. * Sun Apr 10 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-3
  319. - correct SPEC file
  320. * Thu Mar 17 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-2
  321. - Updated to 3.2.4-revised
  322. * Fri Mar 11 2016 Toshiaki Ara <ara_t@384.jp> 3.2.4-1
  323. - Updated to 3.2.4
  324. - fixed build error in src/extra/xz
  325. * Fri Jan 01 2016 Toshiaki Ara <ara_t@384.jp> 3.2.3-2
  326. - add BuildRequires: curl-devel
  327. - add BuildRequires: libgomp
  328. * Sun Dec 13 2015 Toshiaki Ara <ara_t@384.jp> 3.2.3-1
  329. - Updated to 3.2.3
  330. * Mon Nov 09 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.2.2-2
  331. - rebuild with icu-56.1
  332. * Mon Aug 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.2-1
  333. - Updated to 3.2.2
  334. * Wed Jul 15 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-2
  335. - add configure options: --with-tcltk
  336. - add BuildRequires: tcl-devel tk-devel
  337. - add Requires: tcl tk
  338. * Fri Jun 19 2015 Toshiaki Ara <ara_t@384.jp> 3.2.1-1
  339. - Updated to 3.2.1
  340. * Sat Apr 18 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-2
  341. - add "LIBS=-lbz2" to configure option
  342. * Fri Apr 17 2015 Toshiaki Ara <ara_t@384.jp> 3.2.0-1
  343. - Updated to 3.2.0
  344. * Fri Mar 13 2015 Toshiaki Ara <ara_t@384.jp> 3.1.3-1
  345. - Updated to 3.1.3
  346. - added BuildRequires: texlive-collection-fontsextra for Vine6
  347. - changed option "make check-all" to "make check"
  348. - to avoid error in checking of mgcv package
  349. - changed orders of BuildRequires
  350. * Thu Jan 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-2
  351. - rebuild with icu-54.1
  352. * Sat Nov 01 2014 Toshiaki Ara <ara_t@384.jp> 3.1.2-1
  353. - Updated to 3.1.2
  354. * Fri Jul 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.1-1
  355. - Updated to 3.1.1
  356. - add BuildRequires: java-1.7.0-openjdk-devel for VineSeed
  357. * Sat Apr 26 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-2
  358. - add patch (2014-04-26)
  359. * Fri Apr 11 2014 Toshiaki Ara <ara_t@384.jp> 3.1.0-1
  360. - Updated to 3.1.0
  361. * Fri Mar 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.3-1
  362. - Updated to 3.0.3
  363. * Tue Jan 07 2014 Toshiaki Ara <ara_t@384.jp> 3.0.2-4
  364. - rebuild current VineSeed
  365. - add patch (2014-01-06)
  366. * Tue Dec 03 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-3
  367. - add Requires: libicu
  368. * Mon Sep 30 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-2
  369. - combine spec files Vine6 and VineSeed
  370. - correct the days of the week in changelog
  371. * Fri Sep 27 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
  372. - delete BuildRequires: texlive-collection-texinfo
  373. - add BuildRequires: texlive-collection-plainextra
  374. - add BuildRequires: texlive-collection-latexextra
  375. - add BuildRequires: texlive-collection-fontsrecommended
  376. - for VineSeed
  377. * Thu Sep 26 2013 Toshiaki Ara <ara_t@384.jp> 3.0.2-1
  378. - Updated to 3.0.2
  379. * Fri May 17 2013 Toshiaki Ara <ara_t@384.jp> 3.0.1-1
  380. - Updated to 3.0.1
  381. - add BuildRequires: java-1.6.0-openjdk-devel
  382. * Thu Apr 04 2013 Toshiaki Ara <ara_t@384.jp> 3.0.0-1
  383. - Updated to 3.0.0
  384. * Mon Mar 04 2013 Toshiaki Ara <ara_t@384.jp> 2.15.3-1
  385. - Updated to 2.15.3
  386. - use BuildRequires libjpeg-turbo-devel instead of libjpeg-devel
  387. - use BuildRequires ncurses-devel instead of libtermcap-devel
  388. * Mon Oct 29 2012 Toshiaki Ara <ara_t@384.jp> 2.15.2-1
  389. - Updated to 2.15.2
  390. * Sat Sep 08 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-2
  391. - changed group to Applications/Edutainment
  392. - added R to menu
  393. * Mon Jun 25 2012 Toshiaki Ara <ara_t@384.jp> 2.15.1-1
  394. - Updated to 2.15.1
  395. * Sat Mar 31 2012 Toshiaki Ara <ara_t@384.jp> 2.15.0-1
  396. - Updated to 2.15.0
  397. * Thu Mar 01 2012 Toshiaki Ara <ara_t@384.jp> 2.14.2-1
  398. - Updated to 2.14.2
  399. * Sat Dec 24 2011 Toshiaki Ara <ara_t@384.jp> 2.14.1-1
  400. - Updated to 2.14.1
  401. * Tue Nov 01 2011 Toshiaki Ara <ara_t@384.jp> 2.14.0-1
  402. - Updated to 2.14.0
  403. - add BuildRequires: texlive-collection-fontsextra
  404. * Thu Oct 27 2011 Toshiaki Ara <ara_t@384.jp> 2.13.2-1
  405. - Updated to 2.13.2
  406. - add BuildRequires: texlive-common
  407. - use texlive instead of tetex on Vine5 because of failure to create R-exts.pdf
  408. - removed --enable-R-shlib option to %%configure on Vine5 because of segmentation fault
  409. * Sat Sep 3 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.13.1-2
  410. - synchronized to VinePlus/5 package
  411. * Sat Jul 09 2011 Toshiaki Ara <ara_t@384.jp> 2.13.1-1vl5
  412. - Updated to 2.13.1
  413. * Wed Apr 14 2011 Toshiaki Ara <ara_t@384.jp> 2.13.0-1vl5
  414. - Updated to 2.13.0
  415. * Wed Mar 02 2011 Toshiaki Ara <ara_t@384.jp> 2.12.2-1vl5
  416. - Updated to 2.12.2
  417. * Sun Feb 27 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.12.1-3
  418. - add BuildRequires: libicu-devel
  419. * Fri Feb 25 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.12.1-2
  420. - synchronized to VinePlus/5 package
  421. * Tue Dec 21 2010 Toshiaki Ara <ara_t@384.jp> 2.12.1-1vl5
  422. - Updated to 2.12.1
  423. - added --enable-R-shlib option to %%configure
  424. - added static subpackage
  425. - use BR: texlive instead of tetex on VineSeed
  426. * Sun Sep 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.11.0-3
  427. - rebuilt with rpm-4.8.1 for pkg-config
  428. * Sat Apr 24 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-2vl5
  429. - recompiled because tcl/tk were not linked
  430. * Fri Apr 23 2010 Toshiaki Ara <ara_t@384.jp> 2.11.0-1vl5
  431. - Updated to 2.11.0
  432. - added Requires: libgfortran
  433. * Tue Dec 15 2009 Toshiaki Ara <ara_t@384.jp> 2.10.1-1vl5
  434. - Updated to 2.10.1
  435. * Fri Nov 06 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-3vl5
  436. - patched to 2.10.0
  437. * Sat Oct 31 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.10.0-2
  438. - spec in UTF-8
  439. * Tue Oct 27 2009 Toshiaki Ara <ara_t@384.jp> 2.10.0-1vl5
  440. - Updated to 2.10.0
  441. * Wed Sep 23 2009 Toshiaki Ara <ara_t@384.jp> 2.9.2-1vl5
  442. - Updated to 2.9.2
  443. - deleted BuildRequires: lapack-devel blas-devel
  444. - rewrote SPEC file
  445. * Thu Aug 16 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1:2.5.1-0vl1
  446. - Updated to 2.5.1
  447. - added BuildRequires: gcc-gfortran for VineSeed
  448. - added BuildRequires: lapack-devel blas-devel
  449. - fixed %preun script
  450. * Wed Dec 20 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.4.1-0vl1
  451. - Updated to 2.4.1
  452. - Added INFO option
  453. - Exclude Japanese Rprofile.site
  454. * Mon Oct 30 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
  455. - Updated to 2.4.0
  456. * Mon Oct 2 2006 Martyn Plummer <plummer@iarc.fr> 1:2.3.1-2
  457. - Added optimization flags
  458. * Tue Jun 6 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.1-0vl1
  459. - Packaged for VineLinux3.2
  460. * Tue May 9 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl2
  461. - Use JAVA_HOME for R_JAVA_LD_LIBRARY_PATH
  462. * Mon May 8 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp> 1:2.3.0-0vl1
  463. - Packaged for VineLinux3.2
  464. - Slipped texinfo
  465. - Fixed preun error
  466. - Preset Japanese fonts
  467. * Thu Jan 12 2006 Susumu Tanimura <stanimura-ngs@umin.ac.jp>
  468. - Packaged for VineLinux3.2
  469. * Tue Jan 3 2006 Martyn Plumer <plummber@iarc.fr> 1:2.2.1-1
  470. - Restored CAPABILITIES file lost in 2.2.1beta
  471. * Mon Dec 12 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.1beta-1
  472. - Configure uses --without-blas by default.
  473. - Install pdf manuals.
  474. - All toplevel documentation files are installed into _libdir/R
  475. as they may be required by R (qv note on AUTHORS and THANKS below).
  476. - Legacy scripts for rebuilding package indices removed.
  477. * Mon Sep 19 2005 Martyn Plummer <plummer@iarc.fr> 1:2.2.0-0
  478. - R now compiles with gcc 4.0.1 and default rpm optimization flags.
  479. * Wed Jul 13 2005 Martyn Plummer <plummer@iarc.fr> 1:2.1.1-2
  480. - The files AUTHORS and THANKS need to be installed into _libdir/R
  481. as they are required by the function contributors(). Previously
  482. they were installed only as documentation files.
  483. * Tue Jun 21 2005 Martyn Plummer <plummer@iarc.fr>
  484. - Corrected date error in SPEC file.
  485. * Sun Jun 19 2005 Martyn Plummer <plummer@iarc.fr>
  486. - Dropped support for Red Hat boxed set.
  487. - Synchronized with Fedora Extras 4 RPM by Tom Calloway
  488. including support for shared R library.
  489. - Added gfortran support. However, gcc 4.0.0 will not compile R correctly
  490. with the default optimization flags, so there is a temporary work-around.
  491. * Wed Jun 15 2005 Gernot Stocker <gernot.stocker@tugraz.at>
  492. - Adaptations for CentOS and Rocks-Linux, tested under Release 4.0
  493. * Sat Apr 30 2005 Joseph P. Skudlarek <Jskud@Jskud.com> 0:2.1.0-0.fdr.3
  494. - Install R-data.info file as well.
  495. - Make info processing conditional on texinfo version, not platform release,
  496. so that if a new enough version is installed, we will build and install info.
  497. * Mon Apr 18 2005 Martyn Plummer <plummer@iarc.fr> 0:2.1.0-0.fdr.1
  498. - Built R 2.1.0. R now supports internationalization, so the patch
  499. to set the locale to "C" is now dropped.
  500. - install.packages() exits gracefully with a helpful message if
  501. the file INSTALL is not present, so this is now included in the
  502. R-devel package.
  503. * Mon Mar 14 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.5
  504. - Added support for Scientific Linux (http://www.scientificlinux.org)
  505. A distribution based on RHEL. Thanks to Jon Peatfield.
  506. * Mon Feb 28 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.4
  507. - Fixed file ownership in R-devel and libRmath packages
  508. * Wed Feb 16 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.3
  509. - R-devel package is now a stub package with no files, except a documentation
  510. file (RPM won't accept sub-packages with no files). R now conflicts
  511. with earlier (i.e 0:2.0.1-0.fdr.2) versions of R-devel.
  512. - Created libRmath subpackage with shared library.
  513. * Mon Jan 31 2005 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.2
  514. - Created R-devel and libRmath-devel subpackages
  515. * Mon Nov 15 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.1-0.fdr.1
  516. - Built R 2.0.1
  517. * Wed Nov 10 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.3
  518. - Set R_PRINTCMD at configure times so that by default getOption(printcmd)
  519. gives "lpr".
  520. - Define macro fcx for all Fedora distributions. This replaces Rinfo
  521. * Tue Oct 12 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.2
  522. - Info support is now conditional on the macro Rinfo, which is only
  523. defined for Fedora 1 and 2.
  524. * Thu Oct 7 2004 Martyn Plummer <plummer@iarc.fr> 0:2.0.0-0.fdr.1
  525. - Built R 2.0.0
  526. - There is no longer a BUGS file, so this is not installed as a
  527. documentation file.