dump-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431
  1. %define _sbindir /sbin
  2. # XXX --enable-kerberos needs krcmd
  3. %define myoptions --enable-largefile --with-binmode=6755 --with-manowner=root --with-mangrp=root --with-manmode=0644 --with-dumpdates="%{_sysconfdir}/dumpdates" --enable-readline
  4. Summary: Programs for backing up and restoring ext2/ext3 filesystems.
  5. Summary(ja): ext2/ext3 ファイルシステムをバックアップ/リストアするプログラム
  6. Name: dump
  7. Version: 0.4b41
  8. Release: 3%{?_dist_release}
  9. License: BSD
  10. Group: Applications/Archiving
  11. URL: http://dump.sourceforge.net
  12. Source: dump-%{version}.tar.gz
  13. Patch1: dump-dmfix.patch
  14. #Patch2: dump-immutable.patch
  15. #Patch3: dump-0.4b41-libtinfo.patch
  16. BuildRoot: %{_tmppath}/%{name}-root
  17. BuildRequires: libtermcap-devel
  18. BuildRequires: e2fsprogs-devel >= 1.18, readline-devel >= 4.1
  19. BuildRequires: zlib-devel, device-mapper-devel
  20. BuildRequires: libblkid-devel
  21. BuildRequires: libuuid-devel
  22. BuildRequires: bzip2-devel
  23. # This Prereq is now required because we only ship static binaries, and
  24. # need to ensure the "disk" group is created before installation (#60461)
  25. Requires(pre): setup
  26. Requires: rmt
  27. Obsoletes: dump-static
  28. #Provides: dump-static
  29. Packager: daisuke, kazutaka
  30. %description
  31. The dump package contains both dump and restore. Dump examines files
  32. in a filesystem, determines which ones need to be backed up, and
  33. copies those files to a specified disk, tape, or other storage medium.
  34. The restore command performs the inverse function of dump; it can
  35. restore a full backup of a filesystem. Subsequent incremental backups
  36. can then be layered on top of the full backup. Single files and
  37. directory subtrees may also be restored from full or partial backups.
  38. Install dump if you need a system for both backing up filesystems and
  39. restoring filesystems after backups.
  40. %description -l ja
  41. dump パッケージは dump と restore の両方を含んでいます。dump はファイル
  42. システム上のファイルを検査し、どれがバックアップが必要が特定し、指定し
  43. たディスク、テープ、あるいはその他のバックアップ用メディアにファイルを
  44. コピーします。
  45. restore コマンドは dump とは反対の処理を行います。restore コマンドを使
  46. うとファイルシステムのフルバックアップを復元できます。またフルバックアッ
  47. プからの増分バックアップを適用することもできます。フルバックアップ、ま
  48. たは部分パックアップから、単一のファイルやディレクトリのサブツリーだけ
  49. を復元することもできます。
  50. もしファイルシステムのフルバックアップや復元が必要な場合は、dump をイン
  51. ストールしてください。
  52. %package -n rmt
  53. Summary: Provides certain programs with access to remote tape devices.
  54. Summary(ja): リモートテープ装置のアクセスに必要なプログラム
  55. Group: Applications/Archiving
  56. %description -n rmt
  57. The rmt utility provides remote access to tape devices for programs
  58. like dump (a filesystem backup program), restore (a program for
  59. restoring files from a backup), and tar (an archiving program).
  60. %description -n rmt -l ja
  61. rmt ユーティリティは、dump (ファイルシステムのバックアップ)や restore
  62. (バックアップからの復元)、tar (アーカイブの作成/展開) といったプログラ
  63. ムに、テープ装置へのリモートアクセスを提供します。
  64. %prep
  65. %setup -q
  66. %patch1 -p1 -b .dmfix
  67. #%patch2 -p1 -b .orig
  68. #%patch3 -p1 -b .libtinfo
  69. %build
  70. %configure %{myoptions} --disable-static --enable-rmt
  71. %ifarch alpha
  72. RPM_OPT_FLAGS=""
  73. %endif
  74. make OPT="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes \
  75. -Wmissing-prototypes -Wno-char-subscripts "
  76. %install
  77. rm -rf %{buildroot}
  78. mkdir -p %{buildroot}%{_sbindir}
  79. mkdir -p %{buildroot}%{_mandir}/man8
  80. %makeinstall SBINDIR=%{buildroot}%{_sbindir} BINDIR=%{buildroot}%{_sbindir} MANDIR=%{buildroot}%{_mandir}/man8 BINOWNER=$(id -un) BINGRP=$(id -gn) MANOWNER=$(id -un) MANGRP=$(id -gn)
  81. pushd $RPM_BUILD_ROOT
  82. ln -sf dump .%{_sbindir}/rdump
  83. # ln -sf dump .%{_sbindir}/rdump.static
  84. # ln -sf dump .%{_sbindir}/dump.static
  85. ln -sf restore .%{_sbindir}/rrestore
  86. # ln -sf restore .%{_sbindir}/rrestore.static
  87. # ln -sf restore .%{_sbindir}/restore.static
  88. chmod ug-s .%{_sbindir}/rmt
  89. mkdir -p .%{_sysconfdir}
  90. > .%{_sysconfdir}/dumpdates
  91. ln -sf ..%{_sbindir}/rmt .%{_sysconfdir}/rmt
  92. strip $RPM_BUILD_ROOT/sbin/* $RPM_BUILD_ROOT/usr/sbin/* || :
  93. popd
  94. %clean
  95. rm -rf %{buildroot}
  96. %files
  97. %defattr(-,root,root)
  98. %doc CHANGES COPYRIGHT KNOWNBUGS MAINTAINERS README REPORTING-BUGS THANKS TODO
  99. %doc dump.lsm
  100. %attr(0664,root,disk) %config(noreplace) %{_sysconfdir}/dumpdates
  101. %attr(0755,root,root) /sbin/dump
  102. /sbin/rdump
  103. %attr(0755,root,root) /sbin/restore
  104. /sbin/rrestore
  105. #/sbin/*.static
  106. %{_mandir}/man8/dump.*
  107. %{_mandir}/man8/rdump.*
  108. %{_mandir}/man8/restore.*
  109. %{_mandir}/man8/rrestore.*
  110. %files -n rmt
  111. %defattr(-,root,root)
  112. %attr(0755,root,root)
  113. %{_sbindir}/rmt
  114. %{_sysconfdir}/rmt
  115. %{_mandir}/man8/rmt.*
  116. %changelog
  117. * Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4b41-3
  118. - rebuild with rpm-4.8.1
  119. - add BuildRequires: libblkid-devel, libuuid-devel, bzip2-devel
  120. * Mon Jun 22 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4b41-2
  121. - spec in UTF-8
  122. - change configure option to --disable-static
  123. - remove -static stuffs
  124. * Sun Apr 27 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4b41-1
  125. - add Patch1 based on fedora development to build with device-mapper
  126. - add japanese summary and description.
  127. - apply new versioning policy.
  128. * Sun May 13 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4b41-0vl1
  129. - new upstream release
  130. * Fri Oct 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.4b34-0vl2
  131. - spec file was in SJIS. fixed.
  132. * Sat Feb 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4b34-0vl1
  133. - new upstream release
  134. * Sun Feb 9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4b28-5vl1
  135. - update upstream release based on rawhide package.
  136. - rebuild on new environment.
  137. * Fri Mar 15 2002 Toru Sagami <sagami@vinelinux.org> 0.4b22-4vl2
  138. - rebuilt against fixed statically linked system libraries
  139. * Sat Jul 14 2001 Toru Sagami <sagami@vinelinux.org>
  140. - 0.4b22-4vl1: based on 0.4b22-4 from Rawhide
  141. * Mon Oct 7 2002 Mike A. Harris <mharris@redhat.com> 0.4b28-5
  142. - All-arch rebuild
  143. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  144. - automated rebuild
  145. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  146. - automated rebuild
  147. * Tue May 21 2002 Mike A. Harris <mharris@redhat.com> 0.4b28-2
  148. - Updated to dump 0.4b28
  149. - Removed atomic_read/write patch, not needed anymore
  150. * Fri Mar 1 2002 Mike A. Harris <mharris@redhat.com> 0.4b27-3
  151. - BuildRequires readline-devel >= 4.2 for the rl_completion_matches function
  152. - Added dump-0.4b27-dump-atomic-read-write.patch to avoid namespace conflict
  153. with included kernel headers. atomic_read is a function on s390 and as
  154. such, cannot be #undef'd
  155. * Thu Feb 28 2002 Mike A. Harris <mharris@redhat.com> 0.4b27-2
  156. - Added prereq on "setup" to ensure disk group is created prior to this
  157. package being installed
  158. - Somehow the dump package changelog got hosed, and part of the spec file
  159. regressed. I believe it is fixed now.
  160. * Tue Feb 26 2002 Mike A. Harris <mharris@redhat.com> 0.4b27-1
  161. - Updated to dump 0.4b27-1
  162. * Fri Feb 22 2002 Mike A. Harris <mharris@redhat.com> 0.4b25-5
  163. - Bumped release up a couple notches to rebuild in rawhide
  164. * Thu Feb 21 2002 Mike A. Harris <mharris@redhat.com> 0.4b25-1.72.0
  165. - Rebuilt 0.4b25 for erratum release. Fixes various bugs that have been
  166. reported in bugzilla which are logged below. Also fixes a bug caused by
  167. linking statically to a faulty system library.
  168. - Added Provides dump-static line
  169. * Mon Feb 11 2002 Mike A. Harris <mharris@redhat.com> 0.4b25-3
  170. - Added missing zlib buildprereq
  171. - Rebuild in new environment
  172. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  173. - automated rebuild
  174. * Wed Nov 21 2001 Mike A. Harris <mharris@redhat.com> 0.4b25-1
  175. - Updated to version 0.4b25-1
  176. - Added homepage URL for RFE (#54601)
  177. - Also fixed in this release are (#21272, #52663, #56616)
  178. - Dropped time.h patch as it is unneeded now
  179. * Tue Nov 6 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-7
  180. - Updated BuildPreReq to e2fsprogs-devel >= 1.18, readline-devel >= 4.1 to
  181. explicitly state the minimum required deps and fix (#51900)
  182. * Sat Sep 8 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 0.4b22-6
  183. - Kill the static subpackage - the standard binaries are now static
  184. This removes /usb/sbin/*. The static versions are now in /sbin
  185. (#53433)
  186. - Obsolete dump-static
  187. * Tue Aug 14 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 0.4b22-5
  188. - Move non-static binaries to /usr/sbin (#49520)
  189. * Fri Jun 29 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-4
  190. - Added BuildPrereq: readline-devel (#44734 - which was reopened and changed)
  191. * Sat Jun 16 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-3
  192. - Added BuildPrereq: libtermcap-devel (#44734)
  193. * Tue Jun 12 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-2
  194. - Removed release tag from buildroot dirname - messy.
  195. - Broke all lines over multiple lines for readability in specfile.
  196. - Added --enable-largefile configure flags
  197. * Mon Jun 11 2001 Florian La Roche <Florian.LaRoche@redhat.de> 0.4b22-1
  198. - 0.4b22
  199. * Mon May 7 2001 Mike A. Harris <mharris@redhat.com> 0.4b21-5
  200. - Added BuildPrereq: e2fsprogs-devel (#27428)
  201. * Mon Apr 9 2001 Bill Nottingham <notting@redhat.com>
  202. - fix ia64
  203. * Wed Feb 14 2001 Bill Nottingham <notting@redhat.com>
  204. - fix build with current glibc
  205. * Mon Jan 29 2001 Nalin Dahyabhai <nalin@redhat.com>
  206. - change copyright: UCB to License: BSD
  207. * Fri Jan 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  208. - update to 0.4b21.
  209. * Sun Nov 26 2000 Jeff Johnson <jbj@redhat.com>
  210. - update to 0.4b20.
  211. * Fri Nov 10 2000 Stelian Pop <pop@cybercable.fr>
  212. - dump 0.4b20 released, first packaging.
  213. * Tue Oct 31 2000 Jeff Johnson <jbj@redhat.com>
  214. - remove setuid bits for Red Hat 5.x errata.
  215. * Wed Aug 30 2000 Matt Wilson <msw@redhat.com>
  216. - rebuild to cope with glibc locale binary incompatibility, again
  217. * Wed Aug 30 2000 Preston Brown <pbrown@redhat.com>
  218. - fix for dumping files between 2 and 4 gigs (#16466)
  219. * Mon Aug 21 2000 Matt Wilson <msw@redhat.com>
  220. - don't use -O2 on alpha because of compiler ICE
  221. * Sun Aug 20 2000 Jeff Johnson <jbj@redhat.com>
  222. - update to 0.4b19.
  223. * Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
  224. - summaries from specspo.
  225. * Wed Aug 16 2000 Erik Troan <ewt@redhat.com>
  226. - support LABEL= in fstab
  227. * Sat Jul 22 2000 Bill Nottingham <notting@redhat.com>
  228. - if dump/restore aren't set(u|g)id, they don't need group tty (#12670)
  229. * Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
  230. - rebuild to cope with glibc locale binary incompatibility
  231. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  232. - automatic rebuild
  233. * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
  234. - whoops I had dump commented out of the file list. fixed.
  235. - dropped suid bits on the static binaries.
  236. - fix char buffer size issue (#11880)
  237. * Mon Jun 19 2000 Preston Brown <pbrown@redhat.com>
  238. - dropped SUID bits
  239. * Tue Jun 6 2000 Jeff Johnson <jbj@redhat.com>
  240. - update to 0.4b17.
  241. - FHS packaging.
  242. * Thu Jun 1 2000 Stelian Pop <pop@cybercable.fr>
  243. - dump 0.4b17 released, first packaging.
  244. * Sat Mar 11 2000 Stelian Pop <pop@cybercable.fr>
  245. - dump 0.4b16 released, first packaging.
  246. * Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
  247. - use posix signal handling to preserve dump functionality with libc5.
  248. * Thu Mar 2 2000 Bill Nottingham <notting@redhat.com>
  249. - update to 0.4b15
  250. * Thu Feb 10 2000 Jeff Johnson <jbj@redhat.com>
  251. - dump -0ufB /dev/ftape 1638000 /mnt2 fails to use /mnt2 as tape device (#8036)
  252. * Thu Feb 10 2000 Stelian Pop <pop@cybercable.fr>
  253. - dump 0.4b14 released, first packaging.
  254. * Wed Feb 9 2000 Jeff Johnson <jbj@redhat.com>
  255. - compress man pages.
  256. * Thu Jan 27 2000 Jeff Johnson <jbj@redhat.com>
  257. - update to 0.4b13.
  258. * Fri Jan 21 2000 Stelian Pop <pop@cybercable.fr>
  259. - dump 0.4b13 released, first packaging.
  260. * Mon Jan 10 2000 Jeff Johnson <jbj@redhat.com.
  261. - update to 0.4b12.
  262. * Fri Jan 8 2000 Stelian Pop <pop@cybercable.fr>
  263. - dump 0.4b12 released, first packaging.
  264. * Sun Dec 5 1999 Stelian Pop <pop@cybercable.fr>
  265. - dump 0.4b11 released, first packaging.
  266. * Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
  267. - intergrate Stelian's fixes (Thanks!).
  268. * Sun Nov 21 1999 Stelian Pop <pop@cybercable.fr>
  269. - dump 0.4b10 released, first packaging.
  270. * Thu Nov 11 1999 Stelian Pop <pop@cybercable.fr>
  271. - make static versions also for rescue purposes.
  272. * Wed Nov 5 1999 Stelian Pop <pop@cybercable.fr>
  273. - dump 0.4b9 released, first packaging.
  274. * Wed Nov 3 1999 Stelian Pop <pop@cybercable.fr>
  275. - dump 0.4b8 released, first packaging.
  276. * Thu Oct 8 1999 Stelian Pop <pop@cybercable.fr>
  277. - dump 0.4b7 released, first packaging.
  278. * Thu Sep 30 1999 Stelian Pop <pop@cybercable.fr>
  279. - dump 0.4b6 released, first packaging.
  280. * Fri Sep 10 1999 Jeff Johnson <jbj@redhat.com>
  281. - recompile with e2fsprogs = 1.15 (#4962).
  282. * Sat Jul 31 1999 Jeff Johnson <jbj@redhat.com>
  283. - workaround egcs bug (#4281) that caused dump problems (#2989).
  284. - use sigjmp_buf, not jmp_buf (#3260).
  285. - invoke /etc/rmt (instead of rmt) like other unices. (#3272).
  286. - use glibc21 err/glob rather than the internal compatibility routines.
  287. - wire $(OPT) throughout Makefile's.
  288. - fix many printf problems, mostly lint clean.
  289. - merge SuSE, Debian and many OpenBSD fixes.
  290. * Thu Mar 25 1999 Jeff Johnson <jbj@redhat.com>
  291. - remove setuid/setgid bits from /sbin/rmt (dump/restore are OK).
  292. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  293. - auto rebuild in the new build environment (release 6)
  294. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  295. - strip binaries.
  296. * Thu Mar 18 1999 Jeff Johnson <jbj@redhat.com>
  297. - Fix dangling symlinks (#1551).
  298. * Wed Mar 17 1999 Michael Maher <mike@redhat.com>
  299. - Top O' the morning, build root's fixed for man pages.
  300. * Fri Feb 19 1999 Preston Brown <pbrown@redhat.com>
  301. - upgraded to dump 0.4b4, massaged patches.
  302. * Tue Feb 02 1999 Ian A Cameron <I.A.Cameron@open.ac.uk>
  303. - added patch from Derrick J Brashear for traverse.c to stop bread errors
  304. * Wed Jan 20 1999 Jeff Johnson <jbj@redhat.com>
  305. - restore original 6755 root.tty to dump/restore, defattr did tty->root (#684).
  306. - mark /etc/dumpdates as noreplace.
  307. * Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
  308. - add build root.
  309. * Tue May 05 1998 Prospector System <bugs@redhat.com>
  310. - translations modified for de, fr, tr
  311. * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
  312. - added a patch for resolving linux/types.h and sys/types.h conflicts
  313. * Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
  314. - added prototype of llseek() so dump would work on large partitions
  315. * Thu Oct 30 1997 Donnie Barnes <djb@redhat.com>
  316. - made all symlinks relative instead of absolute
  317. * Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
  318. - built against glibc
  319. * Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
  320. - Moved rmt to its own package.
  321. * Tue Feb 11 1997 Michael Fulbright <msf@redhat.com>
  322. - Added endian cleanups for SPARC
  323. * Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
  324. - Made /etc/dumpdates writeable by group disk.