hal-vl.spec 19 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594
  1. %define expat_version 1.95.5
  2. %define glib2_version 2.20.0
  3. %define dbus_version 1.2
  4. %define dbus_glib_version 0.80
  5. %define dbus_python_version 0.80
  6. %define pygtk2_version 2.8.0
  7. %define gnome_python 2.14.0
  8. %define udev_version 145
  9. %define util_linux_ng_version 2.14
  10. %define gettext_version 0.14.5
  11. %define libusb_version 0.1.10a
  12. %define consolekit_version 0.3.0
  13. %define acl_version 2.2.39
  14. %define policykit_version 0.9
  15. %define pciutils_version 2.2.1
  16. %define dmidecode_version 2.7
  17. %define gperf_version 3.0.1
  18. # %define parted_version 1.8.8
  19. %define parted_version 2.3
  20. %define hal_user_uid 68
  21. %define _localstatedir %{_var}
  22. Summary: Hardware Abstraction Layer
  23. Summary(ja): ハードウエア抽象化レイヤ
  24. Name: hal
  25. Version: 0.5.14
  26. Release: 1%{?_dist_release}
  27. Group: System Environment/Libraries
  28. URL: http://www.freedesktop.org/Software/hal
  29. License: AFL/GPL
  30. Source0: %{name}-%{version}.tar.bz2
  31. Patch2: hal-0.5.11-change-priority.patch
  32. # https://bugzilla.redhat.com/show_bug.cgi?id=488177
  33. Patch4: hal-remove-dell-killswitch.patch
  34. # http://lists.freedesktop.org/archives/hal/2009-March/013125.html
  35. Patch9: hal-KVM-evdev.patch
  36. # http://bugs.freedesktop.org/show_bug.cgi?id=22442
  37. Patch11: hal-HDAPS-blacklist.patch
  38. Patch100: hal-use-at-console.patch
  39. Patch200: hal-0.5.13-disable-keyboard-hotplug.patch
  40. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  41. BuildRequires: expat-devel >= %{expat_version}
  42. BuildRequires: glib2-devel >= %{glib2_version}
  43. BuildRequires: dbus-devel >= %{dbus_version}
  44. BuildRequires: python-devel
  45. BuildRequires: hwdata
  46. BuildRequires: gettext >= %{gettext_version}
  47. %ifnarch s390 s390x
  48. BuildRequires: libusb-devel >= %{libusb_version}
  49. %endif
  50. BuildRequires: desktop-file-utils >= 0.9
  51. BuildRequires: dbus-glib-devel >= %{dbus_glib_version}
  52. BuildRequires: pciutils-devel >= %{pciutils_version}
  53. BuildRequires: zlib-devel
  54. BuildRequires: gperf >= %{gperf_version}
  55. BuildRequires: parted-devel >= %{parted_version}
  56. BuildRequires: e2fsprogs-devel
  57. BuildRequires: libblkid-devel
  58. BuildRequires: libuuid-devel
  59. Requires: dbus >= %{dbus_version}
  60. Requires: dbus-glib >= %{dbus_glib_version}
  61. Requires: glib2 >= %{glib2_version}
  62. Requires: udev >= %{udev_version}
  63. Requires: util-linux-ng >= %{util_linux_ng_version}
  64. %ifnarch s390 s390x
  65. Requires: libusb >= %{libusb_version}
  66. %endif
  67. Requires: ConsoleKit >= %{consolekit_version}
  68. Requires: acl >= %{acl_version}
  69. Requires: hal-info
  70. Requires(pre): shadow-utils
  71. Requires(post): chkconfig
  72. Requires(preun): chkconfig, initscripts
  73. Obsoletes: hal-gnome
  74. %description
  75. HAL is daemon for collection and maintaining information from several
  76. sources about the hardware on the system. It provdes a live device
  77. list through D-BUS.
  78. %package gnome
  79. Summary: GNOME based device manager for HAL
  80. Group: Applications/System
  81. Requires: %name = %{version}-%{release}
  82. Requires: dbus-python >= %{dbus_python_version}
  83. Requires: pygtk2 >= %{pygtk2_version}
  84. Requires: pygtk2-libglade >= %{pygtk2_version}
  85. Requires: gnome-python >= %{gnome_python}
  86. %description gnome
  87. GNOME program for displaying the devices detected by HAL
  88. %package devel
  89. Summary: Libraries and headers for HAL
  90. Group: Development/Libraries
  91. Requires: %{name} = %{version}-%{release}
  92. Requires: dbus-devel >= %{dbus_version}
  93. %description devel
  94. Headers, static libraries and API docs for HAL.
  95. %prep
  96. %setup -q -n %{name}-%{version}
  97. %patch2 -p1 -b .priority
  98. %patch4 -p1 -b .dell-killswitch
  99. %patch9 -p1 -b .kvm-evdev
  100. %patch11 -p1 -b .hdaps-blacklist
  101. %patch100 -p1 -b .drop-polkit
  102. %patch200 -p1 -b .disable-keyboard-hotplug
  103. %build
  104. autoreconf -f -i
  105. %configure \
  106. --with-os-type=redhat \
  107. --docdir=%{_docdir}/%{name}-%{version} \
  108. --with-udev-prefix=/etc \
  109. --disable-docbook-docs \
  110. --enable-pcmcia-support \
  111. --enable-umount-helper \
  112. --disable-console-kit \
  113. --disable-policy-kit \
  114. --disable-acpi-ibm \
  115. --disable-smbios \
  116. --enable-parted \
  117. --enable-acpi-toshiba \
  118. --without-usb-csr \
  119. --without-cpufreq \
  120. --with-eject=/usr/sbin/eject
  121. %__make %{?_smp_mflags}
  122. %install
  123. rm -rf %{buildroot}
  124. make install DESTDIR=$RPM_BUILD_ROOT
  125. rm -f $RPM_BUILD_ROOT%{_libdir}/*.{a,la}
  126. %clean
  127. rm -rf $RPM_BUILD_ROOT
  128. %pre
  129. # Add the "haldaemon" user
  130. /usr/sbin/useradd -c 'HAL daemon' -u %{hal_user_uid} \
  131. -s /sbin/nologin -r -d '/' haldaemon 2> /dev/null || :
  132. %post
  133. /sbin/ldconfig
  134. /sbin/chkconfig --add haldaemon
  135. %preun
  136. if [ $1 = 0 ]; then
  137. service haldaemon stop > /dev/null 2>&1
  138. /sbin/chkconfig --del haldaemon
  139. fi
  140. %postun
  141. /sbin/ldconfig
  142. #if [ "$1" -ge "1" ]; then
  143. # service haldaemon condrestart > /dev/null 2>&1
  144. #fi
  145. %triggerpostun -- hal < 0.5.7
  146. #remove lingering fstab-sync entries from /etc/fstab
  147. /bin/cp -f /etc/fstab /etc/fstab.hal-save
  148. (IFS="
  149. "; while read line; do echo $line | awk '{print $4}' | grep -q managed || echo $line | grep -q "^#.*fstab-sync" || echo $line; done < /etc/fstab > fstab.replace)
  150. if [ -s fstab.replace ]; then
  151. /bin/cp -f fstab.replace /etc/fstab
  152. fi
  153. %triggerpostun -- hal < 0.5.11-3
  154. # reset priorities
  155. if [ -f /etc/rc3.d/S98haldaemon ]; then
  156. /sbin/chkconfig haldaemon resetpriorities
  157. fi
  158. %files
  159. %defattr(-,root,root,-)
  160. %doc AUTHORS COPYING ChangeLog HACKING INSTALL README NEWS
  161. #doc examples
  162. %dir %{_sysconfdir}/dbus-1/system.d
  163. %{_sysconfdir}/dbus-1/system.d/*
  164. %config %{_sysconfdir}/rc.d/init.d/haldaemon
  165. %dir %{_sysconfdir}/hal
  166. %{_sysconfdir}/hal/*
  167. /sbin/umount.hal
  168. %{_sbindir}/hald
  169. %{_bindir}/*
  170. %{_libexecdir}/*
  171. %{_libdir}/*hal*.so.*
  172. %dir %{_datadir}/hal
  173. %dir %{_datadir}/hal/fdi
  174. %{_datadir}/hal/fdi/*
  175. %{_mandir}/man1/*
  176. %{_mandir}/man8/*
  177. %{_sysconfdir}/udev/rules.d/90-hal.rules
  178. %attr(0700,haldaemon,haldaemon) %dir %{_localstatedir}/cache/hald
  179. %attr(0700,haldaemon,haldaemon) %dir %{_localstatedir}/run/hald
  180. %files devel
  181. %defattr(-,root,root)
  182. %{_libdir}/lib*.so
  183. %{_libdir}/pkgconfig/*
  184. %{_includedir}/*
  185. %{_datadir}/gtk-doc/html/*
  186. #%files gnome
  187. #%defattr(-,root,root)
  188. #%dir %{_datadir}/hal/device-manager
  189. #%{_datadir}/hal/device-manager/*
  190. #%{_bindir}/hal-device-manager
  191. #%{_datadir}/applications/*.desktop
  192. %changelog
  193. * Sat Dec 25 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.14-1
  194. - update to 0.5.14
  195. - delete Patch12 (hal-mdfind.patch)
  196. * Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.13-6
  197. - add BuildRequires: zlib-devel
  198. * Tue Nov 9 2010 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.5.13-5
  199. - rebuilt with parted 2.3
  200. * Wed Sep 22 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.13-4
  201. - rebuilt with rpm-4.8.1 for pkg-config
  202. * Mon Feb 08 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.13-3
  203. - add BuildRequires: libuuid-devel
  204. * Fri Feb 05 2010 Shu KONNO <owa@bg.wakwak.com> 0.5.13-2
  205. - rebuilt with python-2.6.4-3
  206. * Wed Oct 14 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.13-1
  207. - new upstream release
  208. - merge patches from fedora
  209. - disable ConsoleKit and PolicyKit support
  210. - disable acl management, this is now handled by udev
  211. - disable csr,ibm and cpufreq which is obsolete.
  212. * Sat Oct 03 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.5.12-2.rc1
  213. - add patch11 to disable acl for unpartitioned volumes (such as audio CDs)
  214. ([vine-users:079605])
  215. * Sat Jul 04 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 0.5.12-1.rc1
  216. - added BuildRequires: e2fsprogs-devel
  217. * Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.12-0.rc1
  218. - update to 0.5.12rc1
  219. - add patch5 to allow introspection and Device.KillSwitch access
  220. https://bugs.freedesktop.org/show_bug.cgi?id=18985
  221. * Wed Dec 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.11-6
  222. - rebuild with udev-135-1
  223. * Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.11-5
  224. - add 10-x11-input.fdi again
  225. - add patch10 to disable x11 keyaboard hotplugging
  226. * Tue Aug 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.11-4
  227. - rebuild with parted-1.8.8
  228. - add BuildRequires: util-linux-ng instead of util-linux
  229. * Mon Aug 04 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.11-3
  230. - rebuild with new ConsoleKit/PolicyKit
  231. - change start/stop priority earlier
  232. * Mon Jun 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.11-2
  233. - spec in UTF-8
  234. - Drop 99-redhat-storage-policy-fixed-drives.fdi; this is now
  235. controlled by PolicyKit
  236. - Remove /usr/share/hal/fdi/policy/10osvendor/10-x11-input.fdi which
  237. effectively disables xorg input hotplugging again: this is only a
  238. temporary workaround until a better solution is available
  239. (see: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=447666)
  240. * Sat May 24 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.5.11-1
  241. - updated to 0.5.11
  242. - drop gnome subpackage - obsoleted in the upstream
  243. (but separated into gnome-desktop-manager)
  244. - drop use of find_lang - all translations dropped in the upstream
  245. * Sat Mar 08 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.5.9-0vl5
  246. - add Patch1001 to get proper LCD max brightness with pcc-acpi.
  247. * Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.5.9-0vl4
  248. - rebuild with expat-2.0.1
  249. - add BuildRequires: dbus-glib-devel >= %%{dbus_glib_version}
  250. - update %%{SOURCE2} (drop extension from Icon entry)
  251. * Thu Oct 11 2007 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.5.9-0vl3
  252. - add Patch600 to fix severe memory leak on the system with apm
  253. initially discussed at:
  254. https://bugzilla.redhat.com/show_bug.cgi?id=244995
  255. then more comprehensive fixes posted at:
  256. http://lists.freedesktop.org/archives/hal/2007-September/009642.html
  257. * Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.9-0vl2
  258. - add Requires: hal-info
  259. * Fri Apr 27 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.9-0vl1
  260. - new upstream release
  261. - add Patch1000 to revert kernel-2.6.17 specific changes
  262. * Thu Apr 26 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7.1-0vl4
  263. - rebuild with dbus-1.0
  264. * Sat Nov 25 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.7.1-0vl3
  265. - changed hal-gnome Group to Applications/System
  266. * Wed Sep 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7.1-0vl2
  267. - add Patch10 to detecting usb optical drives
  268. (https://bugs.freedesktop.org/show_bug.cgi?id=5558)
  269. * Fri Jul 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7.1-0vl1
  270. - new upstream release
  271. - add Patch1 to fix confusing lid state. (<BTS:0091>)
  272. * Wed Mar 15 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl3
  273. - add Source1 for workaround policy file to ignore fixed
  274. (non-hotpluggable) disk from FC.
  275. * Mon Mar 13 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl2
  276. - do not restart haldaemon in %%postun script
  277. * Mon Mar 06 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.7-0vl1
  278. - new upstream release
  279. - disable fstab-sync, clear fstab-sync entries from fstab
  280. - import changes from FC
  281. * Mon Oct 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl2
  282. - remove Requires: gnome-python-* from hal-gnome
  283. gnome-python sub packages are obsoleted.
  284. * Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.4-0vl1
  285. - new upstream release
  286. * Wed Jul 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.3-0vl1
  287. - new upstream release
  288. - add Requires: pygtk2-libglade for hal-gnome
  289. * Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.5.2-0vl1
  290. - new upstream release
  291. - import patches from FC
  292. * Sun Mar 20 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4.7-2vl1
  293. - initiual build for Vine Linux based on FC package.
  294. * Thu Jan 27 2005 David Zeuthen <davidz@redhat.com> 0.4.7-2
  295. - Add patch that should close #146316
  296. * Mon Jan 24 2005 David Zeuthen <davidz@redhat.com> 0.4.7-1
  297. - New upstream release.
  298. - Should close #145921, #145750, #145293, #145256
  299. * Mon Jan 24 2005 John (J5) Palmieri <johnp@redhat.com> 0.4.6-3
  300. - Update required dbus version to 0.23
  301. * Thu Jan 20 2005 David Zeuthen <davidz@redhat.com> 0.4.6-2
  302. - Fix parameters to configure
  303. * Thu Jan 20 2005 David Zeuthen <davidz@redhat.com> 0.4.6-1
  304. - New upstream release
  305. - Should close #145099, #144600, #140150, #145223, #137672
  306. * Wed Jan 12 2005 David Zeuthen <davidz@redhat.com> 0.4.5-1
  307. - New upstream release.
  308. - Should close #142834, #141771, #142183
  309. * Fri Dec 12 2004 David Zeuthen <davidz@redhat.com> 0.4.2.cvs20041210-1
  310. - Snapshot from stable branch of upstream CVS
  311. * Tue Oct 26 2004 David Zeuthen <davidz@redhat.com> 0.4.0-8
  312. - Forgot to add some diffs in hal-0.4.0-pcmcia-net-support.patch
  313. * Tue Oct 26 2004 David Zeuthen <davidz@redhat.com> 0.4.0-7
  314. - Change default policy such that non-hotpluggable fixed disks are not
  315. added to the /etc/fstab file because a) ATARAID detection in hal is
  316. incomplete (e.g. RAID members from ATARAID controllers might be added
  317. to /etc/fstab); and b) default install wont corrupt multiboot
  318. systems on fixed drives (#137072)
  319. * Tue Oct 26 2004 David Zeuthen <davidz@redhat.com> 0.4.0-6
  320. - Fix hotplug timeout handling (#136626)
  321. - Detect ATARAID devices and do not add /etc/fstab entry for them
  322. - Probe for ext3 before ntfs (#136966)
  323. - Use fstype 'auto' for optical drives instead of 'iso9660,udf'
  324. - Properly detect wireless ethernet devices (#136591)
  325. - Support 16-bit PCMCIA networking devices (by Dan Williams) (#136658)
  326. * Tue Oct 19 2004 David Zeuthen <davidz@redhat.com> 0.4.0-5
  327. - Make hal work with PCMCIA IDE hotpluggable devices (#133943)
  328. - Fixup URL listed from rpm -qi (#136396)
  329. - Add Portuguese translations for hal
  330. - Fix addition of Russian and Hungarian translations
  331. * Mon Oct 18 2004 David Zeuthen <davidz@redhat.com> 0.4.0-4
  332. - Make hald cope with missing hotplug events from buggy drivers (#135202)
  333. - Fix the order of mount options in fstab-sync (#136191)
  334. - Allow x86 legacy floppy drives in default policy (#133777)
  335. - Fix fstab-sync crashing without any options and not run from hald (#136214)
  336. - man page for fstab-sync references non-existing files (#136026)
  337. - Add Russian translations for hal (#135853)
  338. - Add Hungarian translations for hal
  339. * Fri Oct 15 2004 David Zeuthen <davidz@redhat.com> 0.4.0-3
  340. - Fix bad use of O_NONBLOCK as the 2.6.8-1.624 kernel exposes this (#135886)
  341. - Never use the UUID as mount point candidate in the default policy
  342. as it is unfriendly (#135907)
  343. - Fix a trivial bug in fstab-sync so the syslog messages actually expose
  344. the device name instead of just the word foo
  345. * Thu Oct 14 2004 David Zeuthen <davidz@redhat.com> 0.4.0-2
  346. - Fix issue with fstab-sync not cleaning /etc/fstab on startup
  347. * Thu Oct 14 2004 David Zeuthen <davidz@redhat.com> 0.4.0-1
  348. - Update to upstream stable version 0.4.0
  349. - Remove patch for libhal shutdown since that is now upstream
  350. - fstab-sync: man page, adds comment in /etc/fstab pointing to man page
  351. * Fri Oct 01 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040929-3
  352. - Fix a bug so libhal actually invoke callback functions when needed
  353. * Fri Oct 01 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.98.cvs20040929-2
  354. - Use "user" mount flag for now until "pamconsole" flag gets into mount
  355. * Wed Sep 29 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040929-1
  356. - Update to upstream CVS version
  357. - Enable libselinux again
  358. * Mon Sep 27 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040927-1
  359. - Update to upstream CVS version
  360. * Fri Sep 24 2004 David Zeuthen <davidz@redhat.com> 0.2.98.cvs20040923-1
  361. - Update to upstream CVS release
  362. - Include libhal-storage library
  363. - Should close bug #132876
  364. * Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-4
  365. - Rebuilt
  366. * Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-3
  367. - Rebuilt
  368. * Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-2
  369. - Temporarily disable explicit requirement for libselinux
  370. * Mon Sep 20 2004 David Zeuthen <davidz@redhat.com> 0.2.98-1
  371. - Update to upstream release 0.2.98.
  372. - Use --with-pid-file so we don't depend on /etc/redhat-release
  373. * Wed Sep 01 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040901-1
  374. - Update to upstream CVS HEAD
  375. * Tue Aug 31 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040831-3
  376. - Add UID for haldaemon user
  377. * Tue Aug 31 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040831-2
  378. - Rebuilt with a newer snapshot.
  379. * Fri Aug 27 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040827-3
  380. - Rebuilt
  381. * Fri Aug 27 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040827-2
  382. - Rebuilt
  383. - Closes RH Bug #130971
  384. * Fri Aug 27 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040827-1
  385. - Update to upstream CVS HEAD.
  386. - Should close RH Bug #130588
  387. * Wed Aug 25 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040823-3
  388. - Rebuilt
  389. * Wed Aug 25 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040823-2
  390. - Apply a patch so hald doesn't hang on startup.
  391. * Mon Aug 23 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040823-1
  392. - Update to upstream CVS HEAD
  393. - Remove symlinking of fstab-sync from specfile since this is now being
  394. done in the package
  395. * Mon Aug 23 2004 Florian La Roche <Florian.LaRoche@redhat.de>
  396. - change the %%define names to not use "-"
  397. * Thu Aug 19 2004 David Zeuthen <davidz@redhat.com> 0.2.97.cvs20040819-1
  398. - Update to upstream CVS HEAD
  399. - Remove suid patch as it is fixed upstream
  400. - Fix some dependency issues (RH Bug #130202)
  401. * Wed Aug 18 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.97-2
  402. - Add stopgap patch to remove suid from mount flags (RH Bug #130290)
  403. * Mon Aug 16 2004 David Zeuthen <davidz@redhat.com> 0.2.97-1
  404. - update to upstream release 0.2.97
  405. - use kudzu option in fstab-sync since updfstab is now disabled
  406. * Thu Aug 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.96-2
  407. - fixed Requires lines to use %{} instead of ${}
  408. - made dbus related requires lines use the = condition instead of =<
  409. because the dbus API is still in flux
  410. * Thu Aug 12 2004 David Zeuthen <davidz@redhat.com> 0.2.96
  411. - Update to upstream release 0.2.96
  412. - Symlink fstab-sync into /etc/hal/device.d on install
  413. * Fri Aug 06 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.95.cvs20040802-2
  414. - Base hal package no longer requires python
  415. * Mon Aug 02 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.95.cvs20040802-1
  416. - Update to CVS head
  417. - Remove Dan's patches as they were commited to CVS
  418. * Fri Jul 30 2004 Dan Williams <dcbw@redhat.com> 0.2.93.cvs.20040712-2
  419. - Fix netlink sockets pointer arithmetic bug
  420. * Mon Jul 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.93.cvs.20040712-1
  421. - Update to new CVS version as of 7-12-2004
  422. * Fri Jun 25 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.92.cvs.20040611-2
  423. - take out fstab-update.sh from install
  424. - add to rawhide
  425. * Fri Jun 11 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.92.cvs.20040611-1
  426. - update to CVS head as of 6-11-2004 which contains dcbw's
  427. network link status fix
  428. * Wed Jun 9 2004 Ray Strode <rstrode@redhat.com> 0.2.91.cvs20040527-2
  429. - added dependency on udev
  430. * Wed May 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.91.cvs20040527-1
  431. - update to CVS head as of 5-27-2004 which contains fixes for PCMCIA
  432. and wireless network devices.
  433. * Wed May 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90.cvs20040511-3
  434. - added hal-0.2.90.cvs20040511.callbackscripts.patch which installs
  435. the file system mounting script in /etc/hal/device.d
  436. * Wed May 12 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90.cvs20040511-2
  437. - added the %{_sysconfigdir}/hal directory tree to %files
  438. * Tue May 11 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90.cvs20040511-1
  439. - update to CVS head as of 5-11-2004
  440. * Wed May 5 2004 Christopher Blizzard <blizzard@redhat.com> 0.2.90-2
  441. - Install hal.dev from /etc/dev.d/default/
  442. * Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> 0.2.90-1
  443. - upstream update
  444. * Mon Apr 19 2004 John (J5) Palmieri <johnp@redhat.com> 0.2-1
  445. - initial checkin to package repository
  446. - added dependency to the dbus-python package
  447. - added %{_libexecdir}/hal.dev to teh %files section