stunnel-vl.spec 15 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488
  1. %define ver 5.25
  2. %define rel 1
  3. Summary: An SSL-encrypting socket wrapper
  4. Name: stunnel
  5. Version: %{ver}
  6. Release: %{rel}%{?_dist_release}
  7. License: GPLv2
  8. Group: Applications/Internet
  9. URL: https://www.stunnel.org/
  10. Source0: https://www.stunnel.org/downloads/stunnel-%{version}.tar.gz
  11. Source1: https://www.stunnel.org/downloads/stunnel-%{version}.tar.gz.asc
  12. Source2: Certificate-Creation
  13. Source3: sfinger.xinetd
  14. Source4: stunnel-sfinger.conf
  15. Source5: pop3-redirect.xinetd
  16. Source6: stunnel-pop3s-client.conf
  17. Source100: stunnel.init
  18. Patch0: stunnel-5.25-authpriv.patch
  19. Patch1: stunnel-5.25-config.patch
  20. Buildroot: %{_tmppath}/stunnel-root
  21. # util-linux is needed for rename
  22. BuildRequires: openssl-devel
  23. BuildRequires: pkgconfig
  24. BuildRequires: tcp_wrappers
  25. BuildRequires: util-linux
  26. Vendor: Project Vine
  27. Distribution: Vine Linux
  28. Packager: iwaim
  29. %description
  30. Stunnel is a socket wrapper which can provide SSL (Secure Sockets
  31. Layer) support to ordinary applications. For example, it can be used
  32. in conjunction with imapd to create an SSL secure IMAP server.
  33. %prep
  34. %setup -q
  35. %patch0 -p1 -b .authpriv
  36. %patch1 -p1 -b .config
  37. %build
  38. CFLAGS="$RPM_OPT_FLAGS -fPIC"; export CFLAGS
  39. if pkg-config openssl ; then
  40. CFLAGS="$CFLAGS `pkg-config --cflags openssl`";
  41. LDFLAGS="`pkg-config --libs-only-L openssl`"; export LDFLAGS
  42. fi
  43. %configure --disable-fips --enable-ipv6 \
  44. CPPFLAGS="-UPIDFILE -DPIDFILE='\"%{_localstatedir}/run/stunnel.pid\"'"
  45. make LDADD="-pie -Wl,-z,defs,-z,relro,-z,now"
  46. %install
  47. rm -rf $RPM_BUILD_ROOT
  48. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/conf.d
  49. touch $RPM_BUILD_ROOT%{_sysconfdir}/stunnel/stunnel.pem
  50. make install DESTDIR=$RPM_BUILD_ROOT
  51. # Move the translated man pages to the right subdirectories, and strip off the
  52. # language suffixes.
  53. for lang in pl ; do
  54. mkdir -p $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8
  55. mv $RPM_BUILD_ROOT/%{_mandir}/man8/*.${lang}.8* $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8/
  56. rename ".${lang}" "" $RPM_BUILD_ROOT/%{_mandir}/${lang}/man8/*
  57. done
  58. install -d -m755 %{buildroot}%{_initdir}
  59. install -m755 %{SOURCE100} %{buildroot}%{_initdir}/stunnel
  60. install -d m755 %{buildroot}%{_sysconfdir}/sysconfig
  61. cat <<EOF > %{buildroot}%{_sysconfdir}/sysconfig/stunnel
  62. ENABLED=0
  63. EOF
  64. mkdir -p srpm-docs
  65. cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} %{SOURCE6} srpm-docs
  66. %clean
  67. rm -rf $RPM_BUILD_ROOT
  68. %pre
  69. getent group stunnel >/dev/null || groupadd -r stunnel
  70. getent passwd stunnel >/dev/null || \
  71. useradd -r -g stunnel -d /dev/null -s /sbin/nologin \
  72. -c "stunnel service account" stunnel
  73. %post
  74. /sbin/chkconfig --add stunnel
  75. %preun
  76. if [ $1 -eq 0 ]; then
  77. /sbin/chkconfig --del stunnel
  78. fi
  79. %files
  80. %defattr(-,root,root)
  81. %doc AUTHORS BUGS ChangeLog COPY* CREDITS PORTS README TODO
  82. %doc tools/stunnel.conf-sample
  83. %doc srpm-docs/*
  84. %lang(en) %doc doc/en/*
  85. %lang(po) %doc doc/pl/*
  86. %{_bindir}/stunnel
  87. %{_initdir}/stunnel
  88. %exclude %{_bindir}/stunnel3
  89. %exclude %{_datadir}/doc/stunnel
  90. %{_libdir}/stunnel
  91. %exclude %{_libdir}/stunnel/libstunnel.la
  92. %{_mandir}/man8/stunnel.8*
  93. %lang(pl) %{_mandir}/pl/man8/stunnel.8*
  94. %dir %{_sysconfdir}/%{name}
  95. %dir %{_sysconfdir}/%{name}/conf.d
  96. %exclude %{_sysconfdir}/stunnel/stunnel.conf-sample
  97. %exclude %{_sysconfdir}/stunnel/stunnel.pem
  98. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  99. %changelog
  100. * Fri Nov 6 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.25-1
  101. - new upstream release.
  102. - fixed dates in %%changelog.
  103. - updated all patches.
  104. * Tue Jan 15 2013 IWAI, Masaharu <iwai@alib.jp> 4.54-1
  105. - initial build for Vine Linux
  106. *Mon Dec 10 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.54-2
  107. - 884183: support for full relro.
  108. *Tue Oct 16 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.54-1
  109. - New upstream realease 4.54
  110. - Updated local patches
  111. * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.53-2
  112. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  113. * Mon May 14 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.53-1
  114. - New upstream realease 4.53
  115. - Updated local patches
  116. * Tue Mar 6 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.52-1
  117. - New upstream realease 4.52
  118. - Updated local patches
  119. * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.50-2
  120. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  121. * Tue Jan 3 2012 Avesh Agarwal <avagarwa@redhat.com> - 4.50-1
  122. - New upstream realease 4.50
  123. - Updated local patches
  124. * Tue Sep 20 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.44-1
  125. - New upstream realease 4.44
  126. - Updated local patches
  127. * Fri Aug 19 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.42-1
  128. - New upstream realease 4.42
  129. - Updated local patches
  130. - Fixes #732069
  131. * Mon Aug 1 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.41-1
  132. - New upstream realease 4.41
  133. - Updated local patches to match the new release
  134. * Tue Jun 28 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.37-1
  135. - New upstream realease 4.37
  136. - Updated local patches to match the new release
  137. * Mon Apr 4 2011 Avesh Agarwal <avagarwa@redhat.com> - 4.35-1
  138. - New upstream realease 4.35
  139. - Updated authpriv and sample patches to match the new release
  140. * Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.34-2
  141. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  142. * Mon Oct 4 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.34-1
  143. - New upstream realease 4.34
  144. - Updated authpriv and sample patches to match the new release
  145. * Wed Apr 7 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.33-1
  146. - New upstream realease 4.33
  147. - Updated authpriv and sample patches to match the new release
  148. - Addresses bz 580117 (inted mode support issue)
  149. * Mon Mar 29 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.32-1
  150. - New upstream realease 4.32
  151. - Updated authpriv and sample patches to match the new release
  152. * Tue Feb 16 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.31-1
  153. - New upstream realease 4.31
  154. - Updated authpriv and sample patches to match the new release
  155. * Tue Jan 26 2010 Avesh Agarwal <avagarwa@redhat.com> - 4.30-1
  156. - New upstream realease 4.30
  157. - Updated authpriv and sample patches for the new release
  158. * Wed Dec 09 2009 Avesh Agarwal <avagarwa@redhat.com> - 4.29-1
  159. - New upstream realease 4.29
  160. - Updated authpriv and sample patches for the new release
  161. - Modified spec file to include dist tag
  162. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 4.27-5
  163. - rebuilt with new openssl
  164. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.27-4
  165. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  166. * Sun May 3 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-3
  167. - Fix the previous patch.
  168. * Wed Apr 29 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-2
  169. - Avoid aliasing undefined by ISO C
  170. * Thu Apr 16 2009 Miloslav Trmač <mitr@redhat.com> - 4.27-1
  171. - Update to stunnel-4.27.
  172. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.26-3
  173. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  174. * Sun Jan 18 2009 Tomas Mraz <tmraz@redhat.com> - 4.26-2
  175. - disable openssl upstream fips mode
  176. * Mon Sep 22 2008 Miloslav Trmač <mitr@redhat.com> - 4.26-1
  177. - Update to stunnel-4.26.
  178. * Sun Jun 8 2008 Miloslav Trmač <mitr@redhat.com> - 4.25-2
  179. - Use a clearer error message if the service name is unknown in "accept"
  180. Resolves: #450344
  181. * Mon Jun 2 2008 Miloslav Trmač <mitr@redhat.com> - 4.25-1
  182. - Update to stunnel-4.25
  183. * Tue May 20 2008 Miloslav Trmač <mitr@redhat.com> - 4.24-2
  184. - Drop stunnel3
  185. Resolves: #442842
  186. * Mon May 19 2008 Miloslav Trmač <mitr@redhat.com> - 4.24-1
  187. - Update to stunnel-4.24
  188. * Fri Mar 28 2008 Miloslav Trmač <mitr@redhat.com> - 4.22-1
  189. - Update to stunnel-4.22
  190. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 4.20-6
  191. - Autorebuild for GCC 4.3
  192. * Tue Dec 4 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-5
  193. - Rebuild with openssl-0.9.8g
  194. * Tue Oct 16 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-4
  195. - Revert the port to NSS, wait for NSS-based stunnel 5.x instead
  196. Resolves: #301971
  197. - Mark localized man pages with %%lang (patch by Ville Skyttä)
  198. Resolves: #322281
  199. * Tue Aug 28 2007 Miloslav Trmač <mitr@redhat.com> - 4.20-3.nss
  200. - Port to NSS
  201. * Mon Dec 4 2006 Miloslav Trmac <mitr@redhat.com> - 4.20-2
  202. - Update BuildRequires for the separate tcp_wrappers-devel package
  203. * Thu Nov 30 2006 Miloslav Trmac <mitr@redhat.com> - 4.20-1
  204. - Update to stunnel-4.20
  205. * Sat Nov 11 2006 Miloslav Trmac <mitr@redhat.com> - 4.19-1
  206. - Update to stunnel-4.19
  207. * Wed Oct 25 2006 Miloslav Trmac <mitr@redhat.com> - 4.18-1
  208. - Update to stunnel-4.18
  209. - Remove unused stunnel.cnf from the src.rpm
  210. - Fix some rpmlint warnings
  211. * Fri Aug 18 2006 Jesse Keating <jkeating@redhat.com> - 4.15-2
  212. - rebuilt with latest binutils to pick up 64K -z commonpagesize on ppc*
  213. (#203001)
  214. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 4.15-1.1
  215. - rebuild
  216. * Sat Mar 18 2006 Miloslav Trmac <mitr@redhat.com> - 4.15-1
  217. - Update to stunnel-4.15
  218. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 4.14-3.2
  219. - bump again for double-long bug on ppc(64)
  220. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 4.14-3.1
  221. - rebuilt for new gcc4.1 snapshot and glibc changes
  222. * Tue Jan 31 2006 Miloslav Trmac <mitr@redhat.com> - 4.14-3
  223. - Use pthread threading to fix crash on x86_64 (#179236)
  224. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  225. - rebuilt
  226. * Wed Nov 9 2005 Miloslav Trmac <mitr@redhat.com> - 4.14-2
  227. - Rebuild with newer openssl
  228. * Thu Nov 3 2005 Miloslav Trmac <mitr@redhat.com> - 4.14-1
  229. - Update to stunnel-4.14
  230. - Override changed default pid file location, keep it in %%{_localstatedir}/run
  231. * Sat Oct 22 2005 Miloslav Trmac <mitr@redhat.com> - 4.13-1
  232. - Update to stunnel-4.13
  233. * Fri Sep 30 2005 Miloslav Trmac <mitr@redhat.com> - 4.12-1
  234. - Update to stunnel-4.12
  235. * Thu Sep 22 2005 Miloslav Trmac <mitr@redhat.com> - 4.11-2
  236. - Enable IPv6 (#169050, patch by Peter Bieringer)
  237. - Don't ship another copy of man pages in HTML
  238. * Tue Jul 12 2005 Miloslav Trmac <mitr@redhat.com> - 4.11-1
  239. - Update to stunnel-4.11
  240. - Fix int/size_t mismatches in stack_info ()
  241. - Update Certificate-Creation for /etc/pki
  242. * Wed Jun 1 2005 Miloslav Trmac <mitr@redhat.com> - 4.10-2
  243. - Fix inetd mode
  244. - Remove unnecessary Requires: and BuildRequires:
  245. - Clean up the spec file
  246. * Tue Apr 26 2005 Nalin Dahyabhai <nalin@redhat.com> 4.10-1
  247. - update to 4.10
  248. * Tue Apr 26 2005 Nalin Dahyabhai <nalin@redhat.com> 4.08-2
  249. - add buildprereqs on libtool, util-linux; change textutils/fileutils dep to
  250. coreutils (#133961)
  251. * Wed Mar 16 2005 Nalin Dahyabhai <nalin@redhat.com> 4.08-1
  252. - update to 4.08
  253. - build stunnel as a PIE binary
  254. * Mon Nov 22 2004 Miloslav Trmac <mitr@redhat.com> - 4.05-4
  255. - Convert man pages to UTF-8
  256. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  257. - rebuilt
  258. * Thu May 27 2004 Nalin Dahyabhai <nalin@redhat.com> 4.05-2
  259. - move the sample configuration to %%doc, it shouldn't be used as-is (#124373)
  260. * Thu Mar 11 2004 Nalin Dahyabhai <nalin@redhat.com> 4.05-1
  261. - update to 4.05
  262. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  263. - rebuilt
  264. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  265. - rebuilt
  266. * Thu Aug 7 2003 Elliot Lee <sopwith@redhat.com> 4.04-6
  267. - Fix libtool
  268. * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
  269. - rebuilt
  270. * Fri Mar 21 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-4
  271. - fix xinetd configuration samples
  272. * Mon Feb 10 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-3
  273. - rebuild
  274. * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
  275. - rebuilt
  276. * Wed Jan 15 2003 Nalin Dahyabhai <nalin@redhat.com> 4.04-1
  277. - update to 4.04
  278. * Tue Jan 7 2003 Nalin Dahyabhai <nalin@redhat.com> 4.03-1
  279. - use pkgconfig for information about openssl, if available
  280. * Fri Jan 3 2003 Nalin Dahyabhai <nalin@redhat.com>
  281. - update to 4.03
  282. * Mon Oct 21 2002 Nalin Dahyabhai <nalin@redhat.com> 4.02-1
  283. - update to 4.02
  284. * Fri Oct 4 2002 Nalin Dahyabhai <nalin@redhat.com> 4.00-1
  285. - don't create a dummy cert
  286. * Wed Sep 25 2002 Nalin Dahyabhai <nalin@redhat.com>
  287. - update to 4.00
  288. - remove textutils and fileutils as buildreqs, add automake/autoconf
  289. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  290. - automated rebuild
  291. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  292. - automated rebuild
  293. * Fri May 17 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-2
  294. - rebuild in new environment
  295. * Wed Jan 2 2002 Nalin Dahyabhai <nalin@redhat.com> 3.22-1
  296. - update to 3.22, correcting a format-string vulnerability
  297. * Wed Oct 31 2001 Nalin Dahyabhai <nalin@redhat.com> 3.21a-1
  298. - update to 3.21a
  299. * Tue Aug 28 2001 Nalin Dahyabhai <nalin@redhat.com> 3.20-1
  300. - log using LOG_AUTHPRIV facility by default (#47289)
  301. - make permissions on stunnel binary 0755
  302. - implicitly trust certificates in %%{_datadir}/ssl/trusted (#24034)
  303. * Fri Aug 10 2001 Nalin Dahyabhai <nalin@redhat.com> 3.19-1
  304. - update to 3.19 to avoid problems with stunnel being multithreaded, but
  305. tcp wrappers not being thrad-safe
  306. * Mon Jul 30 2001 Nalin Dahyabhai <nalin@redhat.com>
  307. - update to 3.17
  308. * Mon Jul 23 2001 Nalin Dahyabhai <nalin@redhat.com>
  309. - update to 3.16
  310. * Mon Jul 16 2001 Nalin Dahyabhai <nalin@redhat.com>
  311. - update to 3.15
  312. - enable tcp-wrappers support
  313. * Tue May 29 2001 Nalin Dahyabhai <nalin@redhat.com>
  314. - remove explicit requirement on openssl (specific version isn't enough,
  315. we have to depend on shared library version anyway)
  316. * Fri Apr 27 2001 Nalin Dahyabhai <nalin@redhat.com>
  317. - update to 3.14
  318. * Mon Mar 26 2001 Preston Brown <pbrown@redhat.com>
  319. - depend on make (#33148)
  320. * Fri Mar 2 2001 Nalin Dahyabhai <nalin@redhat.com>
  321. - rebuild in new environment
  322. * Tue Feb 6 2001 Nalin Dahyabhai <nalin@redhat.com>
  323. - update to 3.13 to get pthread, OOB, 64-bit fixes
  324. - don't need sdf any more
  325. * Thu Dec 28 2000 Nalin Dahyabhai <nalin@redhat.com>
  326. - pull in sdf to build the man page (#22892)
  327. * Fri Dec 22 2000 Nalin Dahyabhai <nalin@redhat.com>
  328. - update to 3.11
  329. - chuck the SIGHUP patch (went upstream)
  330. - chuck parts of the 64-bit clean patch (went upstream)
  331. * Thu Dec 21 2000 Nalin Dahyabhai <nalin@redhat.com>
  332. - update to 3.10
  333. - more 64-bit clean changes, hopefully the last bunch
  334. * Wed Dec 20 2000 Nalin Dahyabhai <nalin@redhat.com>
  335. - change piddir from the default /var/stunnel to /var/run
  336. - clean out pid file on SIGHUP
  337. * Fri Dec 15 2000 Nalin Dahyabhai <nalin@redhat.com>
  338. - update to 3.9 to get a security fix
  339. * Wed Oct 25 2000 Matt Wilson <msw@redhat.com>
  340. - change all unsigned longs to u_int32_t when dealing with network
  341. addresses
  342. * Fri Aug 18 2000 Nalin Dahyabhai <nalin@redhat.com>
  343. - make stunnel.pem also be (missingok)
  344. * Thu Jun 29 2000 Nalin Dahyabhai <nalin@redhat.com>
  345. - move to Applications/Internet group
  346. - clean up %%post script
  347. - make stunnel.pem %%ghost %%config(noreplace)
  348. - provide a sample file for use with xinetd
  349. * Thu Jun 8 2000 Nalin Dahyabhai <nalin@redhat.com>
  350. - FHS compliance fixes
  351. - modify defaults
  352. * Tue Mar 14 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  353. - update to 3.8
  354. - do not create certificate if one already exists
  355. * Mon Feb 21 2000 Florian La Roche <Florian.LaRoche@redhat.com>
  356. - update to 3.7
  357. - add patch to find /usr/share/ssl
  358. - change some perms
  359. * Sat Oct 30 1999 Bernhard Rosenkraenzer <bero@redhat.com>
  360. - Modify spec file to match Red Hat standards
  361. * Thu Aug 12 1999 Damien Miller <damien@ibs.com.au>
  362. - Updated to 3.4a
  363. - Patched for OpenSSL 0.9.4
  364. - Cleaned up files section
  365. * Sun Jul 11 1999 Damien Miller <dmiller@ilogic.com.au>
  366. - Updated to 3.3
  367. * Sat Nov 28 1998 Damien Miller <dmiller@ilogic.com.au>
  368. - Initial RPMification