wine-vl.spec 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800801802803804805806807808809810811812813814815816817818819820821822823824825826827828
  1. %define pkg_major_version 1.8
  2. %define pkg_name wine
  3. %define pkg_release 1%{?_dist_release}
  4. # NEW Release: numbering rule. -- Release: 1%{?_dist_release}
  5. # spec file for package wine.. # base (SUSE10 and fedora core 9)
  6. Summary: Allows running Windows 16/32/64 bit programs on Unix.
  7. Summary(ja): Unix で 16/32/64ビットWindoowsプログラムを実行させます
  8. Name: %{pkg_name}
  9. Version: %{pkg_major_version}
  10. Release: %{pkg_release}
  11. URL: http://www.winehq.org/
  12. License: LGPLv2+
  13. Group: Applications/System
  14. #--------------------------------------------------------------------
  15. Source0: http://prdownloads.sourceforge.net/wine/%{name}-%{version}.tar.bz2
  16. #--------------------------------------------------------------------
  17. Source1: wine.init
  18. Source3: wine-README-Fedora
  19. Source4: wine-32.conf
  20. # desktop stuff
  21. Source100: wine-notepad.desktop
  22. Source101: wine-regedit.desktop
  23. Source102: wine-uninstaller.desktop
  24. Source103: wine-winecfg.desktop
  25. Source104: wine-winefile.desktop
  26. Source105: wine-winemine.desktop
  27. Source106: wine-winhelp.desktop
  28. Source107: wine-wineboot.desktop
  29. # desktop dir
  30. Source200: wine.menu
  31. Source201: wine.directory
  32. # mime types
  33. Source300: wine-mime-msi.desktop
  34. Patch0: wine-prefixfonts.patch
  35. Patch1: wine-1.1.28-rpath.patch
  36. Patch2: wine-1.7.40-x86_64_gstreamer.patch
  37. # ADD ja
  38. Source801: wine_README.ja
  39. Source803: wine-README-Fedora.ja
  40. Source804: wine_README_add.ja
  41. Source805: fonts-replace-list.txt
  42. Source806: ja_fonts_replace-js2ipa.reg
  43. Source807: ja_fonts_replace-js2vl.reg
  44. Source808: ja_fonts_replace-ms2ipa.reg
  45. Source809: ja_fonts_replace-ms2vl.reg
  46. Vendor: Project Vine
  47. Distribution: Vine Linux
  48. Packager: daisuke, Takemikaduchi
  49. ExclusiveArch: %{ix86} x86_64
  50. #--------------------------------------------------------------------
  51. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  52. #--------------------------------------------------------------------
  53. ## FedoraCore ##
  54. BuildRequires: bison, flex
  55. BuildRequires: audiofile, audiofile-devel
  56. BuildRequires: alsa-lib-devel
  57. BuildRequires: freeglut-devel, lcms-devel
  58. ## BuildRequires: libieee1284-devel
  59. BuildRequires: libjpeg-devel, libpng-devel
  60. BuildRequires: libstdc++-devel
  61. BuildRequires: libusb-devel
  62. BuildRequires: libxml2-devel, libxslt-devel
  63. BuildRequires: openldap-devel, ncurses-devel
  64. BuildRequires: unixODBC-devel, openssl-devel
  65. # BuildRequires: sane-devel
  66. BuildRequires: zlib-devel
  67. BuildRequires: desktop-file-utils
  68. BuildRequires: fontforge
  69. ## BuildRequires: gphoto2, gphoto2-devel
  70. ## BuildRequires: jack-audio-connection-kit-devel
  71. ## BuildRequires: isdn4k-utils-devel
  72. BuildRequires: cups-devel
  73. BuildRequires: dbus-devel
  74. BuildRequires: gstreamer-plugins-base-devel
  75. ## Requires: %{_bindir}/xmessage
  76. ## X modular(fc) > X 7.2
  77. BuildRequires: libX11-devel
  78. BuildRequires: mesa-libGL-devel
  79. BuildRequires: mesa-libGLU-devel
  80. BuildRequires: mesa-libOSMesa-devel
  81. BuildRequires: libXxf86dga-devel, libXxf86vm-devel
  82. BuildRequires: libXrandr-devel
  83. BuildRequires: libXrender-devel
  84. BuildRequires: libXext-devel
  85. BuildRequires: libXinerama-devel
  86. BuildRequires: libXcomposite-devel
  87. BuildRequires: libXmu-devel
  88. BuildRequires: libXi-devel
  89. BuildRequires: libXcursor-devel
  90. BuildRequires: fontconfig-devel
  91. BuildRequires: giflib-devel
  92. BuildRequires: libtiff-devel
  93. BuildRequires: pkgconfig
  94. BuildRequires: libicu-devel
  95. BuildRequires: freetype2-devel
  96. BuildRequires: lcms2-devel
  97. BuildRequires: gsm-devel
  98. %ifarch x86_64
  99. BuildRequires: compat32-glibc-devel
  100. BuildRequires: compat32-glibc-devel
  101. BuildRequires: compat32-libX11-devel
  102. BuildRequires: compat32-libxcb-devel
  103. BuildRequires: compat32-freetype2-devel
  104. BuildRequires: compat32-libSM-devel
  105. BuildRequires: compat32-libXext-devel
  106. BuildRequires: compat32-libXrender-devel
  107. BuildRequires: compat32-mesa-libGL-devel
  108. BuildRequires: compat32-mesa-libGLU-devel
  109. BuildRequires: compat32-mesa-libOSMesa-devel
  110. BuildRequires: compat32-libxml2-devel
  111. BuildRequires: compat32-libxslt-devel
  112. BuildRequires: compat32-openssl-devel
  113. BuildRequires: compat32-libjpeg-devel
  114. BuildRequires: compat32-libpng-devel
  115. BuildRequires: compat32-zlib-devel
  116. BuildRequires: compat32-alsa-lib-devel
  117. BuildRequires: compat32-dbus-devel
  118. BuildRequires: compat32-lcms2-devel
  119. BuildRequires: compat32-cups-devel
  120. BuildRequires: compat32-gnutls-devel
  121. BuildRequires: compat32-gstreamer-devel
  122. BuildRequires: compat32-gstreamer-plugins-base-devel
  123. BuildRequires: compat32-gsm-devel
  124. ## extension
  125. BuildRequires: compat32-libXcursor-devel
  126. BuildRequires: compat32-libXi-devel
  127. BuildRequires: compat32-libXxf86vm-devel
  128. BuildRequires: compat32-libXrandr-devel
  129. BuildRequires: compat32-libXinerama-devel
  130. BuildRequires: compat32-libXcomposite-devel
  131. BuildRequires: compat32-ncurses-devel
  132. BuildRequires: compat32-fontconfig-devel
  133. BuildRequires: compat32-libtiff-devel
  134. BuildRequires: compat32-openldap-devel
  135. Requires: compat32-freetype2
  136. Requires: compat32-ncurses
  137. %endif
  138. Requires(post): /sbin/ldconfig, /sbin/chkconfig, /sbin/service
  139. Requires(post): desktop-file-utils >= 0.8
  140. Requires(preun): /sbin/chkconfig, /sbin/service
  141. Requires(postun): /sbin/ldconfig
  142. Requires(postun): desktop-file-utils >= 0.8
  143. #--------------------------------------------------------------------
  144. %description
  145. (WINE Is Not an Emulator)
  146. While Wine is usually thought of as a Windows(TM) emulator,
  147. the Wine developers would prefer that users thought of
  148. Wine as a Windows compatibility layer for UNIX.
  149. This package includes a program loader, which allows
  150. unmodified Windows 3.x/9x/NT binaries to run on x86 and
  151. x86_64 Unixes.
  152. Wine does not require MS Windows, but it can use native
  153. system .dll files if they are available.
  154. %description -l ja
  155. (WINE Is Not an Emulator)
  156. WINEは普段、Windows(TM)のエミュレーターと考えられているが、WINEの
  157. 開発者達は、むしろユーザーが、「WINEはUnix環境のためのWindows
  158. 互換レイヤー」と考えてくれる事を好むでしょう。
  159. このパッケージはプログラムローダーを含み、これは未修正の
  160. Windows 3.x/9x/NT バイナリを x86 や x86_64 のUnix システムで動作
  161. させます。
  162. WINE は動作にあたって MS Windows を必要とはしませんが、ネイティブ
  163. Windows システムの .dll ファイルが存在するのならば、それを使用する
  164. 事もできます
  165. #--------------------------------------------------------------------
  166. %package devel
  167. Summary: Wine development environment
  168. Summary(ja): WINE の開発ファイルです
  169. Group: System Environment/Libraries
  170. Requires: wine = %{version}-%{release}
  171. %description devel
  172. This RPM contains the header files and development tools
  173. for the WINE libraries.
  174. %description devel -l ja
  175. WINEの開発用ライブラリやヘッダーファイル、そして開発用の
  176. アプリケーション(例:winebuild)のパッケージです
  177. (development packages)
  178. #--------------------------------------------------------------------
  179. %package init
  180. Summary: WINE binfmt_misc kernel function used for init file.
  181. Summary(ja): WINE で binfmt_misc機能 を使うための起動ファイルです
  182. Group: System Environment/Libraries
  183. Requires: wine = %{version}-%{release}
  184. %description init
  185. WINE binfmt_misc kernel function used for init file.
  186. WIN32-binary attribute run with a Linux-binary run the same way as possible.
  187. (init.d packages)
  188. ** example **
  189. Until now, "$ wine /file/to/path/arege.exe" and then you were running
  190. from the usual binary Linux as "$ /file/to/path/arege.exe"
  191. and just be able to run.
  192. Of course, please be mindful of security.
  193. %description init -l ja
  194. カーネルの binfmt_misc機能 をWINEで使うための initファイルです。
  195. 実行属性の付いた WIN32バイナリを Linuxバイナリと同じように実行できる
  196. ようにします。
  197. (init.d packages)
  198. ※ 例 ※
  199. これまで "$ wine /file/to/path/arege.exe" と入力してから実行していました
  200. が、通常の Linuxバイナリ のように "$ /file/to/path/arege.exe" とする
  201. だけで実行できるようになります。
  202. 無論、セキュリティに留意して下さい。
  203. #--------------------------------------------------------------------
  204. %prep
  205. %setup -q -n %{name}-%{version}
  206. %ifarch x86_64
  207. %patch2 -p1
  208. %endif
  209. # fix typo
  210. sed -i "s|Thamoa|Tahoma|" po/ja.po
  211. %build
  212. autoreconf -if
  213. %ifarch x86_64
  214. export CFLAGS="-O2 -m32 -march=i686 -mtune=generic -fasynchronous-unwind-tables -fno-strict-aliasing -fno-schedule-insns2"
  215. ./configure \
  216. --prefix=%{_prefix} \
  217. --libdir=%{_libdir} \
  218. --with-x \
  219. --without-jack \
  220. --without-capi \
  221. --without-gphoto \
  222. --without-hal \
  223. --without-mpg123 \
  224. --without-sane
  225. %else
  226. export CFLAGS="$RPM_OPT_FLAGS"
  227. %{configure} \
  228. --prefix=%{_prefix} \
  229. --with-x \
  230. --without-jack \
  231. --without-capi \
  232. --without-gphoto \
  233. --without-hal \
  234. --without-mpg123 \
  235. --without-sane
  236. %endif
  237. grep "have_x=yes" config.log || exit 1
  238. %{__make} depend
  239. %{__make} %{?_smp_mflags}
  240. %install
  241. rm -rf ${RPM_BUILD_ROOT}
  242. %{__make} install DESTDIR=${RPM_BUILD_ROOT}
  243. #-----------------------------------------------------------FC9
  244. mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/wine
  245. # Allow users to launch Windows programs by just clicking on the .exe file...
  246. mkdir -p ${RPM_BUILD_ROOT}%{_initrddir}
  247. install -p -c -m 755 %{SOURCE1} ${RPM_BUILD_ROOT}%{_initrddir}/wine
  248. # add wine dir to desktop
  249. mkdir -p ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged
  250. install -p -m 644 %{SOURCE200} \
  251. ${RPM_BUILD_ROOT}%{_sysconfdir}/xdg/menus/applications-merged/wine.menu
  252. mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/desktop-directories
  253. install -p -m 644 %{SOURCE201} \
  254. ${RPM_BUILD_ROOT}%{_datadir}/desktop-directories/Wine.directory
  255. ## mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/applications
  256. ## %%{_datadir}/applications
  257. # install desktop files
  258. desktop-file-install \
  259. --vendor=vine \
  260. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  261. %{SOURCE100}
  262. desktop-file-install \
  263. --vendor=vine \
  264. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  265. %{SOURCE101}
  266. desktop-file-install \
  267. --vendor=vine \
  268. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  269. %{SOURCE102}
  270. desktop-file-install \
  271. --vendor=vine \
  272. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  273. %{SOURCE103}
  274. desktop-file-install \
  275. --vendor=vine \
  276. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  277. %{SOURCE104}
  278. desktop-file-install \
  279. --vendor=vine \
  280. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  281. %{SOURCE105}
  282. desktop-file-install \
  283. --vendor=vine \
  284. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  285. %{SOURCE106}
  286. desktop-file-install \
  287. --vendor=vine \
  288. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  289. %{SOURCE107}
  290. desktop-file-install \
  291. --vendor=vine \
  292. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  293. --delete-original \
  294. ${RPM_BUILD_ROOT}/%{_datadir}/applications/wine.desktop
  295. #mime-types
  296. desktop-file-install \
  297. --vendor=vine \
  298. --dir=${RPM_BUILD_ROOT}/%{_datadir}/applications \
  299. %{SOURCE300}
  300. ## other files
  301. cp %{SOURCE3} README-Fedora
  302. cp %{SOURCE803} README-Fedora.ja
  303. cp %{SOURCE801} documentation/README.ja
  304. cp %{SOURCE804} documentation/README_add.ja
  305. cp %{SOURCE805} %{SOURCE806} %{SOURCE807} %{SOURCE808} %{SOURCE809} documentation/
  306. mkdir -p ${RPM_BUILD_ROOT}/%{_sysconfdir}/ld.so.conf.d/
  307. install -p -m644 %{SOURCE4} ${RPM_BUILD_ROOT}%{_sysconfdir}/ld.so.conf.d/
  308. # check desktop files
  309. %check
  310. desktop-file-validate \
  311. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-notepad.desktop
  312. desktop-file-validate \
  313. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-regedit.desktop
  314. desktop-file-validate \
  315. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-uninstaller.desktop
  316. desktop-file-validate \
  317. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winecfg.desktop
  318. desktop-file-validate \
  319. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winefile.desktop
  320. desktop-file-validate \
  321. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winemine.desktop
  322. desktop-file-validate \
  323. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-winhelp.desktop
  324. desktop-file-validate \
  325. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-wineboot.desktop
  326. desktop-file-validate \
  327. ${RPM_BUILD_ROOT}%{_datadir}/applications/vine-wine-mime-msi.desktop
  328. #--------------------------------------------------------------------
  329. %clean
  330. rm -rf ${RPM_BUILD_ROOT}
  331. %post
  332. /sbin/ldconfig
  333. update-desktop-database &>/dev/null || :
  334. ### add vinelinux
  335. if [ "$LANG" = "ja_JP.UTF-8" ]; then
  336. echo "WINEのシステムフォントをリプレースするには"
  337. echo " fonts-replace-list.txt をお読み下さい。"
  338. else
  339. echo "You need to Japanese fonts name replace, "
  340. echo "See fonts-replace-list.txt ."
  341. fi
  342. %postun
  343. /sbin/ldconfig
  344. update-desktop-database &>/dev/null || :
  345. %post init
  346. if [ $1 = 1 ]; then
  347. /sbin/chkconfig --add wine
  348. /sbin/chkconfig --level 2345 wine on
  349. /sbin/service wine start &>/dev/null || :
  350. fi
  351. ### add vinelinux
  352. if [ "$LANG" = "ja_JP.UTF-8" ]; then
  353. echo "WINE から binfmt_misc 機能を利用するための起動ファイルが"
  354. echo "インストールされ、ランレベル2、3、4、5で有効になりました。"
  355. echo "(ファイル名は /etc/init.d/wine です)"
  356. echo "起動時にファイルシステムのマウントが必要です。"
  357. echo "root権限で次のコマンドを使い、 /etc/fstab に追記して下さい。"
  358. echo "(削除も手動でお願いします)"
  359. echo ""
  360. echo "# cp /etc/fstab /etc/fstab.before ##バックアップの作成"
  361. echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
  362. echo "参照(Ja) http://opentechpress.jp/developer/article.pl?sid=06/08/24/0033257 "
  363. else
  364. echo "WINE binfmt_misc feature from the boot files "
  365. echo "to be installed and enabled 2,3,4,5 runlevel."
  366. echo "(File name in the /etc/init.d/wine )"
  367. echo "Filesystem mounted at boot time is required."
  368. echo "Root privileges using the following command in the /etc/fstab"
  369. echo "please Addenda.(Please delete manually.)"
  370. echo ""
  371. echo "# cp /etc/fstab /etc/fstab.before ##(Create backup)"
  372. echo "# echo 'none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0' >> /etc/fstab "
  373. echo "See also(en)http://www.linux.com/articles/56032 "
  374. fi
  375. %preun init
  376. if [ $1 = 0 ]; then
  377. /sbin/service wine stop >/dev/null 2>&1
  378. /sbin/chkconfig --del wine
  379. fi
  380. #--------------------------------------------------------------------
  381. ## deleted /usr/share/applications/wine.desktop
  382. %files
  383. %defattr(-,root,root,-)
  384. %doc ANNOUNCE AUTHORS COPYING.LIB LICENSE LICENSE.OLD
  385. %doc README VERSION
  386. %doc README-Fedora
  387. %doc README-Fedora.ja
  388. %doc documentation/README* documentation/ChangeLog*
  389. %doc documentation/ja_fonts_replace*
  390. %doc documentation/fonts-replace-list.txt
  391. ### %{_bindir}/*
  392. %{_bindir}/msiexec
  393. %{_bindir}/regedit
  394. %{_bindir}/regsvr32
  395. %{_bindir}/wine
  396. %{_bindir}/wineboot
  397. %{_bindir}/wineconsole
  398. ## %{_bindir}/wineprefixcreate
  399. %{_bindir}/winecfg
  400. %{_bindir}/wine-preloader
  401. # winelauncher --> Remove
  402. %{_bindir}/wineserver
  403. %{_bindir}/notepad
  404. %{_bindir}/winedbg
  405. %{_bindir}/winedump
  406. %{_bindir}/winefile
  407. %{_bindir}/winemaker
  408. %{_bindir}/winemine
  409. %{_bindir}/winepath
  410. ## winhelp -> renamed winhlp32.exe
  411. %{_sysconfdir}/xdg/menus/applications-merged/wine.menu
  412. %{_sysconfdir}/ld.so.conf.d/wine-32.conf
  413. %{_libdir}/libwine.so.1*
  414. %dir %{_libdir}/wine
  415. %{_libdir}/wine/*.cpl.so
  416. %{_libdir}/wine/*.exe.so
  417. %{_libdir}/wine/*.exe16.so
  418. %{_libdir}/wine/*.dll.so
  419. %{_libdir}/wine/*.dll16.so
  420. %{_libdir}/wine/*.drv.so
  421. %{_libdir}/wine/*.drv16.so
  422. %{_libdir}/wine/*.mod16.so
  423. ## %{_libdir}/wine/*.*16
  424. %{_libdir}/wine/*.ds.so
  425. %{_libdir}/wine/*.ocx.so
  426. %{_libdir}/wine/*.vxd.so
  427. %{_libdir}/wine/*.acm.so
  428. %{_libdir}/wine/*.sys.so
  429. %{_libdir}/wine/*.tlb.so
  430. %dir %{_libdir}/wine/fakedlls
  431. %{_libdir}/wine/fakedlls/*
  432. %dir %{_datadir}/wine
  433. %{_datadir}/wine/*
  434. %{_datadir}/applications/vine-wine-mime-msi.desktop
  435. %{_datadir}/applications/vine-wine.desktop
  436. %{_datadir}/applications/vine-wine-regedit.desktop
  437. %{_datadir}/applications/vine-wine-uninstaller.desktop
  438. %{_datadir}/applications/vine-wine-winecfg.desktop
  439. %{_datadir}/applications/vine-wine-wineboot.desktop
  440. %{_datadir}/applications/vine-wine-notepad.desktop
  441. %{_datadir}/applications/vine-wine-winefile.desktop
  442. %{_datadir}/applications/vine-wine-winemine.desktop
  443. %{_datadir}/applications/vine-wine-winhelp.desktop
  444. %{_datadir}/desktop-directories/Wine.directory
  445. %{_mandir}/man1/wine.1.*
  446. %{_mandir}/man1/wineserver.1*
  447. %{_mandir}/man1/msiexec.1*
  448. %{_mandir}/man1/notepad.1*
  449. %{_mandir}/man1/regedit.1*
  450. %{_mandir}/man1/regsvr32.1*
  451. %{_mandir}/man1/wineboot.1*
  452. %{_mandir}/man1/winecfg.1*
  453. %{_mandir}/man1/wineconsole.1*
  454. %{_mandir}/man1/winefile.1*
  455. %{_mandir}/man1/winemine.1*
  456. %{_mandir}/man1/winepath.1*
  457. ## %{_mandir}/man1/wineprefixcreate.1*
  458. %lang(de) %{_mandir}/de.UTF-8/man1/*.1*
  459. %lang(fr) %{_mandir}/fr.UTF-8/man1/*
  460. %lang(pl) %{_mandir}/pl.UTF-8/man1/wine.1*
  461. #--------------------------------------------------------------------
  462. %files devel
  463. %defattr(-,root,root,-)
  464. %{_bindir}/function_grep.pl
  465. %{_bindir}/widl
  466. %{_bindir}/winebuild
  467. %{_bindir}/winecpp
  468. %{_bindir}/winedump
  469. %{_bindir}/wineg++
  470. %{_bindir}/winegcc
  471. %{_bindir}/winemaker
  472. %{_bindir}/wmc
  473. %{_bindir}/wrc
  474. %{_includedir}/wine
  475. %{_libdir}/*.so
  476. %{_libdir}/wine/*.a
  477. %{_libdir}/wine/*.def
  478. %{_mandir}/man1/widl.1*
  479. %{_mandir}/man1/winebuild.1*
  480. %{_mandir}/man1/winecpp.1*
  481. %{_mandir}/man1/winedump.1*
  482. %{_mandir}/man1/winegcc.1*
  483. %{_mandir}/man1/winemaker.1*
  484. %{_mandir}/man1/wmc.1*
  485. %{_mandir}/man1/wrc.1*
  486. %{_mandir}/man1/winedbg.1*
  487. %{_mandir}/man1/wineg++.1*
  488. #--------------------------------------------------------------------
  489. %files init
  490. %defattr(-,root,root,-)
  491. %{_initrddir}/wine
  492. %doc documentation/README_add.ja
  493. #--------------------------------------------------------------------
  494. %changelog
  495. * Sun Dec 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8-1
  496. - new upstream release
  497. - remove Patch400,401,402
  498. - remove Source402,802
  499. * Sat Nov 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.54-1
  500. - update to 1.7.54
  501. * Sat Oct 24 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.53-1
  502. - update to 1.7.53
  503. * Sat Oct 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.52-1
  504. - update to 1.7.52
  505. * Sun Sep 06 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.51-1
  506. - update to 1.7.51
  507. * Sun Aug 23 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.50-1
  508. - update to 1.7.50
  509. * Mon Aug 17 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.49-1
  510. - update to 1.7.49
  511. * Sat Aug 01 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.48-1
  512. - update to 1.7.48
  513. * Sun Jun 07 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.44-1
  514. - update to 1.7.44
  515. * Sun May 03 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.42-1
  516. - update to 1.7.42
  517. * Sun Apr 05 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.7.40-1
  518. - update to 1.7.40
  519. - update Patch2 (wine-1.7.40-x86_64_gstreamer.patch)
  520. - add BuildRequires: compat32-mesa-libOSMesa-devel, compat32-lcms2-devel, compat32-gsm-devel (x86_64 only)
  521. - add BuildRequires: mesa-libOSMesa-devel, lcms2-devel, gsm-devel
  522. * Sat Jan 11 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.2-1
  523. - new upstream release
  524. * Sun Nov 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.1-1
  525. - new upstream release
  526. * Sat Jul 20 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6-1
  527. - new upstream release
  528. - remove Patch1000 (wine-1.4.1-vine.patch)
  529. - update Patch2 (wine-1.6-x86_64_gstreamer.patch)
  530. * Sun Nov 11 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.5.17-1
  531. - update to 1.5.17
  532. * Sat Jun 16 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4.1-1
  533. - new upstream release
  534. - update Patch1000 (wine-1.4.1-vine.patch)
  535. * Thu Mar 08 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.4-1
  536. - new upstream release
  537. - add Patch2 (wine-1.4-x86_64_gstreamer.patch)
  538. - add BuildRequires: gstreamer-plugins-base-devel
  539. * Sat Jul 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.3-1
  540. - update to 1.2.3
  541. - add Requires: compat32-freetype2 (x86_64 only)
  542. * Sat Dec 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.2-1
  543. - new upstream release
  544. * Thu Oct 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
  545. - new upstream release
  546. - drop Patch1
  547. * Mon Aug 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-2
  548. - new upstream release
  549. - fix %configure (add configu:e and gcc option of x86_64)
  550. - fix %install (remove wine.desktop and change make install option)
  551. - add ExclusiveArch: %{ix86} x86_64
  552. - add BuildRequires for x86_64 (compat32 packages)
  553. * Sat Jun 12 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2-1.rc2
  554. - update to 1.2-rc2
  555. - fix spec file
  556. - if [ "$LANG" = "ja_JP.eucJP" ];
  557. + if [ "$LANG" = "ja_JP.UTF-8" ];
  558. - convert kanji code (ja_JP.eucJP -> ja_JP.UTF-8)
  559. - SOURCE801, SOURCE802, SOURCE803, SOURCE804, SOURCE805
  560. - fix %files
  561. - drop patches (Patch0, Patch400, Patch402)
  562. * Sun Sep 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-2
  563. - update BRs
  564. - remove freetype-devel
  565. - remove libungif-devel, add giflib-devel
  566. - remove gphoto2-devel, add libgphoto2-devel
  567. * Thu Sep 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.29-1
  568. - update to 1.1.29
  569. * Tue Sep 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.28-1
  570. - update to 1.1.28
  571. - update winepulse patches
  572. * Mon Jun 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.23-1
  573. - update to 1.1.23
  574. - spec in utf-8
  575. - add patch1000 to enable FontSmoothing by deafult.
  576. - update pulseaudio patches
  577. - remove invalid Provides: Wine HQ
  578. - remove unneeded patches
  579. * Tue Jul 8 2008 Seiichirou Babasaki 1.1.0-1
  580. - Wine development release 1.1.0.
  581. - Updated specfile (for VineSeed)
  582. #--------------------------------------------------------------------
  583. * Sat Jul 5 2008 Seiichirou Babasaki 1.0-2
  584. - added "ja_fonts_replace-*.reg" files.
  585. - Updated specfile
  586. * Fri Jul 4 2008 Seiichirou Babasaki 1.0-1
  587. - version upgrade
  588. - Updated specfile
  589. - Update to 1.0
  590. - fix wine.desktop mime types (fc)
  591. - add desktop package including desktop files and binary handler (fc)
  592. - pull in some wine alsa/pulseaudio patches (fc)
  593. -- NEWS "June 17, 2008: Wine 1.0 Released"
  594. -- read http://www.winehq.org/?issue=348
  595. * Wed Jun 11 2008 Seiichirou Babasaki 1.0-1rc4
  596. - Updated specfile
  597. - Update to 1.0-rc4
  598. - NEWS "June 6, 2008: Wine 1.0-rc4 Released"
  599. -- ntdll: Add local defines for VIF and VIP flags.
  600. -- wininet: Include openssl/ssl.h before Windows headers.
  601. -- shell32: Fixed the French about box.
  602. -- ChangeLog: Moved to documentation/ChangeLog.BETA.
  603. -- fonts: Add a non-breaking space glyph to the Tahoma fonts.
  604. -- ....others , read ChangeLog
  605. --- Bug fixes only, we are in code freeze.
  606. * Tue Jun 03 2008 Seiichirou Babasaki 1.0-1rc3
  607. - Updated specfile
  608. - Update to 1.0-rc3
  609. - NEWS "May 30, 2008: Wine 1.0-rc3 Released"
  610. -- The default version is now Windows XP.
  611. -- Many Richedit improvements.
  612. -- Beginning of jscript dll support.
  613. -- Shell folders now respect XDG directory configuration.
  614. -- Many translation updates.
  615. -- Lots of bug fixes.
  616. -- * Bug fixes only, we are in code freeze.
  617. --- kernel32: Add a builtin 16-bit winhelp.exe.
  618. --- This should be moved to winhlp32.exe once we support 16-bit modules in
  619. --- executables.
  620. ---- winhelp -> renamed winhlp32.exe
  621. ---- programs: Remove winelauncher from install rules.
  622. * Fri Apr 04 2008 Seiichirou Babasaki 0.9.59
  623. - Updated specfile
  624. - Update to 0.9.59
  625. - NEWS.. "April 4, 2008: Wine 0.9.59 Released"
  626. -- * Improved support for the .NET framework.
  627. -- * Better services handling through a separate services.exe process.
  628. -- * Support for ATI fragment shader.
  629. -- * Better support for http proxies.
  630. -- * Window management fixes.
  631. -- * Pre-compiled fonts are now available in the source tree.
  632. -- * Lots of bug fixes.
  633. * Mon Mar 24 2008 Seiichirou Babasaki 0.9.58
  634. - Updated specfile (split wine-init package)
  635. - Update to 0.9.58
  636. - NEWS.. "March 21, 2008: Wine 0.9.58 Released"
  637. -- * The default version is now Windows XP.
  638. -- * Many Richedit improvements.
  639. -- * Beginning of jscript dll support.
  640. -- * Shell folders now respect XDG directory configuration.
  641. -- * Many translation updates.
  642. -- * Lots of bug fixes.
  643. * Tue Mar 11 2008 Seiichirou Babasaki 0.9.57-1vl1
  644. - Updated specfile (*.desktop file %check .)
  645. - Update to 0.9.57
  646. - NEWS.. "March 7, 2008: Wine 0.9.57 Released"
  647. -- * Support for multiple OpenGL pixel formats.
  648. -- * Improved support for color profiles.
  649. -- * Many window management fixes.
  650. -- * Better fullscreen support.
  651. -- * Lots of bug fixes.
  652. * Fri Feb 29 2008 Seiichirou Babasaki 0.9.56-1vl1
  653. - Updated specfile
  654. - ("Build Tool" from the wine-package to move to devel-packages)
  655. - Update to 0.9.56
  656. - NEWS.. "February 22, 2008: Wine 0.9.56 Released"
  657. -- * Proper handling of OpenGL/Direct3D windows with menu bars.
  658. -- * Stubs for all the d3dx9_xx dlls.
  659. -- * Several graphics optimizations.
  660. -- * Many installer fixes.
  661. -- * Improved MIME message support.
  662. -- * Lots of bug fixes.
  663. * Fri Feb 15 2008 Seiichirou Babasaki 0.9.55-1vl2
  664. - Updated specfile (cf. VineLinux .spec file format)
  665. - Add Installed messages for "binfmt_misc" .
  666. - *.desktop file "Name" change to japanese. (UTF8)
  667. * Wed Feb 13 2008 Seiichirou Babasaki 0.9.55-1vl1
  668. - Import WINE - Packager: Babasaki
  669. - Updated specfile (SUSE base + FC9 cfg)
  670. - Update to 0.9.55
  671. - Update to 0.9.54 from FC9
  672. - Update to 0.9.53 from Private package
  673. # FC9 ------------------------------------------------------------- FC9
  674. * Sun Feb 10 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  675. - 0.9.55-1
  676. - version upgrade
  677. * Fri Jan 25 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  678. - 0.9.54-1
  679. - version upgrade
  680. - remove default pulseaudio workaround (#429420,#428745)
  681. - improve pulseaudio readme
  682. * Sun Jan 13 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  683. - 0.9.53-2
  684. - add some missing BR
  685. * Sat Jan 12 2008 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  686. - 0.9.53-1
  687. - version upgrade
  688. * Sat Dec 29 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  689. - 0.9.52-2
  690. - fix menu bug (#393641)
  691. * Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  692. - 0.9.52-1
  693. - version upgrade
  694. * Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  695. - 0.9.51-3
  696. - add -n Wine to pulseaudio workaround
  697. - try to fix menu bug #393641
  698. * Fri Dec 28 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  699. - 0.9.51-2
  700. - add fix for #344281 pulseaudio workaround
  701. - fix #253474: wine-jack should require jack-audio-connection-kit
  702. * Sun Dec 16 2007 Andreas Bierfert <andreas.bierfert[AT]lowlatency.de>
  703. - 0.9.51-1
  704. - version upgrade
  705. # ---- abbreviatio ----------------------------------------------------#
  706. # ----------and suse.
  707. # * Fri Mar 17 2006 - meissner@suse.de
  708. # - Avoid ulimit leading to out of memory situations by using
  709. # the compat address space layout personality. #152115