python-crypto-vl.spec 5.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156
  1. %{!?python_sitelib: %define python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
  2. %{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
  3. Summary: Cryptography library for Python
  4. Summary(ja): Python 用 Cryptography ライブラリ
  5. Name: python-crypto
  6. Version: 2.3
  7. Release: 2%{?_dist_release}
  8. License: Python License (CNRI Python License)
  9. Group: Development/Libraries
  10. URL: http://www.dlitz.net/software/pycrypto/
  11. Source: http://ftp.dlitz.net/pub/dlitz/crypto/pycrypto/pycrypto-%{version}.tar.gz
  12. #Patch0: arc2-buffer-overflow.patch
  13. Patch1: no-usr-local.patch
  14. #Patch2: run-tests.patch
  15. Patch3: doc.patch
  16. BuildRequires: python >= 2.2
  17. BuildRequires: python-devel >= 2.2
  18. BuildRequires: gmp-devel >= 4.1
  19. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  20. %description
  21. Python-crypto is a collection of both secure hash functions
  22. (such as MD5 and SHA), and various encryption algorithms
  23. (AES, DES, IDEA, RSA, ElGamal, etc.).
  24. %prep
  25. %setup -n pycrypto-%{version} -q
  26. #%patch0 -p1
  27. %patch1 -p1
  28. #%patch2 -p1
  29. %patch3 -p1
  30. # Remove spurious shellbangs
  31. %{__sed} -i -e '\|^#!/usr/local/bin/python| d' lib/Crypto/Util/RFC1751.py
  32. %build
  33. CFLAGS="$RPM_OPT_FLAGS" %{__python} setup.py build
  34. %install
  35. %{__rm} -rf %{buildroot}
  36. %{__python} setup.py install -O1 --skip-build --root %{buildroot}
  37. # Remove group write permissions on shared objects
  38. /usr/bin/find %{buildroot}%{python_sitearch} -name '*.so' \
  39. -exec %{__chmod} g-w {} \;
  40. %clean
  41. rm -rf $RPM_BUILD_ROOT
  42. %files
  43. %defattr(-,root,root,-)
  44. %doc README TODO ACKS ChangeLog LEGAL/ COPYRIGHT Doc/
  45. #%{python_sitearch}/pycrypto-2.2-py2.6.egg-info
  46. %{python_sitearch}/
  47. %changelog
  48. * Sun Oct 3 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.3-2
  49. - rebuilt with rpm-4.8.1 for pkg-config
  50. * Sat Aug 28 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.3-1
  51. - new upstream release
  52. - changed %%files
  53. * Sun Aug 22 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.2-2
  54. - fix %files (change directory from %{python_sitelib} to %{python_sitearch})
  55. * Sun Aug 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.2-1
  56. - new upstream release
  57. * Wed Jul 7 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.1.0-1
  58. - new upstream release
  59. - changed URL and SOURCE to new upstream
  60. - dropt patch0,2
  61. - replaced patch1 from Debian newer
  62. - added pacth3 from Debian
  63. - changed document files dir in %%files
  64. * Tue Feb 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.0.1-3
  65. - rebuild with python-2.6
  66. * Fri Oct 23 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.0.1-2
  67. - added Patch0,1,2 from Debian to fix some problem
  68. * Wed Jul 29 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 2.0.1-1
  69. - initial build for VineSeed
  70. * Mon Jun 04 2007 David Woodhouse <dwmw2@infradead.org> - 2.0.1-7.1
  71. - Fix libdir handling so it works on more arches than x86_64
  72. * Wed Apr 18 2007 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-7
  73. - Fix typo
  74. * Wed Apr 18 2007 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-6
  75. - Remove dist
  76. - rebuild, because the older version was much bigger, as it was build when
  77. distutils was doing static links of libpython
  78. * Sat Dec 09 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-5
  79. - Rebuild for python 2.5
  80. * Thu Sep 07 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-4
  81. - Don't ghost pyo files (#205408)
  82. * Tue Aug 29 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-3
  83. - Rebuild for Fedora Extras 6
  84. * Mon Feb 13 2006 Thorsten Leemhuis <fedora[AT]leemhuis.info> - 2.0.1-2
  85. - Rebuild for Fedora Extras 5
  86. * Wed Aug 17 2005 Thorsten Leemhuis <fedora at leemhuis dot info> - 0:2.0.1-1
  87. - Update to 2.0.1
  88. - Use Dist
  89. - Drop python-crypto-64bit-unclean.patch, similar patch was applied
  90. upstream
  91. * Thu May 05 2005 Thorsten Leemhuis <fedora at leemhuis dot info> - 0:2.0-4
  92. - add python-crypto-64bit-unclean.patch (#156173)
  93. * Mon Mar 21 2005 Seth Vidal <skvidal at phy.duke.edu> - 0:2.0-3
  94. - iterate release for build on python 2.4 based systems
  95. * Sat Dec 18 2004 Thorsten Leemhuis <fedora at leemhuis dot info> - 0:2.0-2
  96. - Fix build on x86_64: use python_sitearch for files and patch source
  97. to find gmp
  98. * Thu Aug 26 2004 Thorsten Leemhuis <fedora at leemhuis dot info> - 0:2.0-0.fdr.1
  99. - Update to 2.00
  100. * Fri Aug 13 2004 Ville Skytta <ville.skytta at iki.fi> - 0:1.9-0.fdr.6.a6
  101. - Don't use get_python_version(), it's available in Python >= 2.3 only.
  102. * Thu Aug 12 2004 Thorsten Leemhuis <fedora at leemhuis dot info> 0:1.9-0.fdr.5.a6
  103. - Own dir python_sitearch/Crypto/
  104. * Wed Aug 11 2004 Thorsten Leemhuis <fedora at leemhuis dot info> 0:1.9-0.fdr.4.a6
  105. - Match python spec template more
  106. * Sat Jul 17 2004 Thorsten Leemhuis <fedora at leemhuis dot info> 0:1.9-0.fdr.3.a6
  107. - Own _libdir/python/site-packages/Crypto/
  108. * Wed Mar 24 2004 Panu Matilainen <pmatilai@welho.com> 0.3.2-0.fdr.2.a6
  109. - generate .pyo files during install
  110. - require exact version of python used to build the package
  111. - include more docs + demos
  112. - fix dependency on /usr/local/bin/python
  113. - use fedora.us style buildroot
  114. - buildrequires gmp-devel
  115. - use description from README
  116. * Sun Jan 11 2004 Ryan Boder <icanoop@bitwiser.org> 0.3.2-0.fdr.1.a6
  117. - Initial build.