expect-vl.spec 8.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286
  1. %define tcl_major 8.4
  2. %define thread_major 2.5
  3. %define majorver 5.43
  4. Summary: A Tcl/Tk development environment: expect
  5. Summary(ja): Tcl/Tk 開発環境: expect
  6. Name: expect
  7. Version: %{majorver}.0
  8. Release: 2%{?_dist_release}
  9. Group: Development/Languages
  10. URL: http://expect.nist.gov/
  11. License: BSD
  12. Source0: http://expect.nist.gov/src/%{name}-%{version}.tar.gz
  13. Patch0: expect-5.32.2-random.patch
  14. Patch6: expect-5.38.0-spawn-43310.patch
  15. Patch8: expect-5.32.2-setpgrp.patch
  16. Patch10: expect-5.38.0-lib-spec.patch
  17. Patch11: expect-5.39.0-libdir.patch
  18. Buildroot: %{_tmppath}/%{name}-%{version}-root
  19. BuildRequires: tcl >= %{tcl_major}
  20. BuildRequires: thread >= %{thread_major}
  21. BuildRequires: autoconf213
  22. %description -n expect
  23. Expect is a tcl extension for automating interactive applications such
  24. as telnet, ftp, passwd, fsck, rlogin, tip, etc. Expect is also useful
  25. for testing the named applications. Expect makes it easy for a script
  26. to control another program and interact with it.
  27. Install the expect package if you'd like to develop scripts which interact
  28. with interactive applications. You'll also need to install the tcl
  29. package.
  30. %package devel
  31. Summary: Development files for expect library.
  32. Group: Development/Libraries
  33. Requires: expect = %{version}-%{release}
  34. Obsoletes: expect <= 5.43-0vl4
  35. %description devel
  36. This package contains development files for the expect library.
  37. %package -n expectk
  38. Summary: expectk and some scripts
  39. Group: Development/Languages
  40. Requires: expect = %{version}-%{release}
  41. Obsoletes: expect <= 5.43-0vl4
  42. %description -n expectk
  43. This package contains expectk and some scripts that use it.
  44. %prep
  45. %setup -q -n %{name}-%{majorver}
  46. %patch0 -p1 -b .random
  47. %patch6 -p2 -b .spawn
  48. %patch8 -p2 -b .pgrp
  49. %patch10 -p1 -b .libspec
  50. %patch11 -p1 -b .libdir
  51. # patch10 touch configure.in
  52. autoconf-2.13
  53. %build
  54. %configure --enable-64bit \
  55. --with-tcl=%{_libdir} --with-tk=%{_libdir} \
  56. --with-tclinclude=%{_includedir}/tcl-private/generic \
  57. --with-tkinclude=%{_includedir}/tk-private/generic \
  58. --enable-shared --enable-threads --with-x=yes --enable-gcc
  59. make
  60. %install
  61. rm -rf ${RPM_BUILD_ROOT}
  62. mkdir -p ${RPM_BUILD_ROOT}
  63. make INSTALL_ROOT=%{buildroot} install
  64. # for linking with -lexpect
  65. ln -s libexpect%{majorver}.so "$RPM_BUILD_ROOT"%{_libdir}/libexpect.so
  66. # remove cryptdir/decryptdir, as Linux has no crypt command (bug 6668).
  67. rm -f "$RPM_BUILD_ROOT"%{_bindir}/{cryptdir,decryptdir}
  68. rm -f "$RPM_BUILD_ROOT"%{_mandir}/man1/{cryptdir,decryptdir}.1*
  69. rm -f "$RPM_BUILD_ROOT"%{_bindir}/autopasswd
  70. %post -p /sbin/ldconfig -n expect
  71. %postun -p /sbin/ldconfig -n expect
  72. %clean
  73. rm -rf $RPM_BUILD_ROOT
  74. %files
  75. %%defattr(-,root,root)
  76. %doc FAQ HISTORY NEWS README
  77. %{_bindir}/expect
  78. %{_bindir}/autoexpect
  79. %{_bindir}/dislocate
  80. %{_bindir}/ftp-rfc
  81. %{_bindir}/kibitz
  82. %{_bindir}/lpunlock
  83. %{_bindir}/mkpasswd
  84. %{_bindir}/passmass
  85. %{_bindir}/rftp
  86. %{_bindir}/rlogin-cwd
  87. %{_bindir}/timed-read
  88. %{_bindir}/timed-run
  89. %{_bindir}/unbuffer
  90. %{_bindir}/weather
  91. %{_bindir}/xkibitz
  92. %dir %{_libdir}/expect%{majorver}
  93. %{_libdir}/expect%{majorver}/pkgIndex.tcl
  94. %{_libdir}/libexpect%{majorver}.so
  95. %{_mandir}/man1/autoexpect.1.gz
  96. %{_mandir}/man1/dislocate.1.gz
  97. %{_mandir}/man1/expect.1.gz
  98. %{_mandir}/man1/kibitz.1.gz
  99. %{_mandir}/man1/mkpasswd.1.gz
  100. %{_mandir}/man1/passmass.1.gz
  101. %{_mandir}/man1/tknewsbiff.1.gz
  102. %{_mandir}/man1/unbuffer.1.gz
  103. %{_mandir}/man1/xkibitz.1.gz
  104. %files devel
  105. %defattr(-,root,root,-)
  106. %exclude %{_libdir}/expect%{majorver}/libexpect%{majorver}.a
  107. %exclude %{_libdir}/libexpect%{majorver}.a
  108. %{_libdir}/libexpect.so
  109. %{_mandir}/man3/libexpect.3*
  110. %{_includedir}/*
  111. %files -n expectk
  112. %defattr(-,root,root,-)
  113. %{_bindir}/expectk
  114. %{_bindir}/multixterm
  115. %{_bindir}/tknewsbiff
  116. %{_bindir}/tkpasswd
  117. %{_bindir}/xpstat
  118. %{_mandir}/man1/expectk.1*
  119. %{_mandir}/man1/multixterm.1*
  120. %{_mandir}/man1/tknewsbiff.1*
  121. %changelog
  122. * Tue May 18 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.43-2
  123. - rebuilt with new toolchain
  124. - changed devel Group to Development/Libraries
  125. * Sun Jul 27 2008 Shu KONNO <owa@bg.wakwak.com> 5.43-1vl5
  126. - applied new versioning policy and spec in utf-8
  127. * Sun Feb 17 2008 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl6
  128. - rebuilt with tcl/tk-8.4.18
  129. * Fri Nov 09 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 5.43-0vl5
  130. - split to expect-devel and expectk sub package.
  131. - add libexpect.so to expect-devel (<BTS:wishes:0136>)
  132. * Tue Oct 09 2007 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl4
  133. - rebuilt with tcl/tk-8.4.16
  134. * Wed Jun 13 2007 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl3
  135. - rebuilt with new toolchain
  136. * Sun Jan 29 2006 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl2
  137. - rebuild for tcl/tk-8.4.12
  138. - added --enable-64bit to configure's option
  139. * Fri Sep 09 2005 Shu KONNO <owa@bg.wakwak.com> 5.43-0vl1
  140. - updated expect to 5.43.0
  141. - dropped expect-5.39.0-64bit-82547.patch (for fixed)
  142. - dropped expect-5.32.2-kibitz.patch (for fixed)
  143. - dropped expect-5.38.0-autopasswd-9917.patch (for fixed)
  144. - rebuilt with tcl/tk 8.4.11
  145. * Wed Jun 30 2004 Shu KONNO <owa@bg.wakwak.com> 5.39-95vl2
  146. - rebuild for tcl/tk-8.4.6
  147. * Mon Jan 12 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 5.39-95vl1
  148. - update based on fedora
  149. * Mon Mar 31 2003 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 8.4.2-0vl1
  150. - update based on BitWalk's tcltk-8.4.2-83bw and RawHide tcltk-8.3.5-89
  151. * Thu Nov 15 2001 Kazuhusa TAKEI <takei@linux.or.jp> 8.0.5_jp-10vl3
  152. - splite source package
  153. - add include files
  154. * Sun Jul 15 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl2
  155. - expand some macros.. (FIXME)
  156. * Sat Jul 14 2001 Daisuke SUZUKI <daisuke@linux.or.jp> 8.0.5_jp-10vl1
  157. - use %configure macros
  158. - add Patch 47,50
  159. * Thu May 31 2001 <sagami@vinelinux.org>
  160. - 8.0.5_jp-10
  161. - unexpand old %%{configure}, new one causes build failure
  162. - fixed missing libtkx.so libtclx.so symlink in /usr/lib
  163. - install manpages into %%{_mandir} and mode 644
  164. * Wed Jul 19 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  165. - 8.0.5_jp-9
  166. - modified %install section to handle compressed man pages
  167. - fixed /usr/lib/tk8.0jp/demos.jp/images symlink
  168. * Sun Jul 2 2000 Daisuke SUZUKI <daisuke@linux.or.jp>
  169. - changed default fonts
  170. * Tue Jan 25 2000 Jun Nishii <jun@vinelinux.org>
  171. - added defattr
  172. * Mon Jan 24 2000 Jun Nishii <jun@vinelinux.org>
  173. - added some symlinks, such as libtcl8.0.so.
  174. - obsoletes version number using _jp, now 8.0.5-31vl1
  175. * Wed Jan 5 2000 Norihito Ohmori <nono@vinelinux.org>
  176. - Apply Tcl/Tk 8.0 Japanese Patch 1.7
  177. * Tue Nov 30 1999 Jakub Jelinek <jakub@redhat.com>
  178. - fix tclX symlinks.
  179. - compile on systems where SIGPWR == SIGLOST.
  180. * Sat May 1 1999 Jeff Johnson <jbj@redhat.com>
  181. - update tcl/tk to 8.0.5.
  182. - avoid "containing" in Tix (#2332).
  183. * Thu Apr 8 1999 Jeff Johnson <jbj@redhat.com>
  184. - use /usr/bin/write in kibitz (#1320).
  185. - use cirrus.sprl.umich.edu in weather (#1926).
  186. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  187. - auto rebuild in the new build environment (release 28)
  188. * Mon Mar 08 1999 Preston Brown <pbrown@redhat.com>
  189. - whoops, exec-prefix for itcl was set to '/foo', changed to '/usr'.
  190. * Tue Feb 16 1999 Jeff Johnson <jbj@redhat.com>
  191. - expect does unaligned access on alpha (#989)
  192. - upgrade tcl/tk/tclX to 8.0.4
  193. - upgrade expect to 5.28.
  194. - add itcl 3.0.1
  195. * Tue Jan 12 1999 Cristian Gafton <gafton@redhat.com>
  196. - call libtoolize to allow building on the arm
  197. - build for glibc 2.1
  198. - strip binaries
  199. * Thu Sep 10 1998 Jeff Johnson <jbj@redhat.com>
  200. - update tcl/tk/tclX to 8.0.3, expect is updated also.
  201. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  202. - expect: mkpasswd needs delay before sending password (problem #576)
  203. * Thu May 07 1998 Prospector System <bugs@redhat.com>
  204. - translations modified for de, fr, tr
  205. * Sat May 02 1998 Cristian Gafton <gafton@redhat.com>
  206. - fixed expect binaries exec permissions
  207. * Thu Apr 09 1998 Erik Troan <ewt@redhat.com>
  208. - updated to Tix 4.1.0.006
  209. - updated version numbers of tcl/tk to relflect includsion of p2
  210. * Wed Mar 25 1998 Cristian Gafton <gafton@redhat.com>
  211. - updated tcl/tk to patch level 2
  212. - updated tclX to 8.0.2
  213. * Thu Oct 30 1997 Otto Hammersmith <otto@redhat.com>
  214. - fixed filelist for tix... replacing path to the expect binary in scripts
  215. was leaving junk files around.
  216. * Wed Oct 22 1997 Otto Hammersmith <otto@redhat.com>
  217. - added patch to remove libieee test in configure.in for tcl and tk.
  218. Shoudln't be needed anymore for glibc systems, but this isn't the "proper"
  219. solution for all systems
  220. - fixed src urls
  221. * Mon Oct 06 1997 Erik Troan <ewt@redhat.com>
  222. - removed version numbers from descriptions
  223. * Mon Sep 22 1997 Erik Troan <ewt@redhat.com>
  224. - updated to tcl/tk 8.0 and related versions of packages
  225. * Tue Jun 17 1997 Erik Troan <ewt@redhat.com>
  226. - built against glibc
  227. - fixed dangling tclx/tkx symlinks