acl-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: acl
  3. Summary: Access control list utilities
  4. Version: 2.2.53
  5. Release: 1%{?_dist_release}
  6. Group: System Environment/Base
  7. License: GPLv2+
  8. URL: http://oss.sgi.com/projects/xfs/
  9. Source: http://download.savannah.nongnu.org/releases/acl/acl-%{version}.tar.gz
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: gawk
  14. BuildRequires: gettext
  15. BuildRequires: libattr-devel >= 2.4.1
  16. BuildRequires: libtool
  17. Requires: libacl = %{version}-%{release}
  18. %description
  19. This package contains the getfacl and setfacl utilities needed for
  20. manipulating access control lists.
  21. %package -n libacl
  22. Summary: Dynamic library for access control list support
  23. License: LGPLv2+
  24. Group: System Environment/Libraries
  25. Requires(post): /sbin/ldconfig
  26. Requires(postun): /sbin/ldconfig
  27. %description -n libacl
  28. This package contains the libacl.so dynamic library which contains
  29. the POSIX 1003.1e draft standard 17 functions for manipulating access
  30. control lists.
  31. %package -n libacl-devel
  32. Summary: Access control list static libraries and headers.
  33. License: LGPLv2+
  34. Group: Development/Libraries
  35. Requires: libacl = %{version}-%{release}
  36. Requires: libattr-devel
  37. %description -n libacl-devel
  38. This package contains static libraries and header files needed to develop
  39. programs which make use of the access control list programming interface
  40. defined in POSIX 1003.1e draft standard 17.
  41. %if %build_compat32
  42. %package -n compat32-libacl
  43. Summary: Dynamic library for access control list support
  44. License: LGPLv2+
  45. Group: System Environment/Libraries
  46. Requires(post): /sbin/ldconfig
  47. Requires(postun): /sbin/ldconfig
  48. %description -n compat32-libacl
  49. This package contains the libacl.so dynamic library which contains
  50. the POSIX 1003.1e draft standard 17 functions for manipulating access
  51. control lists.
  52. %endif
  53. %prep
  54. %setup -q
  55. %build
  56. touch .census
  57. # acl abuses libexecdir
  58. %configure --libdir=/%{_lib} --libexecdir=%{_libdir}
  59. make %{?_smp_mflags} LIBTOOL="libtool --tag=CC"
  60. %install
  61. rm -rf %{buildroot}
  62. make install DESTDIR=%{buildroot}
  63. #make install-dev DESTDIR=%{buildroot}
  64. #make install-lib DESTDIR=%{buildroot}
  65. mv -f %{buildroot}%{_datadir}/doc/acl ./doc-nover
  66. # get rid of libacl.a and libacl.la
  67. rm -f %{buildroot}/%{_lib}/libacl.a
  68. rm -f %{buildroot}/%{_lib}/libacl.la
  69. rm -f %{buildroot}%{_libdir}/libacl.a
  70. rm -f %{buildroot}%{_libdir}/libacl.la
  71. # fix links to shared libs and permissions
  72. rm -f %{buildroot}%{_libdir}/libacl.so
  73. mkdir -p %{buildroot}%{_libdir}
  74. ln -sf ../../%{_lib}/libacl.so %{buildroot}%{_libdir}/libacl.so
  75. chmod 0755 %{buildroot}/%{_lib}/libacl.so.*.*.*
  76. mv -f %{buildroot}/%{_lib}/pkgconfig %{buildroot}%{_libdir}/
  77. %find_lang %{name}
  78. %check
  79. if ./setfacl/setfacl -m u:`id -u`:rwx .; then
  80. make tests || exit $?
  81. if test 0 = `id -u`; then
  82. make root-tests || exit $?
  83. fi
  84. else
  85. echo '*** ACLs are probably not supported by the file system,' \
  86. 'the test-suite will NOT run ***'
  87. fi
  88. %clean
  89. rm -rf %{buildroot}
  90. %post -n libacl
  91. /sbin/ldconfig
  92. %postun -n libacl
  93. /sbin/ldconfig
  94. %if %build_compat32
  95. %post -n compat32-libacl
  96. /sbin/ldconfig
  97. %postun -n compat32-libacl
  98. /sbin/ldconfig
  99. %endif
  100. %files -f %{name}.lang
  101. %defattr(-,root,root)
  102. %doc doc-nover/*
  103. %{_bindir}/chacl
  104. %{_bindir}/getfacl
  105. %{_bindir}/setfacl
  106. %{_mandir}/man1/chacl.1*
  107. %{_mandir}/man1/getfacl.1*
  108. %{_mandir}/man1/setfacl.1*
  109. %{_mandir}/man5/acl.5*
  110. %files -n libacl-devel
  111. %defattr(-,root,root)
  112. /%{_lib}/libacl.so
  113. %{_includedir}/acl
  114. %{_includedir}/sys/acl.h
  115. %{_libdir}/libacl.*
  116. %{_libdir}/pkgconfig/*.pc
  117. %{_mandir}/man3/acl_*
  118. %files -n libacl
  119. %defattr(-,root,root)
  120. /%{_lib}/libacl.so.*
  121. %if %build_compat32
  122. %files -n compat32-libacl
  123. %defattr(-,root,root,-)
  124. /%{_lib}/libacl.so.*
  125. %endif
  126. %changelog
  127. * Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.53-1
  128. - new upstream release.
  129. - dropped all patches: fixed in upstream.
  130. * Thu Apr 16 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.52-2
  131. - added compat32 package.
  132. * Fri Jul 4 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.52-1
  133. - new upstream release.
  134. - replaced patches to the newest rawhide's.
  135. * Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.49-1
  136. - updated to 2.2.49
  137. - added Patch2-7 from Fedora
  138. * Wed Apr 06 2011 Kamil Dudka <kdudka@redhat.com> 2.2.49-11
  139. - add function acl_extended_file_nofollow() (#692982)
  140. * Tue Mar 29 2011 Kamil Dudka <kdudka@redhat.com> 2.2.49-10
  141. - fix typos in setfacl(1) man page (#675451)
  142. * Thu Jul 08 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-8
  143. - remove dependency of libacl-devel on nfs-utils-lib and openldap
  144. * Tue May 25 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-7
  145. - let acl depend on the same version of libacl (#595674)
  146. * Wed Mar 24 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-6
  147. - prevent setfacl --restore from SIGSEGV on malformed restore file (#576550)
  148. * Mon Jun 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.47-2
  149. - initial build for Vine Linux
  150. * Tue Feb 12 2008 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.47-1
  151. - new upstream version
  152. * Mon Jan 28 2008 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.45-3
  153. - Fixed segfault when using only "--" as parameter
  154. - Resolves: #430458
  155. * Wed Nov 7 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.45-2
  156. - Fixed setfacl exitcodes
  157. - Resolves: #368451
  158. * Wed Oct 31 2007 Jiri Moskovcak <jmoskovc@redhat.com> - 2.2.45-1
  159. - New version
  160. - dropped walk patch
  161. * Thu Sep 20 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-10
  162. - Rewriten path_max patch to support long UTF8 names
  163. - Resolves #287701, #183181
  164. * Fri Aug 31 2007 Steve Dickson <steved@redhat.com> - 2.2.39-9
  165. - Removed NFS4 ACL patch since it was rejected by upstream.
  166. * Thu Aug 30 2007 Jeremy Katz <katzj@redhat.com> - 2.2.39-8
  167. - disable nfs patch; linking libacl against libs in /usr will lead to breakage
  168. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.2.39-7
  169. - Build Require gawk
  170. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.2.39-6
  171. - Rebuild for selinux ppc32 issue.
  172. * Mon Aug 27 2007 Steve Dickson <steved@redhat.com> 2.2.39-5
  173. - Added NFS v4 ACL support
  174. * Thu Jul 26 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-4.1
  175. - Updated man page for getfacl
  176. * Wed Jul 25 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-4
  177. - Added support fort short params to getfacl
  178. - Resolves: #204087
  179. * Wed Mar 21 2007 Thomas Woerner <twoerner@redhat.com> 2.2.39-3.1
  180. - new improved walk patch with fixed getfacl exit code (rhbz#232884)
  181. * Fri Feb 23 2007 Karsten Hopp <karsten@redhat.com> 2.2.39-3
  182. - fix buildroot
  183. - remove trailing dot from summary
  184. - -devel requires same version of libacl
  185. - escape macro in changelog
  186. - make .so symlink relative
  187. * Thu Feb 22 2007 Steve Grubb <sgrubb@redhat.com> 2.2.39-2
  188. - Apply patch to make order consistent.
  189. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.2.39-1.1
  190. - rebuild
  191. * Wed Jul 5 2006 Thomas Woerner <twoerner@redhat.com> 2.2.39-1
  192. - new version 2.2.39
  193. - fixed usage of long UTF-8 filenames (#183181)
  194. Thanks to Andrey for the initial patch.
  195. * Wed Jun 7 2006 Jeremy Katz <katzj@redhat.com> - 2.2.34-2
  196. - rebuild for -devel deps
  197. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.2.34-1.2
  198. - bump again for double-long bug on ppc(64)
  199. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.2.34-1.1
  200. - rebuilt for new gcc4.1 snapshot and glibc changes
  201. * Fri Feb 3 2006 Thomas Woerner <twoerner@redhat.com> 2.2.34-1
  202. - new version 2.2.34
  203. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  204. - rebuilt
  205. * Tue Dec 6 2005 Thomas Woerner <twoerner@redhat.com> 2.2.32-2.1
  206. - fixed permissions of libacl
  207. * Tue Dec 6 2005 Thomas Woerner <twoerner@redhat.com> 2.2.32-2
  208. - spec file cleanup
  209. - mark po files as lang specific
  210. * Sun Nov 06 2005 Florian La Roche <laroche@redhat.com>
  211. - 2.2.32
  212. * Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.2.31-1
  213. - update to 2.2.31
  214. * Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.2.23-9
  215. - get rid of *.la files
  216. - remove duplicate doc files
  217. * Wed Feb 9 2005 Stephen C. Tweedie <sct@redhat.com> 2.2.23-6
  218. - Rebuild
  219. * Thu Sep 16 2004 Jeremy Katz <katzj@redhat.com> - 2.2.23-5
  220. - make the libs executable so that we find their dependencies (#132696)
  221. * Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.23-4
  222. - libacl-devel Requires: libattr-devel for libattr.la
  223. * Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.23-3
  224. - Requires libtool >= 1.5 for building
  225. * Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.2.23-2
  226. - Make libacl.so.* executable.
  227. * Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.2.23-1
  228. - Update to latest upstream version.
  229. * Sun Aug 8 2004 Alan Cox <alan@redhat.com> 2.2.7-7
  230. - Close bug #125300 (Steve Grubb: build requires libtool,gettext)
  231. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  232. - rebuilt
  233. * Wed Mar 31 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.7-5
  234. - Add missing %%defattr
  235. * Tue Mar 30 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.7-3
  236. - Add /usr/include/acl to files manifest
  237. - Fix location of doc files, add main doc dir to files manifest
  238. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  239. - rebuilt
  240. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  241. - rebuilt
  242. * Tue Aug 5 2003 Elliot Lee <sopwith@redhat.com> 2.2.7-2
  243. - Fix libtool invocation
  244. * Tue Jun 3 2003 Stephen C. Tweedie <sct@redhat.com> 2.2.7-1
  245. - Update to acl-2.2.7
  246. * Wed Mar 26 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.3-2
  247. - include patch from Jay Berkenbilt to print better error messages
  248. * Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.3-1
  249. - udpate/rebuild
  250. * Sat Jan 4 2003 Jeff Johnson <jbj@redhat.com> 2.0.11-7
  251. - set execute bits on library so that requires are generated.
  252. * Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-5
  253. - Correct patch in previous fix so that shared libraries go in /lib*
  254. instead of /usr/lib*
  255. * Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-4
  256. - Fix multilibbing
  257. * Wed Sep 11 2002 Than Ngo <than@redhat.com> 2.0.11-3
  258. - Added fix to install libs in correct directory on 64bit machine
  259. * Thu Aug 08 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.11-2
  260. - Made the package only own the one directory that is unique to it:
  261. /usr/include/acl
  262. * Mon Jun 24 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.11-1
  263. - Initial Red Hat package
  264. Made as few changes as possible relative to upstream packaging to
  265. make it easier to maintain long-term. This means that some of
  266. the techniques used here are definitely not standard Red Hat
  267. techniques. If you are looking for an example package to fit
  268. into Red Hat Linux transparently, this would not be the one to
  269. pick.
  270. - acl-devel -> libacl-devel