attr-vl.spec 11 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: Utilities for managing filesystem extended attributes
  3. Name: attr
  4. Version: 2.4.48
  5. Release: 1%{?_dist_release}
  6. License: GPLv2+
  7. URL: http://oss.sgi.com/projects/xfs/
  8. Group: System Environment/Base
  9. Source: http://download.savannah.nongnu.org/releases/attr/attr-%{version}.tar.gz
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: gettext
  14. BuildRequires: libtool
  15. Requires: libattr = %{version}-%{release}
  16. Conflicts: xfsdump < 2.0.0
  17. %description
  18. A set of tools for manipulating extended attributes on filesystem
  19. objects, in particular getfattr(1) and setfattr(1).
  20. An attr(1) command is also provided which is largely compatible
  21. with the SGI IRIX tool of the same name.
  22. %package -n libattr
  23. Summary: Dynamic library for extended attribute support
  24. Group: System Environment/Libraries
  25. License: LGPLv2+
  26. %description -n libattr
  27. This package contains the libattr.so dynamic library which contains
  28. the extended attribute system calls and library functions.
  29. %package -n libattr-devel
  30. Summary: Extended attribute static libraries and headers
  31. Group: Development/Libraries
  32. License: LGPLv2+
  33. Requires: libattr = %{version}-%{release}
  34. %description -n libattr-devel
  35. This package contains the libraries and header files needed to
  36. develop programs which make use of extended attributes.
  37. For Linux programs, the documented system call API is the
  38. recommended interface, but an SGI IRIX compatibility interface
  39. is also provided.
  40. Currently only ext2, ext3 and XFS support extended attributes.
  41. The SGI IRIX compatibility API built above the Linux system calls is
  42. used by programs such as xfsdump(8), xfsrestore(8) and xfs_fsr(8).
  43. You should install libattr-devel if you want to develop programs
  44. which make use of extended attributes. If you install libattr-devel,
  45. you'll also want to install attr.
  46. # compat32
  47. %package -n compat32-libattr
  48. Summary: Dynamic library for extended attribute support
  49. Group: System Environment/Libraries
  50. License: LGPLv2+
  51. %description -n compat32-libattr
  52. This package contains the libattr.so dynamic library which contains
  53. the extended attribute system calls and library functions.
  54. %package -n compat32-libattr-devel
  55. Summary: Extended attribute static libraries and headers
  56. Group: Development/Libraries
  57. License: LGPLv2+
  58. Requires: libattr-devel = %{version}-%{release}
  59. Requires: compat32-libattr = %{version}-%{release}
  60. %description -n compat32-libattr-devel
  61. This package contains the libraries and header files needed to
  62. develop programs which make use of extended attributes.
  63. For Linux programs, the documented system call API is the
  64. recommended interface, but an SGI IRIX compatibility interface
  65. is also provided.
  66. Currently only ext2, ext3 and XFS support extended attributes.
  67. The SGI IRIX compatibility API built above the Linux system calls is
  68. used by programs such as xfsdump(8), xfsrestore(8) and xfs_fsr(8).
  69. You should install libattr-devel if you want to develop programs
  70. which make use of extended attributes. If you install libattr-devel,
  71. you'll also want to install attr.
  72. %prep
  73. %setup -q
  74. %build
  75. # attr abuses libexecdir
  76. %configure --libdir=/%{_lib} --libexecdir=%{_libdir}
  77. make %{?_smp_mflags} LIBTOOL="libtool --tag=CC"
  78. %install
  79. rm -rf %{buildroot}
  80. make install DESTDIR=%{buildroot}
  81. #make install-dev DESTDIR=%{buildroot}
  82. #make install-lib DESTDIR=%{buildroot}
  83. # get rid of libattr.a and libattr.la
  84. rm -f %{buildroot}/%{_lib}/libattr.a
  85. rm -f %{buildroot}/%{_lib}/libattr.la
  86. rm -f %{buildroot}%{_libdir}/libattr.a
  87. rm -f %{buildroot}%{_libdir}/libattr.la
  88. # fix links to shared libs and permissions
  89. rm -f %{buildroot}%{_libdir}/libattr.so
  90. mkdir -p %{buildroot}%{_libdir}
  91. ln -sf ../../%{_lib}/libattr.so %{buildroot}%{_libdir}/libattr.so
  92. chmod 0755 %{buildroot}/%{_lib}/libattr.so.*.*.*
  93. # remove documents without version
  94. rm -rf %{buildroot}%{_datadir}/doc/attr
  95. mv -f %{buildroot}/%{_lib}/pkgconfig %{buildroot}%{_libdir}/
  96. %find_lang %{name}
  97. %check
  98. if ./setfattr/setfattr -n user.name -v value .; then
  99. make tests || exit $?
  100. # FIXME: root-tests are not ready for the SELinux
  101. #if test 0 = `id -u`; then
  102. # make root-tests || exit $?
  103. #fi
  104. else
  105. echo '*** xattrs are probably not supported by the file system,' \
  106. 'the test-suite will NOT run ***'
  107. fi
  108. %clean
  109. rm -rf %{buildroot}
  110. %post -n libattr
  111. /sbin/ldconfig
  112. %postun -n libattr
  113. /sbin/ldconfig
  114. %post -n compat32-libattr
  115. /sbin/ldconfig
  116. %postun -n compat32-libattr
  117. /sbin/ldconfig
  118. %files -f %{name}.lang
  119. %defattr(-,root,root)
  120. %doc doc
  121. %{_bindir}/attr
  122. %{_bindir}/getfattr
  123. %{_bindir}/setfattr
  124. %{_mandir}/man1/attr.1*
  125. %{_mandir}/man1/getfattr.1*
  126. %{_mandir}/man1/setfattr.1*
  127. #%{_mandir}/man5/attr.5*
  128. %exclude %{_mandir}/man5/attr.5*
  129. %files -n libattr-devel
  130. %defattr(-,root,root)
  131. /%{_lib}/libattr.so
  132. %{_includedir}/attr
  133. %{_libdir}/libattr.*
  134. %{_libdir}/pkgconfig/*.pc
  135. %{_mandir}/man3/attr_*.3.*
  136. %files -n libattr
  137. /%{_lib}/libattr.so.*
  138. %config(noreplace) %{_sysconfdir}/xattr.conf
  139. # compat32
  140. %if %{build_compat32}
  141. %files -n compat32-libattr-devel
  142. %defattr(-,root,root)
  143. /%{_lib}/libattr.so
  144. %{_libdir}/libattr.*
  145. %{_libdir}/pkgconfig/*.pc
  146. %files -n compat32-libattr
  147. /%{_lib}/libattr.so.*
  148. %config(noreplace) %{_sysconfdir}/xattr.conf
  149. %endif
  150. %changelog
  151. * Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.48-1
  152. - new upstream release.
  153. - dropped Patch1, 2.
  154. * Fri Sep 11 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.47-2
  155. - removed a manpage (attr.5).
  156. * Fri Jul 4 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.47-1
  157. - new upstream release.
  158. - replaced patches to the newest rawhide's.
  159. * Sat Apr 9 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.44-1
  160. - new upstream release
  161. - remove static library from devel package
  162. - added Patch2-9
  163. * Tue Mar 29 2011 Kamil Dudka <kdudka@redhat.com> 2.2.44-8
  164. - fix typos in attr(1) man page (#669095)
  165. * Wed Dec 22 2010 Kamil Dudka <kdudka@redhat.com> 2.2.44-6
  166. - setfattr.1: document supported encodings of values (#587516)
  167. - getfattr: encode NULs properly with --encoding=text (#650539)
  168. - getfattr: return non-zero exit code on failure (#660619)
  169. - walk_tree: do not follow symlink to directory with -h (#660613)
  170. * Tue May 25 2010 Kamil Dudka <kdudka@redhat.com> 2.2.44-5
  171. - let attr depend on the same version of libattr (#595689)
  172. - silence compile-time warnings
  173. * Wed Feb 18 2009 Zdenek Prikryl <zprikryl@redhat.com> 2.4.43-2
  174. - Fixed memory leaks (#485473)
  175. * Wed Jul 15 2009 NAKAMURA Kenta <kenta@vinelinux.org> 2.4.43-2
  176. - added compat32 package for x86_64 arch support
  177. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.43-1
  178. - new upstream release
  179. * Mon Jun 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.4.41-2
  180. - initial build for Vine Linux
  181. * Wed Feb 13 2008 Zdenek Prikryl <zprikryl@redhat.com> 2.4.41-1
  182. - New version 2.4.41
  183. - Removed useless attr-2.0.8-docperms.patch
  184. * Wed Oct 31 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.39-1
  185. - New version 2.4.39
  186. - Resolves #284121
  187. * Tue Oct 30 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.38-2
  188. - Removed explicit Requires(post + postun)
  189. - Resolves #225290
  190. * Tue Jul 31 2007 Zdenek Prikryl <zprikryl@redhat.com> 2.4.38-1
  191. - New version 2.4.38
  192. - Resolves #245415
  193. * Fri Feb 23 2007 Karsten Hopp <karsten@redhat.com> 2.4.32-2
  194. - add disttag
  195. - remove trailing dot from summary
  196. - fix buildroot
  197. - -devel package requires same libattr version
  198. - change prereq to Requires(post)
  199. - escape macro in changelog
  200. - replace absolute link with relative link (libattr.so)
  201. - use %%doc macro
  202. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.4.32-1.1
  203. - rebuild
  204. * Wed Jul 5 2006 Thomas Woerner <twoerne@redhat.com> 2.4.32-1
  205. - new version 2.4.32
  206. - fixes segmentation fault in attr, which affects #189106
  207. * Wed Jun 7 2006 Jeremy Katz <katzj@redhat.com> - 2.4.28-2
  208. - rebuild for -devel deps
  209. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.4.28-1.2
  210. - bump again for double-long bug on ppc(64)
  211. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.4.28-1.1
  212. - rebuilt for new gcc4.1 snapshot and glibc changes
  213. * Fri Feb 3 2006 Thomas Woerner <twoerner@redhat.com> 2.4.28-1
  214. - new version 2.4.28
  215. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  216. - rebuilt
  217. * Tue Dec 6 2005 Thomas Woerner <twoerner@redhat.com> 2.4.24-2
  218. - spec file cleanup
  219. - mark po files as lang specific
  220. * Sun Nov 06 2005 Florian La Roche <laroche@redhat.com>
  221. - 2.4.24
  222. * Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.4.23-1
  223. - update to 2.4.23
  224. * Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.4.16-6
  225. - get rid of *.la files
  226. - remove duplicate doc files
  227. * Wed Feb 9 2005 Stephen C. Tweedie <sct@redhat.com> 2.4.16-4
  228. - Rebuild
  229. * Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.16-3
  230. - Build requires libtool >= 1.5
  231. * Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.16-2
  232. - Make libattr.so.* executable.
  233. * Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.16-1
  234. - Update to latest upstream version.
  235. * Sun Aug 8 2004 Alan Cox <alan@redhat.com> 2.4.1-6
  236. - Fix bug #125304 (Steve Grubb: build requires gettext)
  237. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  238. - rebuilt
  239. * Wed Mar 31 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.1-4
  240. - Add missing %%defattr
  241. * Tue Mar 30 2004 Stephen C. Tweedie <sct@redhat.com> 2.4.1-3
  242. - Add /usr/include/attr to files manifest
  243. - Fix location of doc files, add main doc dir to files manifest
  244. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  245. - rebuilt
  246. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  247. - rebuilt
  248. * Tue Aug 5 2003 Elliot Lee <sopwith@redhat.com> 2.4.1-2
  249. - Fix libtool
  250. * Tue Jun 3 2003 Stephen C. Tweedie <sct@redhat.com> 2.4.1-1
  251. - update to attr-2.4.1
  252. * Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.0-1
  253. - update/rebuild
  254. * Sat Jan 4 2003 Jeff Johnson <jbj@redhat.com> 2.0.8-6
  255. - set execute bits on library so that requires are generated.
  256. * Thu Nov 21 2002 Elliot Lee <sopwith@redhat.com> 2.0.8-5
  257. - Redo multilib patch to work everywhere
  258. * Wed Sep 11 2002 Than Ngo <than@redhat.com> 2.0.8-4
  259. - Added fix to install libs in correct directory on 64bit machine
  260. * Thu Aug 08 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-3
  261. - Made the package only own the one directory that is unique to it:
  262. /usr/include/attr
  263. * Wed Jun 26 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-2
  264. - get perl out of base with attr-2.0.8-docperms.patch
  265. * Mon Jun 24 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.8-1
  266. - Initial Red Hat package
  267. Made as few changes as possible relative to upstream packaging to
  268. make it easier to maintain long-term. This means that some of
  269. the techniques used here are definitely not standard Red Hat
  270. techniques. If you are looking for an example package to fit
  271. into Red Hat Linux transparently, this would not be the one to
  272. pick.
  273. - attr-devel -> libattr-devel