foomatic-vl.spec 20 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573
  1. %define enginever 4.0.13
  2. Summary: Foomatic printer database.
  3. Name: foomatic
  4. Version: %{enginever}
  5. Release: 1%{?_dist_release}
  6. License: GPL
  7. Group: System Environment/Libraries
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: tomop, daisuke, machino
  11. Source0: http://www.linuxprinting.org/download/foomatic/foomatic-db-engine-%{enginever}.tar.gz
  12. Patch101: foomatic-manpages.patch
  13. Url: http://www.linuxprinting.org
  14. Requires: cups-filters
  15. Requires: dbus
  16. Requires: foomatic-db
  17. Requires: hplip
  18. Requires: %(eval `perl -V:version`; echo "perl(:MODULE_COMPAT_$version)")
  19. # For 'rm' and '/sbin/service' in post
  20. Requires: fileutils initscripts
  21. BuildRequires: cups
  22. BuildRequires: perl >= 2:5.26.2
  23. BuildRequires: libxml2-devel
  24. BuildRequires: autoconf, automake
  25. BuildRequires: mpage
  26. BuildRequires: dbus-devel
  27. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  28. Provides: perl(Foomatic::GrovePath)
  29. # For 'rm' and '/sbin/service' in post
  30. Requires(pre): coreutils initscripts
  31. Obsoletes: foomatic-db < 4.0
  32. Obsoletes: foomatic-ppd < 4.0
  33. Obsoletes: foomatic-ppd-gimp-print < 4.0
  34. Obsoletes: foomatic-ppd-gimp-print-ijs < 4.0
  35. Obsoletes: foomatic-ppd-omni < 4.0
  36. # We need ghostscript to have the gimp-print-4.2.0 driver, and hpijs 1.1.
  37. Conflicts: ghostscript < 7.05
  38. %description
  39. Foomatic is a comprehensive, spooler-independent database of printers,
  40. printer drivers, and driver descriptions. It contains utilities to
  41. generate driver description files and printer queues for CUPS, LPD,
  42. LPRng, and PDQ using the database. There is also the possibility to
  43. read the PJL options out of PJL-capable laser printers and take them
  44. into account at the driver description file generation.
  45. There are spooler-independent command line interfaces to manipulate
  46. queues (foomatic-configure) and to print files/manipulate jobs
  47. (foomatic printjob).
  48. The site http://www.linuxprinting.org/ is based on this database.
  49. %prep
  50. %setup -q -n foomatic-db-engine-%{version}
  51. # Ship more manpages.
  52. %patch101 -p1 -b .manpages
  53. chmod a+x mkinstalldirs
  54. %build
  55. export LIB_CUPS=%{_libdir}/cups
  56. export CUPS_BACKENDS=%{_libdir}/cups/backend
  57. export CUPS_FILTERS=%{_libdir}/cups/filter
  58. export CUPS_PPDS=%{_datadir}/cups/model
  59. aclocal
  60. autoconf
  61. %configure --disable-xmltest
  62. make PREFIX=%{_prefix} CFLAGS="$RPM_OPT_FLAGS"
  63. %install
  64. make DESTDIR=%buildroot PREFIX=%{_prefix} \
  65. INSTALLSITELIB=%{perl_vendorlib} \
  66. INSTALLSITEARCH=%{perl_vendorarch} \
  67. install
  68. # Use relative, not absolute, symlink for CUPS driver.
  69. ln -sf ../../../bin/foomatic-ppdfile %{buildroot}%{_libdir}/cups/driver/foomatic
  70. mkdir -p %{buildroot}%{_var}/cache/foomatic
  71. echo cups > %{buildroot}%{_sysconfdir}/foomatic/defaultspooler
  72. # Remove things we don't ship.
  73. rm -rf \
  74. %{buildroot}%{_libdir}/ppr \
  75. %{buildroot}%{_sysconfdir}/foomatic/filter.conf.sample \
  76. %{buildroot}%{_datadir}/foomatic/templates
  77. #%{buildroot}%%{_libdir}/perl5/site_perl
  78. find %{buildroot} -name .packlist | xargs rm -f
  79. %post
  80. /bin/rm -f /var/cache/foomatic/*
  81. exit 0
  82. %clean
  83. rm -fr %buildroot $RPM_BUILD_DIR/%{name}
  84. %files
  85. %defattr(-,root,root)
  86. %doc ChangeLog COPYING README TODO
  87. %dir %{_sysconfdir}/foomatic
  88. %config(noreplace) %{_sysconfdir}/foomatic/defaultspooler
  89. %{_bindir}/*
  90. %{_sbindir}/*
  91. %{perl_vendorlib}/Foomatic
  92. %{_libdir}/cups/driver/*
  93. %{_datadir}/foomatic
  94. %{_mandir}/*/*
  95. %{_var}/cache/foomatic
  96. %changelog
  97. * Sat May 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.13-1
  98. - new upstream release.
  99. - rebuilt with perl-5.26.
  100. * Sun Oct 4 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.12-2
  101. - removed foomatic-filters (moved to cups-filters).
  102. - moved foomatic-db as a standalone package.
  103. * Tue Jun 9 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.12-1
  104. - new upstream release.
  105. * Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 4.0.11-2
  106. - rebuild with perl-5.16
  107. - add BR: dbus-devel
  108. * Sun Jun 8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.11-1
  109. - new upstream release.
  110. * Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.9-1
  111. - new upstream release.
  112. * Mon Jun 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-2
  113. - added hplip and coreutils to "Requires:".
  114. - removed hpijs and fileutils from "Requires:".
  115. * Wed Apr 06 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.7-1
  116. - new upstream release.
  117. - dropped Source3 (no longer provided by upstream).
  118. - updated Patch2.
  119. * Thu Mar 24 2011 IWAI, Masaharu <iwai@alib.jp> 4.0.1-3
  120. - rebuild with perl 5.12.3
  121. * Fri Jul 24 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 4.0.1-2
  122. - add Requires: hpijs
  123. * Fri May 29 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 4.0.1-1
  124. - new upstream release
  125. * Sun Mar 22 2009 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 4.0.0-1
  126. - new upstream release.
  127. - applied some patches from Fedora development.
  128. - remove subpackages.
  129. * Fri Sep 12 2008 Shu KONNO <owa@bg.wakwak.com> 3.0.2-1vl5
  130. - applied new versioning policy
  131. - used rpm macros: %%perl_sitelib %%perl_sitearch
  132. - added foomatic-db-engine-3.1-20050411-combo-xml.patch
  133. - added foomatic-db-engine-3.1-20050411-perl-data.patch
  134. - fixed permission of %%{_datadir}/foomatic/db
  135. * Sat Dec 02 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 3.0.2-0vl5
  136. - add BuildRequires: libxml2-devel, mpage, Omni
  137. - use %%{_prefix}/lib/{cups,ppr} instead of %%{_libdir}/{cups,ppr}
  138. - run foomatic-cleanupdrivers, foomatic-compiledb with 'perl -Ilib'
  139. - not create ppd-omni package if omni support is disabled
  140. * Mon Apr 11 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl4
  141. - updated foomatic-db to 20050411
  142. - updated foomatic-db-engine to 3.1-20050411
  143. - updated foomatic-db-hpijs to 1.5-20050411
  144. - updated foomatic-filters to 3.1-20050411
  145. * Wed Jan 12 2005 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl3
  146. - updated foomatic-db to 20050112
  147. - updated foomatic-db-engine to 3.1-20050112
  148. - updated foomatic-db-hpijs to 1.5-20050112
  149. * Tue Dec 21 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl2
  150. - updated foomatic-db to 20041220
  151. - updated foomatic-db-hpijs to 1.5-20041220
  152. * Sun Sep 19 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.2-0vl1
  153. - updated foomatic-db to 20040919
  154. - updated foomatic-db-engine to 3.0.2
  155. - updated foomatic-db-hpijs to 1.5-20040919
  156. - updated foomatic-filters to 3.0.2
  157. * Wed May 26 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl4
  158. - update foomatic-db to 20040526
  159. - update foomatic-db-hpijs to 1.5-20040526
  160. * Tue May 25 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 3.0.1-0vl3
  161. - sprit foomatic-ppd to ppd,ppd-hpijs,ppd-omni,ppd-gimp-print,
  162. ppd-gimp-print-ijs
  163. - add Requires: to ppd-* subpackages.
  164. * Thu Apr 15 2004 KOBAYASHI R. Taizo <tkoba@vinelinux.org> 3.0.1-0vl2
  165. - new upstream version
  166. -- Omni-printers-0.9.1
  167. -- gimp-print-foomatic-db-4.2.6
  168. - foomatic.spec -> foomatic-vl.spec
  169. * Fri Feb 20 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.1-0vl1
  170. - new upstream version
  171. -- foomatic-filters-3.0.1
  172. -- foomatic-db-engine-3.0.1
  173. -- foomatic-db-20040219
  174. -- foomatic-db-hpijs-1.5-20040219
  175. * Mon Jan 26 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl11
  176. - new upstream version
  177. -- foomatic-filters-3.0.1rc3(bug fix. in configure script)
  178. -- defined filterver
  179. - dropped patch101
  180. * Sun Jan 25 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl10
  181. - new upstream cvs version(foomatic-3.0.1rc2)
  182. -- foomatic-db-20040125
  183. -- foomatic-db-engine-3.0.1rc2
  184. -- foomatic-db-hpijs-1.5-20040125
  185. -- foomatic-filters-3.0.1rc2
  186. - added patch101
  187. -- tests diris null in foomatic-filters-3.0.1rc2
  188. * Fri Jan 23 2004 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl9
  189. - new upstream cvs version
  190. -- foomatic-db-20040123
  191. -- foomatic-db-engine-3.0-20040123
  192. -- foomatic-db-hpijs-1.5-20040123
  193. -- foomatic-filters-3.0-20040123
  194. - dropped old patches
  195. * Sat Dec 13 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl8
  196. - built on perl-5.8.2
  197. * Tue Nov 11 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl7
  198. - separated foomatic-db package included xml files
  199. * Mon Nov 10 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl6
  200. - added description of ppd sub package
  201. * Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl5
  202. - separated foomatic-ppd package included PPD files
  203. * Sun Nov 09 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl4
  204. - new upstream version
  205. -- foomatic-db-20031109, foomatic-db-engine-3.0-20031109
  206. -- foomatic-filters-3.0-20031109, foomatic-db-hpijs-1.4-1
  207. - dropped patches
  208. -- foomatic-filters-path.patch(patch0)
  209. -- foomatic-2.0.2-fontpath.patch(patch3)
  210. - updated patches
  211. -- foomatic-filters-3.0-20031109-libdir.patch (patch1)
  212. -- foomatic-db-engine-3.0-20031109-libdir.patch (patch2)
  213. -- foomatic-filters-3.0-20031109-vine.patch (patch100)
  214. * Thu Nov 06 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl3
  215. - built on perl-5.8.1
  216. - fixed install section in spec file
  217. * Sat Aug 30 2003 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 3.0.0-0vl2
  218. - fix some bugs of foomatic-filters.
  219. A
  220. * Sat Jun 07 2003 Satoshi MACHINO <machino@vinelinux.org> 3.0.0-0vl1
  221. - new upstream version
  222. -- rewrote spec file
  223. -- added some patches from rawhide(foomatic-3.0.0-5)
  224. - enable cups support
  225. * Sun Apr 20 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl2
  226. - imported some patches from foomatic-2.0.2-18
  227. -- added foomatic-2.0.2-psc2210.patch
  228. -- added foomatic-2.0.2-duplex184.patch
  229. * Sun Mar 02 2003 Satoshi MACHINO <machino@vinelinux.org> 2.0.2-0vl1
  230. - imported foomatic-2.0.2-15
  231. * Tue Feb 4 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-15
  232. - Update data-generators to CVS.
  233. * Thu Jan 30 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-14
  234. - Use hpijs, not hpijs-rss (we don't ship the RSS patch now).
  235. * Thu Jan 23 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-13
  236. - Pacify printers that don't understand duplex (bug #82385).
  237. * Wed Jan 22 2003 Tim Powers <timp@redhat.com> 2.0.2-12
  238. - rebuilt
  239. * Tue Jan 21 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-11
  240. - Add autodetect info for HP DeskJet 656C. It doesn't really do
  241. IEEE 1284 IDs, but since it's a USB device we can figure out it's
  242. manufacturer and model anyway.
  243. * Thu Jan 9 2003 Tim Waugh <twaugh@redhat.com> 2.0.2-10
  244. - Set GS_FONTPATH in gs wrapper (bug #81410).
  245. * Sat Jan 4 2003 Jeff Johnson <jbj@redhat.com> 2.0.2-9
  246. - use internal dep generator.
  247. * Sun Dec 15 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-8
  248. - Add several device IDs.
  249. * Sat Dec 14 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-7
  250. - Update Omni printers to 0.7.2.
  251. - No longer need Omni badxml patch.
  252. * Sat Dec 14 2002 Tim Powers <timp@redhat.com> 2.0.2-6
  253. - don't use rpms internal dep generator
  254. * Fri Dec 6 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-5
  255. - Omni XML wasn't well-formed.
  256. * Wed Nov 20 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-4
  257. - Update gimp-print data.
  258. - Add 'generic postscript' model.
  259. * Mon Nov 11 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-3
  260. - Update Omni printers to 0.7.1.
  261. * Tue Oct 22 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-2
  262. - Fix file manifest for perl modules.
  263. - Add autodetect information for HP DeskJet 990C.
  264. * Mon Oct 21 2002 Tim Waugh <twaugh@redhat.com> 2.0.2-1
  265. - 2.0.2.
  266. - No longer need 67973, 970c patches.
  267. - Remove cups-drivers-* packages (no longer needed).
  268. - Remove files not shipped. Ship filter.conf.
  269. - Conditionally restart cups.
  270. - Use libdir.
  271. - Don't put things in site_perl; use vendor_perl instead (bug #73528).
  272. * Fri Aug 9 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.6
  273. - Fix autodetect information for HPDJ970C.
  274. * Thu Aug 8 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.5
  275. - For gimp-print, use the Ghostscript stp driver in preference to the
  276. IJS interface.
  277. * Thu Jul 25 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.4
  278. - Quieten scriptlets.
  279. * Fri Jul 5 2002 Tim Waugh <twaugh@redhat.com> 1.9-1.20020617.3
  280. - Fix autodetect information for HPLJ2100/2100M.
  281. * Fri Jun 21 2002 Tim Powers <timp@redhat.com> 1.9-1.20020617.2
  282. - automated rebuild
  283. * Wed Jun 19 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.2
  284. - Omni 0.7.0 printers.
  285. * Mon Jun 17 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020617.1
  286. - Update to CVS.
  287. - Remove some more explicit perl dependencies that are picked up
  288. automatically.
  289. * Wed May 29 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.3
  290. - Remove explicit perl-Storable dependency; it should be perl(Storable),
  291. and that is picked up automatically.
  292. * Tue May 28 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.2
  293. - Fix release number.
  294. - Drop gen-ppds from the file manifest---use foomatic-compiledb instead
  295. (bug #63622).
  296. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  297. - automated rebuild
  298. * Thu May 23 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.1
  299. - Remove ghostscript UPP drivers that are gone in 7.05.
  300. * Sat May 18 2002 Tim Waugh <twaugh@redhat.com> 1.9-0.20020517.0.1
  301. - Update to CVS.
  302. - Updated requirements.
  303. - Updated path and libdir patches.
  304. - Drop hpijs 1.0.2 patch.
  305. - foomatic-datafile has moved to %%{_bindir}.
  306. - Update gimp-print data to 4.2.1.
  307. - Update Omni printer data to 0.6.1.
  308. * Thu Apr 4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.3
  309. - Fix the hpijs option data too (bug #62587).
  310. * Wed Apr 3 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.2
  311. - Back off to 1.0.2 for hpijs driver data (bug #62587).
  312. * Thu Mar 14 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020313.1
  313. - Update to CVS.
  314. * Wed Mar 6 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020306.1
  315. - Update to CVS.
  316. - Patches no longer needed: conffile, sys, cachedir, fd0.
  317. - Adapted path patch.
  318. * Tue Mar 5 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.10
  319. - Fix bug #58319.
  320. - Drop dbg patch.
  321. * Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.9
  322. - Fix file lists.
  323. * Mon Feb 25 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.8
  324. - Fix %post scriplet bug (bug #59942).
  325. * Thu Feb 21 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.7
  326. - Rebuild in new environment.
  327. * Wed Feb 13 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.6
  328. - Merge cups-drivers. No epoch needed.
  329. - Require perl-URI.
  330. * Wed Feb 06 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.5
  331. - Cache fix.
  332. * Mon Feb 4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.4
  333. - Don't ship backup files.
  334. * Mon Feb 4 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.3
  335. - Rebuild to pick up new perl installsitelib.
  336. * Thu Jan 31 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.2
  337. - Fix a thinko in DB.pl.
  338. * Wed Jan 30 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020130.1
  339. - Update to CVS.
  340. - No longer need the cachedir patch.
  341. - Fix config file path.
  342. - Look in /usr/local/bin last, not first, in lpdomatic (bug #57915).
  343. * Tue Jan 29 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020129.1
  344. - Update to CVS.
  345. - Patches no longer needed: prepend, fd3.
  346. - Use RPM_OPT_FLAGS.
  347. - Allow non-root users to use foomatic-datafile (bug #58956).
  348. * Sat Jan 26 2002 Jeff Johnson <jbj@redhat.com> 1.1-0.20020124.2
  349. - added Provides: perl(Foomatic::GrovePath)
  350. * Thu Jan 24 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20020124.1
  351. - Update to CVS.
  352. - Updated Omni printers to those in Omni 0.5.1.
  353. - Updated patches: prepend, fd3.
  354. - Patches no longer needed: utf8, lpdomatic.
  355. - Added gimp-print (formerly stp) foomatic db info, and removed the old
  356. stp.xml file.
  357. - Conflict with ghostscript if it doesn't have gimp-print-4.2.0 yet.
  358. * Fri Jan 18 2002 Tim Waugh <twaugh@redhat.com> 1.1-0.20011218.2
  359. - REALLY fix PCL fixup code (bug #55909, others).
  360. - PreReq fileutils, initscripts (bug #56984).
  361. - Fix prepends in lpdomatic (bug #57371).
  362. - Run foomatic-cleanupdrivers during install, to remove driver entries
  363. with no command line.
  364. - Put lpdomatic in /usr/sbin again.
  365. - Fix foomatic-gswrapper's file descriptor manipulations (bug #56871).
  366. * Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011218.1
  367. - re-imported from upstream to fix some perl fixup code on pcl printers.
  368. * Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.2
  369. - fix the rest of the quoting issues with foomatic-combo-xml with the patch
  370. - foomatic-1.1-20011217-quotes.patch. This has been sent upstream.
  371. * Mon Dec 17 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011217.1
  372. - respin to pull in latest foomatic database, fixes:
  373. - properly use the cache in relation to foomatic-combo-xml's output
  374. - fix _some_ of the quoting issues with calling foomatic-combo-xml
  375. * Wed Dec 5 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011205.1
  376. - respin to pull in latest foomatic database, fixes:
  377. - droping half of a large job
  378. - -Mutf8 added to the upstream filters
  379. - miscelaneous printer db updates
  380. * Thu Nov 29 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.8
  381. - added Requires: fileutils for the 'rm' in post
  382. * Mon Nov 26 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.7
  383. - /var/chache => /var/cache, doh!
  384. * Fri Nov 16 2001 Nalin Dahyabhai <nalin@redhat.com> 1.1-0.20011018.6
  385. - fix %%post scriptlet
  386. * Tue Nov 13 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.5
  387. - changed the patch to use the -Mutf8 command line option,
  388. - and to restart the printserver, after rebuilding the settings.
  389. * Fri Nov 9 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.4
  390. - grumble. Some drivers use inline perl scripts, and need the 'use utf8;'
  391. - pragma. Without it, they break on _some_ of their options.
  392. * Wed Oct 31 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.3
  393. - patched lpdomatic to prepend PostScript options in the _right_ place.
  394. * Thu Oct 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.2
  395. - zap the foomatic cache on install
  396. * Thu Oct 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011018.1
  397. - rolled to pull in latest information.
  398. - added Omni printers to the printer list.
  399. * Fri Oct 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011005.1
  400. - rolled to pull in an ia64 fix to foomatic-combo-xml.c
  401. * Mon Oct 01 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20011001.1
  402. - rolled to pull in foomatic fixes to foomatic-combo-xml.c
  403. * Wed Sep 05 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010905.1
  404. - upgraded to latest foomatic, we now have fast overview generation!
  405. - this means that there is no prebuilt overview file.
  406. * Tue Aug 28 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010828.1
  407. - WOW! The latest foomatic uses Till Kamppeter's C based combo compiler.
  408. - It is now fast enough that there is no real benifit to precompiling.
  409. - NOTE: this forces the package to stop being noarched.
  410. * Mon Aug 27 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010827.1
  411. - fresh pull, maybe it fixes the build errors.
  412. * Sat Aug 25 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010825.1
  413. - did a fresh database pull, which contains the old japanese printers as well.
  414. - removed japanese hack.
  415. * Tue Aug 14 2001 Akira TAGOH <tagoh@redhat.com> 1.1-0.20010717.5
  416. - Add Japanese printer entry.
  417. * Mon Aug 6 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.4
  418. - move the cache back to /var, sigh.
  419. * Mon Jul 23 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.2
  420. - made foomatic pre-compute its db
  421. * Wed Jul 18 2001 Crutcher Dunnavant <crutcher@redhat.com> 1.1-0.20010717.1
  422. - imported from mandrake.
  423. * Tue Jul 17 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010717mdk
  424. - Added job listing/removal/manipulation and queue control to
  425. foomatic-printjob
  426. - Support for printing multiple copies with PDQ
  427. * Sat Jul 14 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010714mdk
  428. - Included the cupsomatic filter script
  429. - When a queue is set up, default options can be set now
  430. - Help messages of foomatic-configure and foomatic-printjob cleaned up.
  431. * Fri Jul 13 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010713mdk
  432. - Many bugfixes in "foomatic-printjob".
  433. - "foomatic-configure" adds the Foomatic config file directory automatically
  434. to the search paths of PDQ.
  435. - Printing a help page under PDQ was broken.
  436. * Thu Jul 12 2001 Stefan van der Eijk <stefan@eijk.nu> 1.1-0.20010712mdk
  437. - BuildRequires: perl-devel
  438. * Wed Jul 11 2001 Till Kamppeter <till@mandrakesoft.com> 1.1-0.20010711mdk
  439. - initial release.
  440. - Deleted the obsolete drivers "stp", "cZ11", and "hpdj".
  441. - Patch applied which flushes the memory cache regularly, otherwise
  442. foomatic-configure would hang when the Foomatic data of GIMP-Print is
  443. installed.