libev-vl.spec 7.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %global source_dir %{_datadir}/%{name}-source
  3. %global inst_srcdir %{buildroot}/%{source_dir}
  4. Name: libev
  5. Version: 4.25
  6. Release: 1%{?_dist_release}
  7. Summary: High-performance event loop/event model with lots of features
  8. Summary(ja): 高機能・高性能のイベントループ・イベントモデル
  9. Group: System Environment/Libraries
  10. License: BSD or GPLv2+
  11. URL: http://software.schmorp.de/pkg/libev.html
  12. Source0: http://dist.schmorp.de/libev/Attic/%{name}-%{version}.tar.gz
  13. Vendor: Project Vine
  14. Distribution: Vine Linux
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  16. BuildRequires: automake libtool
  17. %description
  18. Libev is modeled (very loosely) after libevent and the Event Perl
  19. module, but is faster, scales better and is more correct, and also more
  20. featureful. And also smaller.
  21. %description -l ja
  22. libev は libevent および Perl の Event を大まかに参考にして作られましたが、
  23. それらより高速に動作し、よりスケールし、より正確で、より高機能で、
  24. 同時によりコンパクトです。
  25. %package devel
  26. Summary: Development files for %{name}
  27. Summary(ja): %{name} の開発用ファイル
  28. Group: Development/Libraries
  29. Requires: %{name}%{?_isa} = %{version}-%{release}
  30. Requires: pkgconfig
  31. %description devel
  32. Libev is modeled (very loosely) after libevent and the Event Perl
  33. module, but is faster, scales better and is more correct, and also more
  34. featureful. And also smaller. Development libraries.
  35. %description devel -l ja
  36. このパッケージには libev 用開発ライブラリとヘッダが収録されています。
  37. %package libevent-devel
  38. Summary: Compatibility development header with libevent for %{name}.
  39. Summary(ja): libevent互換の%{name}ヘッダファイル.
  40. Requires: %{name}-devel%{?_isa} = %{version}-%{release}
  41. # The event.h file actually conflicts with the one from libevent-devel
  42. Conflicts: libevent-devel
  43. %description libevent-devel
  44. This package contains a development header to make libev compatible with
  45. libevent.
  46. %description libevent-devel -l ja
  47. このパッケージにはlibevent互換のlibev用ヘッダファイルが収録されています。
  48. %package source
  49. Summary: Source code for libev
  50. Summary(ja): libev のソースコード
  51. Group: Development/Libraries
  52. BuildArch: noarch
  53. %description source
  54. This package contains the source code for libev.
  55. Libev is modeled (very loosely) after libevent and the Event Perl
  56. module, but is faster, scales better and is more correct, and also more
  57. featureful. And also smaller. Development libraries.
  58. %description source -l ja
  59. このパッケージには libev のソースコードが収録されています。
  60. %package -n compat32-%{name}
  61. Summary: High-performance event loop/event model with lots of features
  62. Summary(ja): 高機能・高性能のイベントループ・イベントモデル
  63. Group: System Environment/Libraries
  64. %description -n compat32-%{name}
  65. Libev is modeled (very loosely) after libevent and the Event Perl
  66. module, but is faster, scales better and is more correct, and also more
  67. featureful. And also smaller.
  68. %description -n compat32-%{name} -l ja
  69. libev は libevent および Perl の Event を大まかに参考にして作られましたが、
  70. それらより高速に動作し、よりスケールし、より正確で、より高機能で、
  71. 同時によりコンパクトです。
  72. %prep
  73. %setup -q
  74. #autoreconf -vfi
  75. %build
  76. %configure --disable-static --with-pic
  77. make %{?_smp_mflags}
  78. %check
  79. make check
  80. %install
  81. rm -rf %{buildroot}
  82. make install DESTDIR=%{buildroot} INSTALL="install -p"
  83. rm -rf %{buildroot}%{_libdir}/%{name}.la
  84. # Make the source package
  85. mkdir -p %{inst_srcdir}
  86. find . -type f | grep -E '.*\.(c|h|am|ac|inc|m4|h.in|pc.in|man.pre|pl|txt)$' | xargs tar cf - | (cd %{inst_srcdir} && tar xf -)
  87. install -p -m 0644 Changes ev.pod LICENSE README %{inst_srcdir}
  88. %clean
  89. rm -rf %{buildroot}
  90. %post -p /sbin/ldconfig
  91. %postun -p /sbin/ldconfig
  92. %files
  93. %license LICENSE
  94. %doc Changes README
  95. %{_libdir}/%{name}.so.4*
  96. %files devel
  97. %{_libdir}/%{name}.so
  98. %{_includedir}/ev++.h
  99. %{_includedir}/ev.h
  100. %{_mandir}/man?/*
  101. %files libevent-devel
  102. %{_includedir}/event.h
  103. %files source
  104. %{source_dir}
  105. %if %{build_compat32}
  106. %files -n compat32-%{name}
  107. %{_libdir}/%{name}.so.4*
  108. %endif
  109. %changelog
  110. * Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.25-1
  111. - updated to 4.25.
  112. * Sat Nov 03 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 4.24-1
  113. - updated to 4.24.
  114. - added a sub-package 'libevent-devel'.
  115. - added a sub-package 'compat32-libev'.
  116. * Sat Nov 01 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> - 4.19-1
  117. - updated to 4.19
  118. - spec in UTF-8
  119. - moved devel and source packages to Development/Libraries Group
  120. * Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 4.04-1
  121. - initial build for Vine Linux
  122. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.04-2
  123. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  124. * Tue Aug 9 2011 Tom Callaway <spot@fedoraproject.org> - 4.04-1
  125. - move man page
  126. - cleanup spec
  127. - update to 4.04
  128. * Mon Jun 13 2011 Matト嬲 Cepl <mcepl@redhat.com> - 4.03-2
  129. - EL5 cannot have noarch subpackages.
  130. * Sat Feb 5 2011 Michal Nowak <mnowak@redhat.com> - 4.03-1
  131. - 4.03; RHBZ#674022
  132. - add a -source subpackage (Mathieu Bridon); RHBZ#672153
  133. * Mon Jan 10 2011 Michal Nowak <mnowak@redhat.com> - 4.01-1
  134. - 4.01
  135. - fix grammar in %%description
  136. * Sat Jan 2 2010 Michal Nowak <mnowak@redhat.com> - 3.90-1
  137. - 3.9
  138. * Mon Aug 10 2009 Michal Nowak <mnowak@redhat.com> - 3.80-1
  139. - 3.8
  140. - always use the most recent automake
  141. - BuildRequires now libtool
  142. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.70-3
  143. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  144. * Fri Jul 17 2009 Michal Nowak <mnowak@redhat.com> - 3.70-2
  145. - spec file change, which prevented uploading most recent tarball
  146. so the RPM was "3.70" but tarball was from 3.60
  147. * Fri Jul 17 2009 Michal Nowak <mnowak@redhat.com> - 3.70-1
  148. - v3.7
  149. - list libev soname explicitly
  150. * Mon Jun 29 2009 Michal Nowak <mnowak@redhat.com> - 3.60-1
  151. - previous version was called "3.6" but this is broken update
  152. path wrt version "3.53" -- thus bumping to "3.60"
  153. * Thu Apr 30 2009 Michal Nowak <mnowak@redhat.com> - 3.6-1
  154. - 3.60
  155. - fixed few mixed-use-of-spaces-and-tabs warnings in spec file
  156. * Thu Mar 19 2009 Michal Nowak <mnowak@redhat.com> - 3.53-1
  157. - 3.53
  158. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.52-2
  159. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  160. * Wed Jan 07 2009 Michal Nowak <mnowak@redhat.com> - 3.52-1
  161. - 3.52
  162. * Wed Dec 24 2008 Michal Nowak <mnowak@redhat.com> - 3.51-1
  163. - 3.51
  164. * Thu Nov 20 2008 Michal Nowak <mnowak@redhat.com> - 3.49-1
  165. - version bump: 3.49
  166. * Sun Nov 9 2008 Michal Nowak <mnowak@redhat.com> - 3.48-1
  167. - version bump: 3.48
  168. * Mon Oct 6 2008 kwizart <kwizart at gmail.com> - 3.44-1
  169. - bump to 3.44
  170. * Tue Sep 2 2008 kwizart <kwizart at gmail.com> - 3.43-4
  171. - Fix pkgconfig support
  172. * Tue Aug 12 2008 Michal Nowak <mnowak@redhat.com> - 3.43-2
  173. - removed libev.a
  174. - installing with "-p"
  175. - event.h is removed intentionaly, because is there only for
  176. backward compatibility with libevent
  177. * Mon Aug 04 2008 Michal Nowak <mnowak@redhat.com> - 3.43-1
  178. - initial package