neon-vl.spec 9.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: neon
  3. Summary: An HTTP and WebDAV client library.
  4. Summary(ja): HTTP と WebDAV クライアントのライブラリ
  5. Version: 0.30.2
  6. Release: 1%{?_dist_release}
  7. License: LGPLv2+
  8. Group: System Environment/Libraries
  9. URL: http://www.webdav.org/neon/
  10. Source0: http://www.webdav.org/neon/%{name}-%{version}.tar.gz
  11. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  12. Requires: expat
  13. Requires: zlib >= 1.1.4
  14. Requires: krb5-libs
  15. BuildRequires: expat-devel
  16. BuildRequires: gnutls-devel
  17. BuildRequires: krb5-devel
  18. BuildRequires: libxml2-devel
  19. BuildRequires: sed
  20. BuildRequires: zlib-devel
  21. BuildRequires: keyutils-libs-devel
  22. Vendor: Project Vine
  23. Distribution: Vine Linux
  24. %description
  25. neon is an HTTP and WebDAV client library, with a C interface;
  26. providing a high-level interface to HTTP and WebDAV methods along
  27. with a low-level interface for HTTP request handling. neon
  28. supports persistent connections, proxy servers, basic, digest and
  29. Kerberos authentication, and has complete SSL support.
  30. %package devel
  31. Summary: Development libraries and C header files for the neon library
  32. Summary(ja): neon の開発用ライブラリおよび C言語ヘッダファイル
  33. Group: Development/Libraries
  34. Requires: %{name} = %{version}
  35. Requires: zlib-devel
  36. #Requires: openssl-devel
  37. Requires: expat-devel
  38. Requires: gnutls-devel
  39. Requires: krb5-devel
  40. Requires: keyutils-libs-devel
  41. %description devel
  42. The development library for the C language HTTP and WebDAV client library.
  43. %description devel -l ja
  44. C言語による HTTP と WebDAV クライアントのライブラリの開発用パッケージ
  45. ## to build compat32 for x86_64 architecture support
  46. %package -n compat32-%{name}
  47. Summary: C language HTTP and WebDAV client library.
  48. Group: System Environment/Libraries
  49. Requires: expat
  50. Requires: zlib >= 1.1.4
  51. %description -n compat32-%{name}
  52. A C language HTTP and WebDAV client library.
  53. %package -n compat32-%{name}-devel
  54. Summary: A C language HTTP and WebDAV client library.
  55. Group: Development/Libraries
  56. Requires: compat32-%{name} = %{version}
  57. Requires: compat32-zlib-devel
  58. #Requires: compat32-openssl-devel
  59. Requires: compat32-expat-devel
  60. Requires: compat32-keyutils-libs-devel
  61. Requires: compat32-krb5-devel
  62. %description -n compat32-%{name}-devel
  63. The development library for the C language HTTP and WebDAV client library.
  64. %prep
  65. %setup -q
  66. # for GnuTLS 3.4
  67. sed -e 's/client_set/set/' \
  68. -e 's/gnutls_retr/&2/' \
  69. -e 's/type = t/cert_&/' \
  70. -i src/ne_gnutls.c
  71. %build
  72. %configure \
  73. --with-expat \
  74. --with-ssl=gnutls \
  75. --enable-threadsafe-ssl=posix \
  76. --enable-shared \
  77. --disable-static \
  78. --with-force-ssl
  79. %__make %{?_smp_mflags}
  80. %install
  81. %__rm -rf %{buildroot}
  82. %makeinstall
  83. sed -ri "/^dependency_libs/{s,-l[^ ']*,,g}" \
  84. $RPM_BUILD_ROOT%{_libdir}/libneon.la
  85. %find_lang %{name}
  86. ## remove unuse files
  87. rm -rf $RPM_BUILD_ROOT%{_libdir}/*.la
  88. %clean
  89. rm -rf $RPM_BUILD_ROOT
  90. %post -p /sbin/ldconfig
  91. %postun -p /sbin/ldconfig
  92. %post -n compat32-%{name} -p /sbin/ldconfig
  93. %postun -n compat32-%{name} -p /sbin/ldconfig
  94. %files -f %{name}.lang
  95. %defattr(-,root,root)
  96. %doc AUTHORS BUGS ChangeLog INSTALL.win32 NEWS README THANKS TODO
  97. %doc doc/html
  98. %{_libdir}/*.so.*
  99. %files devel
  100. %defattr(-,root,root)
  101. %{_bindir}/*
  102. %{_includedir}/*
  103. %{_mandir}/man1/*
  104. %{_mandir}/man3/*
  105. #{_libdir}/*.a
  106. #{_libdir}/*.la
  107. %{_libdir}/*.so
  108. %{_libdir}/pkgconfig/*.pc
  109. %if %{build_compat32}
  110. %files -n compat32-%{name}
  111. %defattr(-,root,root)
  112. %{_libdir}/*.so.*
  113. %files -n compat32-%{name}-devel
  114. %defattr(-,root,root)
  115. #{_libdir}/*.a
  116. #{_libdir}/*.la
  117. %{_libdir}/pkgconfig/*.pc
  118. %endif
  119. %changelog
  120. * Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.30.2-1
  121. - new upstream release.
  122. * Wed Dec 30 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.30.1-1
  123. - new upstream release.
  124. - built with gnutls-3.4.x.
  125. * Tue Feb 25 2014 NAKAMURA Kenta <kenta@vinelinux.org> 0.30.0-1
  126. - update to 0.30.0
  127. * Sun Jan 05 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.6-2
  128. - rebuild with VineSeed environment
  129. * Sun Sep 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.6-1
  130. - update to 0.29.6
  131. * Mon May 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.29.3-2
  132. - add BuildRequires: keyutils-libs-devel
  133. - add Requires: krb5-devel, keyutils-libs-devel (-devel package)
  134. * Sun Apr 24 2011 IWAI, Masaharu <iwai@alib.jp> 0.29.3-1
  135. - new upstream release
  136. * Thu Mar 24 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.6-3
  137. - rebuilt with krb5-libs-1.8.2
  138. - removed BR: openssl-devel
  139. - removed static library from devel package
  140. * Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 0.28.6-2
  141. - rebuilt with rpm-4.8.1 for pkg-config
  142. * Tue Aug 25 2009 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.6-1
  143. - new upstream release with security fix (CVE-2009-2473, 2474)
  144. * Sat Jan 17 2009 Toshiharu Kudoh <toshi.kd2@gmail.com> 0.28.3-3vl5
  145. - rebuild with gnutls-2.6.3
  146. * Sun Oct 19 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-2vl5
  147. - add Requires/BuildRequires krb5-libs/krb5-devel tags
  148. - add _smp_mflags into make section
  149. * Fri Oct 17 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 0.28.3-1vl5
  150. - new upstream release with security fix (CVE-2008-3746)
  151. * Fri Sep 26 2008 Shu KONNO <owa@bg.wakwak.com> 0.28.2-3vl5
  152. - removed *.la
  153. - spec in utf-8
  154. * Sat Apr 19 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-2vl5
  155. - added --with-ssl=gnutls --enable-threadsafe-ssl
  156. - added BuildRequires: gnutls-devel
  157. * Fri Apr 18 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.28.2-1vl5
  158. - new upstream release
  159. * Mon Feb 25 2008 NAKAMURA Kenta <kenta@vinelinux.org> 0.26.3-0vl3
  160. - removed %%if !%%{build_compat32} case condition
  161. * Wed Feb 20 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 0.26.3-0vl2
  162. - rebuild with expat-2.0.1
  163. * Wed May 16 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 0.26.3-0vl1
  164. - new upstream release
  165. * Mon Mar 12 2007 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl3
  166. - add Requires: zlib-devel, openssl-devel, expat-devel
  167. * Mon May 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl2
  168. - move %%configure from %%prep to %%build
  169. - remove unneeded locales.patch (for neon-0.26.x or later)
  170. * Wed Apr 05 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 0.25.5-0vl1
  171. - new upstream release
  172. - drop doc.patch (patch0)
  173. - use more macros
  174. - drop BuildRequires: autoconf, automake
  175. - add *.pc to -devel (and compat32's) package
  176. - change group
  177. - add Requires: %%{name} = %%{version} to -devel (and compat32's) package
  178. - add doc/html instead of doc/* to %%doc
  179. - move %%{_mandir}/man1/* and %%{_bindir}/* to -devel package
  180. - run ldconfig in %%post,postun
  181. - add locales.patch (patch0)
  182. * Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl3
  183. - moved macros (_lib, gcc -m32) to /usr/lib/rpm/rpmrc or macros files
  184. * Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 0.24.7-0vl2
  185. - added compat32- packages for x86_64 architecture support
  186. - added --libdir=%{_libdir} option to configure
  187. * Sun Sep 5 2004 USAMI Kosuke <usami-k@yc5.so-net.ne.jp> - 0.24.7-0vl1
  188. - new upstream release
  189. * Sun Nov 23 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.4-0vl1
  190. - upstream release
  191. - update URL and Source0 tag: valid URL
  192. * Fri Sep 19 2003 IWAI, Masaharu <iwai@alib.jp> 0.24.2-0vl1
  193. - upstream release
  194. - add BuildRequires: openssl-devel, libxml2-devel, zlib-devel
  195. - add Japanese Summary and %%description
  196. * Sun Mar 30 2003 Kazuhisa TAKEI <takei@vinelinux.org> 0.23.5-1vl1
  197. - build VineLinux
  198. * Mon Nov 04 2002 David Summers <david@summersoft.fay.ar.us> 0.23.5-1
  199. - Updated to 0.23.5.
  200. * Tue Aug 27 2002 David Summers <david@summersoft.fay.ar.us> 0.23.2-1
  201. - Upgraded to 0.23.2.
  202. * Fri Aug 16 2002 David Summers <david@summersoft.fay.ar.us> 0.22.0-1
  203. - Upgraded to 0.22.0.
  204. - Fixed compilation from CVS.
  205. - Took out man pages until I can figure out xmlto program.
  206. * Sat Aug 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-3
  207. - Fixed compilation on RedHat 7.2 by upgrading libtool and auto* packages
  208. to RedHat 7.3 versions and fixing bug in spec file.
  209. - Gave up on CVS version of neon until we can figure out why autogen.sh doesn't
  210. work.
  211. * Wed Jul 24 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-2
  212. - Fixed file ownership problems. Made them owned by root.
  213. * Fri Jul 19 2002 David Summers <david@summersoft.fay.ar.us> 0.21.3-1
  214. - Updated to neon 0.21.3.
  215. * Sun Jun 16 2002 David Summers <david@summersoft.fay.ar.us> 0.21.2-1
  216. - Updated to neon 0.21.2.
  217. * Mon Jun 03 2002 David Summers <david@summersoft.fay.ar.us> 0.21.1-1
  218. - Updated to neon 0.21.1.
  219. - Now requires zlib >= 1.1.4.
  220. - Broke into zlib and zlib-devel.
  221. - Now builds shared library.
  222. * Sat Apr 27 2002 David Summers <david@summersoft.fay.ar.us> 0.19.4-1
  223. - Updated to neon 0.19.4.
  224. * Fri Feb 22 2002 David Summers <david@summersoft.fay.ar.us> 0.19.2-1
  225. - Updated to neon 0.19.2.
  226. * Thu Dec 20 2001 David Summers <david@summersoft.fay.ar.us> 0.18.2-1
  227. - Updated to neon 0.18.2.
  228. * Wed Oct 31 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-2
  229. - Took out dependency on libxml and w3c-libwww packages.
  230. - Added dependency on expat.
  231. * Sat Oct 27 2001 David Summers <david@summersoft.fay.ar.us> 0.17.2-1
  232. - Release 0.17.2-1: Updated neon.
  233. * Wed Oct 24 2001 David Summers <david@summersoft.fay.ar.us>
  234. - Release 2: Fixed prefix to be /usr instead of /usr/local.
  235. * Sat Oct 20 2001 David Summers <david@summersoft.fay.ar.us>
  236. - Release 2001-10-20: Initial Version.