nginx-vl.spec 26 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784785786787788789790791792793794795796797798799800
  1. # build mod_wsgi
  2. %bcond_with wsgi
  3. # build http_geoip_module
  4. %if "%{_dist_release}" >= "vl7"
  5. %bcond_without geoip
  6. %else
  7. %bcond_with geoip
  8. %endif
  9. %if "%{_dist_release}" > "vl6"
  10. %define nginx_user www-data
  11. %else
  12. %define nginx_user nginx
  13. %endif
  14. %define nginx_group %{nginx_user}
  15. %define nginx_home %{_localstatedir}/lib/nginx
  16. %define nginx_home_tmp %{nginx_home}/tmp
  17. %define nginx_home_cache %{nginx_home}/cache
  18. %define nginx_logdir %{_localstatedir}/log/nginx
  19. %define nginx_confdir %{_sysconfdir}/nginx
  20. %define nginx_datadir %{_datadir}/nginx
  21. %define nginx_webroot %{nginx_datadir}/html
  22. Summary: Robust, small and high performance http and reverse proxy server
  23. Summary(ja): 堅牢・軽量・高性能な HTTP およびリバースプロキシサーバ
  24. Name: nginx
  25. Version: 1.16.0
  26. Release: 2%{?_dist_release}
  27. Group: System Environment/Daemons
  28. # BSD License (two clause)
  29. # http://www.freebsd.org/copyright/freebsd-license.html
  30. License: BSD
  31. URL: http://nginx.net/
  32. Source0: http://sysoev.ru/nginx/nginx-%{version}.tar.gz
  33. Source1: %{name}.init
  34. Source2: %{name}.logrotate
  35. Source3: nginx-virtual.conf.template
  36. Source4: nginx-ssl.conf
  37. Source5: %{name}.sysconfig
  38. Source10: nginx-vine.conf
  39. Source11: nginx-default-vine
  40. Source20: proxy_cache.conf
  41. Source100: nginx-index.html
  42. Source101: poweredby-vine.png
  43. Source102: nginx-logo.png
  44. Source103: nginx-50x.html
  45. Source104: nginx-404.html
  46. %define ngx_fancyindex_version 0.4.3
  47. Source1000: ngx-fancyindex-%{ngx_fancyindex_version}.tar.gz
  48. %define nginx_accept_language_module_version 2f69842
  49. Source1010: giom-nginx_accept_language_module-%{nginx_accept_language_module_version}.tar.gz
  50. ## https://github.com/phusion/passenger/archive/release-%{passenger_version}.tar.gz
  51. %define passenger_version 6.0.2
  52. Source1020: passenger-%{passenger_version}.tar.gz
  53. %define upstream_fair_version a18b409
  54. Source1030: gnosek-nginx-upstream-fair-%{upstream_fair_version}.tar.gz
  55. %define mod_wsgi_version 6975f0ec7eeb
  56. Source2000: lifeeth-mod_wsgi-%{mod_wsgi_version}.tar.bz2
  57. %define nginx_dav_ext_module_version 3.0.0
  58. Source2010: https://github.com/arut/nginx-dav-ext-module/archive/v%{nginx_dav_ext_module_version}.tar.gz#/nginx-dav-ext-module-%{nginx_dav_ext_module_version}.tar.gz
  59. # removes -Werror in upstream build scripts. -Werror conflicts with
  60. # -D_FORTIFY_SOURCE=2 causing warnings to turn into errors.
  61. Patch0: nginx-auto-cc-gcc.patch
  62. # to fix https://svn.boost.org/trac/boost/ticket/8731
  63. Patch100: boost-changeset_84950.diff
  64. # to fix https://github.com/gnosek/nginx-upstream-fair/pull/23
  65. Patch101: gnosek-nginx-upstream-fair-pull-23.patch
  66. # to fix compile error with C++11.
  67. Patch1000: passenger-5.0.28-boost.patch
  68. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  69. %if "%{_dist_release}" > "vl6"
  70. BuildRequires: libboost-devel
  71. %endif
  72. BuildRequires: libxcrypt-devel
  73. BuildRequires: libnsl2-devel
  74. BuildRequires: pcre-devel
  75. BuildRequires: zlib-devel
  76. BuildRequires: openssl-devel
  77. BuildRequires: gd-devel
  78. BuildRequires: perl
  79. BuildRequires: perl(ExtUtils::Embed)
  80. BuildRequires: libxml2-devel
  81. BuildRequires: libxslt-devel
  82. BuildRequires: curl-devel
  83. %if %{with geoip}
  84. BuildRequires: GeoIP-devel
  85. %endif
  86. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  87. # for /usr/sbin/useradd
  88. Requires(pre): shadow-utils
  89. Requires(post): chkconfig
  90. # for /sbin/service
  91. Requires(preun): chkconfig, initscripts
  92. Requires(postun): initscripts
  93. %if "%{_dist_release}" > "vl6"
  94. Requires(pre): www-common
  95. %endif
  96. Provides: webserver
  97. Vendor: Project Vine
  98. Distribution: Vine Linux
  99. Packager: daisuke
  100. %description
  101. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  102. proxy server written by Igor Sysoev.
  103. %description -l ja
  104. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  105. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  106. - HTTP(S) サーバ
  107. - HTTP(S) リバースプロキシサーバ
  108. - IMAP/POP3 プロキシサーバ
  109. %package passenger
  110. Summary: Nginx with mod_passenger support
  111. Summary(ja): Passenger サポート入りの Nginx
  112. Group: System Environment/Daemons
  113. BuildRequires: ruby, rubygem-rake
  114. Requires: ruby, rubygem-rake
  115. %if "%{_dist_release}" >= "vl7"
  116. BuildRequires: ruby-devel, ruby-rubygems
  117. Requires: ruby-rubygems
  118. %else
  119. BuildRequires: rubygems
  120. Requires: rubygems
  121. %endif
  122. Requires: nginx
  123. %description passenger
  124. Nginx [engine x] is an HTTP(S) server, HTTP(S) reverse proxy and IMAP/POP3
  125. This package contains nginx server with passenger support.
  126. %description -l ja passenger
  127. Nginx [engine x/エンジンX] は Igor Sysoev により開発された以下の機能をもつ
  128. 堅牢・軽量・高性能なHTTPサーバかつリバースプロキシサーバです。
  129. - HTTP(S) サーバ
  130. - HTTP(S) リバースプロキシサーバ
  131. - IMAP/POP3 プロキシサーバ
  132. このパッケージには Passenger サポートを含んだ nginxサーバが入っています。
  133. %prep
  134. %setup -q -a 1000 -a 1010 -a 1020 -a 1030 %{?with_wsgi:-a 2000} -a 2010
  135. %patch0 -p0
  136. # pushd passenger-%{passenger_version}/ext/
  137. # %patch100 -p2
  138. # popd
  139. pushd gnosek-nginx-upstream-fair-%{upstream_fair_version}
  140. %patch101 -p1
  141. popd
  142. %if %{?_dist_release} == "vl7"
  143. pushd passenger-%{passenger_version}
  144. #% patch1000 -p1
  145. popd
  146. %endif
  147. %build
  148. # nginx does not utilize a standard configure script. It has its own
  149. # and the standard configure options cause the nginx configure script
  150. # to error out. This is is also the reason for the DESTDIR environment
  151. # variable. The configure script(s) have been patched (Patch1 and
  152. # Patch2) in order to support installing into a build environment.
  153. export DESTDIR=%{buildroot}
  154. CONFIGOPTS="\
  155. --user=%{nginx_user} \
  156. --group=%{nginx_group} \
  157. --prefix=%{nginx_datadir} \
  158. --sbin-path=%{_sbindir}/%{name} \
  159. --conf-path=%{nginx_confdir}/%{name}.conf \
  160. --error-log-path=%{nginx_logdir}/error.log \
  161. --http-log-path=%{nginx_logdir}/access.log \
  162. --http-client-body-temp-path=%{nginx_home_tmp}/client_body \
  163. --http-proxy-temp-path=%{nginx_home_tmp}/proxy \
  164. --http-fastcgi-temp-path=%{nginx_home_tmp}/fastcgi \
  165. --pid-path=%{_localstatedir}/run/%{name}.pid \
  166. --lock-path=%{_localstatedir}/lock/subsys/%{name} \
  167. --with-file-aio \
  168. --with-ipv6 \
  169. --with-http_ssl_module \
  170. --with-http_v2_module \
  171. --with-http_realip_module \
  172. --with-http_addition_module \
  173. --with-http_xslt_module \
  174. --with-http_image_filter_module \
  175. %if %{with geoip}
  176. --with-http_geoip_module \
  177. %endif
  178. --with-http_sub_module \
  179. --with-http_dav_module \
  180. --with-http_flv_module \
  181. --with-http_mp4_module \
  182. --with-http_gunzip_module \
  183. --with-http_gzip_static_module \
  184. --with-http_auth_request_module \
  185. --with-http_random_index_module \
  186. --with-http_secure_link_module \
  187. --with-http_degradation_module \
  188. --with-http_stub_status_module \
  189. --with-http_perl_module \
  190. --with-mail \
  191. --with-mail_ssl_module \
  192. --with-stream \
  193. --with-stream_ssl_preread_module \
  194. --add-module=ngx-fancyindex-%{ngx_fancyindex_version} \
  195. --add-module=giom-nginx_accept_language_module-%{nginx_accept_language_module_version} \
  196. --add-module=gnosek-nginx-upstream-fair-%{upstream_fair_version} \
  197. %if %{with wsgi}
  198. --add-module=lifeeth-mod_wsgi-%{mod_wsgi_version} \
  199. %endif
  200. --add-module=nginx-dav-ext-module-%{nginx_dav_ext_module_version} \
  201. %ifarch i686
  202. --with-cpu-opt=pentiumpro \
  203. --with-zlib-asm=pentiumpro \
  204. --with-md5-asm \
  205. --with-sha1-asm \
  206. %endif
  207. "
  208. ## build with passenger
  209. ./configure \
  210. $CONFIGOPTS \
  211. --with-cc-opt="%{optflags}" \
  212. --add-module=passenger-%{passenger_version}/src/nginx_module
  213. make %{?_smp_mflags}
  214. mv objs/nginx objs/nginx.passenger
  215. ## build without passenger
  216. ./configure \
  217. $CONFIGOPTS \
  218. --with-cc-opt="%{optflags}"
  219. make %{?_smp_mflags}
  220. %install
  221. rm -rf %{buildroot}
  222. make install DESTDIR=%{buildroot} INSTALLDIRS=vendor
  223. find %{buildroot} -type f -name .packlist -exec rm -f {} \;
  224. find %{buildroot} -type f -name perllocal.pod -exec rm -f {} \;
  225. find %{buildroot} -type f -empty -exec rm -f {} \;
  226. find %{buildroot} -type f -exec chmod 0644 {} \;
  227. find %{buildroot} -type f -name '*.so' -exec chmod 0755 {} \;
  228. mv %{buildroot}%{_sbindir}/nginx %{buildroot}%{_sbindir}/nginx.normal
  229. %{__install} -m 0755 objs/nginx.passenger %{buildroot}%{_sbindir}/
  230. chmod 0755 %{buildroot}%{_sbindir}/nginx.*
  231. %{__install} -p -D -m 0755 %{SOURCE1} %{buildroot}%{_initrddir}/%{name}
  232. %{__install} -p -D -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/logrotate.d/%{name}
  233. %{__install} -p -D -m 0644 %{SOURCE5} %{buildroot}%{_sysconfdir}/sysconfig/%{name}
  234. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/conf.d
  235. %{__install} -p -d -m 0755 %{buildroot}%{nginx_confdir}/sites.d
  236. %{__install} -p -m 0644 %{SOURCE3} %{buildroot}%{nginx_confdir}/sites.d/virtual.conf.template
  237. %{__install} -p -m 0644 %{SOURCE4} %{buildroot}%{nginx_confdir}/conf.d/ssl.conf
  238. %{__sed} -e 's/__NGINXUSER__/%{nginx_user}/g' %{SOURCE10} > %{buildroot}%{nginx_confdir}/nginx.conf
  239. %{__cp} %{buildroot}%{nginx_confdir}/nginx.conf %{buildroot}%{nginx_confdir}/nginx.conf.default
  240. %{__install} -p -m 0644 %{SOURCE11} %{buildroot}%{nginx_confdir}/sites.d/default
  241. %{__install} -p -m 0644 %{SOURCE20} %{buildroot}%{nginx_confdir}/conf.d/proxy_cache.conf
  242. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_cache}
  243. %{__install} -p -d -m 0755 %{buildroot}%{nginx_home_tmp}
  244. %{__install} -p -d -m 0755 %{buildroot}%{nginx_logdir}
  245. %{__install} -p -d -m 0755 %{buildroot}%{nginx_webroot}
  246. %{__install} -p -m 0644 %{SOURCE100} %{buildroot}%{nginx_webroot}/index.html
  247. %{__install} -p -m 0644 %{SOURCE101} %{buildroot}%{nginx_webroot}/poweredby.png
  248. %{__install} -p -m 0644 %{SOURCE102} %{buildroot}%{nginx_webroot}/nginx-logo.png
  249. %{__install} -p -m 0644 %{SOURCE103} %{buildroot}%{nginx_webroot}/50x.html
  250. %{__install} -p -m 0644 %{SOURCE104} %{buildroot}%{nginx_webroot}/404.html
  251. %if %{with wsgi}
  252. %{__install} -p -m 0644 \
  253. lifeeth-mod_wsgi-%{mod_wsgi_version}/conf/wsgi_vars \
  254. %{buildroot}%{nginx_confdir}
  255. cp -f lifeeth-mod_wsgi-%{mod_wsgi_version}/README README.mod_wsgi
  256. %endif
  257. # upstream fair module document
  258. cp -f gnosek-nginx-upstream-fair-%{upstream_fair_version}/README README.upstream_fair
  259. # document for nginx-dav-ext-module
  260. cp -f nginx-dav-ext-module-%{nginx_dav_ext_module_version}/LICENSE LICENSE.dav-ext-module
  261. cp -f nginx-dav-ext-module-%{nginx_dav_ext_module_version}/README.rst README.dav-ext-module.rst
  262. touch %{buildroot}%{nginx_confdir}/conf.d/virtual.conf
  263. # convert to UTF-8 all files that give warnings.
  264. for textfile in CHANGES
  265. do
  266. mv $textfile $textfile.old
  267. iconv --from-code ISO8859-1 --to-code UTF-8 --output $textfile $textfile.old
  268. rm -f $textfile.old
  269. done
  270. %clean
  271. rm -rf %{buildroot}
  272. %post
  273. if [ $1 == 1 ]; then
  274. /sbin/chkconfig --add %{name}
  275. fi
  276. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.normal 20
  277. %post passenger
  278. update-alternatives --install %{_sbindir}/nginx nginx %{_sbindir}/nginx.passenger 30
  279. %preun
  280. if [ $1 = 0 ]; then
  281. /sbin/service %{name} stop >/dev/null 2>&1
  282. /sbin/chkconfig --del %{name}
  283. update-alternatives --remove nginx %{_sbindir}/nginx.normal
  284. fi
  285. %preun passenger
  286. if [ $1 = 0 ]; then
  287. update-alternatives --remove nginx %{_sbindir}/nginx.passenger
  288. fi
  289. %postun
  290. if [ $1 == 2 ]; then
  291. /sbin/service %{name} upgrade || :
  292. fi
  293. %files
  294. %defattr(-,root,root,-)
  295. %doc LICENSE CHANGES README LICENSE.dav-ext-module
  296. %doc README.upstream_fair
  297. %doc README.dav-ext-module.rst
  298. %doc %{?with_wsgi:README.mod_wsgi}
  299. %{nginx_datadir}/
  300. %{_sbindir}/%{name}.normal
  301. %{_mandir}/man3/%{name}.3pm.gz
  302. %{_initrddir}/%{name}
  303. %dir %{nginx_confdir}
  304. %dir %{nginx_confdir}/conf.d
  305. %config(noreplace) %{nginx_confdir}/conf.d/*.conf
  306. %ghost %config(noreplace) %{nginx_confdir}/conf.d/virtual.conf
  307. %config(noreplace) %{nginx_confdir}/sites.d/*
  308. %config(noreplace) %{nginx_confdir}/win-utf
  309. %config(noreplace) %{nginx_confdir}/%{name}.conf.default
  310. %config(noreplace) %{nginx_confdir}/mime.types.default
  311. %config(noreplace) %{nginx_confdir}/fastcgi_params
  312. %config(noreplace) %{nginx_confdir}/fastcgi_params.default
  313. %config(noreplace) %{nginx_confdir}/koi-win
  314. %config(noreplace) %{nginx_confdir}/koi-utf
  315. %config(noreplace) %{nginx_confdir}/%{name}.conf
  316. %config(noreplace) %{nginx_confdir}/mime.types
  317. %config(noreplace) %{nginx_confdir}/fastcgi.conf
  318. %config(noreplace) %{nginx_confdir}/fastcgi.conf.default
  319. %config(noreplace) %{nginx_confdir}/scgi_params
  320. %config(noreplace) %{nginx_confdir}/scgi_params.default
  321. %config(noreplace) %{nginx_confdir}/uwsgi_params
  322. %config(noreplace) %{nginx_confdir}/uwsgi_params.default
  323. %if %{with wsgi}
  324. %config(noreplace) %{nginx_confdir}/wsgi_vars
  325. %endif
  326. %config(noreplace) %{_sysconfdir}/logrotate.d/%{name}
  327. %config(noreplace) %{_sysconfdir}/sysconfig/%{name}
  328. %dir %{perl_vendorarch}/auto/%{name}
  329. %{perl_vendorarch}/%{name}.pm
  330. %{perl_vendorarch}/auto/%{name}/%{name}.so
  331. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home}
  332. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_tmp}
  333. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_home_cache}
  334. %attr(-,%{nginx_user},%{nginx_group}) %dir %{nginx_logdir}
  335. %files passenger
  336. %defattr(-,root,root,-)
  337. %doc passenger-%{passenger_version}/doc/*.md
  338. %doc passenger-%{passenger_version}/doc/*.txt
  339. %doc passenger-%{passenger_version}/doc/*.html
  340. %doc passenger-%{passenger_version}/doc/templates
  341. %doc passenger-%{passenger_version}/doc/users_guide_snippets
  342. %doc passenger-%{passenger_version}/doc/images
  343. %{_sbindir}/%{name}.passenger
  344. %changelog
  345. * Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.0-2
  346. - rebuilt with perl-5.26.
  347. * Sun May 05 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.0-1
  348. - updated to 1.16.0.
  349. - updated passenger to 6.0.2.
  350. - updated nginx-dav-ext-module to 3.0.0.
  351. - dropped Patch1001: fixed in upstream.
  352. * Tue Nov 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.15.5-1
  353. - updated to 1.15.5.
  354. - updated passenger to 5.3.6.
  355. - updated ngx_fancyindex_version to 0.4.3.
  356. * Mon Mar 05 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.13.9-1
  357. - updated to 1.13.9.
  358. - updated ngx-fancyindex to 0.4.2.
  359. - updated nginx-accept_language_module to git HEAD.
  360. - updated nginx-upstream-fair to git HEAD.
  361. - updated passenger to 5.2.1.
  362. - added Source2010 (nginx-dav-ext-module).
  363. - enabled --with-stream and --with-stream_ssl_preread_module.
  364. * Fri Sep 8 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.5-1
  365. - updated to 1.13.5
  366. - updated passenger to 5.1.8
  367. * Fri Aug 11 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.4-1
  368. - updated to 1.13.4
  369. - updated passenger to 5.1.7
  370. * Fri Jul 14 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.3-1
  371. - updated to 1.13.3
  372. * Sat Jul 1 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.2-1
  373. - updated to 1.13.2
  374. * Sun Jun 18 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.1-1
  375. - updated to 1.13.1
  376. - updated passenger to 5.1.5
  377. * Wed Apr 26 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.13.0-1
  378. - updated to 1.13.0
  379. * Wed Apr 5 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.13-1
  380. - updated to 1.11.13
  381. * Sat Mar 25 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.12-1
  382. - updated to 1.11.12
  383. * Tue Mar 7 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.10-1
  384. - updated to 1.11.10
  385. - updated passenger to 5.1.2
  386. * Tue Jan 31 2017 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.9-1
  387. - updated to 1.11.9
  388. * Wed Dec 28 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.8-1
  389. - updated to 1.11.8
  390. * Sat Nov 19 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.6-1
  391. - updated to 1.11.6
  392. - applied gnosek-nginx-upstream-fair-pull-23.patch against nginx-1.11.6
  393. * Mon Sep 5 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.11.3-1
  394. - updated to 1.11.3
  395. - updated passenger to 5.0.30
  396. * Fri Sep 02 2016 Toshiaki Ara <ara_t@384.jp> 1.10.1-2
  397. - rebuild with gcc-5.4.0
  398. * Tue Jun 7 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.10.1-1
  399. - updated to 1.10.1.
  400. - updated passenger to 5.0.28.
  401. * Wed Apr 20 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.15-1
  402. - updated to 1.9.15
  403. * Thu Apr 7 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.14-1
  404. - updated to 1.9.14
  405. - updated passenger to 5.0.27
  406. * Wed Apr 6 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.13-1
  407. - new upstream release
  408. * Mon Mar 14 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.12-1
  409. - updated to 1.9.12.
  410. - updated passenger to 5.0.26.
  411. * Wed Feb 17 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.11-1
  412. - new upstream release
  413. * Wed Feb 3 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.10-1
  414. - update to 1.9.10
  415. - update passenger to 5.0.24
  416. * Sun Jan 10 2016 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-2
  417. - update passenger to 5.0.23
  418. * Sun Dec 20 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.9-1
  419. - new upstream release
  420. * Sat Dec 5 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.7-1
  421. - new upstream release
  422. * Sat Oct 10 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.5-1
  423. - new upstream release
  424. * Sun Aug 23 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.4-1
  425. - new upstream release
  426. * Thu Jul 16 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.3-1
  427. - update to 1.9.3
  428. - update passenger to 5.0.11
  429. * Thu Jun 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.9.2-2
  430. - updated Source4 (ssl.conf).
  431. * Wed Jun 17 2015 Munehiro Yamamoto <munepi@vinelinux.org> 1.9.2-1
  432. - update to 1.9.2
  433. - update passenger to 5.0.10
  434. - update ngx-fancyindex to 0.3.5
  435. * Thu Sep 25 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.2-1
  436. - update to 1.6.2
  437. - update passenger to 4.0.52
  438. * Fri Aug 08 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.1-1
  439. - new upstream release
  440. * Mon Jun 30 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-3
  441. - rebuild with new environment
  442. * Mon Jun 23 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 1.6.0-2
  443. - update passenger to 4.0.45
  444. * Fri Apr 25 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.0-1
  445. - update to 1.6.0 (stable)
  446. * Thu Feb 20 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-2
  447. - update fancyindex to 0.3.3
  448. * Wed Feb 12 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.10-1
  449. - update to 1.5.10
  450. - update passenger to 4.0.37
  451. * Sat Jan 04 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.6-2
  452. - rebuilt with GeoIP-1.6.0.
  453. - added Patch100.
  454. * Tue Oct 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.5.6-1
  455. - update to 1.5.6
  456. - update passenger to 4.0.21
  457. * Wed Oct 02 2013 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.4.1-2
  458. - rebuilt with gd-2.1.0.
  459. * Wed May 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.1-1
  460. - update to 1.4.1
  461. * Mon Apr 29 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.0-1
  462. - update to 1.4.0
  463. - enable SPDY module
  464. * Wed Feb 13 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.7-1
  465. - new upstream release
  466. - update passenger to 3.0.19
  467. - update ngx-fancyindex to upstream git master
  468. * Thu Nov 29 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.5-1
  469. - new upstream release
  470. - update passenger to 3.0.17
  471. * Wed Oct 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-3
  472. - rebuild with pcre-8.31
  473. * Tue Oct 09 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.4-2
  474. - added http_geoip_module.
  475. * Tue Sep 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-1
  476. - update to 1.2.4
  477. * Thu Jul 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
  478. - update to 1.2.2
  479. * Thu Jun 28 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-1
  480. - update to 1.2.1
  481. - change nginx user from nginx to www-data
  482. - R(pre): www-common
  483. * Wed Apr 25 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
  484. - update to 1.2.0
  485. - update passenger to 3.0.12
  486. - drop http_upstream_keepalive
  487. * Mon Mar 19 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.14-1
  488. - new upstream release
  489. * Thu Feb 23 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.12-1
  490. - update to 1.0.12
  491. * Tue Jan 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.11-1
  492. - update to 1.0.11
  493. - update passenger to 3.0.11
  494. * Mon Nov 21 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.10-1
  495. - update to 1.0.10
  496. * Tue Sep 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-2
  497. - update passenger to 3.0.9
  498. * Tue Aug 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.6-1
  499. - update to 1.0.6
  500. * Thu Jun 09 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-1
  501. - update to 1.0.4
  502. * Wed May 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-3
  503. - add gnosek-nginx-upstream-fair module
  504. - add ngx_http_upstream_keepalive module
  505. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-2
  506. - add nginx-passenger sub pakckage
  507. - use alternatives to choose nginx with or without passenger
  508. - add BR: ruby, rubygems, rubygem-rake
  509. * Wed May 11 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-1
  510. - update to 1.0.2
  511. * Wed May 04 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.1-1
  512. - update to 1.0.1
  513. * Sun May 01 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-2
  514. - add bcond_with wsgi for mod_wsgi
  515. - add bcond_with passenger
  516. - you need to install rake.gem to build with this option.
  517. - add Provides: webserver
  518. * Tue Apr 12 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-1
  519. - new upstream release 1.0.0!
  520. * Sun Mar 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-2
  521. - rebuild with perl-5.12.3
  522. * Mon Jan 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.54-1
  523. - update to 0.8.54
  524. * Sun Nov 28 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.53-1
  525. - update to 0.8.53
  526. - add nginx_accept_language_module
  527. * Fri Sep 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.50-1
  528. - update to 0.8.50
  529. - update ngx-fancyindex to 0.3
  530. - add BR: libxml2-devel, libxslt-devel
  531. - add scgi_params* and uwsgi_params* to %%files
  532. * Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 0.8.35-1
  533. - update to 0.8.35 (development version)
  534. - add sites.d/ to store vitualhost settings
  535. - split out default server settings to sites.d/default
  536. - add fancyindex module
  537. * Fri Dec 04 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.63-1
  538. - new upstream release
  539. * Sun Sep 20 2009 Shu KONNO <owa@bg.wakwak.com> 0.7.62-1
  540. - update to 0.7.62 (included security fix: VU#180065)
  541. * Wed Aug 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-4
  542. - fix typo
  543. * Thu Aug 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-3
  544. - add translated descriptions
  545. * Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-2
  546. - update 404.html/50x.html to use powered by vine logo.
  547. * Wed Jul 15 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 0.7.61-1
  548. - initial build for Vine Linux
  549. - update to 0.7.61
  550. * Sun May 17 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-2
  551. - init script updates from Gena Makhomed
  552. - remove nginx-upstream-fair
  553. * Sat Apr 11 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.36-1
  554. - update to 0.6.36
  555. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.35-3
  556. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  557. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-2
  558. - rebuild
  559. * Thu Feb 19 2009 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.35-1
  560. - update to 0.6.35
  561. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 0.6.34-2
  562. - rebuild with new openssl
  563. * Tue Dec 30 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.34-1
  564. - update to 0.6.34
  565. * Thu Dec 4 2008 Michael Schwendt <mschwendt@fedoraproject.org> - 0.6.33-2
  566. - Fix inclusion of /usr/share/nginx tree => no unowned directories.
  567. * Sun Nov 23 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.33-1
  568. - update to 0.6.33
  569. * Tue Jul 22 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.32-1
  570. - update to 0.6.32
  571. - nginx now supports DESTDIR so removed the patches that enabled it
  572. * Mon May 26 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-3
  573. - init script fixes
  574. - resolve 'listen 80 default' [#447873]
  575. * Mon May 12 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.31-2
  576. - update to 0.6.31
  577. * Sun May 11 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.6.30-2
  578. - upate to new upstream stable branch 0.6
  579. - added 3rd party module nginx-upstream-fair
  580. - added default webpages
  581. * Sun Apr 20 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-2
  582. - update init script to match recommended guidelines
  583. - add /etc/nginx/conf.d support [#443280]
  584. - use /etc/sysconfig/nginx to determine nginx.conf [#442708]
  585. * Tue Mar 18 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.5.35-3
  586. - add Requires for versioned perl (libperl.so)
  587. - drop silly file Requires
  588. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.5.35-2
  589. - Autorebuild for GCC 4.3
  590. * Sat Jan 19 2008 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.35-1
  591. - update to 0.5.35
  592. * Sat Dec 15 2007 Jeremy Hinegardner <jeremy at hinegardner dot org> - 0.5.34-1
  593. - update to 0.5.34
  594. * Wed Dec 05 2007 Release Engineering <rel-eng at fedoraproject dot org> - 0.5.33-2
  595. - Rebuild for deps
  596. * Sun Nov 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.33-1
  597. - update to 0.5.33
  598. * Mon Sep 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.32-1
  599. - updated to 0.5.32
  600. - fixed rpmlint UTF-8 complaints.
  601. * Sat Aug 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-2
  602. - added --with-http_stub_status_module build option.
  603. - added --with-http_sub_module build option.
  604. - added use of pcre-config --cflags
  605. * Fri Aug 17 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.31-1
  606. - Update to 0.5.31
  607. - specify license is BSD
  608. * Sat Aug 11 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-2
  609. - Add BuildRequires: perl-devel - fixing rawhide build
  610. * Mon Jul 30 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.30-1
  611. - Update to 0.5.30
  612. * Tue Jul 24 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.29-1
  613. - Update to 0.5.29
  614. * Wed Jul 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.28-1
  615. - Update to 0.5.28
  616. * Mon Jul 09 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.27-1
  617. - Update to 0.5.27
  618. * Mon Jun 18 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.26-1
  619. - Update to 0.5.26
  620. * Sat Apr 28 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.19-1
  621. - Update to 0.5.19
  622. * Mon Apr 02 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.17-1
  623. - Update to 0.5.17
  624. * Mon Mar 26 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.16-1
  625. - Update to 0.5.16
  626. - add ownership of /usr/share/nginx/html (#233950)
  627. * Fri Mar 23 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-3
  628. - fixed package review bugs (#235222) given by ruben@rubenkerkhof.com
  629. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-2
  630. - fixed package review bugs (#233522) given by kevin@tummy.com
  631. * Thu Mar 22 2007 Jeremy Hinegardner <jeremy@hinegardner.org> - 0.5.15-1
  632. - create patches to assist with building for Fedora
  633. - initial packaging for Fedora