perl-Clone-vl.spec 4.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148
  1. Name: perl-Clone
  2. Version: 0.41
  3. Release: 1%{?_dist_release}
  4. Summary: Recursively copy perl datatypes
  5. Group: Development/Libraries
  6. License: GPL+ or Artistic
  7. URL: http://search.cpan.org/dist/Clone
  8. Source0: http://search.cpan.org/CPAN/authors/id/R/RD/RDF/Clone-%{version}.tar.gz
  9. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  10. BuildRequires: libxcrypt-devel
  11. BuildRequires: perl(ExtUtils::ParseXS)
  12. BuildRequires: perl(Taint::Runtime)
  13. BuildRequires: perl(Test::More)
  14. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  15. # don't "provide" private Perl libs
  16. %global _use_internal_dependency_generator 0
  17. %global __deploop() while read FILE; do /usr/lib/rpm/rpmdeps -%{1} ${FILE}; done | /bin/sort -u
  18. %global __find_provides /bin/sh -c "%{__grep} -v '%_docdir' | %{__grep} -v '%{perl_vendorarch}/.*\\.so$' | %{__deploop P}"
  19. %global __find_requires /bin/sh -c "%{__grep} -v '%_docdir' | %{__deploop R}"
  20. Vendor: Project Vine
  21. Distribution: Vine Linux
  22. Packager: shaolin
  23. %description
  24. This module provides a clone() method which makes recursive
  25. copies of nested hash, array, scalar and reference types,
  26. including tied variables and objects.
  27. clone() takes a scalar argument and an optional parameter that
  28. can be used to limit the depth of the copy. To duplicate lists,
  29. arrays or hashes, pass them in by reference.
  30. %prep
  31. %setup -q -n Clone-%{version}
  32. find . -type f -exec chmod -c -x {} ';'
  33. %build
  34. %{__perl} Makefile.PL INSTALLDIRS=vendor OPTIMIZE="$RPM_OPT_FLAGS"
  35. make %{?_smp_mflags}
  36. %install
  37. rm -rf $RPM_BUILD_ROOT
  38. make pure_install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
  39. find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
  40. find $RPM_BUILD_ROOT -type f -name '*.bs' -a -size 0 -exec rm -f {} ';'
  41. find $RPM_BUILD_ROOT -type d -depth -exec rmdir {} 2>/dev/null ';'
  42. chmod -R u+w $RPM_BUILD_ROOT/*
  43. %check
  44. make test
  45. %clean
  46. rm -rf $RPM_BUILD_ROOT
  47. %files
  48. %defattr(-,root,root,-)
  49. %doc Changes
  50. %{perl_vendorarch}/auto/Clone/
  51. %{perl_vendorarch}/Clone.pm
  52. %{_mandir}/man3/*.3*
  53. %changelog
  54. * Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 0.41-1
  55. - new upstream release.
  56. - rebuilt with perl-5.26.
  57. - added BR:libxcrypt-devel.
  58. * Thu Apr 16 2015 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 0.38-1
  59. - new upstream release
  60. * Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 0.31-2
  61. - build with Perl 5.16
  62. * Fri Feb 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.31-1
  63. - initial build for Vine Linux
  64. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.31-9
  65. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  66. * Mon Jun 20 2011 Marcela Mašláňová <mmaslano@redhat.com> - 0.31-8
  67. - Perl mass rebuild
  68. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.31-7
  69. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  70. * Wed Dec 15 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.31-6
  71. - 661697 rebuild for fixing problems with vendorach/lib
  72. * Fri Apr 30 2010 Marcela Maslanova <mmaslano@redhat.com> - 0.31-5
  73. - Mass rebuild with perl-5.12.0
  74. * Fri Dec 4 2009 Stepan Kasal <skasal@redhat.com> - 0.31-4
  75. - rebuild against perl 5.10.1
  76. * Sat Jul 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.31-3
  77. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  78. * Sat May 23 2009 Chris Weyl <cweyl@alumni.drew.edu> - 0.31-2
  79. - filter private Perl solibs from provides
  80. - remove some executable bits -- keep rpmlint happy
  81. * Fri Mar 13 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 0.31-1
  82. - update to 0.31
  83. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.28-5
  84. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  85. * Wed Feb 27 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0.28-4
  86. - Rebuild for perl 5.10 (again)
  87. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0.28-3
  88. - Autorebuild for GCC 4.3
  89. * Fri Jan 11 2008 Tom "spot" Callaway <tcallawa@redhat.com> 0.28-2
  90. - rebuild for new perl
  91. * Wed Nov 28 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.28-1
  92. - bump to 0.28
  93. * Fri Aug 24 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.27-2
  94. - license fix
  95. * Fri Jul 27 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.27-1
  96. - bump to 0.27
  97. * Wed Jan 17 2007 Tom "spot" Callaway <tcallawa@redhat.com> 0.22-1
  98. - bump to 0.22
  99. * Fri Sep 15 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.20-2
  100. - bump for fc6
  101. * Fri Mar 31 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.20-1
  102. - bump to 0.20
  103. - new BR: perl-Taint-Runtime
  104. * Tue Feb 28 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.18-3
  105. - bump for FC-5
  106. * Fri Jan 6 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.18-2
  107. - don't pass optflags twice
  108. - remove .bs files
  109. * Thu Jan 5 2006 Tom "spot" Callaway <tcallawa@redhat.com> 0.18-1
  110. - Initial package for Fedora Extras