perl-DBD-SQLite-vl.spec 4.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156
  1. %define module DBD-SQLite
  2. %define name perl-%{module}
  3. %define version 1.62
  4. %define release 1%{_dist_release}
  5. Name: %{name}
  6. Version: %{version}
  7. Release: %{release}
  8. Summary: Self Contained RDBMS in a DBI Driver
  9. License: Artistic or GPL+
  10. Group: Development/Libraries
  11. URL: http://search.cpan.org/dist/%{module}/
  12. Source: ftp://ftp.perl.org/pub/CPAN/modules/by-module/DBD/%{module}-%{version}.tar.gz
  13. Buildroot: %{_tmppath}/%{name}-%{version}
  14. BuildRequires: perl(DBI)
  15. BuildRequires: sqlite3-devel
  16. BuildRequires: libxcrypt-devel
  17. Requires: perl(DBI)
  18. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  19. Vendor: Project Vine
  20. Distribution: Vine Linux
  21. %description
  22. SQLite is a small fast embedded SQL database engine.
  23. DBD::SQLite embeds that database engine into a DBD driver, so
  24. if you want a relational database for your project, but don't
  25. want to install a large RDBMS system like MySQL or PostgreSQL,
  26. then DBD::SQLite may be just what you need.
  27. It supports quite a lot of features, such as transactions (atomic
  28. commit and rollback), indexes, DBA-free operation, a large subset
  29. of SQL92 supported, and more.
  30. #'
  31. %prep
  32. %setup -q -n %{module}-%{version}
  33. %build
  34. CFLAGS="%{optflags}" %{__perl} Makefile.PL INSTALLDIRS="vendor"
  35. make %{?_smp_mflags}
  36. %check
  37. make test
  38. %install
  39. rm -rf %{buildroot}
  40. make pure_install PERL_INSTALL_ROOT=%{buildroot}
  41. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  42. find %{buildroot} -type f -name '*.bs' -empty -exec rm -f {} ';'
  43. find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
  44. chmod -R u+w %{buildroot}/*
  45. rm -rf %{buildroot}%{perl_vendorarch}/auto/share
  46. %clean
  47. rm -rf %{buildroot}
  48. %files
  49. %defattr(-,root,root)
  50. %doc README* Changes
  51. %{perl_vendorarch}/DBD
  52. %{perl_vendorarch}/auto/DBD
  53. %{_mandir}/*/*
  54. %changelog
  55. * Fri May 17 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.62-1
  56. - new upstream release.
  57. - rebuilt with perl-5.26.
  58. - added BR:libxcrypt-devel.
  59. * Sat Oct 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.42-1
  60. - new upstream release
  61. * Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.31-2
  62. - build with Perl 5.16
  63. - add Requires: MODULE_COMPAT_*
  64. * Thu Mar 31 2011 IWAI, Masaharu <iwai@alib.jp> 1.31-1
  65. - new upstream release
  66. - update {Build,}Requires: perl-DBI version: sync upstream
  67. * Fri May 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.14-1vl5
  68. - rebuild with perl 5.10
  69. - new versioning policy
  70. * Mon Mar 10 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.14-0vl1
  71. - rebuild for VineSeed
  72. - disable test
  73. * Sat Mar 08 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.14-0vl0.43
  74. - add Requires: perl(DBI) >= 1.03
  75. * Sun Mar 02 2008 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 1.14-0vl0.42
  76. - new upstream release
  77. - built for Vine 4.2 testing
  78. * Sun Dec 17 2006 Guillaume Rousse <guillomovitch@mandriva.org> 1.13-2mdv2007.0
  79. + Revision: 98263
  80. - fix build dependencies
  81. * Sat Dec 16 2006 Guillaume Rousse <guillomovitch@mandriva.org> 1.13-1mdv2007.1
  82. + Revision: 98198
  83. - new version
  84. * Mon Aug 07 2006 Olivier Thauvin <nanardon@mandriva.org> 1.12-2mdv2007.0
  85. + Revision: 53730
  86. - rebuild
  87. - Import perl-DBD-SQLite
  88. * Thu Apr 13 2006 Guillaume Rousse <guillomovitch@mandriva.org> 1.12-1mdk
  89. - New release 1.12
  90. - better source URL
  91. - better buildrequires syntax
  92. * Tue Dec 20 2005 Guillaume Rousse <guillomovitch@mandriva.org> 1.11-1mdk
  93. - new version
  94. - fix directory ownership
  95. * Mon Sep 26 2005 Guillaume Rousse <guillomovitch@mandriva.org> 1.09-2mdk
  96. - rebuild to link against external library
  97. - spec cleanup
  98. - %%mkrel
  99. * Tue Jun 21 2005 Rafael Garcia-Suarez <rgarciasuarez@mandriva.com> 1.09-1mdk
  100. - 1.09
  101. - spec cleanups
  102. * Mon Mar 14 2005 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.08-1mdk
  103. - new veresion 1.08
  104. * Mon Nov 15 2004 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.07-2mdk
  105. - rebuild for new perl
  106. - remove README.urpmi
  107. * Thu Oct 14 2004 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.07-1mdk
  108. - 1.07.
  109. * Tue Aug 10 2004 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.03-1mdk
  110. - 1.03.
  111. - Remove patch 1.
  112. * Wed Jul 28 2004 Rafael Garcia-Suarez <rgarciasuarez@mandrakesoft.com> 1.00-1mdk
  113. - 1.00, incompatible format with previous versions.
  114. - Remove MANIFEST, add README.update.urpmi.
  115. - Patch to prevent interactivity in Makefile.PL
  116. * Mon May 17 2004 Olivier Thauvin <thauvin@aerov.jussieu.fr> 0.31-2mdk
  117. - Fix compile FLAGS
  118. * Fri Nov 01 2002 Olivier Thauvin <thauvin@aerov.jussieu.fr> 0.31-1mdk
  119. - first version of rpm.