perl-DBI-vl.spec 6.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217
  1. %define version 1.642
  2. %define release 1
  3. Summary: A database access API for perl
  4. Summary(ja): perl 用データベース接続 API
  5. Name: perl-DBI
  6. Version: %{version}
  7. Release: %{release}%{?_dist_release}
  8. License: GPL or Artistic
  9. Group: Development/Libraries
  10. URL: http://dbi.perl.org/
  11. Source0: http://www.cpan.org/authors/id/T/TI/TIMB/DBI-%{version}.tar.gz
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: libxcrypt-devel
  16. BuildRequires: perl(ExtUtils::MakeMaker)
  17. # Run-time
  18. BuildRequires: perl(base)
  19. BuildRequires: perl(constant)
  20. BuildRequires: perl(Carp)
  21. # Clone is optional
  22. BuildRequires: perl(Clone)
  23. BuildRequires: perl(Coro)
  24. BuildRequires: perl(Coro::Handle)
  25. BuildRequires: perl(Coro::Select)
  26. BuildRequires: perl(Cwd)
  27. BuildRequires: perl(Data::Dumper)
  28. # DB_File is optional
  29. BuildRequires: perl(DB_File)
  30. BuildRequires: perl(DynaLoader)
  31. BuildRequires: perl(Errno)
  32. BuildRequires: perl(Exporter)
  33. BuildRequires: perl(Fcntl)
  34. BuildRequires: perl(File::Basename)
  35. BuildRequires: perl(File::Spec)
  36. BuildRequires: perl(Getopt::Long)
  37. BuildRequires: perl(IO::File)
  38. BuildRequires: perl(IO::Select)
  39. BuildRequires: perl(IPC::Open3)
  40. BuildRequires: perl(Math::BigInt)
  41. # MLDBM is optional
  42. ##BuildRequires: perl(MLDBM)
  43. # RPC::PlClient is optional
  44. ##BuildRequires: perl(RPC::PlClient) >= 0.2000
  45. # RPC::PlServer is optional
  46. ##BuildRequires: perl(RPC::PlServer)
  47. BuildRequires: perl(Scalar::Util)
  48. # SQL::Statement is optional
  49. BuildRequires: perl(SQL::Statement)
  50. BuildRequires: perl(Storable)
  51. BuildRequires: perl(Symbol)
  52. BuildRequires: perl(threads)
  53. BuildRequires: perl(Tie::Hash)
  54. BuildRequires: perl(UNIVERSAL)
  55. # Tests
  56. BuildRequires: perl(Encode)
  57. BuildRequires: perl(File::Path)
  58. BuildRequires: perl(lib)
  59. BuildRequires: perl(Net::Daemon::Test)
  60. BuildRequires: perl(Test::More)
  61. BuildRequires: perl(Test::Simple)
  62. # Optional tests
  63. BuildRequires: perl(Test::Pod)
  64. BuildRequires: perl(Test::Pod::Coverage)
  65. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  66. Requires: perl(Math::BigInt)
  67. %description
  68. DBI is a database access Application Programming Interface (API) for
  69. the Perl Language. The DBI API Specification defines a set of
  70. functions, variables and conventions that provide a consistent
  71. database interface independent of the actual database being used.
  72. %description -l ja
  73. DBI は Perl でデータベースにアクセスするための API です.
  74. DBI API では,実際に使われるデータベースに依存しない様に,
  75. 関数,変数などの取り決めが定義されています.
  76. %prep
  77. %setup -q -n DBI-%{version}
  78. iconv -f iso8859-1 -t utf-8 lib/DBD/Gofer.pm >lib/DBD/Gofer.pm.new &&
  79. mv lib/DBD/Gofer.pm{.new,}
  80. chmod 644 ex/*
  81. chmod 744 dbixs_rev.pl
  82. sed -i 's?#!perl?#!%{__perl}?' ex/corogofer.pl
  83. %build
  84. perl Makefile.PL INSTALLDIRS=vendor OPTIMIZE="%{optflags}"
  85. make %{?_smp_mflags}
  86. %install
  87. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  88. make pure_install PERL_INSTALL_ROOT=%{buildroot}
  89. find %{buildroot} -type f -name .packlist -exec rm -f {} ';'
  90. find %{buildroot} -type f -name '*.bs' -empty -exec rm -f {} ';'
  91. find %{buildroot} -type d -depth -exec rmdir {} 2>/dev/null ';'
  92. chmod -R u+w %{buildroot}/*
  93. # Remove Win32 specific files and man pages to avoid unwanted dependencies
  94. rm -rf %{buildroot}%{perl_vendorarch}/{Win32,DBI/W32ODBC.pm} \
  95. %{buildroot}%{_mandir}/man3/{DBI::W32,Win32::DBI}ODBC.3pm
  96. perl -pi -e 's"#!perl -w"#!/usr/bin/perl -w"' \
  97. %{buildroot}%{perl_vendorarch}/{goferperf,dbixs_rev}.pl
  98. %clean
  99. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  100. %check
  101. make test
  102. %files
  103. %defattr(-,root,root)
  104. %doc Changes README.md ex/
  105. %{perl_vendorarch}/*.p*
  106. %{perl_vendorarch}/Bundle/
  107. %{perl_vendorarch}/DBD/
  108. %{perl_vendorarch}/DBI/
  109. %{perl_vendorarch}/auto/DBI/
  110. %{_bindir}/*
  111. %{_mandir}/*/*
  112. %changelog
  113. * Wed May 15 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.642-1
  114. - updated to 1.642.
  115. - rebuilt with perl-5.26.
  116. - added BR:libxcrypt-devel.
  117. * Fri Dec 5 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 1.632-1
  118. - updated to 1.632
  119. * Fri Jun 27 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.618-2
  120. - build with Perl 5.16
  121. * Fri Mar 02 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.618-1
  122. - updated to 1.618; spec revamped
  123. * Sat Mar 26 2011 IWAI, Masaharu <iwai@alib.jp> 1.604-4vl6
  124. - rebuild with perl 5.12.3
  125. - using __perl_requires macro for VineSeed (vl6)
  126. * Wed Apr 08 2009 Shu KONNO <owa@bg.wakwak.com> 1.604-3
  127. - spec in utf-8
  128. * Thu May 1 2008 Tomohiro 'Tomo-p' KATO <tomop@teamgedoh.net> 1.604-2
  129. - rebuilt with perl-5.10.0.
  130. * Wed Apr 23 2008 IWAI, Masaharu <iwaim@cc.mbn.or.jp> 1.604-1
  131. - new upstream release
  132. * Mon Aug 20 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.58-0vl1
  133. - new upstream release
  134. * Sun Jan 28 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.53-0vl1
  135. - new upstream release
  136. * Sun Sep 10 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.51-0vl1
  137. - new upstream release
  138. - changed Group to Development/Libraries
  139. - installed module files to vendor_perl
  140. * Sat Jul 22 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.46-0vl2
  141. - use filter-requires-dbi.sh instead of find-requires.perl
  142. * Sat Dec 04 2004 IWAI, Masaharu <iwai@alib.jp> 1.46-0vl1
  143. - new upstream version
  144. - build on perl-5.8.6-0vl1
  145. * Sat May 22 2004 Satoshi MACHINO <machino@vinelinux.org> 1.40-0vl1
  146. - new upstream version
  147. * Sat May 24 2003 IWAI Masaharu <iwai@alib.jp> 1.37-0vl1
  148. - update 1.37
  149. - build with perl-5.8.0
  150. - add make test
  151. * Sat Feb 23 2002 Satoshi MACHINO <machino@vinelinux.org> 1.21-0vl1
  152. - updated 1.21
  153. * Wed Dec 05 2001 Satoshi MACHINO <machino@vinelinux.org> 1.20-0vl1
  154. - updated 1.20
  155. * Sat Sep 15 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.19-0vl2
  156. - the spec was in Shift-JIS. Fixed.
  157. * Fri Aug 03 2001 Satoshi MACHINO <machino@vinelinux.org> 1.19-0vl1
  158. - updated 1.19
  159. * Fri Jun 15 2001 Satoshi MACHINO <machino@vinelinux.org> 1.15-1vl2
  160. - rebuild on perl-5.6.0
  161. - changed mandir to /usr/share/man
  162. - removed version in Requires perl
  163. * Sun May 27 2001 Satoshi MACHINO <machino@vinelinux.org> 1.15-1vl1
  164. - updated perl-DBL-1.15
  165. * Tue May 08 2001 Satoshi MACHINO <machino@vinelinux.org> 1.14-10vl1
  166. - fixed Vine Linux
  167. * Tue Feb 27 2001 Trond Eivind Glomsr <teg@redhat.com>
  168. - Cleanups
  169. * Thu Nov 30 2000 Trond Eivind Glomsr <teg@redhat.com>
  170. - build for main distribution
  171. - use %%{_tmppath}
  172. - change name of specfile
  173. - don't use a find script to generate file lists
  174. - general cleanup
  175. - add descriptive summary and description
  176. * Mon Aug 14 2000 Tim Powers <timp@redhat.com>
  177. - Spec file was autogenerated.