self-build-mplayer-codecs-vl.spec 5.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143
  1. %define pkgname mplayer-codecs
  2. %define name self-build-%{pkgname}
  3. %define version 20071007
  4. %define release 7%{?_dist_release}
  5. %ifarch %{ix86}
  6. %define source0path MPlayer/releases/codecs/essential-%{version}.tar.bz2
  7. %endif
  8. %ifarch ppc
  9. %define source0path MPlayer/releases/codecs/essential-ppc-%{version}.tar.bz2
  10. %endif
  11. %ifarch x86_64
  12. %define source0path MPlayer/releases/codecs/essential-amd64-%{version}.tar.bz2
  13. %endif
  14. Summary: Package to automatically build %{pkgname} rpm package
  15. Summary(ja): %{pkgname} の rpm パッケージを自動作成するパッケージ
  16. Name: %{name}
  17. Version: %{version}
  18. Release: %{release}
  19. Source0: %{pkgname}-vl.spec
  20. License: GPL
  21. Group: Restricted Software
  22. Requires(post): self-build-setup >= 0.9.9
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. Packager: munepi
  25. %description
  26. Binary codecs for MPlayer.
  27. If you install this package, it automaticaly downloads source
  28. code ,compile it, and create rpm packages of %{pkgname}-%{version}.
  29. And the created rpm packages are automatically installed
  30. if installation is executed by apt-get command or synaptic
  31. package manager.
  32. [Note]
  33. This package requires many other packages to compile
  34. targetsoftware. So it consume more disk space than usual.
  35. Also installation takes logner time because of compilation.
  36. (This will take a few minutes to quarter or half of an hour,
  37. depends on building environment)
  38. [About self-build package]
  39. For some kind of software, distributing of binary package
  40. may viorate the patent or law. Therefore we chose self-build
  41. packge, create binary package on your machine, for such kind
  42. of softwares instead of distributing binary package.
  43. Please obey the national law when you use the created binary
  44. packages. And if you want to use the softwares using patented
  45. thechnology, it may be required to get a permission, make an
  46. agreement or purchas a license. Please consider it with your
  47. purpose or way of use and take appropriate action.
  48. %description -l ja
  49. MPlayer 用のバイナリ Codec です。
  50. このパッケージをインストールすると、自動的にソースコードを
  51. ダウンロードしてコンパイルし、%{pkgname}-%{version}
  52. の rpm パッケージを作成します。
  53. また apt-get コマンドや synaptic パッケージマネージャから実行
  54. した場合は、作成された rpm パッケージのインストールも自動的に
  55. 行います。
  56. [注意]
  57. コンパイルに必要な多くの関連パッケージを要求するので通常より
  58. ディスクの領域を多く消費します。
  59. またインストール時にコンパイルを行うため、通常より時間がかか
  60. る場合があります。(環境にもよりますが数分から数十分程度)
  61. [self-build パッケージについて]
  62. ソフトウェアによってはバイナリパッケージの配布が特許や法律に
  63. 違反する可能性があるものがあります。その為、このような問題が
  64. 懸念されるソフトウェアについてはバイナリパッケージを直接配布
  65. せずに、ユーザの環境でバイナリを作成する self-build パッケー
  66. ジという方法を採っています。
  67. 作成されたバイナリパッケージの利用にあたっては、各ソフトウェ
  68. アのライセンス、および利用する国の各種法令に従ってください。
  69. また特許に関連するソフトウェアの場合、利用許諾や契約、ライ
  70. センスの購入などが必要となる場合がありますので、利用する目的
  71. や形態に応じて各自で判断し適切な対応を取ってください。
  72. %prep
  73. [ "%{version}-%{release}" != $(rpm -q --queryformat "%%{version}-%%{release}\n" --specfile %{SOURCE0} | tail -1) ] && exit 1
  74. %install
  75. %{__rm} -rf ${RPM_BUILD_ROOT}
  76. %{__install} -d ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  77. %{__install} -m 644 %{SOURCE0} ${RPM_BUILD_ROOT}/%{_datadir}/%{name}
  78. %clean
  79. %{__rm} -rf ${RPM_BUILD_ROOT}
  80. %posttrans
  81. /usr/lib/rpm/self-build-rpm.sh %{name} %{pkgname}-vl.spec \
  82. http://www{1,2,3,4,5,7,8}.mplayerhq.hu/%{source0path} 2250
  83. %files
  84. %defattr(-,root,root)
  85. %{_datadir}/%{name}/*
  86. %changelog
  87. * Mon Jan 19 2015 Munehiro Yamamoto <munepi@vinelinux.org> 20071007-7
  88. - dropped Requires: libstdc++3
  89. * Sun Mar 20 2010 Munehiro Yamamoto <munepi@vinelinux.org> 20071007-6
  90. - renamed %%{Source0} to mplayer-codecs-vl.spec
  91. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 20071007-5
  92. - added Requires: libstdc++3
  93. * Sun Jun 07 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 20071007-4
  94. - dropped BuildArch: noarch
  95. * Tue May 26 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 20071007-3
  96. - added BuildArch: noarch
  97. - avoided to execute self-build-rpm.sh on RPM transaction
  98. - moved %%post actions to %%posttrans
  99. * Sun Nov 02 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 20071007-2
  100. - spec in utf8
  101. - fixed %%release for new versioning policy in mplayer-codecs.spec
  102. - dropped ttfontdir variable in mplayer-codecs.spec
  103. * Sun Jun 08 2008 Atsushi SHICHI <ats777@gmail.com> 20071007-1
  104. - build with new versioning policy.
  105. - fix <BTS:VineLinux:603>.
  106. - add ">= 0.7-1" to "PreReq: self-build-setup".
  107. - add mirror URLs to self-build-rpm.sh.
  108. * Sun Mar 2 2008 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 20071007-0vl2
  109. - change source download URL. (see <BTS:VineLinux:603>)
  110. * Fri Jan 18 2008 Kazutaka HARADA <Kazutaka HARADA> 20071007-0vl1
  111. - initial build for Vine Linux.