python-asn1crypto-vl.spec 3.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145
  1. # Created by pyp2rpm-3.2.2
  2. %global pypi_name asn1crypto
  3. %bcond_without python2
  4. %bcond_without python3
  5. %{!?python3_pkgversion:%global python3_pkgversion 3}
  6. Summary: Fast Python ASN.1 parser and serializer
  7. Name: python-%{pypi_name}
  8. Version: 1.5.1
  9. Release: 1%{?_dist_release}
  10. Group: programming
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. License: MIT
  14. URL: https://github.com/wbond/asn1crypto
  15. Source0: https://files.pythonhosted.org/packages/source/a/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
  16. BuildArch: noarch
  17. %if 0%{?with_python2}
  18. BuildRequires: python-rpm-macros
  19. BuildRequires: python2-rpm-macros
  20. BuildRequires: python-devel
  21. BuildRequires: python-setuptools
  22. %{?python_provide:%python_provide python2-%{pypi_name}}
  23. %endif
  24. %if 0%{?with_python3}
  25. BuildRequires: python%{python3_pkgversion}-rpm-macros
  26. BuildRequires: python%{python3_pkgversion}-devel
  27. BuildRequires: python%{python3_pkgversion}-setuptools
  28. %endif
  29. %description
  30. Fast ASN.1 parser and serializer with definitions for private keys,
  31. public keys, certificates, CRL, OCSP, CMS, PKCS#3, PKCS#7, PKCS#8,
  32. PKCS#12, PKCS#5, X.509 and TSP.
  33. %if 0%{?with_python3}
  34. %package -n python%{python3_pkgversion}-%{pypi_name}
  35. Summary: %{summary}
  36. %{?python_provide:%python_provide python%{python3_pkgversion}-%{pypi_name}}
  37. %description -n python%{python3_pkgversion}-%{pypi_name}
  38. Fast ASN.1 parser and serializer with definitions for private keys,
  39. public keys, certificates, CRL, OCSP, CMS, PKCS#3, PKCS#7, PKCS#8,
  40. PKCS#12, PKCS#5, X.509 and TSP.
  41. %endif
  42. %prep
  43. %autosetup -n %{pypi_name}-%{version}
  44. # Remove bundled egg-info
  45. rm -rf %{pypi_name}.egg-info
  46. %build
  47. %if 0%{?with_python2}
  48. %py2_build
  49. %endif
  50. %if 0%{?with_python3}
  51. %pip3_build_wheel
  52. %endif
  53. %install
  54. %if 0%{?with_python2}
  55. %py2_install
  56. %endif
  57. %if 0%{?with_python3}
  58. %pip3_install_wheel
  59. %endif
  60. %check
  61. # asn1crypto source distribution doesn't come with tests
  62. # {__python2} setup.py test
  63. %if 0%{?with_python3}
  64. # {__python3} setup.py test
  65. %endif
  66. %if 0%{?with_python2}
  67. %files
  68. %license LICENSE
  69. %doc readme* changelog*
  70. %{python2_sitelib}/%{pypi_name}
  71. %{python2_sitelib}/%{pypi_name}-%{version}-py?.?.egg-info
  72. %endif
  73. %if 0%{?with_python3}
  74. %files -n python%{python3_pkgversion}-%{pypi_name}
  75. %license LICENSE
  76. %doc readme* changelog*
  77. %{python3_sitelib}/%{pypi_name}
  78. %{python3_sitelib}/%{pypi_name}-*-info
  79. %endif
  80. %changelog
  81. * Fri Oct 28 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.5.1-1
  82. - new upstream release.
  83. * Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.4.0-1
  84. - new upstream release.
  85. * Mon Nov 19 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 0.24.0-6
  86. - initial build for Vine Linux.
  87. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.24.0-5
  88. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  89. * Mon Jul 02 2018 Miro Hrončok <mhroncok@redhat.com> - 0.24.0-4
  90. - Rebuilt for Python 3.7
  91. * Tue Jun 19 2018 Christian Heimes <cheimes@redhat.com> - 0.24.0-3
  92. - Build Python 2 package conditionally
  93. * Fri Jun 15 2018 Miro Hrončok <mhroncok@redhat.com> - 0.24.0-2
  94. - Rebuilt for Python 3.7
  95. * Wed Mar 21 2018 Christian Heimes <cheimes@redhat.com> - 0.24.0-1
  96. - New upstream release 0.24.0
  97. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.23.0-2
  98. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  99. * Thu Oct 12 2017 Christian Heimes <cheimes@redhat.com> - 0.23-1
  100. - New upstream release 0.23.0
  101. * Fri Aug 04 2017 Christian Heimes <cheimes@redhat.com> - 0.22.0-5
  102. - Use python2-setuptools, add with_python3
  103. * Thu Aug 03 2017 Christian Heimes <cheimes@redhat.com> - 0.22.0-4
  104. - Modernize spec
  105. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.22.0-3
  106. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  107. * Tue Jun 27 2017 Christian Heimes <cheimes@redhat.com> - 0.22.0-2
  108. - Address rpmlint issues
  109. * Tue Jun 27 2017 Christian Heimes <cheimes@redhat.com> - 0.22.0-1
  110. - Initial package.