python-dns-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331
  1. Name: python-dns
  2. Version: 2.2.1
  3. Release: 1%{?_dist_release}
  4. Summary: DNS toolkit for Python
  5. Summary(ja): Python 用 DNS ツールキット
  6. Group: programming
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: MIT
  10. URL: http://www.dnspython.org/
  11. Source0: https://github.com/rthalley/dnspython/archive/v%{version}.tar.gz#/dnspython-%{version}.tar.gz
  12. BuildArch: noarch
  13. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  14. BuildRequires: python-rpm-macros
  15. BuildRequires: python3-rpm-macros
  16. BuildRequires: python3-setuptools
  17. BuildRequires: python3-devel
  18. BuildRequires: python3-poetry-core
  19. %description
  20. dnspython is a DNS toolkit for Python. It supports almost all record
  21. types. It can be used for queries, zone transfers, and dynamic
  22. updates. It supports TSIG authenticated messages and EDNS0.
  23. dnspython provides both high and low level access to DNS. The high
  24. level classes perform queries for data of a given name, type, and
  25. class, and return an answer set. The low level classes allow direct
  26. manipulation of DNS zones, messages, names, and records.
  27. %package -n python3-dns
  28. Summary: DNS toolkit for Python 3
  29. Group: programming
  30. %{?python_provide:%python_provide python3-dns}
  31. Requires: python3-idna
  32. Requires: python3-cryptography
  33. %description -n python3-dns
  34. dnspython3 is a DNS toolkit for Python 3. It supports almost all
  35. record types. It can be used for queries, zone transfers, and dynamic
  36. updates. It supports TSIG authenticated messages and EDNS0.
  37. dnspython3 provides both high and low level access to DNS. The high
  38. level classes perform queries for data of a given name, type, and
  39. class, and return an answer set. The low level classes allow direct
  40. manipulation of DNS zones, messages, names, and records.
  41. %prep
  42. %setup0 -q -n dnspython-%{version}
  43. # strip executable permissions so that we don't pick up dependencies
  44. # from documentation
  45. find examples -type f | xargs chmod a-x
  46. %build
  47. %pip3_build_wheel
  48. %install
  49. rm -rf %{buildroot}
  50. %pip3_install_wheel
  51. #%check
  52. #%{__python3} setup.py test
  53. %clean
  54. rm -rf %{buildroot}
  55. %files -n python3-dns
  56. %defattr(-,root,root,-)
  57. %license LICENSE
  58. %doc README* examples
  59. %{python3_sitelib}/*-info
  60. %{python3_sitelib}/dns
  61. %changelog
  62. * Fri Oct 28 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.1.1-1
  63. - new upstream release.
  64. * Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.0-1
  65. - new upstream release.
  66. - built with python3 only.
  67. * Tue May 14 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.0-1
  68. - new upstream release.
  69. - added python3 support.
  70. * Sun Jan 12 2014 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-3
  71. - rebuild with VineSeed environment
  72. * Mon Apr 08 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-2
  73. - add BR: python-devel, python
  74. * Sat Sep 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
  75. - new upstream release
  76. * Thu Apr 05 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.4-1
  77. - initial build for Vine Linux
  78. * Mon Mar 28 2011 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.4-1
  79. -
  80. - dnspython 1.9.4 has been released and is available at
  81. - http://www.dnspython.org/kits/1.9.4/
  82. -
  83. - There is no new functionality in this release; just a few bug fixes
  84. - in RRSIG and SIG code.
  85. -
  86. - I will be eliminating legacy code for earlier versions of DNSSEC in a
  87. - future release of dnspython.
  88. * Fri Mar 25 2011 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.3-1
  89. -
  90. - New since 1.9.2:
  91. -
  92. - A boolean parameter, 'raise_on_no_answer', has been added to
  93. - the query() methods. In no-error, no-data situations, this
  94. - parameter determines whether NoAnswer should be raised or not.
  95. - If True, NoAnswer is raised. If False, then an Answer()
  96. - object with a None rrset will be returned.
  97. -
  98. - Resolver Answer() objects now have a canonical_name field.
  99. -
  100. - Rdata now have a __hash__ method.
  101. -
  102. - Bugs fixed since 1.9.2:
  103. -
  104. - Dnspython was erroneously doing case-insensitive comparisons
  105. - of the names in NSEC and RRSIG RRs.
  106. -
  107. - We now use "is" and not "==" when testing what section an RR
  108. - is in.
  109. -
  110. - The resolver now disallows metaqueries.
  111. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.9.2-2
  112. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  113. * Tue Nov 23 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.2-1
  114. - It's brown paper bag time :) The fix for the import problems was
  115. - actually bad, but didn't show up in testing because the test suite's
  116. - conditional importing code hid the problem.
  117. -
  118. - Any, 1.9.2 is out.
  119. -
  120. - Sorry for the churn!
  121. * Mon Nov 22 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.9.1-1
  122. - New since 1.9.0:
  123. -
  124. - Nothing.
  125. -
  126. - Bugs fixed since 1.9.0
  127. -
  128. - The dns.dnssec module didn't work with DSA due to namespace
  129. - contamination from a "from"-style import.
  130. -
  131. - New since 1.8.0:
  132. -
  133. - dnspython now uses poll() instead of select() when available.
  134. -
  135. - Basic DNSSEC validation can be done using dns.dnsec.validate()
  136. - and dns.dnssec.validate_rrsig() if you have PyCrypto 2.3 or
  137. - later installed. Complete secure resolution is not yet
  138. - available.
  139. -
  140. - Added key_id() to the DNSSEC module, which computes the DNSSEC
  141. - key id of a DNSKEY rdata.
  142. -
  143. - Added make_ds() to the DNSSEC module, which returns the DS RR
  144. - for a given DNSKEY rdata.
  145. -
  146. - dnspython now raises an exception if HMAC-SHA284 or
  147. - HMAC-SHA512 are used with a Python older than 2.5.2. (Older
  148. - Pythons do not compute the correct value.)
  149. -
  150. - Symbolic constants are now available for TSIG algorithm names.
  151. -
  152. - Bugs fixed since 1.8.0
  153. -
  154. - dns.resolver.zone_for_name() didn't handle a query response
  155. - with a CNAME or DNAME correctly in some cases.
  156. -
  157. - When specifying rdata types and classes as text, Unicode
  158. - strings may now be used.
  159. -
  160. - Hashlib compatibility issues have been fixed.
  161. -
  162. - dns.message now imports dns.edns.
  163. -
  164. - The TSIG algorithm value was passed incorrectly to use_tsig()
  165. - in some cases.
  166. * Fri Aug 13 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-3
  167. - Add a patch from upstream to fix a Python 2.7 issue.
  168. * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.8.0-2.1
  169. - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
  170. * Wed Jan 27 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-1.1
  171. - Fix error
  172. * Wed Jan 27 2010 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.8.0-1
  173. - New since 1.7.1:
  174. -
  175. - Support for hmac-sha1, hmac-sha224, hmac-sha256, hmac-sha384 and
  176. - hmac-sha512 has been contributed by Kevin Chen.
  177. -
  178. - The tokenizer's tokens are now Token objects instead of (type,
  179. - value) tuples.
  180. -
  181. - Bugs fixed since 1.7.1:
  182. -
  183. - Escapes in masterfiles now work correctly. Previously they were
  184. - only working correctly when the text involved was part of a domain
  185. - name.
  186. -
  187. - When constructing a DDNS update, if the present() method was used
  188. - with a single rdata, a zero TTL was not added.
  189. -
  190. - The entropy pool needed locking to be thread safe.
  191. -
  192. - The entropy pool's reading of /dev/random could cause dnspython to
  193. - block.
  194. -
  195. - The entropy pool did buffered reads, potentially consuming more
  196. - randomness than we needed.
  197. -
  198. - The entropy pool did not seed with high quality randomness on
  199. - Windows.
  200. -
  201. - SRV records were compared incorrectly.
  202. -
  203. - In the e164 query function, the resolver parameter was not used.
  204. * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7.1-2
  205. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  206. * Fri Jun 19 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.1-1
  207. - New since 1.7.0:
  208. -
  209. - Nothing
  210. -
  211. - Bugs fixed since 1.7.0:
  212. -
  213. - The 1.7.0 kitting process inadventently omitted the code for the
  214. - DLV RR.
  215. -
  216. - Negative DDNS prerequisites are now handled correctly.
  217. * Fri Jun 19 2009 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.7.0-1
  218. - New since 1.6.0:
  219. -
  220. - Rdatas now have a to_digestable() method, which returns the
  221. - DNSSEC canonical form of the rdata, suitable for use in
  222. - signature computations.
  223. -
  224. - The NSEC3, NSEC3PARAM, DLV, and HIP RR types are now supported.
  225. -
  226. - An entropy module has been added and is used to randomize query ids.
  227. -
  228. - EDNS0 options are now supported.
  229. -
  230. - UDP IXFR is now supported.
  231. -
  232. - The wire format parser now has a 'one_rr_per_rrset' mode, which
  233. - suppresses the usual coalescing of all RRs of a given type into a
  234. - single RRset.
  235. -
  236. - Various helpful DNSSEC-related constants are now defined.
  237. -
  238. - The resolver's query() method now has an optional 'source' parameter,
  239. - allowing the source IP address to be specified.
  240. -
  241. - Bugs fixed since 1.6.0:
  242. -
  243. - On Windows, the resolver set the domain incorrectly.
  244. -
  245. - DS RR parsing only allowed one Base64 chunk.
  246. -
  247. - TSIG validation didn't always use absolute names.
  248. -
  249. - NSEC.to_text() only printed the last window.
  250. -
  251. - We did not canonicalize IPv6 addresses before comparing them; we
  252. - would thus treat equivalent but different textual forms, e.g.
  253. - "1:00::1" and "1::1" as being non-equivalent.
  254. -
  255. - If the peer set a TSIG error, we didn't raise an exception.
  256. -
  257. - Some EDNS bugs in the message code have been fixed (see the ChangeLog
  258. - for details).
  259. * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-4
  260. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  261. * Sat Nov 29 2008 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.0-3
  262. - Rebuild for Python 2.6
  263. * Fri Aug 29 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 1.6.0-2
  264. - fix license tag
  265. * Tue Dec 4 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.6.0-1
  266. - Update to 1.6.0
  267. * Tue Oct 9 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.5.0-2
  268. - Follow new Python egg packaging specs
  269. * Thu Jan 11 2007 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.5.0-1
  270. - Update to 1.5.0
  271. * Fri Dec 8 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-3
  272. - Bump release for rebuild with Python 2.5
  273. * Mon Aug 14 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-2
  274. - No longer ghost *.pyo files, thus further simplifying the files section.
  275. * Sat Aug 5 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.4.0-1
  276. - Update to 1.4.0
  277. - Remove unneeded python-abi requires
  278. - Remove unneeded python_sitearch macro
  279. * Fri May 26 2006 Jeffrey C. Ollie <jeff@ocjtech.us> - 1.3.5-1
  280. - First version for Fedora Extras