python-idna-vl.spec 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170
  1. %bcond_without python3
  2. %global srcname idna
  3. Name: python-%{srcname}
  4. Version: 3.4
  5. Release: 1%{?_dist_release}
  6. Summary: Internationalized Domain Names in Applications (IDNA)
  7. Group: programming
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: BSD and Python and Unicode
  11. URL: https://github.com/kjd/idna
  12. Source0: https://pypi.io/packages/source/i/%{srcname}/%{srcname}-%{version}.tar.gz
  13. BuildArch: noarch
  14. BuildRequires: python-rpm-macros
  15. %if 0%{?with_python3}
  16. BuildRequires: python%{python3_pkgversion}-rpm-macros
  17. BuildRequires: python%{python3_pkgversion}-devel
  18. BuildRequires: python%{python3_pkgversion}-setuptools
  19. BuildRequires: python%{python3_pkgversion}-setuptools_scm
  20. BuildRequires: python%{python3_pkgversion}-flit
  21. %endif # with_python3
  22. %description
  23. A library to support the Internationalised Domain Names in Applications (IDNA)
  24. protocol as specified in RFC 5891 <http://tools.ietf.org/html/rfc5891>. This
  25. version of the protocol is often referred to as "IDNA2008" and can produce
  26. different results from the earlier standard from 2003.
  27. The library is also intended to act as a suitable drop-in replacement for the
  28. "encodings.idna" module that comes with the Python standard library but
  29. currently only supports the older 2003 specification.
  30. %if 0%{?with_python3}
  31. %package -n python%{python3_pkgversion}-%{srcname}
  32. Summary: Internationalized Domain Names in Applications (IDNA)
  33. Group: programming
  34. %{?python_provide:%python_provide python%{python3_pkgversion}-%{srcname}}
  35. %description -n python%{python3_pkgversion}-%{srcname}
  36. A library to support the Internationalised Domain Names in Applications (IDNA)
  37. protocol as specified in RFC 5891 <http://tools.ietf.org/html/rfc5891>. This
  38. version of the protocol is often referred to as "IDNA2008" and can produce
  39. different results from the earlier standard from 2003.
  40. The library is also intended to act as a suitable drop-in replacement for the
  41. "encodings.idna" module that comes with the Python standard library but
  42. currently only supports the older 2003 specification.
  43. %endif # with_python3
  44. %prep
  45. %setup -q -n %{srcname}-%{version}
  46. # Remove bundled egg-info
  47. rm -rf %{srcname}.egg-info
  48. %build
  49. %if 0%{?with_python3}
  50. %pip3_build_wheel
  51. %endif # with_python3
  52. %install
  53. %if 0%{?with_python3}
  54. %pip3_install_wheel
  55. %endif # with_python3
  56. %check
  57. %if 0%{?with_python3}
  58. #{__python3} setup.py test
  59. %endif # with_python3
  60. %if 0%{?with_python3}
  61. %files -n python%{python3_pkgversion}-%{srcname}
  62. %license LICENSE.md
  63. %doc README.rst HISTORY.rst
  64. %{python3_sitelib}/%{srcname}
  65. %{python3_sitelib}/%{srcname}-*-info
  66. %endif # with_python3
  67. %changelog
  68. * Sat Oct 22 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.4-1
  69. - new upstream release.
  70. - dropped python2 support.
  71. * Tue Feb 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.10-2
  72. - rebuilt with rpm-4.16.
  73. * Sat Aug 15 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.10-1
  74. - new upstream release.
  75. * Mon Nov 19 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 2.7-4
  76. - initial build for Vine Linux.
  77. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.7-3
  78. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  79. * Thu Jun 14 2018 Miro Hrončok <mhroncok@redhat.com> - 2.7-2
  80. - Rebuilt for Python 3.7
  81. * Tue Jun 12 2018 Jeremy Cline <jeremy@jcline.org> - 2.7-1
  82. - Update to v2.7 (rhbz 1589803)
  83. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.5-4
  84. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  85. * Fri Jan 19 2018 Iryna Shcherbina <ishcherb@redhat.com> - 2.5-3
  86. - Update Python 2 dependency declarations to new packaging standards
  87. (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
  88. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.5-2
  89. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  90. * Tue Mar 07 2017 Jeremy Cline <jeremy@jcline.org> - 2.5-1
  91. - Update to version 2.5
  92. * Wed Mar 01 2017 Jeremy Cline <jeremy@jcline.org> - 2.4-1
  93. - Update to version 2.4
  94. * Tue Feb 28 2017 Paul Wouters <pwouters@redhat.com> - 2.3-1
  95. - Resolves: rhbz#1427499 Update to 2.3 for IDNAError bugfix and memory improvement
  96. * Thu Feb 09 2017 Jeremy Cline <jeremy@jcline.org> - 2.2-1
  97. - Update to version 2.2 (#1406757)
  98. * Fri Dec 09 2016 Charalampos Stratakis <cstratak@redhat.com> - 2.1-3
  99. - Rebuild for Python 3.6
  100. * Mon Nov 28 2016 Orion Poplawski <orion@cora.nwra.com> - 2.1-2
  101. - Ship python2-idna
  102. - Enable python3 for EPEL
  103. - Modernize spec
  104. * Mon Oct 17 2016 tom.prince@ualberta.net - 2.1-1
  105. - Bump version.
  106. * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0-4
  107. - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
  108. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.0-3
  109. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  110. * Wed Nov 04 2015 Robert Kuska <rkuska@redhat.com> - 2.0-2
  111. - Rebuilt for Python3.5 rebuild
  112. * Thu Aug 13 2015 Paul Wouters <pwouters@redhat.com> - 2.0-1
  113. - Update to 2.0 which is required by python-cryptography
  114. * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0-2
  115. - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
  116. * Wed Dec 31 2014 tom.prince@ualberta.net - 1.0-1
  117. - Bump version.
  118. * Mon Oct 27 2014 tom.prince@ualberta.net - 0.8-3
  119. - Update licences.
  120. * Sat Jul 12 2014 tom.prince@ualberta.net - 0.8-2
  121. - Be more specfic about .egg-info directories.
  122. - Use python2-devel
  123. * Sat Jul 12 2014 tom.prince@ualberta.net - 0.8-1
  124. - Initial package.