123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328 |
- %global srcname Markdown
- %global pkgname markdown
- Name: python-%{pkgname}
- Summary: Markdown implementation in Python
- Version: 3.4.1
- Release: 1%{?_dist_release}
- Group: programming
- Vendor: Project Vine
- Distribution: Vine Linux
- License: BSD
- URL: https://python-markdown.github.io/
- Source0: %{pypi_source}
- BuildArch: noarch
- %description
- This is a Python implementation of John Gruber’s Markdown. It is
- almost completely compliant with the reference implementation, though
- there are a few very minor differences.
- %package -n python3-%{pkgname}
- Summary: Markdown implementation in Python
- Group: programming
- BuildRequires: python3-devel
- BuildRequires: python3-PyYAML
- BuildRequires: python3-setuptools
- %if 0%{?rhel} && 0%{?rhel} < 9
- BuildRequires: python3-importlib-metadata
- Requires: python3-importlib-metadata
- %endif
- %{?python_provide:%python_provide python3-%{pkgname}}
- %description -n python3-%{pkgname}
- This is a Python implementation of John Gruber's Markdown. It is
- almost completely compliant with the reference implementation, though
- there are a few known issues.
- %prep
- %autosetup -p1 -n %{srcname}-%{version}
- %build
- %pip3_build_wheel
- %install
- %pip3_install_wheel
- PYTHONPATH=%{buildroot}%{python3_sitelib} \
- %{buildroot}%{_bindir}/markdown_py \
- LICENSE.md > LICENSE.html
- %check
- python3 -m unittest discover tests
- %files -n python3-%{pkgname}
- %license LICENSE.*
- %{python3_sitelib}/*
- %{_bindir}/markdown_py
- %changelog
- * Fri Oct 28 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.4.1-1
- - new upstream release.
- * Fri Apr 09 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.3.4-3
- - initial build for Vine Linux.
- * Sat Feb 27 2021 Thomas Moschny <thomas.moschny@gmx.de> - 3.3.4-2
- - Apply PR6 by Igor Raits <ignatenkobrain@fedoraproject.org>: Support
- for building on EPEL8 + upstream tests invocation.
- - Remove unused BR on python3-tidy (we'd need pytidylib instead, which
- doesn't seem to be packaged).
- * Sat Feb 27 2021 Thomas Moschny <thomas.moschny@gmx.de> - 3.3.4-1
- - Update to 3.3.4.
- * Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.3.3-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
- * Sun Oct 25 2020 Thomas Moschny <thomas.moschny@gmx.de> - 3.3.3-1
- - Update to 3.3.3.
- * Sun Oct 25 2020 Thomas Moschny <thomas.moschny@gmx.de> - 3.3.2-1
- - Update to 3.3.2.
- * Tue Oct 13 2020 Thomas Moschny <thomas.moschny@gmx.de> - 3.3.1-1
- - Update to 3.3.1.
- * Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.2.2-4
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
- * Fri May 22 2020 Miro Hrončok <mhroncok@redhat.com> - 3.2.2-3
- - Rebuilt for Python 3.9
- * Sat May 16 2020 Thomas Moschny <thomas.moschny@gmx.de> - 3.2.2-2
- - Update BRs.
- * Sat May 16 2020 Thomas Moschny <thomas.moschny@gmx.de> - 3.2.2-1
- - Update to 3.2.2.
- * Sat Feb 22 2020 Thomas Moschny <thomas.moschny@gmx.de> - 3.2.1-1
- - Update to 3.2.1.
- * Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.1-7
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
- * Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 3.1.1-6
- - Rebuilt for Python 3.8.0rc1 (#1748018)
- * Thu Aug 15 2019 Miro Hrončok <mhroncok@redhat.com> - 3.1.1-5
- - Rebuilt for Python 3.8
- * Tue Aug 13 2019 Thomas Moschny <thomas.moschny@gmx.de> - 3.1.1-4
- - Drop versioned binaries.
- * Tue Aug 13 2019 Gwyn Ciesla <gwync@protonmail.com> - 3.1.1-3
- - Drop Python 2.
- * Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.1-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
- * Sat May 25 2019 Thomas Moschny <thomas.moschny@gmx.de> - 3.1.1-1
- - Update to 3.1.1.
- * Fri May 03 2019 Miro Hrončok <mhroncok@redhat.com> - 3.1-2
- - Move /usr/bin/markdown_py to python3-markdown (#1705777)
- * Tue Mar 26 2019 Thomas Moschny <thomas.moschny@gmx.de> - 3.1-1
- - Update to 3.1.
- * Mon Mar 25 2019 Thomas Moschny <thomas.moschny@gmx.de> - 3.0.1-1
- - Update to 3.0.1.
- - Simplify spec file.
- - CLI tool uses Python3 now.
- - Update BRs.
- * Sat Feb 02 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.11-5
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
- * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.11-4
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
- * Sun Jun 17 2018 Miro Hrončok <mhroncok@redhat.com> - 2.6.11-3
- - Rebuilt for Python 3.7
- * Sun Jun 3 2018 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.11-2
- - Try to fix a FTBFS with Python 3.7 (rhbz#1583678).
- * Sun Feb 11 2018 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.11-1
- - Update to 2.6.11.
- * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.9-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
- * Wed Aug 30 2017 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.9-2
- - Fix BRs.
- * Wed Aug 30 2017 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.9-1
- - Update to 2.6.9.
- - Allow building a python3 subpackage on EPEL7+.
- * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.8-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
- * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.8-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
- * Sun Jan 29 2017 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.8-1
- - Update to 2.6.8.
- * Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 2.6.7-2
- - Rebuild for Python 3.6
- * Sat Sep 24 2016 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.7-1
- - Update to 2.6.7.
- - Update Source0 URL.
- * Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.6-2
- - https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
- * Tue Apr 5 2016 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.6-1
- - Update to 2.6.6.
- * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.6.5-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
- * Sun Nov 29 2015 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.5-1
- - Update to 2.6.5.
- * Sat Nov 21 2015 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.4-1
- - Update to 2.6.4.
- - Follow updated Python packaging guidelines.
- * Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.2-3
- - Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
- * Thu Jun 18 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.6.2-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
- * Wed Apr 22 2015 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.2-1
- - Update to 2.6.2.
- * Sat Mar 14 2015 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.1-2
- - Add license file.
- * Sat Mar 14 2015 Thomas Moschny <thomas.moschny@gmx.de> - 2.6.1-1
- - Update to 2.6.1.
- - Apply updated Python packaging guidelines.
- * Sun Feb 22 2015 Thomas Moschny <thomas.moschny@gmx.de> - 2.6-1
- - Update to 2.6.
- - Update the upstream URL.
- * Sun Nov 23 2014 Thomas Moschny <thomas.moschny@gmx.de> - 2.5.2-1
- - Update to 2.5.2.
- * Thu Oct 2 2014 Thomas Moschny <thomas.moschny@gmx.de> - 2.5.1-1
- - Update to 2.5.1.
- * Thu Sep 25 2014 Thomas Moschny <thomas.moschny@gmx.de> - 2.5-1
- - Update to 2.5.
- - Add BR on PyYAML.
- * Wed Jun 4 2014 Thomas Moschny <thomas.moschny@gmx.de> - 2.4.1-1
- - Update to 2.4.1.
- * Wed May 28 2014 Kalev Lember <kalevlember@gmail.com> - 2.4-2
- - Rebuilt for https://fedoraproject.org/wiki/Changes/Python_3.4
- * Tue Apr 15 2014 Thomas Moschny <thomas.moschny@gmx.de> - 2.4-1
- - Update to 2.4.
- - Update Python3 conditional.
- - Fix wrong line endings.
- * Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.3.1-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
- * Fri Jul 19 2013 Thomas Moschny <thomas.moschny@gmx.dee> - 2.3.1-2
- - Move python3 runtime dependency to python3 subpackage (rhbz#986376).
- * Mon Apr 8 2013 Thomas Moschny <thomas.moschny@gmx.de> - 2.3.1-1
- - Update to 2.3.1.
- * Mon Mar 18 2013 Thomas Moschny <thomas.moschny@gmx.de> - 2.3-1
- - Update to 2.3.
- - Spec file cleanups.
- * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.1-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
- * Fri Nov 23 2012 Thomas Moschny <thomas.moschny@gmx.de> - 2.2.1-1
- - Update to 2.2.1.
- * Sat Aug 04 2012 David Malcolm <dmalcolm@redhat.com> - 2.2.0-3
- - rebuild for https://fedoraproject.org/wiki/Features/Python_3.3
- * Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.2.0-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
- * Sat Jul 14 2012 Thomas Moschny <thomas.moschny@gmx.de> - 2.2.0-1
- - Update to 2.2.0.
- - Update url.
- - Add patch from upstream git for failing test.
- * Wed Feb 8 2012 Thomas Moschny <thomas.moschny@gmx.de> - 2.1.1-1
- - Update to 2.1.1.
- * Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.1.0-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
- * Sat Dec 17 2011 Thomas Moschny <thomas.moschny@gmx.de> - 2.1.0-1
- - Update to 2.1.0.
- - Fix rhel conditional.
- - Binary has been renamed.
- - Build python3 subpackage.
- - Include documentation in HTML instead of Markdown format.
- - Run tests.
- * Wed Sep 07 2011 Jesse Keating <jkeating@redhat.com> - 2.0.3-4
- - Set a version in the rhel macro
- * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.3-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
- * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 2.0.3-2
- - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
- * Thu Oct 8 2009 Thomas Moschny <thomas.moschny@gmx.de> - 2.0.3-1
- - Update to 2.0.3.
- * Thu Aug 27 2009 Thomas Moschny <thomas.moschny@gmx.de> - 2.0.1-3
- - Add requirement on python-elementtree, which was a separate package
- before Python 2.5.
- - Re-add changelog entries accidentally removed earlier.
- * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.1-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Sat Jul 11 2009 Thomas Moschny <thomas.moschny@gmx.de> - 2.0.1-1
- - Update to 2.0.1.
- - Upstream stripped .py of the cmdline script.
- * Sat Apr 25 2009 Thomas Moschny <thomas.moschny@gmx.de> - 2.0-1
- - Update to 2.0.
- - Adjusted source URL.
- - License changed to BSD only.
- - Upstream now provides a script to run markdown from the cmdline.
- * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.7-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
- * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 1.7-2
- - Rebuild for Python 2.6
- * Mon Aug 4 2008 Thomas Moschny <thomas.moschny@gmx.de> - 1.7-1
- - New package.
|