python-packaging-vl.spec 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140
  1. %bcond_with test
  2. %global pypi_name packaging
  3. #global build_wheel 1
  4. %global with_python3 1
  5. Summary: Core utilities for Python packages
  6. Name: python-%{pypi_name}
  7. Version: 21.3
  8. Release: 1%{?_dist_release}
  9. Group: programming
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. License: BSD or ASL 2.0
  13. URL: https://github.com/pypa/packaging
  14. Source0: https://files.pythonhosted.org/packages/source/p/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
  15. Patch1: python-packaging-dependency.patch
  16. BuildArch: noarch
  17. BuildRequires: python-rpm-macros
  18. # Build Python 3 subpackage only for Fedora
  19. %if 0%{?with_python3}
  20. BuildRequires: python3-rpm-macros
  21. BuildRequires: python3-setuptools
  22. BuildRequires: python3-devel
  23. BuildRequires: python3-pyparsing
  24. BuildRequires: python3-six
  25. %if %{with test}
  26. BuildRequires: python3-pytest
  27. BuildRequires: python3-pretend
  28. %endif
  29. %endif
  30. %description
  31. python-packaging provides core utilities for Python packages like utilities for
  32. dealing with versions, specifiers, markers etc.
  33. %if 0%{?with_python3}
  34. %package -n python3-%{pypi_name}
  35. Summary: %{summary}
  36. %{?python_provide:%python_provide python3-%{pypi_name}}
  37. Requires: python3-pyparsing
  38. Requires: python3-six
  39. %description -n python3-%{pypi_name}
  40. python3-packaging provides core utilities for Python packages like utilities for
  41. dealing with versions, specifiers, markers etc.
  42. %endif
  43. %prep
  44. %autosetup -p1 -n %{pypi_name}-%{version}
  45. # Remove bundled egg-info
  46. rm -rf %{pypi_name}.egg-info
  47. %build
  48. %if 0%{?with_python3}
  49. %pip3_build_wheel
  50. %endif
  51. %install
  52. %if 0%{?with_python3}
  53. %pip3_install_wheel
  54. %endif
  55. %check
  56. %if %{with test}
  57. %{__python3} -m pytest tests/
  58. %endif
  59. %if 0%{?with_python3}
  60. %files -n python3-%{pypi_name}
  61. %license LICENSE LICENSE.APACHE LICENSE.BSD
  62. %doc README.rst CHANGELOG.rst CONTRIBUTING.rst
  63. %{python3_sitelib}/%{pypi_name}/
  64. %{python3_sitelib}/%{pypi_name}-*-info/
  65. %endif
  66. %changelog
  67. * Sun Oct 23 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 21.3-1
  68. - new upstream release.
  69. * Tue Feb 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 20.9-1
  70. - new upstream release.
  71. * Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 20.4-1
  72. - new upstream release.
  73. * Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 18.0-1
  74. - new upstream release.
  75. - initial build for Vine Linux.
  76. * Tue Jul 31 2018 Charalampos Stratakis <cstratak@redhat.com> - 17.1-1
  77. - Update to 17.1
  78. * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 16.8-11
  79. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  80. * Sat Jun 16 2018 Miro Hrončok <mhroncok@redhat.com> - 16.8-10
  81. - Rebuilt for Python 3.7
  82. * Thu Jun 14 2018 Miro Hrončok <mhroncok@redhat.com> - 16.8-9
  83. - Bootstrap for Python 3.7
  84. * Fri Feb 09 2018 Iryna Shcherbina <ishcherb@redhat.com> - 16.8-8
  85. - Update Python 2 dependency declarations to new packaging standards
  86. (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
  87. * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 16.8-7
  88. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  89. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 16.8-6
  90. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  91. * Wed Mar 22 2017 Lumir Balhar <lbalhar@redhat.com> - 16.8-5
  92. - Epel7 compatible spec/package
  93. * Mon Feb 13 2017 Charalampos Stratakis <cstratak@redhat.com> - 16.8-4
  94. - Rebuild as wheel
  95. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 16.8-3
  96. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  97. * Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 16.8-2
  98. - Rebuild for Python 3.6
  99. * Wed Nov 02 2016 Lumir Balhar <lbalhar@redhat.com> - 16.8-1
  100. - New upstream version
  101. * Fri Sep 16 2016 Lumir Balhar <lbalhar@redhat.com> - 16.7-1
  102. - Initial package.