123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140 |
- %bcond_with test
- %global pypi_name packaging
- #global build_wheel 1
- %global with_python3 1
- Summary: Core utilities for Python packages
- Name: python-%{pypi_name}
- Version: 21.3
- Release: 1%{?_dist_release}
- Group: programming
- Vendor: Project Vine
- Distribution: Vine Linux
- License: BSD or ASL 2.0
- URL: https://github.com/pypa/packaging
- Source0: https://files.pythonhosted.org/packages/source/p/%{pypi_name}/%{pypi_name}-%{version}.tar.gz
- Patch1: python-packaging-dependency.patch
- BuildArch: noarch
- BuildRequires: python-rpm-macros
- # Build Python 3 subpackage only for Fedora
- %if 0%{?with_python3}
- BuildRequires: python3-rpm-macros
- BuildRequires: python3-setuptools
- BuildRequires: python3-devel
- BuildRequires: python3-pyparsing
- BuildRequires: python3-six
- %if %{with test}
- BuildRequires: python3-pytest
- BuildRequires: python3-pretend
- %endif
- %endif
- %description
- python-packaging provides core utilities for Python packages like utilities for
- dealing with versions, specifiers, markers etc.
- %if 0%{?with_python3}
- %package -n python3-%{pypi_name}
- Summary: %{summary}
- %{?python_provide:%python_provide python3-%{pypi_name}}
-
- Requires: python3-pyparsing
- Requires: python3-six
- %description -n python3-%{pypi_name}
- python3-packaging provides core utilities for Python packages like utilities for
- dealing with versions, specifiers, markers etc.
- %endif
- %prep
- %autosetup -p1 -n %{pypi_name}-%{version}
- # Remove bundled egg-info
- rm -rf %{pypi_name}.egg-info
- %build
- %if 0%{?with_python3}
- %pip3_build_wheel
- %endif
- %install
- %if 0%{?with_python3}
- %pip3_install_wheel
- %endif
- %check
- %if %{with test}
- %{__python3} -m pytest tests/
- %endif
- %if 0%{?with_python3}
- %files -n python3-%{pypi_name}
- %license LICENSE LICENSE.APACHE LICENSE.BSD
- %doc README.rst CHANGELOG.rst CONTRIBUTING.rst
- %{python3_sitelib}/%{pypi_name}/
- %{python3_sitelib}/%{pypi_name}-*-info/
- %endif
- %changelog
- * Sun Oct 23 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 21.3-1
- - new upstream release.
- * Tue Feb 23 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 20.9-1
- - new upstream release.
- * Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 20.4-1
- - new upstream release.
- * Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 18.0-1
- - new upstream release.
- - initial build for Vine Linux.
- * Tue Jul 31 2018 Charalampos Stratakis <cstratak@redhat.com> - 17.1-1
- - Update to 17.1
- * Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 16.8-11
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
- * Sat Jun 16 2018 Miro Hrončok <mhroncok@redhat.com> - 16.8-10
- - Rebuilt for Python 3.7
- * Thu Jun 14 2018 Miro Hrončok <mhroncok@redhat.com> - 16.8-9
- - Bootstrap for Python 3.7
- * Fri Feb 09 2018 Iryna Shcherbina <ishcherb@redhat.com> - 16.8-8
- - Update Python 2 dependency declarations to new packaging standards
- (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
- * Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 16.8-7
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
- * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 16.8-6
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
- * Wed Mar 22 2017 Lumir Balhar <lbalhar@redhat.com> - 16.8-5
- - Epel7 compatible spec/package
- * Mon Feb 13 2017 Charalampos Stratakis <cstratak@redhat.com> - 16.8-4
- - Rebuild as wheel
- * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 16.8-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
- * Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 16.8-2
- - Rebuild for Python 3.6
- * Wed Nov 02 2016 Lumir Balhar <lbalhar@redhat.com> - 16.8-1
- - New upstream version
- * Fri Sep 16 2016 Lumir Balhar <lbalhar@redhat.com> - 16.7-1
- - Initial package.
|