python-rpm-macros-vl.spec 6.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207
  1. Name: python-rpm-macros
  2. Summary: The unversioned Python RPM macros
  3. Version: 3.11
  4. Release: 1%{?_dist_release}
  5. Group: programming
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. Packager: tomop
  9. License: MIT
  10. Source0: macros.python
  11. Source1: macros.python-srpm
  12. Source2: macros.python2
  13. Source3: macros.python3
  14. Source4: macros.platform-python
  15. Source100: python.attr
  16. Source101: pythondist.attr
  17. Source102: pythondistdeps.py
  18. BuildArch: noarch
  19. # For %%python3_pkgversion used in %%python_provide
  20. Requires: python-srpm-macros
  21. Requires: python3-packaging
  22. Obsoletes: python-macros < 3
  23. Provides: python-macros = %{version}-%{release}
  24. %description
  25. This package contains the unversioned Python RPM macros, that most
  26. implementations should rely on.
  27. You should not need to install this package manually as the various
  28. python?-devel packages require it. So install a python-devel package instead.
  29. %package -n python-srpm-macros
  30. Summary: RPM macros for building Python source packages
  31. %description -n python-srpm-macros
  32. RPM macros for building Python source packages.
  33. %package -n python2-rpm-macros
  34. Summary: RPM macros for building Python 2 packages
  35. # Would need to be different for each release - worth it?
  36. #Conflicts: python2-devel < 2.7.11-3
  37. Requires: python-rpm-macros
  38. Requires: python-srpm-macros
  39. %description -n python2-rpm-macros
  40. RPM macros for building Python 2 packages.
  41. %package -n python3-rpm-macros
  42. Summary: RPM macros for building Python 3 packages
  43. # Would need to be different for each release - worth it?
  44. #Conflicts: python3-devel < 3.5.1-3
  45. Requires: python-rpm-macros
  46. Requires: python-srpm-macros
  47. Requires: python3-pip
  48. %description -n python3-rpm-macros
  49. RPM macros for building Python 3 packages.
  50. #%package -n platform-python-rpm-macros
  51. #Summary: RPM macros for building Platform-Python packages
  52. #%description -n platform-python-rpm-macros
  53. #RPM macros for building Platform-Python packages.
  54. %prep
  55. %setup -T -c
  56. cp -f %{SOURCE102} ./
  57. %build
  58. %install
  59. mkdir -p %{buildroot}%{_rpmmacrodir}
  60. install -m 644 %{SOURCE0} %{SOURCE1} %{SOURCE2} %{SOURCE3} %{SOURCE4} \
  61. %{buildroot}%{_rpmmacrodir}/
  62. mkdir -p %{buildroot}%{_fileattrsdir}
  63. install -m 644 %{SOURCE100} %{SOURCE101} \
  64. %{buildroot}%{_fileattrsdir}/
  65. mkdir -p %{buildroot}%{_rpmconfigdir}
  66. install -m 755 pythondistdeps.py \
  67. %{buildroot}%{_rpmconfigdir}/
  68. %files
  69. %{_rpmmacrodir}/macros.python
  70. %{_rpmconfigdir}/pythondistdeps.py
  71. %{_fileattrsdir}/*
  72. %files -n python-srpm-macros
  73. %{_rpmmacrodir}/macros.python-srpm
  74. %files -n python2-rpm-macros
  75. %{_rpmmacrodir}/macros.python2
  76. %files -n python3-rpm-macros
  77. %{_rpmmacrodir}/macros.python3
  78. #%files -n platform-python-rpm-macros
  79. #%{rpmmacrodir}/macros.platform-python
  80. %exclude %{_rpmmacrodir}/macros.platform-python
  81. %changelog
  82. * Sun Oct 23 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.11-1
  83. - built with python-3.11.
  84. * Mon Feb 22 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.8-2
  85. - added scripts.
  86. * Wed Apr 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.8-1
  87. - updated to 3.8.
  88. * Wed Oct 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3-26
  89. - updated macros.
  90. * Mon Dec 18 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3-25
  91. - fixed a typo.
  92. * Wed Sep 20 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3-24
  93. - fixed a path to install.
  94. * Tue Sep 19 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3-23
  95. - initial build for Vine Linux.
  96. * Wed Aug 02 2017 Tomas Orsava <torsava@redhat.com> - 3-22
  97. - Add platform-python macros (https://fedoraproject.org/wiki/Changes/Platform_Python_Stack)
  98. * Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3-21
  99. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  100. * Fri Mar 03 2017 Michal Cyprian <mcyprian@redhat.com> - 3-20
  101. - Revert "Switch %%__python3 to /usr/libexec/system-python"
  102. after the Fedora Change https://fedoraproject.org/wiki/Changes/Making_sudo_pip_safe
  103. was postponed
  104. * Fri Feb 17 2017 Michal Cyprian <mcyprian@redhat.com> - 3-19
  105. - Switch %%__python3 to /usr/libexec/system-python
  106. * Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3-18
  107. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  108. * Mon Jan 23 2017 Michal Cyprian <mcyprian@redhat.com> - 3-17
  109. - Add --no-deps option to py_install_wheel macros
  110. * Tue Jan 17 2017 Tomas Orsava <torsava@redhat.com> - 3-16
  111. - Added macros for Build/Requires tags using Python dist tags:
  112. https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
  113. * Thu Nov 24 2016 Orion Poplawski <orion@cora.nwra.com> 3-15
  114. - Make expanded macros start on the same line as the macro
  115. * Wed Nov 16 2016 Orion Poplawski <orion@cora.nwra.com> 3-14
  116. - Fix %%py3_install_wheel (bug #1395953)
  117. * Wed Nov 16 2016 Orion Poplawski <orion@cora.nwra.com> 3-13
  118. - Add missing sleeps to other build macros
  119. - Fix build_egg macros
  120. - Add %%py_build_wheel and %%py_install_wheel macros
  121. * Tue Nov 15 2016 Orion Poplawski <orion@cora.nwra.com> 3-12
  122. - Add %%py_build_egg and %%py_install_egg macros
  123. - Allow multiple args to %%py_build/install macros
  124. - Tidy up macro formatting
  125. * Wed Aug 24 2016 Orion Poplawski <orion@cora.nwra.com> 3-11
  126. - Use %%rpmmacrodir
  127. * Tue Jul 12 2016 Orion Poplawski <orion@cora.nwra.com> 3-10
  128. - Do not generate useless Obsoletes with %%{?_isa}
  129. * Fri May 13 2016 Orion Poplawski <orion@cora.nwra.com> 3-9
  130. - Make python-rpm-macros require python-srpm-macros (bug #1335860)
  131. * Thu May 12 2016 Jason L Tibbitts III <tibbs@math.uh.edu> - 3-8
  132. - Add single-second sleeps to work around setuptools bug.
  133. * Thu Feb 04 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3-7
  134. - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
  135. * Thu Jan 14 2016 Orion Poplawski <orion@cora.nwra.com> 3-6
  136. - Fix typo in %%python_provide
  137. * Thu Jan 14 2016 Orion Poplawski <orion@cora.nwra.com> 3-5
  138. - Handle noarch python sub-packages (bug #1290900)
  139. * Wed Jan 13 2016 Orion Poplawski <orion@cora.nwra.com> 3-4
  140. - Fix python2/3-rpm-macros package names
  141. * Thu Jan 7 2016 Orion Poplawski <orion@cora.nwra.com> 3-3
  142. - Add empty %%prep and %%build
  143. * Mon Jan 4 2016 Orion Poplawski <orion@cora.nwra.com> 3-2
  144. - Combined package
  145. * Wed Dec 30 2015 Orion Poplawski <orion@cora.nwra.com> 3-1
  146. - Initial package