123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405 |
- %bcond_with bootstrap
- %global upstream_name Sphinx
- %global py3_default 0
- Summary: Python documentation generator
- Name: python-sphinx
- Version: 5.3.0
- Release: 1%{?_dist_release}
- Group: publishing,programming
- Vendor: Project Vine
- Distribution: Vine Linux
- # Unless otherwise noted, the license for code is BSD
- # sphinx/util/stemmer.py Public Domain
- # sphinx/pycode/pgen2 Python
- # jquery (MIT or GPLv2)
- License: BSD and Public Domain and Python and (MIT or GPLv2)
- URL: http://sphinx.pocoo.org/
- Source0: https://pypi.python.org/packages/source/S/%{upstream_name}/%{upstream_name}-%{version}.tar.gz
- # Allow extra themes to exist. We pull in python[23]-sphinx-theme-alabaster
- # which causes that test to fail.
- Patch1: sphinx-test_theming.diff
- BuildArch: noarch
- BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
- BuildRequires: python-rpm-macros
- %description
- Sphinx is a tool that makes it easy to create intelligent and
- beautiful documentation for Python projects (or other documents
- consisting of multiple reStructuredText sources), written by Georg
- Brandl. It was originally created to translate the new Python
- documentation, but has now been cleaned up in the hope that it will be
- useful to many other projects.
- Sphinx uses reStructuredText as its markup language, and many of its
- strengths come from the power and straightforwardness of
- reStructuredText and its parsing and translating suite, the Docutils.
- Although it is still under constant development, the following
- features are already present, work fine and can be seen "in action" in
- the Python docs:
- * Output formats: HTML (including Windows HTML Help) and LaTeX,
- for printable PDF versions
- * Extensive cross-references: semantic markup and automatic links
- for functions, classes, glossary terms and similar pieces of
- information
- * Hierarchical structure: easy definition of a document tree, with
- automatic links to siblings, parents and children
- * Automatic indices: general index as well as a module index
- * Code handling: automatic highlighting using the Pygments highlighter
- * Various extensions are available, e.g. for automatic testing of
- snippets and inclusion of appropriately formatted docstrings.
- %package -n python3-sphinx
- Summary: Python documentation generator
- Group: publishing,programming
- BuildRequires: python3-rpm-macros
- BuildRequires: python3-devel
- BuildRequires: python3-setuptools
- BuildRequires: python3-six
- BuildRequires: python3-jinja2
- BuildRequires: python3-docutils
- BuildRequires: python3-snowballstemmer
- BuildRequires: python3-babel
- BuildRequires: python3-sphinx-theme-alabaster
- BuildRequires: python3-imagesize
- BuildRequires: python3-requests
- BuildRequires: python3-packaging
- BuildRequires: python3-flit-core
- Requires: python3-setuptools
- Requires: python-sphinx-locale = %{version}-%{release}
- Requires: python3-six
- Requires: python3-jinja2
- Requires: python3-docutils
- Requires: python3-snowballstemmer
- Requires: python3-babel
- Requires: python3-sphinx-theme-alabaster
- Requires: python3-imagesize
- Requires: python3-requests
- Requires: python3-packaging
- %if !%{with bootstrap}
- BuildRequires: python3-pygments
- BuildRequires: python3-sphinxcontrib-websupport
- BuildRequires: python3-sphinxcontrib-serializinghtml
- BuildRequires: python3-sphinxcontrib-applehelp
- BuildRequires: python3-sphinxcontrib-devhelp
- BuildRequires: python3-sphinxcontrib-htmlhelp
- BuildRequires: python3-sphinxcontrib-qthelp
- BuildRequires: python3-sphinxcontrib-jsmath
- Requires: python3-pygments
- Requires: python3-sphinxcontrib-websupport
- %endif
- %description -n python3-sphinx
- Sphinx is a tool that makes it easy to create intelligent and
- beautiful documentation for Python projects (or other documents
- consisting of multiple reStructuredText sources), written by Georg
- Brandl. It was originally created to translate the new Python
- documentation, but has now been cleaned up in the hope that it will be
- useful to many other projects.
- Sphinx uses reStructuredText as its markup language, and many of its
- strengths come from the power and straightforwardness of
- reStructuredText and its parsing and translating suite, the Docutils.
- Although it is still under constant development, the following
- features are already present, work fine and can be seen "in action" in
- the Python docs:
- * Output formats: HTML (including Windows HTML Help) and LaTeX,
- for printable PDF versions
- * Extensive cross-references: semantic markup and automatic links
- for functions, classes, glossary terms and similar pieces of
- information
- * Hierarchical structure: easy definition of a document tree, with
- automatic links to siblings, parents and children
- * Automatic indices: general index as well as a module index
- * Code handling: automatic highlighting using the Pygments highlighter
- * Various extensions are available, e.g. for automatic testing of
- snippets and inclusion of appropriately formatted docstrings.
- %package locale
- Summary: Locale files for %{name}
- Group: publishing
- License: BSD
- %description locale
- Sphinx is a tool that makes it easy to create intelligent and
- beautiful documentation for Python projects (or other documents
- consisting of multiple reStructuredText sources), written by Georg
- Brandl. It was originally created to translate the new Python
- documentation, but has now been cleaned up in the hope that it will be
- useful to many other projects.
- This package contains locale files for Sphinx
- %package doc
- Summary: Documentation for %{name}
- Group: documentation
- License: BSD
- %description doc
- Sphinx is a tool that makes it easy to create intelligent and
- beautiful documentation for Python projects (or other documents
- consisting of multiple reStructuredText sources), written by Georg
- Brandl. It was originally created to translate the new Python
- documentation, but has now been cleaned up in the hope that it will be
- useful to many other projects.
- This package contains documentation in reST and HTML formats.
- %prep
- %autosetup -n %{upstream_name}-%{version} -p1
- # fix line encoding of bundled jquery.js
- perl -pi -e 's/\r//' ./sphinx/themes/basic/static/jquery.js
- %if %{with bootstrap}
- sed -i \
- -e '/"sphinxcontrib-/d' \
- -e '/"Pygments/d' \
- pyproject.toml
- %endif
- %build
- %pip3_build_wheel
- %if !%{with bootstrap}
- export PYTHONPATH=$PWD
- pushd doc
- export SPHINXBUILD="%{__python3} ../sphinx/cmd/build.py"
- make html SPHINXBUILD="$SPHINXBUILD"
- make man SPHINXBUILD="$SPHINXBUILD"
- rm -rf _build/html/.buildinfo
- mv _build/html ..
- popd
- %endif
- %install
- %__rm -rf %{buildroot}
- %pip3_install_wheel
- # Clean up non-python files
- rm -f %{buildroot}%{python3_sitelib}/sphinx/locale/.DS_Store
- rm -rf %{buildroot}%{python3_sitelib}/sphinx/locale/.tx
- %if !%{with bootstrap}
- pushd doc
- # Deliver man pages
- install -d %{buildroot}%{_mandir}/man1
- for f in _build/man/sphinx-*.1;
- do
- cp -p $f %{buildroot}%{_mandir}/man1/$(basename $f)
- done
- popd
- %endif
- # Deliver rst files
- rm -rf doc/_build
- sed -i 's|python ../sphinx-build.py|/usr/bin/sphinx-build|' doc/Makefile
- mv doc reST
- rm reST/make.bat
- # Move language files to /usr/share;
- # patch to support this incorporated in 0.6.6
- pushd %{buildroot}%{python3_sitelib}
- for lang in `find sphinx/locale -maxdepth 1 -mindepth 1 -type d -not -path '*/\.
- *' -printf "%f "`;
- do
- test $lang == __pycache__ && continue
- install -d %{buildroot}%{_datadir}/sphinx/locale/$lang
- install -d %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES
- mv sphinx/locale/$lang/LC_MESSAGES/sphinx.js \
- %{buildroot}%{_datadir}/sphinx/locale/$lang/
- mv sphinx/locale/$lang/LC_MESSAGES/sphinx.mo \
- %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/
- rm -rf sphinx/locale/$lang
- done
- popd
- # Create the sphinxcontrib directory, so we can own it
- # See https://bugzilla.redhat.com/show_bug.cgi?id=1669790 for rationale
- mkdir %{buildroot}%{python3_sitelib}/sphinxcontrib
- %find_lang sphinx
- # Language files; Since these are javascript, it's not immediately obvious to
- # find_lang that they need to be marked with a language.
- (cd %{buildroot} && find . -name 'sphinx.js') | sed -e 's|^.||' | sed -e \
- 's:\(.*/locale/\)\([^/_]\+\)\(.*\.js$\):%lang(\2) \1\2\3:' \
- >> sphinx.lang
- %clean
- %__rm -rf %{buildroot}
- %check
- #__make test
- %files -n python3-sphinx
- %license LICENSE
- %doc AUTHORS CHANGES EXAMPLES README.*
- %{_bindir}/sphinx-*
- %{python3_sitelib}/sphinx/
- %{python3_sitelib}/sphinx-*-info/
- %dir %{python3_sitelib}/sphinxcontrib/
- %dir %{_datadir}/sphinx/
- %if !%{with bootstrap}
- %{_mandir}/man1/sphinx-*
- %endif
- %files locale -f sphinx.lang
- %license LICENSE
- %dir %{_datadir}/sphinx/
- %dir %{_datadir}/sphinx/locale
- %dir %{_datadir}/sphinx/locale/*
- %files doc
- %defattr(-,root,root,-)
- %license LICENSE
- %if !%{with bootstrap}
- %doc html reST
- %endif
- %changelog
- * Tue Nov 01 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 5.3.0-1
- - new upstream release.
- * Tue Aug 18 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.1-2
- - added R:python3-sphinxcontrib-jsmath.
- * Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 3.2.1-1
- - new upstream release.
- - built with python3 only.
- * Thu Nov 29 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.9-2
- - fixed R:.
- * Wed Nov 28 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.9-1
- - new upstream release.
- - dropped Patch2.
- - imported Patch0-1 from rawhide.
- - added python3 support.
- * Wed May 09 2018 Toshiaki Ara <ara_t@384.jp> 1.1.3-3
- - added patch2 from RedHat
- * Thu Jul 2 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.3-2
- - added patch0.
- * Sun Jun 30 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> 1.1.3-1
- - new upstream release
- * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.0.7-2
- - rebuild with python-2.7.2
- * Thu May 5 2011 IWAI, Masaharu <iwai@alib.jp> 1.0.7-1
- - new upstream release
- - add BuildRequires: python-simplejson for Vine5
- - add Vendor and Distribution tags
- * Wed Dec 01 2010 Shu KONNO <owa@bg.wakwak.com> 1.0.5-1
- - update sphinx to 1.0.5
- * Mon Aug 23 2010 Munehiro Yamamoto <munepi@vinelinux.org> 1.0-1.b2
- - initial build based on Fedora development
- * Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 1.0-0.1.b2.1
- - Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
- * Mon May 31 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 1.0-0.2.b2
- - Update to 1.0 beta 2
- - Fixes problem building html documentation in non-English locales
- * Wed May 26 2010 Michel Salim <salimma@fedoraproject.org> - 1.0-0.1.b1
- - Update to 1.0 beta 1
- * Tue May 25 2010 Michel Salim <salimma@fedoraproject.org> - 0.6.6-1
- - Update to 0.6.6
- * Fri May 21 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.5-2
- - Few minor tweaks to Gareth's spec file update
- * Mon May 10 2010 Gareth Armstrong <gareth.armstrong@hp.com> - 0.6.5-1.hp
- - Update to 0.6.5
- - Initial import of python-sphinx from Fedora Rawhide for use in HP CMS
- - Enforce that Sphinx requires Python 2.4 or later via an explicit BR
- - Minor tweaks to spec file
- - Move language files to %%{_datadir}, idea borrowed from Debian's sphinx
- package
- - Deliver man pages for sphinx-build & sphinx-quickstart
- - Deliver rst documentation files to reST directory in doc sub-package
- - Add %%check section for Python2 and add BR on python-nose
- * Wed Jan 13 2010 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.4-1
- - Update to 0.6.4
- - Fixes a problem using autodoc with pylons projects.
- * Fri Sep 4 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.3-1
- - Update to 0.6.3
- * Mon Aug 17 2009 Toshio Kuratomi <toshio@fedoraproject.org> - 0.6.2-1
- - Update to 0.6.2 -- upstream bugfix requested inside bz#512438
- * Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.6.1-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
- * Fri Jun 05 2009 Luke Macken <lmacken@redhat.com> - 0.6.1-2
- - Add a patch to use our own setuptools package
- * Fri Apr 17 2009 Michel Salim <salimma@fedoraproject.org> - 0.6.1-1
- - Update to 0.6.1
- * Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.1-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
- * Fri Jan 2 2009 Michel Salim <salimma@fedoraproject.org> - 0.5.1-1
- - Update to 0.5.1
- * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 0.5-2
- - Rebuild for Python 2.6
- * Mon Nov 24 2008 Michel Salim <salimma@fedoraproject.org> - 0.5-1
- - Update to 0.5
- * Fri Oct 10 2008 Michel Salim <salimma@fedoraproject.org> - 0.4.3-1
- - Update to 0.4.3
- * Wed Aug 27 2008 Toshio Kuratomi <toshio@fedoraproject.org> - 0.4.2-1.1
- - Fix for EL-5 build.
- * Mon Aug 25 2008 Michel Salim <salimma@fedoraproject.org> - 0.4.2-1
- - Update to 0.4.2
- * Mon May 26 2008 Michel Salim <salimma@fedoraproject.org> - 0.3-1
- - Update to 0.3
- * Fri May 2 2008 Michel Salim <salimma@fedoraproject.org> - 0.1.61950-3
- - Split documentation into subpackage
- - Exclude C files (not built by default anyway)
- * Wed Apr 16 2008 José Matos <jamatos@fc.up.pt> - 0.1.61950-2
- - Build html documentation, include it and include the rst
- documentation.
- * Thu Mar 27 2008 Michel Salim <michel.sylvan@gmail.com> 0.1.61950-1
- - Initial package
|