123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120 |
- %global pypi_name sphinxcontrib-devhelp
- # when bootstrapping sphinx, we cannot run tests yet
- %bcond_with check
- Summary: Sphinx extension for Devhelp documents
- Name: python-%{pypi_name}
- Version: 1.0.2
- Release: 4%{?_dist_release}
- Group: programming
- Vendor: Project Vine
- Distribution: Vine Linux
- License: BSD
- URL: http://sphinx-doc.org/
- Source0: %{pypi_source}
- BuildArch: noarch
- BuildRequires: gettext
- BuildRequires: python3-devel
- BuildRequires: python3-setuptools
- %if %{with check}
- BuildRequires: python3-pytest
- BuildRequires: python3-sphinx >= 1:2
- %endif
- %description
- sphinxcontrib-devhelp is a sphinx extension which outputs Devhelp document.
- %package -n python3-%{pypi_name}
- Summary: %{summary}
- Group: programming
- %{?python_provide:%python_provide python3-%{pypi_name}}
- %description -n python3-%{pypi_name}
- sphinxcontrib-devhelp is a sphinx extension which outputs Devhelp document.
- %prep
- %autosetup -n %{pypi_name}-%{version}
- find -name '*.mo' -delete
- %build
- for po in $(find -name '*.po'); do
- msgfmt --output-file=${po%.po}.mo ${po}
- done
- %pip3_build_wheel
- %install
- %pip3_install_wheel
- # Move language files to /usr/share
- pushd %{buildroot}%{python3_sitelib}
- for lang in `find sphinxcontrib/devhelp/locales -maxdepth 1 -mindepth 1 -type d -not -path '*/\.*' -printf "%f "`;
- do
- test $lang == __pycache__ && continue
- install -d %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES
- mv sphinxcontrib/devhelp/locales/$lang/LC_MESSAGES/*.mo %{buildroot}%{_datadir}/locale/$lang/LC_MESSAGES/
- done
- rm -rf sphinxcontrib/devhelp/locales
- ln -s %{_datadir}/locale sphinxcontrib/devhelp/locales
- popd
- %find_lang sphinxcontrib.devhelp
- %if %{with check}
- %check
- %pytest
- %endif
- %files -n python3-%{pypi_name} -f sphinxcontrib.devhelp.lang
- %license LICENSE
- %doc README.rst
- %{python3_sitelib}/sphinxcontrib/
- %{python3_sitelib}/sphinxcontrib_devhelp-*
- %changelog
- * Tue Nov 01 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.0.2-4
- - rebuilt with python3-3.11.
- * Sun Aug 16 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.0.2-3
- - initial build for Vine Linux.
- * Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.2-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
- * Mon Jun 01 2020 Charalampos Stratakis <cstratak@redhat.com> - 1.0.2-1
- - Update to 1.0.2 (#1808639)
- * Sat May 23 2020 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-8
- - Rebuilt for Python 3.9
- * Fri May 22 2020 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-7
- - Bootstrap for Python 3.9
- * Thu Jan 30 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-6
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
- * Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-5
- - Rebuilt for Python 3.8.0rc1 (#1748018)
- * Fri Aug 16 2019 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-4
- - Rebuilt for Python 3.8
- * Thu Aug 15 2019 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-3
- - Bootstrap for Python 3.8
- * Fri Jul 26 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
- * Fri Mar 01 2019 Miro Hrončok <mhroncok@redhat.com> - 1.0.1-1
- - Initial package
|