OpenIPMI-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584
  1. %bcond_with systemd
  2. %bcond_without python3
  3. # TODO: uses private copy of libedit, should be modified to use system one
  4. Summary: IPMI (Intelligent Platform Management Interface) library and tools
  5. Summary(ja): IPMI (Intelligent Platform Management Interface) ライブラリおよびツール
  6. Name: OpenIPMI
  7. Version: 2.0.31
  8. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  9. Group: admin-tools
  10. Vendor: Project Vine
  11. Distribution: Vine Linux
  12. License: LGPLv2+ and GPLv2+ or BSD
  13. URL: https://sourceforge.net/projects/openipmi/
  14. Source: https://downloads.sourceforge.net/openipmi/%{name}-%{version}.tar.gz
  15. Source1: openipmi.sysconf
  16. Source2: openipmi.initscript
  17. Source3: openipmigui.desktop
  18. Source4: README.initscript
  19. Source5: openipmi-helper
  20. Source6: ipmi.service
  21. Patch1: 0001-man.patch
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
  23. BuildRequires: desktop-file-utils
  24. BuildRequires: gdbm-devel
  25. BuildRequires: glib2-devel
  26. BuildRequires: readline-devel
  27. BuildRequires: libxcrypt-devel
  28. BuildRequires: ncurses-devel
  29. BuildRequires: net-snmp-devel
  30. BuildRequires: openssl-devel
  31. BuildRequires: perl
  32. BuildRequires: popt-devel
  33. BuildRequires: swig
  34. BuildRequires: tcl
  35. BuildRequires: python-rpm-macros
  36. %if %{with python3}
  37. BuildRequires: python3-devel
  38. BuildRequires: python3-rpm-macros
  39. BuildRequires: python3-tkinter
  40. %else
  41. BuildRequires: python-devel
  42. BuildRequires: python2-rpm-macros
  43. BuildRequires: tkinter
  44. %endif
  45. %if %{with systemd}
  46. BuildRequires: systemd
  47. %{?systemd_requires}
  48. %else
  49. Requires(post): chkconfig
  50. Requires(preun): chkconfig
  51. %endif
  52. # Prevent bogus provides of private libs from perl
  53. %global __provides_exclude_from %{?__provides_exclude_from:%{__provides_exclude_
  54. from}|}^%{perl_vendorarch}/auto/.*\\.so$
  55. %description
  56. The Open IPMI project aims to develop an open code base to allow access to
  57. platform information using Intelligent Platform Management Interface (IPMI).
  58. This package contains the tools of the OpenIPMI project.
  59. %package libs
  60. Summary: The OpenIPMI runtime libraries
  61. Summary(ja): OpenIPMI ランタイムライブラリ
  62. Group: system
  63. %description libs
  64. The OpenIPMI-libs package contains the runtime libraries for shared binaries
  65. and applications.
  66. %package perl
  67. Summary: IPMI Perl language bindings
  68. Summary(ja): IPMI Perl 言語バインディング
  69. Group: programming
  70. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  71. %description perl
  72. The OpenIPMI-perl package contains the Perl language bindings for OpenIPMI.
  73. %if %{with python3}
  74. %package -n python3-openipmi
  75. Summary: IPMI Python3 language bindings
  76. Summary(ja): IPMI Python3 言語バインディング
  77. Group: programming
  78. Requires: python3
  79. Obsoletes: %{name}-python < %{version}-%{release}
  80. Provides: %{name}-python = %{version}-%{release}
  81. %description -n python3-openipmi
  82. The OpenIPMI-python3 package contains the Python3 language bindings for OpenIPMI.
  83. %else
  84. %package python
  85. Summary: IPMI Python language bindings
  86. Summary(ja): IPMI Python 言語バインディング
  87. Group: programming
  88. Requires: python
  89. %description python
  90. The OpenIPMI-python package contains the Python language bindings for OpenIPMI.
  91. %endif
  92. %package devel
  93. Summary: The development environment for the OpenIPMI project
  94. Summary(ja): OpenIPMI の開発キット
  95. Group: programming
  96. Requires: %{name} = %{version}-%{release}
  97. Requires: pkgconfig
  98. %description devel
  99. The OpenIPMI-devel package contains the development libraries and header files
  100. of the OpenIPMI project.
  101. %package gui
  102. Summary: IPMI graphical user interface tool
  103. Summary(ja): IPMI GUI ツール
  104. Group: admin-tools
  105. Requires: tix
  106. Requires: tkinter
  107. %if %{with python3}
  108. Requires: python3-openipmi = %{version}-%{release}
  109. %else
  110. Requires: %{name}-python = %{version}-%{release}
  111. %endif
  112. %description gui
  113. The OpenIPMI-gui package contains the graphical user interface to monitor
  114. and control IPMI-enabled devices.
  115. %debug_package
  116. %prep
  117. %autosetup -p1
  118. %build
  119. %configure \
  120. CFLAGS="-fPIC %{optflags} -z now -fno-strict-aliasing" \
  121. LDFLAGS="%{?__global_ldflags} -Wl,--as-needed" \
  122. --disable-dependency-tracking \
  123. --disable-static \
  124. %if %{with python3}
  125. --with-python=%{__python3} \
  126. --with-pythoninstall=%{python3_sitearch} \
  127. %else
  128. --with-pythoninstall=%{python_sitearch} \
  129. %endif
  130. --with-tcl=no \
  131. --with-tkinter=yes
  132. # get rid of rpath
  133. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  134. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  135. make # not %{?_smp_mflags} safe
  136. %install
  137. rm -rf $RPM_BUILD_ROOT
  138. make install DESTDIR=$RPM_BUILD_ROOT
  139. find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} \;
  140. %if %{with systemd}
  141. install -d %{buildroot}{%{_unitdir},%{_libexecdir}}
  142. install -m 755 %{SOURCE5} %{buildroot}%{_libexecdir}/openipmi-helper
  143. install -m 644 %{SOURCE6} %{buildroot}%{_unitdir}/ipmi.service
  144. %else
  145. install -d ${RPM_BUILD_ROOT}%{_initrddir}
  146. install -m 755 %SOURCE2 ${RPM_BUILD_ROOT}%{_initrddir}/ipmi
  147. %endif
  148. install -d ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig
  149. install -m 644 %SOURCE1 ${RPM_BUILD_ROOT}%{_sysconfdir}/sysconfig/ipmi
  150. install -d %{buildroot}%{_sysconfdir}/modprobe.d
  151. # add missing documentation
  152. echo ".so man1/openipmicmd.1" > %{buildroot}%{_mandir}/man1/ipmicmd.1
  153. echo ".so man1/openipmish.1" > %{buildroot}%{_mandir}/man1/ipmish.1
  154. desktop-file-install --vendor="fedora" --dir=${RPM_BUILD_ROOT}%{_datadir}/applications %{SOURCE3}
  155. install -m 644 %SOURCE4 .
  156. %post
  157. %if %{with systemd}
  158. %systemd_post ipmi.service
  159. %else
  160. /sbin/chkconfig --add ipmi
  161. %endif
  162. %preun
  163. %if %{with systemd}
  164. %systemd_preun ipmi.service
  165. %else
  166. if [ $1 = 0 -o -x /bin/systemctl ]; then
  167. service ipmi stop >/dev/null 2>&1
  168. /sbin/chkconfig --del ipmi
  169. fi
  170. %endif
  171. %postun
  172. %if %{with systemd}
  173. %systemd_postun_with_restart ipmi.service
  174. %else
  175. if [ "$1" -ge "1" ]; then
  176. service ipmi condrestart >/dev/null 2>&1 || :
  177. fi
  178. %endif
  179. %post libs -p /sbin/ldconfig
  180. %postun libs -p /sbin/ldconfig
  181. %clean
  182. rm -rf $RPM_BUILD_ROOT
  183. %files
  184. %defattr(-,root,root)
  185. %license COPYING COPYING.BSD COPYING.LIB
  186. %doc CONFIGURING_FOR_LAN FAQ README README.Force README.MotorolaMXP README.initscript
  187. %config(noreplace) %{_sysconfdir}/ipmi/ipmisim1.emu
  188. %config(noreplace) %{_sysconfdir}/ipmi/lan.conf
  189. %config(noreplace) %{_sysconfdir}/sysconfig/ipmi
  190. %if %{with systemd}
  191. %{_unitdir}/ipmi.service
  192. %{_libexecdir}/openipmi-helper
  193. %else
  194. %{_initrddir}/ipmi
  195. %endif
  196. %{_bindir}/ipmicmd
  197. %{_bindir}/ipmilan
  198. %{_bindir}/ipmish
  199. %{_bindir}/ipmi_sim
  200. %{_bindir}/ipmi_ui
  201. %{_bindir}/openipmicmd
  202. %{_bindir}/openipmish
  203. %{_bindir}/rmcp_ping
  204. %{_bindir}/sdrcomp
  205. %{_bindir}/solterm
  206. %{_bindir}/openipmi_eventd
  207. %{_mandir}/man1/ipmi_*
  208. %{_mandir}/man1/ipmicmd.*
  209. %{_mandir}/man1/ipmish.*
  210. %{_mandir}/man1/openipmicmd*
  211. %{_mandir}/man1/openipmish*
  212. %{_mandir}/man1/rmcp_ping*
  213. %{_mandir}/man1/solterm*
  214. %{_mandir}/man5/ipmi_*
  215. %{_mandir}/man1/openipmi_eventd*
  216. %{_mandir}/man7/ipmi_cmdlang*
  217. %{_mandir}/man7/openipmi_conparms*
  218. %{_mandir}/man8/ipmilan*
  219. %files perl
  220. %defattr(-,root,root)
  221. %attr(644,root,root) %{perl_vendorarch}/OpenIPMI.pm
  222. %{perl_vendorarch}/auto/OpenIPMI/
  223. %if %{with python3}
  224. %files -n python3-openipmi
  225. %defattr(-,root,root)
  226. %{python3_sitearch}/*OpenIPMI*
  227. %else
  228. %files python
  229. %defattr(-,root,root)
  230. %{python_sitearch}/*OpenIPMI*
  231. %endif
  232. %files libs
  233. %defattr(-,root,root)
  234. %{_libdir}/*.so.*
  235. %files devel
  236. %defattr(-,root,root)
  237. %{_includedir}/OpenIPMI
  238. %{_libdir}/*.so
  239. %{_libdir}/pkgconfig/*.pc
  240. %files gui
  241. %defattr(-,root,root)
  242. %{_bindir}/openipmigui
  243. %{_mandir}/man1/openipmigui*
  244. %if %{with python3}
  245. %{python3_sitearch}/openipmigui
  246. %else
  247. %{python_sitearch}/openipmigui
  248. %endif
  249. %{_datadir}/applications/fedora-openipmigui.desktop
  250. %changelog
  251. * Tue Oct 05 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.31-1
  252. - updated to 2.0.31.
  253. * Tue Sep 08 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.29-1
  254. - updated to 2.0.29.
  255. - imported Source5-6 and Patch1 from rawhide.
  256. - added systemd support (disabled as default).
  257. * Mon May 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.27-1
  258. - updated to 2.0.27.
  259. - dropped Patch2 (fixed in upstream).
  260. - added BR:libxcrypt-devel.
  261. - switched to python3.
  262. * Wed Nov 07 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.0.25-1
  263. - updated to 2.0.25.
  264. - dropped Patch1 (fixed in upstream).
  265. - imported Patch2 from rawhide.
  266. - added BR:libedit-devel.
  267. * Fri May 06 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.21-3
  268. - rebuild with openssl-1.0.2
  269. * Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.21-2
  270. - remove *.la files
  271. * Sat Oct 11 2014 Ryoichi INAGAKI <ryo1@toki.waseda.jp> 2.0.21-1
  272. - updated to 2.0.21
  273. - rebuilt with perl-5.16.3
  274. * Wed Mar 07 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-5
  275. - rebuild with net-snmp-5.7.1
  276. * Sun Feb 19 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-4
  277. - rebuild with python-2.7.2
  278. * Sat May 21 2011 IWAI, Masaharu <iwai@alib.jp> 2.0.18-3
  279. - build with perl 5.12.3
  280. - add Vendor and Distribution tags
  281. * Sun Mar 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.18-2
  282. - rebuild with openssl-1.0.0d
  283. * Sat Jul 10 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.18-1
  284. - initial build for Vine Linux
  285. * Tue Jun 01 2010 Marcela Maslanova <mmaslano@redhat.com> - 2.0.18-2
  286. - Mass rebuild with perl-5.12.0
  287. * Wed May 5 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.18-1
  288. - updated to OpenIPMI-2.0.18
  289. - fixed OpenIPMIpthread pkgconfig file (#468067)
  290. * Mon May 3 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.17-1
  291. - updated to OpenIPMI-2.0.17
  292. * Thu Mar 18 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-12
  293. - implemented mandatory 'force-reload' command in ipmi service
  294. * Thu Mar 11 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-11
  295. - rebuild against new gdbm
  296. * Wed Mar 3 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-10
  297. - add README.initscript describing /etc/init.d/ipmi initscript exit codes
  298. (#562151)
  299. * Mon Feb 22 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-9
  300. - fix package License: field, there *are* sources with BSD header
  301. - distribute README files and COPYING in package
  302. * Tue Jan 5 2010 Jan Safranek <jsafrane@redhat.com> - 2.0.16-8
  303. - fix package License: field, there is no source with BSD header
  304. * Mon Dec 7 2009 Stepan Kasal <skasal@redhat.com> - 2.0.16-7
  305. - rebuild against perl 5.10.1
  306. * Tue Dec 1 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-6
  307. - fix package compilation to remove rpmlint errors
  308. * Wed Sep 30 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-5
  309. - rebuilt with new net-snmp
  310. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.16-4
  311. - rebuilt with new openssl
  312. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.16-3
  313. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  314. * Wed Apr 15 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-2
  315. - fix compilation flags, debuginfo package is correctly generated now
  316. * Thu Mar 19 2009 Jan Safranek <jsafrane@redhat.com> - 2.0.16-1
  317. - new upstream release
  318. * Mon Feb 23 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.14-11
  319. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  320. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 2.0.14-10
  321. - rebuild with new openssl
  322. * Thu Dec 11 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-9
  323. - fix linking without rpath, prelink won't screw up the libraries
  324. anymore (#475265)
  325. * Wed Dec 10 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-8
  326. - shorter probe interval is used in init script, making the service startup
  327. quicker in most situations (#475101)
  328. * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 2.0.14-7
  329. - Rebuild for Python 2.6
  330. * Thu Oct 30 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-6
  331. - removed static libraries from the -devel subpackage
  332. - fixed openipmigui.desktop file
  333. * Thu Oct 23 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-5
  334. - fixed typos in the descriptions
  335. - added .desktop file for openipmigui tool
  336. * Mon Oct 20 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-4
  337. - fixed description of the package
  338. * Thu Oct 16 2008 Jan Safranek <jsafrane@redhat.com> - 2.0.14-3
  339. - split ipmitool to separate package
  340. - added 'reload' functionality to init script
  341. - added seraparate -gui subpackage
  342. * Wed Jul 30 2008 Phil Knirsch <pknirsch@redhat.com> - 2.0.14-2
  343. - Fixed rpath problem in libOpenIPMIposix.so.0.0.1
  344. * Tue Jul 29 2008 Phil Knirsch <pknirsch@redhat.com> - 2.0.14-1
  345. - Fixed several specfile problems (#453751)
  346. - Update to OpenIPMI-2.0.14
  347. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.0.13-2
  348. - Autorebuild for GCC 4.3
  349. * Wed Dec 05 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.13-1
  350. - Updated to OpenIPMI-2.0.13
  351. - Rebuild due to new openssl
  352. * Wed Oct 10 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-3
  353. - Added missing perl-devel buildrequires
  354. * Mon Sep 24 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-2
  355. - Added missing popt-devel buildrequires
  356. * Fri Aug 17 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-2
  357. - Fix rebuild problems due to glibc change
  358. - License review and fixes
  359. * Tue Apr 24 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.11-1
  360. - Update to OpenIPMI-2.0.11
  361. * Tue Feb 27 2007 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-8
  362. - Update for ipmitool-1.8.9
  363. * Thu Dec 7 2006 Jeremy Katz <katzj@redhat.com> - 2.0.6-7
  364. - rebuild for python 2.5
  365. * Tue Nov 28 2006 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-6.fc7
  366. - Update due to new net-snmp-5.4
  367. - Some specfile updates
  368. * Tue Jul 18 2006 Phil Knirsch <pknirsch@redhat.com> - 2.0.6-5
  369. - Fixed check for udev in initscript (#197956)
  370. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.0.6-4.1
  371. - rebuild
  372. * Fri Jun 16 2006 Bill Nottingham <notting@redhat.com> 2.0.6-4
  373. - don't include <linux/compiler.h>
  374. * Fri Jun 16 2006 Jon Masters <jcm@redhat.com> 2.0.6-3
  375. - Fix a build requires (needs glibc-kernheaders)
  376. * Thu Jun 15 2006 Jesse Keating <jkeating@redhat.com> 2.0.6-2
  377. - Bump for new glib2
  378. * Tue May 16 2006 Phil Knirsch <pknirsch@redhat.com> 2.0.6-1
  379. - Fixed bug with type conversion in ipmitool (#191091)
  380. - Added python bindings
  381. - Split off perl and python bindings in separate subpackages
  382. - Dropped obsolete patches
  383. - Added missing buildprereq on readline-devel
  384. - Made it install the python bindings properly on 64bit archs
  385. * Mon May 15 2006 Phil Knirsch <pknirsch@redhat.com>
  386. - Updated ipmitool to 1.8.8
  387. - Updated OpenIPMI to 2.0.6
  388. * Fri Feb 17 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-19
  389. - Added missing PreReq for chkconfig
  390. * Mon Feb 13 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.2.1
  391. - rebump for build order issues during double-long bump
  392. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.2
  393. - bump again for double-long bug on ppc(64)
  394. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.4.14-18.1
  395. - rebuilt for new gcc4.1 snapshot and glibc changes
  396. * Mon Feb 06 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-18
  397. - Updated ipmitool to latest upstream version.
  398. - Removed 3 patches for already fixed bugs in latest ipmitool.
  399. - Adapted warning message fix for ipmitool for latest version.
  400. * Tue Jan 24 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-17
  401. - Fixed some minor things in initscripts.
  402. * Mon Jan 09 2006 Phil Knirsch <pknirsch@redhat.com> 1.4.14-16
  403. - Included FRU fix for displaying FRUs with ipmitool
  404. - Included patch for new option to specify a BMC password for IPMI 2.0 sessions
  405. * Tue Jan 03 2006 Radek Vokal <rvokal@redhat.com> 1.4.14-15
  406. - Rebuilt against new libnetsnmp
  407. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  408. - rebuilt
  409. * Wed Nov 23 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-14
  410. - Some more initscript and sysconfig updates from Dell.
  411. * Wed Nov 09 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-13
  412. - Rebuilt to link against latest openssl libs.
  413. - Fixed ipmitool not setting session privilege level (#172312)
  414. * Wed Nov 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-11
  415. - Rebuild to link against new net-snmp libs.
  416. * Tue Oct 11 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-10
  417. - Updated initscript to fix missing redhat-lsb bug (#169901)
  418. * Thu Sep 08 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-9
  419. - Another update to latest initscripts from Dell
  420. - Fixed some missing return statements for non-void functions (#164138)
  421. * Thu Sep 01 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-8
  422. - Updated initscript to latest version from Dell
  423. * Fri Aug 12 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-7
  424. - Fixed the unwanted output of failed module loading of the initscript. Behaves
  425. now like all our other initscripts (#165476)
  426. * Fri Aug 05 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-6
  427. - Fixed build problem on 64bit machines
  428. * Fri Jul 15 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-5
  429. - Fixed missing change to not autostart in the initscript
  430. * Wed Jul 06 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-4
  431. - Made the initscript a replacing configfile
  432. * Mon Jul 04 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-3
  433. - Updated versions of the initscripts and sysconf files
  434. - Fixed typo in preun script and changelog
  435. * Mon Jun 27 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.14-2
  436. - Updated to OpenIPMI-1.4.14
  437. - Split the main package into normal and libs package for multilib support
  438. - Added ipmitool-1.8.2 to OpenIPMI and put it in tools package
  439. - Added sysconf and initscript (#158270)
  440. - Fixed oob subscripts (#149142)
  441. * Wed Mar 30 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-5
  442. - Correctly put libs in the proper packages
  443. * Thu Mar 17 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-4
  444. - gcc4 rebuild fixes
  445. - Added missing gdbm-devel buildprereq
  446. * Wed Mar 02 2005 Phil Knirsch <pknirsch@redhat.com> 1.4.11-3
  447. - bump release and rebuild with gcc 4
  448. * Tue Feb 08 2005 Karsten Hopp <karsten@redhat.de> 1.4.11-2
  449. - update
  450. * Tue Oct 26 2004 Phil Knirsch <pknirsch@redhat.com>
  451. - Initial version