acl-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Name: acl
  3. Summary: Access control list utilities
  4. Version: 2.3.1
  5. Release: 1%{?_dist_release}
  6. Group: system
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: GPLv2+
  10. URL: https://savannah.nongnu.org/projects/acl
  11. Source: http://download.savannah.nongnu.org/releases/acl/acl-%{version}.tar.gz
  12. # avoid permission denied problem with LD_PRELOAD in the test-suite
  13. Patch1: 0001-acl-2.2.53-test-runwrapper.patch
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: gawk
  16. BuildRequires: gettext
  17. BuildRequires: libattr-devel >= 2.4.1
  18. BuildRequires: libtool
  19. Requires: libacl = %{version}-%{release}
  20. %description
  21. This package contains the getfacl and setfacl utilities needed for
  22. manipulating access control lists.
  23. %package -n libacl
  24. Summary: Dynamic library for access control list support
  25. License: LGPLv2+
  26. Group: system
  27. %description -n libacl
  28. This package contains the libacl.so dynamic library which contains
  29. the POSIX 1003.1e draft standard 17 functions for manipulating access
  30. control lists.
  31. %package -n libacl-devel
  32. Summary: Access control list static libraries and headers.
  33. License: LGPLv2+
  34. Group: programming
  35. Requires: libacl = %{version}-%{release}
  36. Requires: libattr-devel
  37. %description -n libacl-devel
  38. This package contains static libraries and header files needed to develop
  39. programs which make use of the access control list programming interface
  40. defined in POSIX 1003.1e draft standard 17.
  41. %if %build_compat32
  42. %package -n compat32-libacl
  43. Summary: Dynamic library for access control list support
  44. License: LGPLv2+
  45. Group: system,legacy
  46. %description -n compat32-libacl
  47. This package contains the libacl.so dynamic library which contains
  48. the POSIX 1003.1e draft standard 17 functions for manipulating access
  49. control lists.
  50. %endif
  51. %debug_package
  52. %prep
  53. %setup -q
  54. %autopatch -p1
  55. %build
  56. touch .census
  57. # acl abuses libexecdir
  58. %configure --libdir=/%{_lib} --libexecdir=%{_libdir}
  59. %make_build
  60. %install
  61. rm -rf %{buildroot}
  62. %make_install
  63. mv -f %{buildroot}%{_datadir}/doc/acl ./doc-nover
  64. # get rid of libacl.a and libacl.la
  65. rm -f %{buildroot}/%{_lib}/libacl.{a,la}
  66. rm -f %{buildroot}%{_libdir}/libacl.{a,la}
  67. # fix links to shared libs and permissions
  68. rm -f %{buildroot}%{_libdir}/libacl.so
  69. mkdir -p %{buildroot}%{_libdir}
  70. ln -sf ../../%{_lib}/libacl.so %{buildroot}%{_libdir}/libacl.so
  71. chmod 0755 %{buildroot}/%{_lib}/libacl.so.*.*.*
  72. # drop already installed documentation, we will use an RPM macro to install it
  73. rm -rf $RPM_BUILD_ROOT%{_docdir}/%{name}*
  74. mv -f %{buildroot}/%{_lib}/pkgconfig %{buildroot}%{_libdir}/
  75. %find_lang %{name}
  76. %check
  77. if ./setfacl/setfacl -m u:`id -u`:rwx .; then
  78. make tests || exit $?
  79. if test 0 = `id -u`; then
  80. make root-tests || exit $?
  81. fi
  82. else
  83. echo '*** ACLs are probably not supported by the file system,' \
  84. 'the test-suite will NOT run ***'
  85. fi
  86. %clean
  87. rm -rf %{buildroot}
  88. %files -f %{name}.lang
  89. %defattr(-,root,root)
  90. %doc doc-nover/*
  91. %{_bindir}/chacl
  92. %{_bindir}/getfacl
  93. %{_bindir}/setfacl
  94. %{_mandir}/man1/chacl.1*
  95. %{_mandir}/man1/getfacl.1*
  96. %{_mandir}/man1/setfacl.1*
  97. %{_mandir}/man5/acl.5*
  98. %files -n libacl-devel
  99. %defattr(-,root,root)
  100. /%{_lib}/libacl.so
  101. %{_includedir}/acl
  102. %{_includedir}/sys/acl.h
  103. %{_libdir}/libacl.*
  104. %{_libdir}/pkgconfig/*.pc
  105. %{_mandir}/man3/acl_*
  106. %files -n libacl
  107. %defattr(-,root,root)
  108. /%{_lib}/libacl.so.*
  109. %if %build_compat32
  110. %files -n compat32-libacl
  111. %defattr(-,root,root,-)
  112. /%{_lib}/libacl.so.*
  113. %endif
  114. %changelog
  115. * Wed Oct 26 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.3.1-1
  116. - new upstream release.
  117. * Wed Mar 10 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.53-2
  118. - dropped scriptlets.
  119. * Sun May 19 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.53-1
  120. - new upstream release.
  121. - dropped all patches: fixed in upstream.
  122. * Thu Apr 16 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.52-2
  123. - added compat32 package.
  124. * Fri Jul 4 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.2.52-1
  125. - new upstream release.
  126. - replaced patches to the newest rawhide's.
  127. * Sat Apr 09 2011 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.2.49-1
  128. - updated to 2.2.49
  129. - added Patch2-7 from Fedora
  130. * Wed Apr 06 2011 Kamil Dudka <kdudka@redhat.com> 2.2.49-11
  131. - add function acl_extended_file_nofollow() (#692982)
  132. * Tue Mar 29 2011 Kamil Dudka <kdudka@redhat.com> 2.2.49-10
  133. - fix typos in setfacl(1) man page (#675451)
  134. * Thu Jul 08 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-8
  135. - remove dependency of libacl-devel on nfs-utils-lib and openldap
  136. * Tue May 25 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-7
  137. - let acl depend on the same version of libacl (#595674)
  138. * Wed Mar 24 2010 Kamil Dudka <kdudka@redhat.com> 2.2.49-6
  139. - prevent setfacl --restore from SIGSEGV on malformed restore file (#576550)
  140. * Mon Jun 30 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 2.2.47-2
  141. - initial build for Vine Linux
  142. * Tue Feb 12 2008 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.47-1
  143. - new upstream version
  144. * Mon Jan 28 2008 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.45-3
  145. - Fixed segfault when using only "--" as parameter
  146. - Resolves: #430458
  147. * Wed Nov 7 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.45-2
  148. - Fixed setfacl exitcodes
  149. - Resolves: #368451
  150. * Wed Oct 31 2007 Jiri Moskovcak <jmoskovc@redhat.com> - 2.2.45-1
  151. - New version
  152. - dropped walk patch
  153. * Thu Sep 20 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-10
  154. - Rewriten path_max patch to support long UTF8 names
  155. - Resolves #287701, #183181
  156. * Fri Aug 31 2007 Steve Dickson <steved@redhat.com> - 2.2.39-9
  157. - Removed NFS4 ACL patch since it was rejected by upstream.
  158. * Thu Aug 30 2007 Jeremy Katz <katzj@redhat.com> - 2.2.39-8
  159. - disable nfs patch; linking libacl against libs in /usr will lead to breakage
  160. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.2.39-7
  161. - Build Require gawk
  162. * Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 2.2.39-6
  163. - Rebuild for selinux ppc32 issue.
  164. * Mon Aug 27 2007 Steve Dickson <steved@redhat.com> 2.2.39-5
  165. - Added NFS v4 ACL support
  166. * Thu Jul 26 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-4.1
  167. - Updated man page for getfacl
  168. * Wed Jul 25 2007 Jiri Moskovcak <jmoskovc@redhat.com> 2.2.39-4
  169. - Added support fort short params to getfacl
  170. - Resolves: #204087
  171. * Wed Mar 21 2007 Thomas Woerner <twoerner@redhat.com> 2.2.39-3.1
  172. - new improved walk patch with fixed getfacl exit code (rhbz#232884)
  173. * Fri Feb 23 2007 Karsten Hopp <karsten@redhat.com> 2.2.39-3
  174. - fix buildroot
  175. - remove trailing dot from summary
  176. - -devel requires same version of libacl
  177. - escape macro in changelog
  178. - make .so symlink relative
  179. * Thu Feb 22 2007 Steve Grubb <sgrubb@redhat.com> 2.2.39-2
  180. - Apply patch to make order consistent.
  181. * Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 2.2.39-1.1
  182. - rebuild
  183. * Wed Jul 5 2006 Thomas Woerner <twoerner@redhat.com> 2.2.39-1
  184. - new version 2.2.39
  185. - fixed usage of long UTF-8 filenames (#183181)
  186. Thanks to Andrey for the initial patch.
  187. * Wed Jun 7 2006 Jeremy Katz <katzj@redhat.com> - 2.2.34-2
  188. - rebuild for -devel deps
  189. * Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 2.2.34-1.2
  190. - bump again for double-long bug on ppc(64)
  191. * Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 2.2.34-1.1
  192. - rebuilt for new gcc4.1 snapshot and glibc changes
  193. * Fri Feb 3 2006 Thomas Woerner <twoerner@redhat.com> 2.2.34-1
  194. - new version 2.2.34
  195. * Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
  196. - rebuilt
  197. * Tue Dec 6 2005 Thomas Woerner <twoerner@redhat.com> 2.2.32-2.1
  198. - fixed permissions of libacl
  199. * Tue Dec 6 2005 Thomas Woerner <twoerner@redhat.com> 2.2.32-2
  200. - spec file cleanup
  201. - mark po files as lang specific
  202. * Sun Nov 06 2005 Florian La Roche <laroche@redhat.com>
  203. - 2.2.32
  204. * Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.2.31-1
  205. - update to 2.2.31
  206. * Wed Sep 28 2005 Than Ngo <than@redhat.com> 2.2.23-9
  207. - get rid of *.la files
  208. - remove duplicate doc files
  209. * Wed Feb 9 2005 Stephen C. Tweedie <sct@redhat.com> 2.2.23-6
  210. - Rebuild
  211. * Thu Sep 16 2004 Jeremy Katz <katzj@redhat.com> - 2.2.23-5
  212. - make the libs executable so that we find their dependencies (#132696)
  213. * Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.23-4
  214. - libacl-devel Requires: libattr-devel for libattr.la
  215. * Fri Sep 10 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.23-3
  216. - Requires libtool >= 1.5 for building
  217. * Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.2.23-2
  218. - Make libacl.so.* executable.
  219. * Thu Aug 19 2004 Phil Knirsch <pknirsch@redhat.com> 2.2.23-1
  220. - Update to latest upstream version.
  221. * Sun Aug 8 2004 Alan Cox <alan@redhat.com> 2.2.7-7
  222. - Close bug #125300 (Steve Grubb: build requires libtool,gettext)
  223. * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
  224. - rebuilt
  225. * Wed Mar 31 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.7-5
  226. - Add missing %%defattr
  227. * Tue Mar 30 2004 Stephen C. Tweedie <sct@redhat.com> 2.2.7-3
  228. - Add /usr/include/acl to files manifest
  229. - Fix location of doc files, add main doc dir to files manifest
  230. * Tue Mar 02 2004 Elliot Lee <sopwith@redhat.com>
  231. - rebuilt
  232. * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
  233. - rebuilt
  234. * Tue Aug 5 2003 Elliot Lee <sopwith@redhat.com> 2.2.7-2
  235. - Fix libtool invocation
  236. * Tue Jun 3 2003 Stephen C. Tweedie <sct@redhat.com> 2.2.7-1
  237. - Update to acl-2.2.7
  238. * Wed Mar 26 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.3-2
  239. - include patch from Jay Berkenbilt to print better error messages
  240. * Tue Jan 28 2003 Michael K. Johnson <johnsonm@redhat.com> 2.2.3-1
  241. - udpate/rebuild
  242. * Sat Jan 4 2003 Jeff Johnson <jbj@redhat.com> 2.0.11-7
  243. - set execute bits on library so that requires are generated.
  244. * Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-5
  245. - Correct patch in previous fix so that shared libraries go in /lib*
  246. instead of /usr/lib*
  247. * Tue Nov 19 2002 Elliot Lee <sopwith@redhat.com> 2.0.11-4
  248. - Fix multilibbing
  249. * Wed Sep 11 2002 Than Ngo <than@redhat.com> 2.0.11-3
  250. - Added fix to install libs in correct directory on 64bit machine
  251. * Thu Aug 08 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.11-2
  252. - Made the package only own the one directory that is unique to it:
  253. /usr/include/acl
  254. * Mon Jun 24 2002 Michael K. Johnson <johnsonm@redhat.com> 2.0.11-1
  255. - Initial Red Hat package
  256. Made as few changes as possible relative to upstream packaging to
  257. make it easier to maintain long-term. This means that some of
  258. the techniques used here are definitely not standard Red Hat
  259. techniques. If you are looking for an example package to fit
  260. into Red Hat Linux transparently, this would not be the one to
  261. pick.
  262. - acl-devel -> libacl-devel