arpack-vl.spec 2.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117
  1. %define pkg_name arpack
  2. %define pkg_version 3.7.0
  3. %define pkg_release 1%{?_dist_release}
  4. Summary: A collection of Fortran77 subroutines designed to solve large scale eigenvalue problems
  5. Name: %{pkg_name}
  6. Version: %{pkg_version}
  7. Release: %{pkg_release}
  8. License: BSD Software License
  9. Group: System Environment/Libraries
  10. URL: https://github.com/opencollab/arpack-ng
  11. Source0: %{name}-ng-%{version}.tar.gz
  12. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  13. BuildRequires: cmake
  14. BuildRequires: gcc-gfortran
  15. BuildRequires: blas-devel lapack-devel
  16. Requires: blas lapack
  17. Vendor: Project Vine
  18. Distribution: Vine Linux
  19. Packager: ara_t
  20. %description
  21. ARPACK-NG is a collection of Fortran77 subroutines designed to solve
  22. large scale eigenvalue problems.
  23. Important Features:
  24. * Reverse Communication Interface.
  25. * Single and Double Precision Real Arithmetic Versions for Symmetric,
  26. Non-symmetric, Standard or Generalized Problems.
  27. * Single and Double Precision Complex Arithmetic Versions for Standard or
  28. Generalized Problems.
  29. * Routines for Banded Matrices - Standard or Generalized Problems.
  30. * Routines for The Singular Value Decomposition.
  31. * Example driver routines that may be used as templates to implement numerous
  32. Shift-Invert strategies for all problem types, data types and precision.
  33. This project is a joint project between Debian, Octave and Scilab in order to
  34. provide a common and maintained version of arpack.
  35. %package devel
  36. Summary: Header files for arpack library
  37. Summary(ja): arpack ライブラリのヘッダファイル
  38. Group: Development/Libraries
  39. Requires: %{name} = %{version}-%{release}
  40. %description devel
  41. Header files for %{name} library.
  42. %description devel -l ja
  43. %{name}のヘッダーファイル
  44. %prep
  45. %{__rm} -rf ${RPM_BUILD_ROOT}
  46. %setup -q -n %{name}-ng-%{version}
  47. %build
  48. ./bootstrap
  49. %{configure} \
  50. --enable-shared \
  51. --disable-static
  52. %{__make}
  53. %install
  54. %{make_install}
  55. %{__rm} ${RPM_BUILD_ROOT}%{_libdir}/*.la
  56. %clean
  57. %{__rm} -rf ${RPM_BUILD_ROOT}
  58. %post -p %{_syssbindir}/ldconfig
  59. %postun -p %{_syssbindir}/ldconfig
  60. %files
  61. %defattr(-,root,root)
  62. %doc CHANGES COPYING README.md TODO
  63. %doc DOCUMENTS EXAMPLES
  64. %{_libdir}/libarpack.so.*
  65. %files devel
  66. %defattr(-,root,root)
  67. %{_includedir}/
  68. %{_libdir}/libarpack.so
  69. %{_libdir}/pkgconfig/arpack.pc
  70. %changelog
  71. * Fri Jan 25 2019 Toshiaki Ara <ara_t@384.jp> 3.7.0-1
  72. - update to 3.7.0
  73. * Wed Sep 19 2018 Toshiaki Ara <ara_t@384.jp> 3.6.3-1
  74. - update to 3.6.3
  75. * Wed Aug 08 2018 Toshiaki Ara <ara_t@384.jp> 3.6.2-1
  76. - update to 3.6.2
  77. * Wed Jun 06 2018 Toshiaki Ara <ara_t@384.jp> 3.6.0-1
  78. - update to 3.6.0
  79. - separate subpackage arpack-devel
  80. * Thu Jul 28 2016 Toshiaki Ara <ara_t@384.jp> 3.4.0-1
  81. - update to 3.4.0 for VineSeed
  82. - add BuildRequires: cmake
  83. * Mon Apr 11 2016 Toshiaki Ara <ara_t@384.jp> 3.2.0-2
  84. - correct SPEC file
  85. * Sat Mar 19 2016 Toshiaki Ara <ara_t@384.jp> 3.2.0-1
  86. - new package