auto-complete-mode-vl.spec 3.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123
  1. %define _noVersionedDependencies 1
  2. %define prereq_ge() %(LC_ALL="C" rpm -q --queryformat 'Requires(post)::%%{NAME} >= %%{VERSION}' %1| grep -v "is not")
  3. %define origname auto-complete
  4. %define origver 1.3.1
  5. Summary: The most intelligent auto-completion extension for GNU Emacs
  6. Summary(ja): GNU Emacs のための最も賢い自動補完機能
  7. Name: %{origname}-mode
  8. Version: %{origver}
  9. Release: 1%{?_dist_release}
  10. Source0: http://cx4a.org/pub/auto-complete/auto-complete-%{version}.tar.bz2
  11. Source1: %{origname}-install.sh
  12. Source2: %{origname}-remove.sh
  13. Source3: vine-default-%{origname}.el.in
  14. Source4: %{origname}-init.el
  15. License: GPLv3
  16. Group: Applications/Editors/Emacs
  17. URL: http://cx4a.org/software/auto-complete/
  18. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  19. BuildArch: noarch
  20. Requires: emacsen
  21. Requires(post): emacsen
  22. #%prereq_ge emacsen-common
  23. Distribution: Vine Linux
  24. Vendor: Project Vine
  25. Packager: munepi
  26. %description
  27. Auto Complete Mode is the most intelligent auto-completion extension for GNU
  28. Emacs. Auto Complete Mode renews an old completion interface and provides an
  29. environment that makes users could be more concentrate on their own works.
  30. Features
  31. * Visual interface
  32. * Reduce overhead of completion by using statistic method
  33. * Extensibility
  34. %description -l ja
  35. Auto Complete ModeはGNU Emacsのための最も賢い自動補完機能です。
  36. 従来の使いづらい補完インターフェースを一新し、
  37. ユーザーがより本質的な作業に集中できる環境を提供します。
  38. 特徴
  39. * 視覚的な操作感
  40. * 統計的手法による補完オーバーヘッドの削減
  41. * 拡張性
  42. %prep
  43. %setup -q -n %{origname}-%{origver}
  44. %build
  45. %install
  46. [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
  47. [ "%{buildroot}" != "/" ] && mkdir -p %{buildroot}
  48. %__mkdir_p %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
  49. %__mkdir_p %{buildroot}%{emacsen_pkgdir}/install
  50. %__mkdir_p %{buildroot}%{emacsen_pkgdir}/remove
  51. #
  52. # install el files
  53. #
  54. %__cp -p *.el %{SOURCE3} %{SOURCE4} %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}
  55. %__cp -ra dict %{buildroot}%{_datadir}/emacs/site-lisp/%{origname}/ac-dict || exit 1
  56. #
  57. # install script (bytecompile el and install elc , remove)
  58. #
  59. %_installemacsenscript %{origname} %{SOURCE1}
  60. %_removeemacsenscript %{origname} %{SOURCE2}
  61. %clean
  62. [ "%{buildroot}" != "/" ] && %__rm -rf %{buildroot}
  63. %post
  64. #
  65. # bytecompile and install
  66. #
  67. if [ "$1" = 2 ]; then
  68. %_emacsenPackageRemove %{origname}
  69. fi
  70. %_addemacsenlist %{origname}
  71. %_emacsenPackageInstall %{origname}
  72. %preun
  73. if [ "$1" = 0 ]; then
  74. %_emacsenPackageRemove %{origname}
  75. %_removeemacsenlist %{origname}
  76. fi
  77. %files
  78. %defattr(-,root,root)
  79. %doc COPYING.FDL.txt COPYING.GPLv3.txt README.txt TODO.txt
  80. %doc doc etc
  81. %{_datadir}/emacs/site-lisp/%{origname}
  82. %{emacsen_pkgdir}/install/%{origname}
  83. %{emacsen_pkgdir}/remove/%{origname}
  84. %changelog
  85. * Thu Aug 25 2011 Munehiro Yamamoto <munepi@vinelinux.org> 1.3.1-1
  86. - first release for Vine Linux