bootparamd-vl.spec 5.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192
  1. Summary: A server process which provides boot information to diskless clients.
  2. Summary(ja): ディスクレスクライアントに起動情報を提供するサーバプロセス
  3. Name: bootparamd
  4. Version: 0.17
  5. Release: 16%{?_dist_release}
  6. License: BSD
  7. Group: System Environment/Daemons
  8. Source: ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/netkit-%{name}-%{version}.tar.gz
  9. Source1: bootparamd.init
  10. Patch0: bootparamd-manpage-63567.patch
  11. Patch1: bootparamd-resolver.patch
  12. Patch2: bootparamd-debug.patch
  13. Patch3: bootparamd.fast-dns.patch
  14. Patch4: bootparamd-resolver-fix.patch
  15. Patch5: bootparamd-get-router.patch
  16. Patch6: bootparamd-err.patch
  17. Patch7: bootparamd-byteorder.patch
  18. #PreReq: /sbin/chkconfig /sbin/init.d
  19. Requires(post): /sbin/chkconfig
  20. Requires(preun): /sbin/chkconfig
  21. Requires: portmap
  22. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  23. %description
  24. The bootparamd process provides bootparamd, a server process which
  25. provides the information needed by diskless clients in order for them
  26. to successfully boot. Bootparamd looks first in /etc/bootparams for an
  27. entry for that particular client; if a local bootparams file doesn't
  28. exist, it looks at the appropriate Network Information Service (NIS)
  29. map. Some network boot loaders (notably Sun's) rely on special boot
  30. server code on the server, in addition to the RARP and TFTP servers.
  31. This bootparamd server process is compatible with SunOS bootparam clients
  32. and servers which need that boot server code.
  33. You should install bootparamd if you need to provide boot information to
  34. diskless clients on your network.
  35. %description -l ja
  36. bootparamd はディスクレスクライアントが正しく起動する為の情報を
  37. 提供するサーバプロセスです.bootparamd は最初に /etc/bootparams を
  38. 見て特定のクライアントの情報を探します./etc/bootparams がなければ
  39. NIS (Network Information Service) のマップを探します.
  40. ネットワークブートローダの中には (特に Sun のものが) RARP や TFTP
  41. サーバに加えて特別なブートサーバを必要とします.この bootparamd サーバは
  42. SunOS の bootparam クライアント/サーバと互換性があります.
  43. ネットワーク上のディスクレスクライアントに起動情報を提供する必要が
  44. ある場合は bootparamd パッケージをインストールして下さい.
  45. %prep
  46. %setup -q -n netkit-%{name}-%{version}
  47. %patch0 -p1
  48. %patch1 -p1
  49. %patch2 -p1 -b .unblocksignals
  50. %patch3 -p1
  51. %patch4 -p1
  52. %patch5 -p1 -b .router
  53. %patch6 -p1 -b .err
  54. %patch7 -p1 -b .byteorder
  55. %build
  56. sh configure --with-c-compiler=gcc
  57. perl -pi -e '
  58. s,^CC=.*$,CC=cc,;
  59. s,-O2,\$(RPM_OPT_FLAGS) -D_BSD_SOURCE \$(f_PIE),;
  60. s,^BINDIR=.*$,BINDIR=%{_bindir},;
  61. s,^MANDIR=.*$,MANDIR=%{_mandir},;
  62. s,^SBINDIR=.*$,SBINDIR=%{_sbindir},;
  63. ' MCONFIG
  64. %ifarch s390 s390x
  65. export f_PIE="-fPIE"
  66. %else
  67. export f_PIE="-fpie"
  68. %endif
  69. make %{?_smp_mflags}
  70. %install
  71. rm -rf %{buildroot}
  72. mkdir -p %{buildroot}%{_bindir}
  73. mkdir -p %{buildroot}%{_mandir}/man{1,8}
  74. mkdir -p %{buildroot}%{_sbindir}
  75. mkdir -p %{buildroot}%{_initdir}
  76. make INSTALLROOT=%{buildroot} install
  77. install -m 755 %{SOURCE1} %{buildroot}%{_initdir}/bootparamd
  78. %clean
  79. rm -rf %{buildroot}
  80. %post
  81. /sbin/chkconfig --add bootparamd
  82. %preun
  83. if [ $1 = 0 ]; then
  84. /sbin/chkconfig --del bootparamd
  85. fi
  86. %files
  87. %defattr(-,root,root)
  88. %{_sbindir}/rpc.bootparamd
  89. %{_bindir}/callbootd
  90. %{_mandir}/man8/rpc.bootparamd.*
  91. %{_mandir}/man8/bootparamd.*
  92. %config %{_initdir}/bootparamd
  93. %changelog
  94. * Sat Mar 24 2012 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.17-16
  95. - updated to 0.17 release
  96. - import Patch1-7 from Fedora
  97. * Fri Sep 19 2008 Shu KONNO <owa@bg.wakwak.com> 0.17-15vl5
  98. - applied new versioning policy, spec in utf-8
  99. * Thu Jul 3 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.17-14vl1
  100. - based on Redhat Rawhide 0.17-14
  101. - rebuild with new toolchains
  102. - s/Copyright/License/
  103. * Wed Jan 10 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
  104. - 0.17-5vl3
  105. - use better macros (%%{_initdir})
  106. - added Japanese summary and description
  107. - rebuilt with newer %%{_mandir} definition
  108. * Tue Dec 12 2000 Daisuke SUZUKI <daisuke@linux.or.jp> 0.17-5vl2
  109. - remove /etc/init.d from PreReq
  110. * Sun Nov 19 2000 Satoshi MACHINO <machino@vinelinux.org> 0.17-5vl1
  111. - build on Vine Linux with gcc-2.95.3
  112. * Sat Aug 05 2000 Bill Nottingham <notting@redhat.com>
  113. - condrestart fixes
  114. * Sat Jul 15 2000 Bill Nottingham <notting@redhat.com>
  115. - move initscript back
  116. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  117. - automatic rebuild
  118. * Mon Jul 10 2000 Preston Brown <pbrown@redhat.com>
  119. - move initscript
  120. * Sun Jun 18 2000 Matt Wilson <msw@redhat.com>
  121. - FHS packaging
  122. - 0.17
  123. * Thu Feb 03 2000 Erik Troan <ewt@redhat.com>
  124. - gzipped man pages
  125. * Tue Dec 21 1999 Jeff Johnson <jbj@redhat.com>
  126. - update to 0.16.
  127. * Fri Sep 25 1999 Bill Nottingham <notting@redhat.com>
  128. - *sigh*.
  129. * Mon Aug 16 1999 Bill Nottingham <notting@redhat.com>
  130. - initrscript munging
  131. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  132. - auto rebuild in the new build environment (release 22)
  133. * Mon Mar 15 1999 Jeff Johnson <jbj@redhat.com>
  134. - compile for 6.0
  135. * Mon Jun 29 1998 Jeff Johnson <jbj@redhat.com>
  136. - removed triggerpostun.
  137. * Fri May 01 1998 Jeff Johnson <jbj@redhat.com>
  138. - added triggerpostun
  139. * Wed Apr 22 1998 Michael K. Johnson <johnsonm@redhat.com>
  140. - enhanced initscript
  141. * Thu Jan 08 1998 Erik Troan <ewt@redhat.com>
  142. - updated initscript to include functions
  143. - fixed 'stop' action of initscript
  144. - added requirement for portmap
  145. * Sun Oct 19 1997 Erik Troan <ewt@redhat.com>
  146. - added an initscript
  147. * Tue Jul 15 1997 Erik Troan <ewt@redhat.com>
  148. - initial build