brotli-vl.spec 5.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186
  1. %bcond_with test
  2. Summary: Lossless compression algorithm
  3. Summary(ja): ロスレス圧縮アルゴリズム
  4. Name: brotli
  5. Version: 1.1.0
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: MIT
  11. URL: https://github.com/google/brotli
  12. Source0: https://github.com/google/brotli/archive/v%{version}.tar.gz
  13. BuildRequires: cmake
  14. BuildRequires: python3-devel python-rpm-macros python3-rpm-macros
  15. %description
  16. Brotli is a generic-purpose lossless compression algorithm that compresses
  17. data using a combination of a modern variant of the LZ77 algorithm, Huffman
  18. coding and 2nd order context modeling, with a compression ratio comparable
  19. to the best currently available general-purpose compression methods.
  20. It is similar in speed with deflate but offers more dense compression.
  21. %package -n python3-%{name}
  22. Summary: Lossless compression algorithm (python 3)
  23. Group: programming
  24. %{?python_provide:%python_provide python3-%{name}}
  25. Requires: python3
  26. %description -n python3-%{name}
  27. Brotli is a generic-purpose lossless compression algorithm that compresses
  28. data using a combination of a modern variant of the LZ77 algorithm, Huffman
  29. coding and 2nd order context modeling, with a compression ratio comparable
  30. to the best currently available general-purpose compression methods.
  31. It is similar in speed with deflate but offers more dense compression.
  32. This package installs a Python 3 module.
  33. %package -n %{name}-devel
  34. Summary: Lossless compression algorithm (development files)
  35. Group: programming
  36. Requires: %{name}%{?_isa} = %{version}-%{release}
  37. %description -n %{name}-devel
  38. Brotli is a generic-purpose lossless compression algorithm that compresses
  39. data using a combination of a modern variant of the LZ77 algorithm, Huffman
  40. coding and 2nd order context modeling, with a compression ratio comparable
  41. to the best currently available general-purpose compression methods.
  42. It is similar in speed with deflate but offers more dense compression.
  43. This package installs the development files
  44. %debug_package
  45. %prep
  46. %autosetup -p1
  47. # fix permissions for -debuginfo
  48. # rpmlint will complain if I create an extra %%files section for
  49. # -debuginfo for this so we'll put it here instead
  50. %{__chmod} 644 c/enc/*.[ch]
  51. %{__chmod} 644 c/include/brotli/*.h
  52. %{__chmod} 644 c/tools/brotli.c
  53. %build
  54. %cmake \
  55. -DCMAKE_INSTALL_PREFIX="%{_prefix}" \
  56. -DCMAKE_INSTALL_LIBDIR="%{_libdir}"
  57. %cmake_build
  58. %py3_build
  59. %install
  60. %cmake_install
  61. %py3_install
  62. %{__install} -dm755 "%{buildroot}%{_mandir}/man3"
  63. cd docs
  64. for i in *.3;do
  65. %{__install} -m644 "$i" "%{buildroot}%{_mandir}/man3/${i}brotli"
  66. done
  67. %if %{with test}
  68. %check
  69. %ctest
  70. %{__python3} setup.py test
  71. %endif
  72. %files
  73. %license LICENSE
  74. %{_bindir}/brotli
  75. %{_libdir}/*.so.*
  76. # Note that there is no %%files section for the unversioned python module
  77. # if we are building for several python runtimes
  78. %files -n python3-%{name}
  79. %license LICENSE
  80. %{python3_sitearch}/*
  81. %files -n %{name}-devel
  82. %{_includedir}/*
  83. %{_libdir}/*.so
  84. %{_libdir}/pkgconfig/*
  85. %{_mandir}/man3/*
  86. %changelog
  87. * Thu Aug 31 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.1.0-1
  88. - new upstream release.
  89. - dropped Patch0: fixed in upstream.
  90. * Fri Apr 02 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.9-2
  91. - imported Patch0 from upstream to fix *.pc.
  92. - dropped ldconfig scriptlets.
  93. * Tue Sep 22 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.9-1
  94. - new upstream release.
  95. * Mon Aug 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.0.7-5
  96. - rebuilt with python-3.8.
  97. * Tue Aug 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.0.7-4
  98. - rebuilt with current environment.
  99. * Thu Jan 03 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.0.7-3
  100. - initial build for Vine Linux.
  101. * Sun Dec 09 2018 Miro Hrončok <mhroncok@redhat.com> - 1.0.7-2
  102. - Remove last python2 bits
  103. * Wed Nov 28 2018 Travis Kendrick pouar@pouar.net> - 1.0.7-1
  104. - Update to 1.0.7
  105. * Wed Nov 28 2018 Travis Kendrick pouar@pouar.net> - 1.0.5-2
  106. - remove Python 2 support https://fedoraproject.org/wiki/Changes/Mass_Python_2_Package_Removal
  107. * Fri Jul 13 2018 Travis Kendrick pouar@pouar.net> - 1.0.5-1
  108. - update to 1.0.5
  109. * Thu Jul 12 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.4-4
  110. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  111. * Mon Jun 18 2018 Miro Hrončok <mhroncok@redhat.com> - 1.0.4-3
  112. - Rebuilt for Python 3.7
  113. * Wed Apr 18 2018 Travis Kendrick pouar@pouar.net> - 1.0.4-2
  114. - update to 1.0.4
  115. * Sat Mar 03 2018 Travis Kendrick <pouar@pouar.net> - 1.0.3-1
  116. - update to 1.0.3
  117. * Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0.1-3
  118. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  119. * Sat Feb 03 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 1.0.1-2
  120. - Switch to %%ldconfig_scriptlets
  121. * Fri Sep 22 2017 Travis Kendrick <pouar@pouar.net> - 1.0.1-1
  122. - update to 1.0.1
  123. * Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.0-6
  124. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  125. * Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.0-5
  126. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  127. * Tue May 23 2017 Travis Kendrick <pouar@pouar.net> - 0.6.0-4
  128. - add man pages
  129. * Sun May 14 2017 Travis Kendrick <pouar@pouar.net> - 0.6.0-3
  130. - wrong directory for ctest
  131. - LICENSE not needed in -devel
  132. - fix "spurious-executable-perm"
  133. - rpmbuild does the cleaning for us, so 'rm -rf %%{buildroot}' isn't needed
  134. * Sat May 13 2017 Travis Kendrick <pouar@pouar.net> - 0.6.0-2
  135. - include libraries and development files
  136. * Sat May 06 2017 Travis Kendrick <pouar@pouar.net> - 0.6.0-1
  137. - Initial build