cairo-vl.spec 13 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438
  1. %bcond_with check
  2. Summary: Cairo - multi-platform 2D graphics library.
  3. Summary(ja): Cairo - マルチプラットフォーム 2D グラフィックスライブラリ
  4. Name: cairo
  5. Version: 1.18.0
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. License: LGPL/MPL
  11. URL: https://cairographics.org/
  12. %define shortver %(echo %{version} | cut -d. -f1-2)
  13. Source0: https://www.cairographics.org/releases/%{name}-%{version}.tar.xz
  14. Patch1: cairo-multilib.patch
  15. # security fixes
  16. # none
  17. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  18. BuildRequires: meson
  19. BuildRequires: pkgconfig
  20. BuildRequires: expat-devel
  21. BuildRequires: pixman-devel
  22. BuildRequires: freetype2-devel
  23. BuildRequires: fontconfig-devel
  24. BuildRequires: glib2-devel
  25. BuildRequires: libpng-devel
  26. BuildRequires: librsvg2-devel
  27. BuildRequires: libX11-devel
  28. BuildRequires: libXrender-devel
  29. BuildRequires: gtk-doc
  30. BuildRequires: mesa-libGL-devel
  31. BuildRequires: mesa-libEGL-devel
  32. BuildConflicts: XOrg-compat70-devel
  33. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  34. %description
  35. Cairo provides anti-aliased vector-based rendering for X. Paths
  36. consist of line segments and cubic splines and can be rendered at any
  37. width with various join and cap styles. All colors may be specified
  38. with optional translucence (opacity/alpha) and combined using the
  39. extended Porter/Duff compositing algebra as found in the X Render
  40. Extension.
  41. Cairo exports a stateful rendering API similar in spirit to the path
  42. construction, text, and painting operators of PostScript, (with the
  43. significant addition of translucence in the imaging model). When
  44. complete, the API is intended to support the complete imaging model of
  45. PDF 1.4.
  46. Cairo relies on the Xc library for backend rendering. Xc provides an
  47. abstract interface for rendering to multiple target types. As of this
  48. writing, Xc allows Cairo to target X drawables as well as generic
  49. image buffers. Future backends such as PostScript, PDF, and perhaps
  50. OpenGL are currently being planned.
  51. %package -n compat32-%{name}
  52. Summary: Cairo - multi-platform 2D graphics library.
  53. Summary(ja): Cairo - マルチプラットフォーム 2D グラフィックスライブラリ
  54. Group: system,legacy
  55. Requires: %{name} = %{version}
  56. %description -n compat32-%{name}
  57. Cairo provides anti-aliased vector-based rendering for X. Paths
  58. consist of line segments and cubic splines and can be rendered at any
  59. width with various join and cap styles. All colors may be specified
  60. with optional translucence (opacity/alpha) and combined using the
  61. extended Porter/Duff compositing algebra as found in the X Render
  62. Extension.
  63. Cairo exports a stateful rendering API similar in spirit to the path
  64. construction, text, and painting operators of PostScript, (with the
  65. significant addition of translucence in the imaging model). When
  66. complete, the API is intended to support the complete imaging model of
  67. PDF 1.4.
  68. Cairo relies on the Xc library for backend rendering. Xc provides an
  69. abstract interface for rendering to multiple target types. As of this
  70. writing, Xc allows Cairo to target X drawables as well as generic
  71. image buffers. Future backends such as PostScript, PDF, and perhaps
  72. OpenGL are currently being planned.
  73. %package devel
  74. Summary: Development files for Cairo library.
  75. Summary(ja): Cairo ライブラリの開発用ファイル
  76. Group: programming
  77. Provides: lib%{name}-devel = %{version}-%{release}
  78. Requires: %{name} = %{version}
  79. Requires: libpng-devel
  80. Requires: freetype2-devel
  81. Requires: fontconfig-devel
  82. Requires: libX11-devel
  83. Requires: libXrender-devel
  84. Requires: pixman-devel
  85. Requires: glib2-devel
  86. Requires: mesa-libEGL-devel
  87. %description devel
  88. Development files for Cairo library.
  89. %package tools
  90. Summary: Development tools for cairo
  91. Group: programming
  92. %description tools
  93. Cairo is a 2D graphics library designed to provide high-quality display
  94. and print output.
  95. This package contains tools for working with the cairo graphics library.
  96. * cairo-trace: Record cairo library calls for later playback
  97. %debug_package
  98. %prep
  99. %autosetup -p1
  100. %build
  101. %meson \
  102. -Dfreetype=enabled \
  103. -Dfontconfig=enabled \
  104. -Dglib=enabled \
  105. -Dgtk_doc=true \
  106. -Dspectre=disabled \
  107. -Dsymbol-lookup=disabled \
  108. -Dtee=enabled \
  109. -Dtests=disabled \
  110. -Dxcb=enabled \
  111. -Dxlib=enabled \
  112. %{nil}
  113. %meson_build
  114. %install
  115. %meson_install
  116. %if %{with check}
  117. %check
  118. %meson_test
  119. %endif
  120. %files
  121. %license COPYING COPYING-*
  122. %doc AUTHORS BUGS NEWS README.md
  123. %{_libdir}/lib*.so.*
  124. %files devel
  125. %{_libdir}/lib*.so
  126. %{_includedir}/*
  127. %{_libdir}/pkgconfig/*.pc
  128. #{_libdir}/lib*.a
  129. %{_datadir}/gtk-doc/html/cairo
  130. %files tools
  131. %{_bindir}/cairo-trace
  132. %{_libdir}/cairo
  133. %if %{build_compat32}
  134. %files -n compat32-%{name}
  135. %{_libdir}/lib*.so.*
  136. %endif
  137. %changelog
  138. * Tue Oct 03 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.18.0-1
  139. - new upstream release.
  140. * Mon Feb 13 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.17.8-1
  141. - new upstream release.
  142. - dropped Patch1 and 2: fixed in upstream.
  143. - imported Patch1 from upstream.
  144. * Thu Aug 11 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.17.6-1
  145. - dropped Patch1,5,6 and 1000.
  146. - renumberd Patch4 to 1.
  147. * Fri Mar 26 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.0-1
  148. - imported Patch1000 from upstream to fix CVE-2020-35492.
  149. - dropped ldconfig scriptlets.
  150. * Fri Oct 18 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.16.0-1
  151. - new upstream release.
  152. - imported Patch4-6 from rawhide.
  153. * Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.14.12-1
  154. - new upstream release.
  155. * Sun Dec 20 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.6-1
  156. - new upstream release
  157. * Thu Nov 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.4-2
  158. - fix spec file
  159. * Thu Oct 29 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.4-1
  160. - new upstream release
  161. * Sun May 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.2-2
  162. - remove *.la files
  163. * Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.14.2-1
  164. - new upstream release
  165. * Sun Nov 16 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.18-1
  166. - new upstream release
  167. * Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.16-2
  168. - rebuild with libpng-1.6.12
  169. * Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.16-1
  170. - new upstream release
  171. * Sat May 25 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.14-2
  172. - remove hardcoded libdir and runpath from libtool
  173. * Sun Feb 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.14-1
  174. - new upstream release
  175. * Wed Jan 02 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.8-1
  176. - new upstream release
  177. * Fri Nov 02 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.6-1
  178. - new upstream release
  179. * Sat Oct 13 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.4-1
  180. - new upstream release
  181. * Sun Jul 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.2-2
  182. - add Requires: mesa-libEGL-devel
  183. * Sat Jul 21 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.12.2-1
  184. - new upstream release
  185. - Enable OpenGL backend
  186. - add BR: librsvg2-devel, mesa-libGL-devel, mesa-libEGL-devel
  187. * Sat Mar 31 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.12.0-1
  188. - new upstream release
  189. * Mon Mar 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.2-2
  190. - enable tee support
  191. - add configure options specifically
  192. - disable static library
  193. * Wed Jan 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.2-1
  194. - new upstream release
  195. - add BuildRequires: glib2-devel
  196. - add Requires: glib2-devel (devel package)
  197. * Wed Oct 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.10.0-2
  198. - add patch1 from ubuntu to fix performance regressions
  199. - don't use serverside gradients, most drivers don't handle those and are
  200. really slow, should workaround performances issues for ati, nouveau and nvidia
  201. https://launchpad.net/ubuntu/maverick/+source/cairo/1.10.0-1ubuntu1
  202. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.10.0-1
  203. - new upstream release
  204. - add tools sub package
  205. * Tue Sep 21 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.10-3
  206. - add BuildRequires: fontconfig-devel
  207. - add Requires: fontconfig-devel (devel package)
  208. * Tue Sep 21 2010 IWAI, Masaharu <iwai@alib.jp> 1.8.10-2
  209. - build with rpm-4.8.1-1 for pkg-config file
  210. * Tue Mar 2 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.8.10-1
  211. - new upstream release
  212. * Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.8-1
  213. - new upstream release
  214. * Sat May 02 2009 Munehiro Yamamoto <munepi@cg8.so-net.ne.jp> 1.8.6-2
  215. - applied cairo-1.8.6-status-return-fix.patch from Gentoo Linux
  216. - added BuildRequires: gtk-doc
  217. * Sat Jan 10 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.6-1
  218. - new upstream release
  219. * Tue Nov 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.4-1
  220. - new upstream release
  221. * Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.0-1
  222. - new upstream release
  223. * Tue Sep 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.6-1
  224. - new upstream release
  225. * Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.7.4-1
  226. - new upstream release
  227. * Wed May 28 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.6.4-3
  228. - add Requires: pixman-devel to -devel
  229. * Sun May 25 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-2
  230. - rebuilt with xorg-x11 7.3
  231. - spec in UTF-8
  232. * Thu May 1 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.6.4-1
  233. - new upstream release
  234. - removed lib*.la from devel package
  235. * Thu Mar 20 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.14-1vl5
  236. - used %%{?_dist_release}
  237. * Thu Feb 7 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.14-0vl1
  238. - new upstream release
  239. * Sun Dec 9 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.12-0vl1
  240. - new upstream release
  241. * Tue Jul 17 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.10-0vl1
  242. - new upstream release
  243. * Sun May 20 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.6-0vl1
  244. - new upstream release
  245. - remove BuildRequires: pango-devel, gtk2-devel
  246. (these are only needed for testing)
  247. * Sat Mar 31 2007 KANEKO Seiji <giraffe@m2.pbc.ne.jp> 1.4.2-0vl1
  248. - upstream release
  249. - Patch30 and Patch40 is skipped (not working correctly)
  250. but held in src.rpm
  251. - add BUGS, ROADMAP to %%doc
  252. - add BuildRequires: pango-devel, gtk2-devel
  253. * Tue Oct 24 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl2
  254. - rebuild without XOrg-compat70-devel
  255. - add BuildConflicts: XOrg-compat70-devel
  256. * Sun Oct 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.4-0vl1
  257. - new upstream release
  258. - remove unneeded Patch20 which breaks 8bpp rendering (<BTS:297>)
  259. * Tue Sep 19 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.2-0vl3
  260. - added Patch40 for 15bpp problem
  261. * Tue Sep 5 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.2.2-0vl2
  262. - added ad-hoc Patch30 for 16bpp problem
  263. * Thu Aug 10 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
  264. - new upstream release
  265. * Sat Aug 05 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-0vl1
  266. - new upstream release
  267. * Sun May 28 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.4-0vl1
  268. - new upstream release
  269. * Sat May 20 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.0.2-0vl4
  270. - added compat32- package for x86_64 architecture support
  271. * Sun Mar 05 2006 Shu KONNO <owa@bg.wakwak.com> 1.0.2-0vl3
  272. - added x86_64 architecture support
  273. * Sat Dec 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl2
  274. - add Patch20 to fix broken desktop rendering on xorg-x11-6.9
  275. - add X.Org 6.9.0 (6090000) to blacklist
  276. * Wed Oct 05 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.2-0vl1
  277. - new upstream release
  278. * Tue Oct 04 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl5
  279. - update Patch10
  280. * Sun Oct 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl4
  281. - add Patch10 to use embedded bitmap font if available.
  282. (controllable by "embeddedbitmap" in fontconfig)
  283. * Thu Sep 29 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl3
  284. - rebuild with new fontconfig
  285. * Sun Sep 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl2
  286. - add Requires: libpng-devel, XOrg-devel, freetype2-devel
  287. to devel package instead of BuildRequires (typo)
  288. - add Japanese summaries
  289. * Sun Aug 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.0-0vl1
  290. - new upstream release
  291. - remove libpixman dependency (which is now included in cairo)
  292. - obsoletes libpixman <= 0.1.6
  293. - add more BuildRequires
  294. * Sat Aug 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.9.2-0vl1
  295. - new upstream version
  296. * Sun Jul 10 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.5.1-0vl1
  297. - new upstream version
  298. - fixed License (http://cairographics.org/introduction)
  299. * Sun Mar 20 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.4.0-0vl1
  300. - new upstream version
  301. - include gtk-doc files
  302. * Sun Jan 23 2005 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 0.3.0-0vl1
  303. - new upstream version
  304. - add Requires: libpixman
  305. * Mon Nov 01 2004 Satoshi MACHINO <machino@vinelinux.org> 0.2.0-0vl1
  306. - new upstream version (cairo-0.2.0)
  307. * Mon Oct 11 2004 Satoshi MACHINO <machino@vinelinux.org> 0.1.23-1vl1
  308. - rebuilt for VineLinux
  309. * Tue Jun 01 2004 Marcel Pol <mpol@mandrake.org> 0.1.23-1mdk
  310. - 0.1.23
  311. - reenable libtoolize
  312. * Wed May 5 2004 G魚Waschk <waschk@linux-mandrake.com> 0.1.22-1mdk
  313. - fix devel provides
  314. - drop redundant buildrequires
  315. - requires new pixman
  316. - autoconf 2.5 macro
  317. - New release 0.1.22
  318. * Fri Feb 06 2004 Marcel Pol <mpol@mandrake.org> 0.1.17-2mdk
  319. - build with X11
  320. * Sun Feb 01 2004 Marcel Pol <mpol@mandrake.org> 0.1.17-1mdk
  321. - 0.1.17
  322. - provides cairo
  323. - drop patch, use --disable-xlib
  324. - buildrequires
  325. - don't run libtoolize
  326. * Sun Dec 14 2003 Marcel Pol <mpol@mandrake.org> 0.1.13-1mdk
  327. - initial mandrake package