cronie-vl.spec 17 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517
  1. %bcond_with systemd
  2. %bcond_with selinux
  3. %bcond_without pam
  4. %bcond_without audit
  5. %bcond_without inotify
  6. Summary: Cron daemon for executing programs at set times
  7. Name: cronie
  8. Version: 1.5.7
  9. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  10. Group: system
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. Packager: iwaim
  14. License: MIT and BSD and ISC and GPLv2+
  15. URL: https://github.com/cronie-crond/cronie
  16. Source0: https://github.com/cronie-crond/cronie/releases/download/%{name}-%{version}/%{name}-%{version}.tar.gz
  17. # from cronie 1.4.8 tarball
  18. Source1: cronie.init
  19. Patch0: 0001-Address-issues-found-by-coverity-scan.patch
  20. Requires: dailyjobs
  21. Conflicts: vixie-cron
  22. %if %{with selinux}
  23. Requires: libselinux >= 2.0.64
  24. BuildRequires: libselinux-devel >= 2.0.64
  25. %endif
  26. %if %{with pam}
  27. Requires: pam >= 1.0.1
  28. BuildRequires: pam-devel >= 1.0.1
  29. %endif
  30. %if %{with audit}
  31. BuildRequires: audit-libs-devel >= 1.4.1
  32. %endif
  33. %if %{with systemd}
  34. BuildRequires: systemd
  35. %{?systemd_requires}
  36. %else
  37. Requires(post): chkconfig
  38. Requires(preun): chkconfig
  39. %endif
  40. Requires(post): coreutils sed
  41. Obsoletes: vixie-cron <= 3.0.1
  42. %description
  43. Cronie contains the standard UNIX daemon crond that runs specified programs at
  44. scheduled times and related tools. It is a fork of the original vixie-cron and
  45. has security and configuration enhancements like the ability to use pam and
  46. SELinux.
  47. %package anacron
  48. Summary: Utility for running regular jobs
  49. Requires: crontabs
  50. Group: system
  51. Provides: dailyjobs
  52. Provides: anacron = 2.4
  53. Obsoletes: anacron <= 2.3
  54. Requires(post): coreutils
  55. Requires: %{name} = %{version}-%{release}
  56. %description anacron
  57. Anacron is part of cronie that is used for running jobs with regular
  58. periodicity which do not have exact time of day of execution.
  59. The default settings of anacron execute the daily, weekly, and monthly
  60. jobs, but anacron allows setting arbitrary periodicity of jobs.
  61. Using anacron allows running the periodic jobs even if the system is often
  62. powered off and it also allows randomizing the time of the job execution
  63. for better utilization of resources shared among multiple systems.
  64. %package noanacron
  65. Summary: Utility for running simple regular jobs in old cron style
  66. Group: system
  67. Provides: dailyjobs
  68. Requires: crontabs
  69. Requires: %{name} = %{version}-%{release}
  70. %description noanacron
  71. Old style of running {hourly,daily,weekly,monthly}.jobs without anacron. No
  72. extra features.
  73. %debug_package
  74. %prep
  75. %autosetup -p1
  76. %build
  77. %configure \
  78. %if %{with pam}
  79. --with-pam \
  80. %endif
  81. %if %{with selinux}
  82. --with-selinux \
  83. %endif
  84. %if %{with audit}
  85. --with-audit \
  86. %endif
  87. %if %{with inotify}
  88. --with-inotify \
  89. %endif
  90. --enable-anacron \
  91. --enable-pie \
  92. --enable-relro
  93. make %{?_smp_mflags}
  94. %install
  95. make install DESTDIR=$RPM_BUILD_ROOT DESTMAN=$RPM_BUILD_ROOT%{_mandir}
  96. mkdir -pm700 $RPM_BUILD_ROOT%{_localstatedir}/spool/cron
  97. mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/
  98. mkdir -pm755 $RPM_BUILD_ROOT%{_sysconfdir}/cron.d/
  99. %if ! %{with pam}
  100. rm -f $RPM_BUILD_ROOT%{_sysconfdir}/pam.d/crond
  101. %endif
  102. install -m 600 crond.sysconfig $RPM_BUILD_ROOT%{_sysconfdir}/sysconfig/crond
  103. touch $RPM_BUILD_ROOT%{_sysconfdir}/cron.deny
  104. install -m 600 contrib/anacrontab $RPM_BUILD_ROOT%{_sysconfdir}/anacrontab
  105. install -c -m755 contrib/0hourly $RPM_BUILD_ROOT%{_sysconfdir}/cron.d/0hourly
  106. mkdir -pm 700 $RPM_BUILD_ROOT%{_sysconfdir}/cron.hourly
  107. install -c -m755 contrib/0anacron $RPM_BUILD_ROOT%{_sysconfdir}/cron.hourly/0anacron
  108. mkdir -p $RPM_BUILD_ROOT/var/spool/anacron
  109. touch $RPM_BUILD_ROOT/var/spool/anacron/cron.daily
  110. touch $RPM_BUILD_ROOT/var/spool/anacron/cron.weekly
  111. touch $RPM_BUILD_ROOT/var/spool/anacron/cron.monthly
  112. # noanacron package
  113. install -m 644 contrib/dailyjobs $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/dailyjobs
  114. %if %{with systemd}
  115. # install systemd initscript
  116. mkdir -p $RPM_BUILD_ROOT%{_unitdir}
  117. install -m 644 contrib/cronie.systemd $RPM_BUILD_ROOT%{_unitdir}/crond.service
  118. %else
  119. # install initscript
  120. mkdir -p $RPM_BUILD_ROOT%{_initddir}
  121. install -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_initddir}/crond
  122. %endif
  123. %post
  124. # run after an installation
  125. %if %{with systemd}
  126. %systemd_post crond.service
  127. %else
  128. /sbin/chkconfig --add crond
  129. %endif
  130. %post anacron
  131. [ -e /var/spool/anacron/cron.daily ] || touch /var/spool/anacron/cron.daily 2>/dev/null || :
  132. [ -e /var/spool/anacron/cron.weekly ] || touch /var/spool/anacron/cron.weekly 2>/dev/null || :
  133. [ -e /var/spool/anacron/cron.monthly ] || touch /var/spool/anacron/cron.monthly 2>/dev/null || :
  134. %preun
  135. # run before a package is removed
  136. %if %{with systemd}
  137. %systemd_preun crond.service
  138. %else
  139. if [ "$1" -eq 0 -o -x /bin/systemctl ]; then
  140. /sbin/service crond stop >/dev/null 2>&1
  141. /sbin/chkconfig --del crond
  142. fi
  143. %endif
  144. %postun
  145. # run after a package is removed
  146. %if %{with systemd}
  147. %systemd_postun_with_restart crond.service
  148. %else
  149. if [ "$1" -ge "1" ]; then
  150. /sbin/service crond condrestart >/dev/null 2>&1 || :
  151. fi
  152. %endif
  153. %triggerpostun -- vixie-cron
  154. %if %{with systemd}
  155. %systemd_postun_with_restart crond.service
  156. %else
  157. /sbin/chkconfig --add crond
  158. %endif
  159. %files
  160. %license COPYING*
  161. %doc AUTHORS INSTALL README ChangeLog
  162. %attr(755,root,root) %{_sbindir}/crond
  163. %attr(4755,root,root) %{_bindir}/crontab
  164. %attr(755,root,root) %{_bindir}/cronnext
  165. %{_mandir}/man8/crond.*
  166. %{_mandir}/man8/cron.*
  167. %{_mandir}/man5/crontab.*
  168. %{_mandir}/man1/crontab.*
  169. %{_mandir}/man1/cronnext.*
  170. %dir %{_localstatedir}/spool/cron
  171. %dir %{_sysconfdir}/cron.d
  172. %if %{with pam}
  173. %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/pam.d/crond
  174. %endif
  175. %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/sysconfig/crond
  176. %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/cron.deny
  177. %attr(0644,root,root) %{_sysconfdir}/cron.d/0hourly
  178. %if %{with systemd}
  179. %{_unitdir}/crond.service
  180. %else
  181. %attr(0755,root,root) %{_initddir}/crond
  182. %endif
  183. %files anacron
  184. %{_sbindir}/anacron
  185. %attr(0755,root,root) %{_sysconfdir}/cron.hourly/0anacron
  186. %attr(0600,root,root) %config(noreplace) %{_sysconfdir}/anacrontab
  187. %dir /var/spool/anacron
  188. %ghost %verify(not md5 size mtime) /var/spool/anacron/cron.daily
  189. %ghost %verify(not md5 size mtime) /var/spool/anacron/cron.weekly
  190. %ghost %verify(not md5 size mtime) /var/spool/anacron/cron.monthly
  191. %{_mandir}/man5/anacrontab.*
  192. %{_mandir}/man8/anacron.*
  193. %files noanacron
  194. %attr(0644,root,root) %{_sysconfdir}/cron.d/dailyjobs
  195. %changelog
  196. * Wed Nov 24 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.7-1
  197. - new upstream release.
  198. - imported Patch0 from rawhide.
  199. * Sun Aug 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.5-2
  200. - added systemd support (disabled as default).
  201. * Wed Mar 25 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.5-1
  202. - new upstream release.
  203. - dropped all patches.
  204. * Mon Sep 11 2017 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.1-1
  205. - new upstream release.
  206. - dropped Patch0.
  207. - imported Patch0 and Patch1 from rawhide.
  208. * Sat Jul 25 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.5.0-1
  209. - new upstream release.
  210. - dropped all patches.
  211. - imported Patch0 from rawhide.
  212. - added O:vixie-cron.
  213. * Thu Jun 26 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.11-2
  214. - run chkconfig for vixie-cron in triggerpostun script
  215. * Thu Jun 26 2014 IWAI, Masaharu <iwaim.sub@gmail.com> 1.4.11-1
  216. - initial build for Vine Linux
  217. * Mon Jan 27 2014 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-11
  218. - now it's work even on ppc64, all checks working correctly
  219. - Related: rhbz#1031384
  220. * Fri Jan 24 2014 Daniel Mach <dmach@redhat.com> - 1.4.11-10
  221. - Mass rebuild 2014-01-24
  222. * Wed Jan 22 2014 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-9
  223. - fix coverity warnings about dead code. Incorrect checking of values.
  224. - Related: rhbz#1031384
  225. * Mon Jan 20 2014 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-8
  226. - anacron do not execute jobs run from command line
  227. - Related: rhbz#1031384
  228. * Wed Jan 08 2014 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-7
  229. - anacron segfaults with certain config data
  230. - Resolves: rhbz#1031384
  231. * Fri Dec 27 2013 Daniel Mach <dmach@redhat.com> - 1.4.11-6
  232. - Mass rebuild 2013-12-27
  233. * Tue Oct 15 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-5
  234. - Cronie doesn't work when is executed as stand alone without systemd (for
  235. debuging issues)
  236. - Fix another permission, hopefully all now.
  237. - Resolves: rhbz#1012420, rhbz#1015567
  238. * Fri Sep 13 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-4
  239. - fix permission on configuration files, same as rhbz#706979
  240. * Fri Aug 30 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-3
  241. - 919290 systemd script use "KillMode=process"
  242. - Fcntl locking has different semantics than flock. Prefer flock.
  243. - 49225e172d156531ca142518d2638350752e373a
  244. - Pull PAM environment variables also from session modules.
  245. - c8e7d1b43c86a85441cb09cf7e08090f3ec1f384
  246. * Mon Jul 22 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-2
  247. - scriptlets are not created correctly if systemd is not in BR 986698
  248. - remove sub-package sysvinit, which is not needed anymore
  249. - update license, anacron is under GPLv2+
  250. * Thu Jul 18 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.11-1
  251. - new release 1.4.11 (contains previous bug fixes from 1.4.10-5)
  252. * Tue Jun 11 2013 Tomáš Mráz <tmraz@redhat.com> - 1.4.10-5
  253. - add support for RANDOM_DELAY - delaying job startups
  254. - pass some environment variables to processes (LANG, etc.) (#969761)
  255. - do not use putenv() with string literals (#971516)
  256. * Wed Feb 13 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.10-4
  257. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  258. * Wed Jan 2 2013 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.10-3
  259. - change configuration files to 644
  260. - change 6755 to 4755 for crontab binary
  261. * Tue Nov 27 2012 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.10-1
  262. - New release 1.4.10
  263. * Thu Nov 22 2012 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.9-1
  264. - New release 1.4.9
  265. * Wed Sep 05 2012 Václav Pavlín <vpavlin@redhat.com> - 1.4.8-13
  266. - Scriptlets replaced with new systemd macros (#850070)
  267. * Fri Jul 27 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-12
  268. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  269. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-11
  270. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  271. * Wed Oct 26 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.8-10
  272. - Rebuilt for glibc bug#747377
  273. * Tue Oct 25 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.8-9
  274. - make crond run a little bit later in the boot process (#747759)
  275. * Mon Oct 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.8-8
  276. - change triggerun to fix 735802 during upgrade
  277. * Wed Jul 27 2011 Karsten Hopp <karsten@redhat.com> 1.4.8-7
  278. - rebuild again, ppc still had the broken rpm in the buildroots
  279. * Thu Jul 21 2011 Rex Dieter <rdieter@fedoraproject.org> 1.4.8-6
  280. - rebuild (broken rpm in buildroot)
  281. * Thu Jul 21 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.8-5
  282. - fix permission of init.d/crond
  283. * Thu Jun 30 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.8-4
  284. - drop the without systemd build condition
  285. - add the chkconfig readding trigger to the sysvinit subpackage
  286. * Wed Jun 29 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.8-3
  287. - start crond after auditd
  288. * Wed Jun 29 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.8-2
  289. - fix inotify support to not leak fds (#717505)
  290. * Tue Jun 28 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.8-1
  291. - update to 1.4.8
  292. - create sub-package sysvinit for initscript
  293. * Mon May 9 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.7-3
  294. - missing requirement on systemd-sysv for scriptlets
  295. * Thu May 05 2011 Tomáš Mráz <tmraz@redhat.com> - 1.4.7-2
  296. - use only systemd units with systemd
  297. - add trigger for restart on glibc, libselinux or pam upgrades (#699189)
  298. * Tue Mar 15 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.7-1
  299. - new release 1.4.7
  300. * Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4.6-9
  301. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  302. * Mon Jan 17 2011 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-8
  303. - enable crond even with systemctl
  304. * Thu Dec 16 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-7
  305. - 663193 rewritten selinux support
  306. * Wed Dec 15 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-6
  307. - apply selinux patch from dwalsh
  308. * Fri Dec 10 2010 Tomas Mraz <tmraz@redhat.com> - 1.4.6-5
  309. - do not lock jobs that fall out of allowed range - 661966
  310. * Thu Dec 02 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-4
  311. - fix post (thanks plautrba for review)
  312. * Tue Nov 30 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-3
  313. - systemd init script 617320
  314. * Tue Nov 30 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-2
  315. - fix typos in man pages
  316. * Fri Oct 22 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.6-1
  317. - update to 1.4.6
  318. * Fri Aug 13 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.5-4
  319. - 623908 fix fd leak in anacron, which caused denail of prelink
  320. and others
  321. * Mon Aug 9 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.5-2
  322. - remove sendmail from requirements. If it's not installed, it will
  323. log into (r)syslog.
  324. * Mon Aug 2 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.5-1
  325. - update to new release
  326. * Fri Feb 19 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.4-1
  327. - update to new release
  328. * Mon Feb 15 2010 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.3-3
  329. - 564894 FTBFS DSOLinking
  330. * Thu Nov 5 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.3-2
  331. - 533189 pam needs add a line and selinux needs defined one function
  332. * Fri Oct 30 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.3-1
  333. - 531963 and 532482 creating noanacron package
  334. * Mon Oct 19 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.2-2
  335. - 529632 service crond stop returns appropriate value
  336. * Mon Oct 12 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.2-1
  337. - new release
  338. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.1-3
  339. - rebuilt with new audit
  340. * Fri Aug 14 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.1-2
  341. - create the anacron timestamps in correct post script
  342. * Fri Aug 14 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4.1-1
  343. - update to 1.4.1
  344. - create and own /var/spool/anacron/cron.{daily,weekly,monthly} to
  345. remove false warning about non existent files
  346. - Resolves: 517398
  347. * Wed Aug 5 2009 Tomas Mraz <tmraz@redhat.com> - 1.4-4
  348. - 515762 move anacron provides and obsoletes to the anacron subpackage
  349. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-3
  350. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  351. * Mon Jul 20 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.4-2
  352. - merge cronie and anacron in new release of cronie
  353. - obsolete/provide anacron in spec
  354. * Thu Jun 18 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.3-2
  355. - 506560 check return value of access
  356. * Mon Apr 27 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.3-1
  357. - new release
  358. * Fri Apr 24 2009 Marcela Mašláňová <mmaslano@redhat.com> - 1.2-8
  359. - 496973 close file descriptors after exec
  360. * Mon Mar 9 2009 Tomas Mraz <tmraz@redhat.com> - 1.2-7
  361. - rebuild
  362. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-6
  363. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  364. * Tue Dec 23 2008 Marcela Mašláňová <mmaslano@redhat.com> - 1.2-5
  365. - 477100 NO_FOLLOW was removed, reload after change in symlinked
  366. crontab is needed, man updated.
  367. * Fri Oct 24 2008 Marcela Mašláňová <mmaslano@redhat.com> - 1.2-4
  368. - update init script
  369. * Thu Sep 25 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.2-3
  370. - add sendmail file into requirement, cause it's needed some MTA
  371. * Thu Sep 18 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.2-2
  372. - 462252 /etc/sysconfig/crond does not need to be executable
  373. * Thu Jun 26 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.2-1
  374. - update to 1.2
  375. * Tue Jun 17 2008 Tomas Mraz <tmraz@redhat.com> - 1.1-3
  376. - fix setting keycreate context
  377. - unify logging a bit
  378. - cleanup some warnings and fix a typo in TZ code
  379. - 450993 improve and fix inotify support
  380. * Wed Jun 4 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.1-2
  381. - 49864 upgrade/update problem. Syntax error in spec.
  382. * Wed May 28 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.1-1
  383. - release 1.1
  384. * Tue May 20 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-6
  385. - 446360 check for lock didn't call chkconfig
  386. * Tue Feb 12 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-5
  387. - upgrade from less than cronie-1.0-4 didn't add chkconfig
  388. * Wed Feb 6 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-4
  389. - 431366 after reboot wasn't cron in chkconfig
  390. * Tue Feb 5 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-3
  391. - 431366 trigger part => after update from vixie-cron on cronie will
  392. be daemon running.
  393. * Wed Jan 30 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-2
  394. - change the provides on higher version than obsoletes
  395. * Tue Jan 8 2008 Marcela Maslanova <mmaslano@redhat.com> - 1.0-1
  396. - packaging cronie
  397. - thank's for help with packaging to my reviewers