docker-ce-vl.spec 5.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213
  1. %bcond_with systemd
  2. %bcond_with build_nosrc
  3. %if !%{with build_nosrc}
  4. %global _disable_source_fetch 0
  5. %endif
  6. Name: docker-ce
  7. Summary: The open-source application container engine
  8. Version: 24.0.2
  9. Release: 1%{?_dist_release}%{?with_systemd:.systemd}
  10. Group: system,virtualization
  11. Vendor: Project Vine
  12. Distribution: Vine Linux
  13. Packager: tomop
  14. License: ASL 2.0
  15. URL: https://www.docker.com
  16. Source0: https://download.docker.com/linux/static/stable/x86_64/docker-%{version}.tgz
  17. Source1: https://raw.githubusercontent.com/docker/cli/v%{version}/README.md
  18. Source2: https://raw.githubusercontent.com/docker/cli/v%{version}/LICENSE
  19. Source10: docker.init
  20. Source11: docker.sysconfig
  21. Source12: docker.conf
  22. Source100: docker.service
  23. Source101: docker.socket
  24. Source102: containerd.service
  25. %if %{with build_nosrc}
  26. NoSource: 0
  27. NoSource: 1
  28. NoSource: 2
  29. %endif
  30. # required packages on install
  31. Requires: /bin/sh
  32. Requires: libcgroup
  33. Requires: docker-ce-cli = %{version}-%{release}
  34. %if %{with systemd}
  35. %{?systemd_requires}
  36. %endif
  37. Conflicts: docker-ee
  38. Conflicts: docker-ee-cli
  39. %description
  40. Docker is is a product for you to build, ship and run any application as a
  41. lightweight container.
  42. Docker containers are both hardware-agnostic and platform-agnostic. This means
  43. they can run anywhere, from your laptop to the largest cloud compute instance and
  44. everything in between - and they don't require you to use a particular
  45. language, framework or packaging system. That makes them great building blocks
  46. for deploying and scaling web apps, databases, and backend services without
  47. depending on a particular stack or provider.
  48. %package cli
  49. Summary: clients for Docker
  50. Group: admin-tools,virtualization
  51. %description cli
  52. Docker is is a product for you to build, ship and run any application as a
  53. lightweight container.
  54. Docker containers are both hardware-agnostic and platform-agnostic. This means
  55. they can run anywhere, from your laptop to the largest cloud compute instance and
  56. everything in between - and they don't require you to use a particular
  57. language, framework or packaging system. That makes them great building blocks
  58. for deploying and scaling web apps, databases, and backend services without
  59. depending on a particular stack or provider.
  60. %prep
  61. %setup -q -c -n docker
  62. %build
  63. # %check
  64. # cli/build/docker -v
  65. %install
  66. # install binary
  67. install -d %{buildroot}%{_bindir}
  68. install -d %{buildroot}%{_localstatedir}/lib/docker
  69. for f in docker/*; do
  70. install -p -m 755 $f %{buildroot}%{_bindir}/
  71. done
  72. %if %{with systemd}
  73. install -D -p -m 644 %{SOURCE100} %{buildroot}%{_unitdir}/docker.service
  74. install -D -p -m 755 %{SOURCE101} %{buildroot}%{_unitdir}/docker.socket
  75. install -D -p -m 644 %{SOURCE102} %{buildroot}%{_unitdir}/containerd.service
  76. %else
  77. install -d %{buildroot}%{_localstatedir}/run/docker
  78. install -D -p -m 755 %{SOURCE10} %{buildroot}%{_initdir}/docker
  79. install -D -p -m 644 %{SOURCE11} %{buildroot}%{_sysconfdir}/sysconfig/docker
  80. install -D -p -m 644 %{SOURCE12} %{buildroot}%{_sysconfdir}/rsyslog.d/docker
  81. %endif
  82. install -p -m 644 %{SOURCE1} ./
  83. install -p -m 644 %{SOURCE2} ./
  84. %clean
  85. rm -rf %{buildroot}
  86. %pre
  87. if ! getent group docker > /dev/null; then
  88. groupadd --system docker
  89. fi
  90. %post
  91. %if %{with systemd}
  92. %systemd_post containerd.service docker.service
  93. %else
  94. if [ $1 -eq 1 ]; then
  95. /sbin/chkconfig --add docker
  96. fi
  97. %endif
  98. %preun
  99. %if %{with systemd}
  100. %systemd_preun containerd.service docker.service
  101. %else
  102. if [ $1 -eq 0 -o -x /bin/systemctl ]; then
  103. /sbin/chkconfig docker off
  104. /sbin/chkconfig --del docker
  105. fi
  106. %endif
  107. %if %{with systemd}
  108. %postun
  109. %systemd_postun_with_restart containerd.service docker.service
  110. %endif
  111. # list files owned by the package here
  112. %files
  113. %defattr(-,root,root,-)
  114. %license LICENSE
  115. %doc README.md
  116. %{_bindir}/containerd
  117. %{_bindir}/containerd-shim*
  118. %{_bindir}/ctr
  119. %{_bindir}/docker-init
  120. %{_bindir}/docker-proxy
  121. %{_bindir}/dockerd
  122. %{_bindir}/runc
  123. %dir %{_localstatedir}/lib/docker
  124. %if %{with systemd}
  125. %{_unitdir}/docker.service
  126. %{_unitdir}/docker.socket
  127. %{_unitdir}/containerd.service
  128. %else
  129. %{_initdir}/docker
  130. %dir %{_localstatedir}/run/docker
  131. %config(noreplace) %{_sysconfdir}/sysconfig/docker
  132. %config(noreplace) %{_sysconfdir}/rsyslog.d/docker
  133. %endif
  134. %files cli
  135. %defattr(-,root,root,-)
  136. %license LICENSE
  137. %doc README.md
  138. %{_bindir}/docker
  139. %changelog
  140. * Thu Jun 08 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 24.0.2-1
  141. - new upstream release.
  142. * Mon Feb 13 2023 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20.10.23-1
  143. - new upstream release.
  144. * Mon Sep 12 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20.10.18-1
  145. - new upstream release.
  146. * Tue Dec 28 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20.10.12-1
  147. - new upstream release.
  148. * Wed Dec 01 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20.10.9-1
  149. - new upstream release.
  150. * Wed May 12 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20.10.6-1
  151. - new upstream release.
  152. * Thu Feb 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 20.10.3-1
  153. - new upstream release.
  154. * Thu Dec 17 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 19.03.14-1
  155. - new upstream release.
  156. * Sun Jul 26 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 19.03.09-1
  157. - new upstream release.
  158. - added systemd support (disabled as default).
  159. * Thu Mar 19 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 19.03.08-1
  160. - new upstream release.
  161. * Thu Oct 10 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 19.03.03-1
  162. - new upstream release.
  163. * Tue Aug 27 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 19.03.1-2
  164. - updated initscript: added syslog support.
  165. * Sun Aug 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 19.03.1-1
  166. - initial build for Vine Linux.