doxygen-vl.spec 10 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364
  1. # Set this to "1" if you want to build doxywizard
  2. %define wizard 1
  3. Summary: A documentation system for C/C++.
  4. Summary(ja): C/C++ 向けドキュメンテーションシステム
  5. Name: doxygen
  6. Version: 1.9.1
  7. Release: 1%{?_dist_release}
  8. Group: programming
  9. Vendor: Project Vine
  10. Distribution: Vine Linux
  11. License: GPLv2
  12. URL: https://www.doxygen.nl/
  13. Source0: https://doxygen.nl/files/%{name}-%{version}.src.tar.gz
  14. # this icon is part of kdesdk
  15. Source1: doxywizard.desktop
  16. # these icons are part of doxygen and converted from doxywizard.ico
  17. Source2: doxywizard-icons.tar.xz
  18. # upstream patches
  19. Patch1: doxgen-1.9.1-crash-when-parsing-config-file.patch
  20. Patch2: doxgen-1.9.1-crash-when-parsing-config-file-part2.patch
  21. Patch3: doxygen-1.9.1-Coverity_issues.patch
  22. Patch4: doxygen-1.9.1-crash_in_docparser.patch
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. BuildRequires: perl texlive texlive-collection-fontutils ghostscript gettext
  25. BuildRequires: flex bison
  26. BuildRequires: desktop-file-utils
  27. BuildRequires: graphviz
  28. BuildRequires: python3
  29. BuildRequires: cmake
  30. %if %{wizard}
  31. BuildRequires: qt5-qtbase-devel
  32. %endif
  33. Requires: graphviz
  34. %description
  35. Doxygen can generate an online class browser (in HTML) and/or a
  36. reference manual (in LaTeX) from a set of documented source files. The
  37. documentation is extracted directly from the sources. Doxygen can
  38. also be configured to extract the code structure from undocumented
  39. source files.
  40. %package doxywizard
  41. Summary: A GUI for creating and editing configuration files.
  42. Group: programming
  43. Requires: %{name} = %{version}-%{release}
  44. %description doxywizard
  45. Doxywizard is a GUI for creating and editing configuration files that
  46. are used by doxygen.
  47. %debug_package
  48. %prep
  49. %autosetup -p1 -a2
  50. # convert into utf-8
  51. iconv --from=ISO-8859-1 --to=UTF-8 LANGUAGE.HOWTO > LANGUAGE.HOWTO.new
  52. touch -r LANGUAGE.HOWTO LANGUAGE.HOWTO.new
  53. mv LANGUAGE.HOWTO.new LANGUAGE.HOWTO
  54. %build
  55. %cmake \
  56. -DPYTHON_EXECUTABLE=%{_bindir}/python3 \
  57. -Duse_libclang=OFF \
  58. -Dbuild_doc=OFF \
  59. %if %{wizard}
  60. -Dbuild_wizard=ON \
  61. %else
  62. -Dbuild_wizard=OFF \
  63. %endif
  64. -Dbuild_xmlparser=ON \
  65. -Dbuild_search=OFF \
  66. -DMAN_INSTALL_DIR=%{_mandir}/man1 \
  67. -DCMAKE_INSTALL_PREFIX:PATH=%{_prefix} \
  68. -DBUILD_SHARED_LIBS=OFF
  69. make %{?_smp_mflags}
  70. %install
  71. rm -rf $RPM_BUILD_ROOT
  72. make install DESTDIR=$RPM_BUILD_ROOT
  73. # install icons
  74. icondir=%{buildroot}%{_datadir}/icons/hicolor
  75. mkdir -m755 -p $icondir/{16x16,32x32,48x48,128x128}/apps
  76. install -m644 -p -D doxywizard-6.png $icondir/16x16/apps/doxywizard.png
  77. install -m644 -p -D doxywizard-5.png $icondir/32x32/apps/doxywizard.png
  78. install -m644 -p -D doxywizard-4.png $icondir/48x48/apps/doxywizard.png
  79. install -m644 -p -D doxywizard-3.png $icondir/128x128/apps/doxywizard.png
  80. # install man pages
  81. mkdir -p %{buildroot}/%{_mandir}/man1
  82. cp doc/*.1 %{buildroot}/%{_mandir}/man1/
  83. %if 0%{?_module_build}
  84. rm -f %{buildroot}/%{_mandir}/man1/doxywizard.1*
  85. %endif
  86. %if "x%{?xapian_core_support}" == "xOFF"
  87. rm -f %{buildroot}/%{_mandir}/man1/doxyindexer.1* %{buildroot}/%{_mandir}/man1/d
  88. oxysearch.1*
  89. %endif
  90. # remove duplicate
  91. rm -rf %{buildroot}/%{_docdir}/packages
  92. %if 0%{?wizard}
  93. desktop-file-install --dir=%{buildroot}%{_datadir}/applications %{SOURCE1}
  94. %endif
  95. %clean
  96. rm -rf $RPM_BUILD_ROOT
  97. %files
  98. %defattr(-,root,root)
  99. %license LICENSE
  100. %doc LANGUAGE.HOWTO README.md
  101. %{_bindir}/doxygen
  102. %{_mandir}/man1/doxygen.*
  103. %exclude %{_mandir}/man1/doxyindexer.*
  104. %exclude %{_mandir}/man1/doxysearch.*
  105. %if %{wizard}
  106. %files doxywizard
  107. %defattr(-,root,root)
  108. %{_bindir}/doxywizard
  109. %{_mandir}/man1/doxywizard.*
  110. %{_datadir}/applications/doxywizard.desktop
  111. %endif
  112. %{_datadir}/icons/hicolor/*/apps/doxywizard.png
  113. %changelog
  114. * Sat Feb 20 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.9.1-1
  115. - new upstream release.
  116. - dropped all patches.
  117. - imported Patch1-4 from rawhide.
  118. * Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> - 1.8.6-2
  119. - rebuild with gcc-5.4.0
  120. * Tue Jan 14 2014 NAKAMURA Kenta <kenta@vinelinux.org> - 1.8.6-1
  121. - new upstream release
  122. * Wed Nov 02 2011 NAKAMURA Kenta <kenta@vinelinux.org> - 1.7.5.1-1
  123. - new upstream release
  124. - updated Patch0 and 1
  125. * Mon Oct 19 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> - 1.6.1-1
  126. - new upstream release
  127. - added Patch0, 1 from Fedora
  128. * Mon Aug 24 2009 Than Ngo <than@redhat.com> - 1.6.0-2
  129. - fix #516339, allow to enable/disable timstamp to avoid the multilib issue
  130. HTMP_TIMESTAMP is disable by default
  131. - enabled doxywizard
  132. * Tue Dec 9 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.7.1-1
  133. - new upstream release
  134. - disable doxywizard
  135. * Thu May 29 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.6-1
  136. - new upstream release
  137. * Thu Feb 21 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.5-0vl1
  138. - new upstream release
  139. * Mon May 14 2007 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.5.2-0vl1
  140. - new upstream release
  141. * Thu May 10 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 1.4.7-0vl3
  142. - rebuild with libstdc++34
  143. * Sun Oct 15 2006 KAZUKI SHIMURA <kazuki@ma.ccnw.ne.jp> 1.4.7-0vl2
  144. - add BuildRequires: flex
  145. * Fri Sep 29 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.4.7-0vl1
  146. - new upstream release
  147. - changed doxygen-doxywizard Group to Applications/Development
  148. * Sat Aug 05 2006 NAKAMURA Kenta <kenta@vinelinux.org> 1.4.5-0vl2
  149. - added doxygen-1.4.5-libdir.patch for x86_64 and ppc64 archtecture
  150. * Tue Nov 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.5-0vl1
  151. - new upstream release
  152. * Fri Jul 22 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.4-0vl1
  153. - new upstream release
  154. - update Requires
  155. * Wed Jun 1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl2
  156. - build for VineSeed
  157. * Wed Jun 1 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.3-0vl1
  158. - new upstream release
  159. - build for Vine3.1
  160. - LANG=C when build and install
  161. - add man pages
  162. * Mon Jan 24 2005 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.4.1-0vl1
  163. - new upstream release
  164. - BuildPrereq: qt-devel => 3.2
  165. * Tue Dec 7 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.9.1-0vl1
  166. - source upgrade
  167. * Sun May 16 2004 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.7-0vl1
  168. - source upgrade
  169. - remove %%{_bindir}/doxysearch from %%files
  170. - remove about Vine2.6
  171. * Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.3-0vl2
  172. - build for VineSeed
  173. * Tue Dec 16 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.3-0vl1
  174. - source upgrade
  175. - add BuildPrereq: graphviz and Requires: graphviz
  176. - change spec to build both VineSeed and Vine2.5/2.6
  177. * Sat May 31 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3.1-0vl1
  178. - source upgrade
  179. * Sat May 17 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl1
  180. - source upgrade
  181. * Wed Jan 8 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl0.3
  182. - source upgrade to 1.3-rc3
  183. - enable %%configure --with-doxywizard
  184. * Wed Jan 8 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.3-0vl0.1
  185. - source upgrade to 1.3-rc2
  186. - add BuildPrereq: libpng-devel
  187. - add Requires: XFree86-gl libexpat to %%package doxywizard
  188. - add LICENSE to %%docs
  189. - disable %%configure --with-doxywizard
  190. * Fri Jan 3 2003 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.18-0vl1
  191. - source upgrade
  192. - build with new toolchains
  193. - delete Patch2
  194. * Mon Aug 5 2002 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.17-0vl1
  195. - source upgrade
  196. - build with qt-3.0.5
  197. * Sun Jun 9 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.2.16-0vl1
  198. - source update to 1.2.16
  199. * Thu May 09 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.2.15-0vl1
  200. - source update to 1.2.15
  201. * Sat Mar 23 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 1.2.14-3vl1
  202. - build for VineSeed
  203. - delete Epoch
  204. * Fri Mar 8 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.13-3
  205. - rebuild against qt 3.0.2
  206. * Tue Feb 26 2002 Than Ngo <than@redhat.com> 1.2.14-2
  207. - rebuild against qt 2.3.2
  208. * Tue Feb 19 2002 Bernhard Rosenkraenzer <bero@redhat.com> 1.2.14-1
  209. - 1.2.14
  210. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  211. - automated rebuild
  212. * Sun Jan 06 2002 Than Ngo <than@redhat.com> 1.2.13.1-1
  213. - update to 1.2.13.1
  214. - fixed build doxywizard with qt3
  215. * Sun Dec 30 2001 Jeff Johnson <jbj@redhat.com> 1.2.13-1
  216. - update to 1.2.13
  217. * Sun Nov 18 2001 Than Ngo <than@redhat.com> 1.2.12-1
  218. - update to 1.2.12
  219. - s/Copyright/License
  220. * Wed Sep 12 2001 Tim Powers <timp@redhat.com>
  221. - rebuild with new gcc and binutils
  222. * Wed Jun 13 2001 Than Ngo <than@redhat.com>
  223. - update tp 1.2.8.1
  224. - make doxywizard as separat package
  225. - fix to use install as default
  226. * Tue Jun 05 2001 Than Ngo <than@redhat.com>
  227. - update to 1.2.8
  228. * Tue May 01 2001 Than Ngo <than@redhat.com>
  229. - update to 1.2.7
  230. - clean up specfile
  231. - patch to use RPM_OPT_FLAG
  232. * Wed Mar 14 2001 Jeff Johnson <jbj@redhat.com>
  233. - update to 1.2.6
  234. * Wed Feb 28 2001 Trond Eivind Glomsrød <teg@redhat.com>
  235. - rebuild
  236. * Tue Dec 26 2000 Than Ngo <than@redhat.com>
  237. - update to 1.2.4
  238. - remove excludearch ia64
  239. - bzip2 sources
  240. * Mon Dec 11 2000 Than Ngo <than@redhat.com>
  241. - rebuild with the fixed fileutils
  242. * Mon Oct 30 2000 Jeff Johnson <jbj@redhat.com>
  243. - update to 1.2.3.
  244. * Sun Oct 8 2000 Jeff Johnson <jbj@redhat.com>
  245. - update to 1.2.2.
  246. - enable doxywizard.
  247. * Sat Aug 19 2000 Preston Brown <pbrown@redhat.com>
  248. - 1.2.1 is latest stable, so we upgrade before Winston is released.
  249. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  250. - automatic rebuild
  251. * Tue Jul 4 2000 Jakub Jelinek <jakub@redhat.com>
  252. - Rebuild with new C++
  253. * Fri Jun 30 2000 Florian La Roche <laroche@redhat.de>
  254. - fix QTDIR detection
  255. * Fri Jun 09 2000 Preston Brown <pbrown@redhat.com>
  256. - compile on x86 w/o optimization, revert when compiler fixed!!
  257. * Wed Jun 07 2000 Preston Brown <pbrown@redhat.com>
  258. - use newer RPM macros
  259. * Tue Jun 6 2000 Jeff Johnson <jbj@redhat.com>
  260. - add to distro.
  261. * Tue May 9 2000 Tim Powers <timp@redhat.com>
  262. - rebuilt for 7.0
  263. * Wed Feb 2 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  264. - recompile with current Qt (2.1.0/1.45)
  265. * Wed Jan 5 2000 Jeff Johnson <jbj@redhat.com>
  266. - update to 1.0.0.
  267. - recompile with qt-2.0.1 if available.
  268. - relocatable package.
  269. * Mon Nov 8 1999 Tim Powers <timp@redhat.com>
  270. -updated to 0.49-991106
  271. * Tue Jul 13 1999 Tim Powers <timp@redhat.com>
  272. - updated source
  273. - cleaned up some stuff in the spec file
  274. * Thu Apr 22 1999 Jeff Johnson <jbj@redhat.com>
  275. - Create Power Tools 6.0 package.