dump-vl.spec 14 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414
  1. %define _sbindir /sbin
  2. # XXX --enable-kerberos needs krcmd
  3. %define myoptions --enable-largefile --with-binmode=6755 --with-manowner=root --with-mangrp=root --with-manmode=0644 --enable-readline
  4. Summary: Programs for backing up and restoring ext2/ext3/ext4 filesystems.
  5. Summary(ja): ext2/ext3/ext4 ファイルシステムをバックアップ/リストアするプログラム
  6. Name: dump
  7. Version: 0.4b44
  8. Release: 2%{?_dist_release}
  9. License: BSD
  10. Group: Applications/Archiving
  11. URL: http://dump.sourceforge.net/
  12. Source: dump-%{version}.tar.gz
  13. Patch0: dump-buildfix.patch
  14. Patch3: dump-rmt-moved-star.patch
  15. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  16. BuildRequires: libtermcap-devel
  17. BuildRequires: e2fsprogs-devel >= 1.18, readline-devel >= 4.2
  18. BuildRequires: zlib-devel, device-mapper-devel
  19. BuildRequires: libblkid-devel
  20. BuildRequires: libuuid-devel
  21. BuildRequires: bzip2-devel
  22. # This Prereq is now required because we only ship static binaries, and
  23. # need to ensure the "disk" group is created before installation (#60461)
  24. Requires(pre): setup
  25. Requires: rmt
  26. Obsoletes: dump-static
  27. Packager: daisuke, kazutaka, shaolin
  28. %description
  29. The dump package contains both dump and restore. Dump examines files
  30. in a filesystem, determines which ones need to be backed up, and
  31. copies those files to a specified disk, tape, or other storage medium.
  32. The restore command performs the inverse function of dump; it can
  33. restore a full backup of a filesystem. Subsequent incremental backups
  34. can then be layered on top of the full backup. Single files and
  35. directory subtrees may also be restored from full or partial backups.
  36. Install dump if you need a system for both backing up filesystems and
  37. restoring filesystems after backups.
  38. %description -l ja
  39. dump パッケージは dump と restore の両方を含んでいます。dump はファイル
  40. システム上のファイルを検査し、どれがバックアップが必要が特定し、指定し
  41. たディスク、テープ、あるいはその他のバックアップ用メディアにファイルを
  42. コピーします。
  43. restore コマンドは dump とは反対の処理を行います。restore コマンドを使
  44. うとファイルシステムのフルバックアップを復元できます。またフルバックアッ
  45. プからの増分バックアップを適用することもできます。フルバックアップ、ま
  46. たは部分パックアップから、単一のファイルやディレクトリのサブツリーだけ
  47. を復元することもできます。
  48. もしファイルシステムのフルバックアップや復元が必要な場合は、dump をイン
  49. ストールしてください。
  50. %prep
  51. %setup -q
  52. %patch0 -p1 -b .buildfix
  53. %patch3 -p1 -b .rmt-moved-star
  54. for i in THANKS MAINTAINERS COPYRIGHT CHANGES; do
  55. iconv -f iso-8859-1 -t utf-8 $i -o $i.new
  56. touch -r $i $i.new
  57. mv $i.new $i
  58. done
  59. %build
  60. autoreconf -fiv
  61. export CFLAGS="$RPM_OPT_FLAGS -Wall -Wpointer-arith -Wstrict-prototypes \
  62. -Wmissing-prototypes -Wno-char-subscripts -fno-strict-aliasing"
  63. %configure %{myoptions} \
  64. --disable-static \
  65. --enable-largefile \
  66. --disable-rmt \
  67. --enable-readline \
  68. --disable-transselinux
  69. make %{?_smp_mflags}
  70. %install
  71. rm -rf %{buildroot}
  72. mkdir -p %{buildroot}%{_sbindir}
  73. mkdir -p %{buildroot}%{_mandir}/man8
  74. %makeinstall SBINDIR=%{buildroot}%{_sbindir} BINDIR=%{buildroot}%{_sbindir} MANDIR=%{buildroot}%{_mandir}/man8 BINOWNER=$(id -un) BINGRP=$(id -gn) MANOWNER=$(id -un) MANGRP=$(id -gn)
  75. pushd $RPM_BUILD_ROOT
  76. ln -sf dump .%{_sbindir}/rdump
  77. ln -sf restore .%{_sbindir}/rrestore
  78. mkdir -p .%{_sysconfdir}
  79. > .%{_sysconfdir}/dumpdates
  80. popd
  81. %clean
  82. rm -rf %{buildroot}
  83. %files
  84. %defattr(-,root,root)
  85. %doc CHANGES COPYRIGHT KNOWNBUGS MAINTAINERS README REPORTING-BUGS THANKS TODO
  86. %doc dump.lsm
  87. %attr(0664,root,disk) %config(noreplace) %{_sysconfdir}/dumpdates
  88. %attr(0755,root,root) /sbin/dump
  89. /sbin/rdump
  90. %attr(0755,root,root) /sbin/restore
  91. /sbin/rrestore
  92. #/sbin/*.static
  93. %{_mandir}/man8/dump.*
  94. %{_mandir}/man8/rdump.*
  95. %{_mandir}/man8/restore.*
  96. %{_mandir}/man8/rrestore.*
  97. %changelog
  98. * Tue Jun 17 2014 Daisuke SUZUKI <daisuke@vinelinux.org> 0.4b44-2
  99. - remove rmt subpackage, moved to star.
  100. * Sat Aug 27 2011 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.4b44-1
  101. - updated to 0.4b44 (ext4 support in particular)
  102. * Sat Apr 30 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.4b41-3
  103. - rebuild with rpm-4.8.1
  104. - add BuildRequires: libblkid-devel, libuuid-devel, bzip2-devel
  105. * Mon Jun 22 2009 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4b41-2
  106. - spec in UTF-8
  107. - change configure option to --disable-static
  108. - remove -static stuffs
  109. * Sun Apr 27 2008 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4b41-1
  110. - add Patch1 based on fedora development to build with device-mapper
  111. - add japanese summary and description.
  112. - apply new versioning policy.
  113. * Sun May 13 2007 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.4b41-0vl1
  114. - new upstream release
  115. * Fri Oct 15 2004 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.4b34-0vl2
  116. - spec file was in SJIS. fixed.
  117. * Sat Feb 28 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4b34-0vl1
  118. - new upstream release
  119. * Sun Feb 9 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 0.4b28-5vl1
  120. - update upstream release based on rawhide package.
  121. - rebuild on new environment.
  122. * Fri Mar 15 2002 Toru Sagami <sagami@vinelinux.org> 0.4b22-4vl2
  123. - rebuilt against fixed statically linked system libraries
  124. * Sat Jul 14 2001 Toru Sagami <sagami@vinelinux.org>
  125. - 0.4b22-4vl1: based on 0.4b22-4 from Rawhide
  126. * Mon Oct 7 2002 Mike A. Harris <mharris@redhat.com> 0.4b28-5
  127. - All-arch rebuild
  128. * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
  129. - automated rebuild
  130. * Sun May 26 2002 Tim Powers <timp@redhat.com>
  131. - automated rebuild
  132. * Tue May 21 2002 Mike A. Harris <mharris@redhat.com> 0.4b28-2
  133. - Updated to dump 0.4b28
  134. - Removed atomic_read/write patch, not needed anymore
  135. * Fri Mar 1 2002 Mike A. Harris <mharris@redhat.com> 0.4b27-3
  136. - BuildRequires readline-devel >= 4.2 for the rl_completion_matches function
  137. - Added dump-0.4b27-dump-atomic-read-write.patch to avoid namespace conflict
  138. with included kernel headers. atomic_read is a function on s390 and as
  139. such, cannot be #undef'd
  140. * Thu Feb 28 2002 Mike A. Harris <mharris@redhat.com> 0.4b27-2
  141. - Added prereq on "setup" to ensure disk group is created prior to this
  142. package being installed
  143. - Somehow the dump package changelog got hosed, and part of the spec file
  144. regressed. I believe it is fixed now.
  145. * Tue Feb 26 2002 Mike A. Harris <mharris@redhat.com> 0.4b27-1
  146. - Updated to dump 0.4b27-1
  147. * Fri Feb 22 2002 Mike A. Harris <mharris@redhat.com> 0.4b25-5
  148. - Bumped release up a couple notches to rebuild in rawhide
  149. * Thu Feb 21 2002 Mike A. Harris <mharris@redhat.com> 0.4b25-1.72.0
  150. - Rebuilt 0.4b25 for erratum release. Fixes various bugs that have been
  151. reported in bugzilla which are logged below. Also fixes a bug caused by
  152. linking statically to a faulty system library.
  153. - Added Provides dump-static line
  154. * Mon Feb 11 2002 Mike A. Harris <mharris@redhat.com> 0.4b25-3
  155. - Added missing zlib buildprereq
  156. - Rebuild in new environment
  157. * Wed Jan 09 2002 Tim Powers <timp@redhat.com>
  158. - automated rebuild
  159. * Wed Nov 21 2001 Mike A. Harris <mharris@redhat.com> 0.4b25-1
  160. - Updated to version 0.4b25-1
  161. - Added homepage URL for RFE (#54601)
  162. - Also fixed in this release are (#21272, #52663, #56616)
  163. - Dropped time.h patch as it is unneeded now
  164. * Tue Nov 6 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-7
  165. - Updated BuildPreReq to e2fsprogs-devel >= 1.18, readline-devel >= 4.1 to
  166. explicitly state the minimum required deps and fix (#51900)
  167. * Sat Sep 8 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 0.4b22-6
  168. - Kill the static subpackage - the standard binaries are now static
  169. This removes /usb/sbin/*. The static versions are now in /sbin
  170. (#53433)
  171. - Obsolete dump-static
  172. * Tue Aug 14 2001 Trond Eivind Glomsr藷?<teg@redhat.com> 0.4b22-5
  173. - Move non-static binaries to /usr/sbin (#49520)
  174. * Fri Jun 29 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-4
  175. - Added BuildPrereq: readline-devel (#44734 - which was reopened and changed)
  176. * Sat Jun 16 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-3
  177. - Added BuildPrereq: libtermcap-devel (#44734)
  178. * Tue Jun 12 2001 Mike A. Harris <mharris@redhat.com> 0.4b22-2
  179. - Removed release tag from buildroot dirname - messy.
  180. - Broke all lines over multiple lines for readability in specfile.
  181. - Added --enable-largefile configure flags
  182. * Mon Jun 11 2001 Florian La Roche <Florian.LaRoche@redhat.de> 0.4b22-1
  183. - 0.4b22
  184. * Mon May 7 2001 Mike A. Harris <mharris@redhat.com> 0.4b21-5
  185. - Added BuildPrereq: e2fsprogs-devel (#27428)
  186. * Mon Apr 9 2001 Bill Nottingham <notting@redhat.com>
  187. - fix ia64
  188. * Wed Feb 14 2001 Bill Nottingham <notting@redhat.com>
  189. - fix build with current glibc
  190. * Mon Jan 29 2001 Nalin Dahyabhai <nalin@redhat.com>
  191. - change copyright: UCB to License: BSD
  192. * Fri Jan 26 2001 Nalin Dahyabhai <nalin@redhat.com>
  193. - update to 0.4b21.
  194. * Sun Nov 26 2000 Jeff Johnson <jbj@redhat.com>
  195. - update to 0.4b20.
  196. * Fri Nov 10 2000 Stelian Pop <pop@cybercable.fr>
  197. - dump 0.4b20 released, first packaging.
  198. * Tue Oct 31 2000 Jeff Johnson <jbj@redhat.com>
  199. - remove setuid bits for Red Hat 5.x errata.
  200. * Wed Aug 30 2000 Matt Wilson <msw@redhat.com>
  201. - rebuild to cope with glibc locale binary incompatibility, again
  202. * Wed Aug 30 2000 Preston Brown <pbrown@redhat.com>
  203. - fix for dumping files between 2 and 4 gigs (#16466)
  204. * Mon Aug 21 2000 Matt Wilson <msw@redhat.com>
  205. - don't use -O2 on alpha because of compiler ICE
  206. * Sun Aug 20 2000 Jeff Johnson <jbj@redhat.com>
  207. - update to 0.4b19.
  208. * Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
  209. - summaries from specspo.
  210. * Wed Aug 16 2000 Erik Troan <ewt@redhat.com>
  211. - support LABEL= in fstab
  212. * Sat Jul 22 2000 Bill Nottingham <notting@redhat.com>
  213. - if dump/restore aren't set(u|g)id, they don't need group tty (#12670)
  214. * Wed Jul 19 2000 Jakub Jelinek <jakub@redhat.com>
  215. - rebuild to cope with glibc locale binary incompatibility
  216. * Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
  217. - automatic rebuild
  218. * Tue Jun 27 2000 Preston Brown <pbrown@redhat.com>
  219. - whoops I had dump commented out of the file list. fixed.
  220. - dropped suid bits on the static binaries.
  221. - fix char buffer size issue (#11880)
  222. * Mon Jun 19 2000 Preston Brown <pbrown@redhat.com>
  223. - dropped SUID bits
  224. * Tue Jun 6 2000 Jeff Johnson <jbj@redhat.com>
  225. - update to 0.4b17.
  226. - FHS packaging.
  227. * Thu Jun 1 2000 Stelian Pop <pop@cybercable.fr>
  228. - dump 0.4b17 released, first packaging.
  229. * Sat Mar 11 2000 Stelian Pop <pop@cybercable.fr>
  230. - dump 0.4b16 released, first packaging.
  231. * Tue Mar 7 2000 Jeff Johnson <jbj@redhat.com>
  232. - use posix signal handling to preserve dump functionality with libc5.
  233. * Thu Mar 2 2000 Bill Nottingham <notting@redhat.com>
  234. - update to 0.4b15
  235. * Thu Feb 10 2000 Jeff Johnson <jbj@redhat.com>
  236. - dump -0ufB /dev/ftape 1638000 /mnt2 fails to use /mnt2 as tape device (#8036)
  237. * Thu Feb 10 2000 Stelian Pop <pop@cybercable.fr>
  238. - dump 0.4b14 released, first packaging.
  239. * Wed Feb 9 2000 Jeff Johnson <jbj@redhat.com>
  240. - compress man pages.
  241. * Thu Jan 27 2000 Jeff Johnson <jbj@redhat.com>
  242. - update to 0.4b13.
  243. * Fri Jan 21 2000 Stelian Pop <pop@cybercable.fr>
  244. - dump 0.4b13 released, first packaging.
  245. * Mon Jan 10 2000 Jeff Johnson <jbj@redhat.com.
  246. - update to 0.4b12.
  247. * Sat Jan 8 2000 Stelian Pop <pop@cybercable.fr>
  248. - dump 0.4b12 released, first packaging.
  249. * Sun Dec 5 1999 Stelian Pop <pop@cybercable.fr>
  250. - dump 0.4b11 released, first packaging.
  251. * Sat Nov 27 1999 Jeff Johnson <jbj@redhat.com>
  252. - intergrate Stelian's fixes (Thanks!).
  253. * Sun Nov 21 1999 Stelian Pop <pop@cybercable.fr>
  254. - dump 0.4b10 released, first packaging.
  255. * Thu Nov 11 1999 Stelian Pop <pop@cybercable.fr>
  256. - make static versions also for rescue purposes.
  257. * Fri Nov 5 1999 Stelian Pop <pop@cybercable.fr>
  258. - dump 0.4b9 released, first packaging.
  259. * Wed Nov 3 1999 Stelian Pop <pop@cybercable.fr>
  260. - dump 0.4b8 released, first packaging.
  261. * Fri Oct 8 1999 Stelian Pop <pop@cybercable.fr>
  262. - dump 0.4b7 released, first packaging.
  263. * Thu Sep 30 1999 Stelian Pop <pop@cybercable.fr>
  264. - dump 0.4b6 released, first packaging.
  265. * Fri Sep 10 1999 Jeff Johnson <jbj@redhat.com>
  266. - recompile with e2fsprogs = 1.15 (#4962).
  267. * Sat Jul 31 1999 Jeff Johnson <jbj@redhat.com>
  268. - workaround egcs bug (#4281) that caused dump problems (#2989).
  269. - use sigjmp_buf, not jmp_buf (#3260).
  270. - invoke /etc/rmt (instead of rmt) like other unices. (#3272).
  271. - use glibc21 err/glob rather than the internal compatibility routines.
  272. - wire $(OPT) throughout Makefile's.
  273. - fix many printf problems, mostly lint clean.
  274. - merge SuSE, Debian and many OpenBSD fixes.
  275. * Thu Mar 25 1999 Jeff Johnson <jbj@redhat.com>
  276. - remove setuid/setgid bits from /sbin/rmt (dump/restore are OK).
  277. * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
  278. - auto rebuild in the new build environment (release 6)
  279. * Fri Mar 19 1999 Jeff Johnson <jbj@redhat.com>
  280. - strip binaries.
  281. * Thu Mar 18 1999 Jeff Johnson <jbj@redhat.com>
  282. - Fix dangling symlinks (#1551).
  283. * Wed Mar 17 1999 Michael Maher <mike@redhat.com>
  284. - Top O' the morning, build root's fixed for man pages.
  285. * Fri Feb 19 1999 Preston Brown <pbrown@redhat.com>
  286. - upgraded to dump 0.4b4, massaged patches.
  287. * Tue Feb 02 1999 Ian A Cameron <I.A.Cameron@open.ac.uk>
  288. - added patch from Derrick J Brashear for traverse.c to stop bread errors
  289. * Wed Jan 20 1999 Jeff Johnson <jbj@redhat.com>
  290. - restore original 6755 root.tty to dump/restore, defattr did tty->root (#684).
  291. - mark /etc/dumpdates as noreplace.
  292. * Tue Jul 14 1998 Jeff Johnson <jbj@redhat.com>
  293. - add build root.
  294. * Tue May 05 1998 Prospector System <bugs@redhat.com>
  295. - translations modified for de, fr, tr
  296. * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
  297. - added a patch for resolving linux/types.h and sys/types.h conflicts
  298. * Wed Dec 31 1997 Erik Troan <ewt@redhat.com>
  299. - added prototype of llseek() so dump would work on large partitions
  300. * Thu Oct 30 1997 Donnie Barnes <djb@redhat.com>
  301. - made all symlinks relative instead of absolute
  302. * Thu Jul 10 1997 Erik Troan <ewt@redhat.com>
  303. - built against glibc
  304. * Thu Mar 06 1997 Michael K. Johnson <johnsonm@redhat.com>
  305. - Moved rmt to its own package.
  306. * Tue Feb 11 1997 Michael Fulbright <msf@redhat.com>
  307. - Added endian cleanups for SPARC
  308. * Fri Feb 07 1997 Michael K. Johnson <johnsonm@redhat.com>
  309. - Made /etc/dumpdates writeable by group disk.