fcgi-vl.spec 4.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169
  1. #define snap -SNAP-0910052249
  2. Summary: FastCGI development kit
  3. Summary(ja): FastCGI 開発キット
  4. Name: fcgi
  5. Version: 2.4.2
  6. Release: 2%{?_dist_release}
  7. Group: programming
  8. License: BSD
  9. URL: https://github.com/FastCGI-Archives/fcgi2
  10. Source0: https://github.com/FastCGI-Archives/fcgi2/archive/%{version}.tar.gz#/fcgi-%{version}%{?snap}.tar.gz
  11. Source1: fcgi-autogen.sh
  12. Patch0: fcgi-2.4.0-autotools.patch
  13. # Patch0 created with Source1 after patching Patch1 and Patch2
  14. #Patch1: fcgi-2.4.0-configure.in.patch
  15. #Patch2: fcgi-2.4.0-Makefile.am-CPPFLAGS.patch
  16. Patch3: fcgi-2.4.0-gcc44_fixes.patch
  17. # for -perl
  18. BuildRequires: perl(ExtUtils::MakeMaker)
  19. # don't "provide" private Perl libs
  20. %global __provides_exclude_from %{perl_vendorarch}.*\\.so$
  21. %description
  22. FastCGI is a language independent, scalable, open extension to CGI that
  23. provides high performance without the limitations of server specific APIs.
  24. %package devel
  25. Summary: Development files for %{name}
  26. Summary(ja): Development files for %{name}
  27. Group: programming
  28. Requires: %{name} = %{version}-%{release}
  29. %description devel
  30. The %{name}-devel package contains libraries and header files for
  31. developing applications that use %{name}.
  32. %package perl
  33. Summary: Perl bindings for %{name}
  34. Summary(ja): Perl bindings for %{name}
  35. Group: programming
  36. Requires: %{name} = %{version}-%{release}
  37. Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
  38. %description perl
  39. The %{name}-perl package contains the perl bindings for fcgi.
  40. %debug_package
  41. %prep
  42. %setup -q -n "fcgi2-%{version}%{?snap}"
  43. #%patch0 -p1
  44. %patch3 -p1
  45. # remove DOS End Of Line Encoding
  46. sed -i 's/\r//' doc/fastcgi-prog-guide/ch2c.htm
  47. # fix file permissions
  48. chmod a-x include/fcgios.h libfcgi/os_unix.c
  49. autoreconf -ivf
  50. %build
  51. %configure
  52. # does not build with parallel make flags
  53. make
  54. %install
  55. %{__rm} -rf %{buildroot}
  56. %{__mkdir_p} %{buildroot}
  57. make install DESTDIR=%{buildroot}
  58. %{__rm} -fv %{buildroot}/%{_libdir}/libfcgi{++,}.{l,}a
  59. install -p -m 0644 -D doc/cgi-fcgi.1 %{buildroot}/%{_mandir}/man1/cgi-fcgi.1
  60. for manpage in doc/*.3
  61. do
  62. install -p -m 0644 -D $manpage %{buildroot}%{_mandir}/man3/$(basename $manpage)
  63. done
  64. %{__rm} -f -- doc/*.1
  65. %{__rm} -f -- doc/*.3
  66. %clean
  67. rm -rf $RPM_BUILD_ROOT
  68. %files
  69. %defattr(-,root,root,-)
  70. %{_bindir}/cgi-fcgi
  71. %{_libdir}/libfcgi.so.*
  72. %{_libdir}/libfcgi++.so.*
  73. %{_mandir}/man1/*
  74. %defattr(0644,root,root,0755)
  75. %license LICENSE.TERMS
  76. %doc README
  77. %files devel
  78. %defattr(-,root,root,-)
  79. %{_includedir}/*
  80. %{_libdir}/libfcgi.so
  81. %{_libdir}/libfcgi++.so
  82. %{_libdir}/pkgconfig/*
  83. %{_mandir}/man3/*
  84. %defattr(0644,root,root,0755)
  85. %doc doc/
  86. %changelog
  87. * Sat Nov 27 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.2-2
  88. - dropped ldconfig scriptlets.
  89. * Sat Apr 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.2-1
  90. - new upstream release.
  91. - dropped Patch4: fixed in upstream.
  92. * Thu Sep 01 2016 Toshiaki Ara <ara_t@384.jp> 2.4.1-3
  93. - rebuild with gcc-5.4.0
  94. * Mon Dec 21 2015 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.1-2
  95. - made to use internal dependency generator.
  96. * Tue Jul 8 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.4.1-1
  97. - new upstream release.
  98. - removed perl binding (not used).
  99. * Sun Apr 3 2011 IWAI, Masaharu <iwai@alib.jp> 2.4.0-2vl6
  100. - build with perl 5.12.3
  101. * Sat Jul 25 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
  102. - initial build for Vine Linux
  103. * Sun Mar 01 2009 Chris Weyl <cweyl@alumni.drew.edu> - 2.4.0-9
  104. - Stripping bad provides of private Perl extension libs
  105. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.4.0-8
  106. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  107. * Sun Feb 15 2009 Till Maas <opensource@till.name> - 2.4.0-7
  108. - Add missing #include <cstdio> to make it compile with gcc 4.4
  109. * Tue Oct 14 2008 Chris Weyl <cweyl@alumni.drew.edu> - 2.4.0-6
  110. - package up the perl bindings in their own subpackage
  111. * Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 2.4.0-5
  112. - Autorebuild for GCC 4.3
  113. * Thu Aug 23 2007 Till Maas <opensource till name> - 2.4.0-4
  114. - bump release for rebuild
  115. * Wed Jul 11 2007 Till Maas <opensource till name> - 2.4.0-3
  116. - remove parallel make flags
  117. * Tue Apr 17 2007 Till Maas <opensource till name> - 2.4.0-2
  118. - add some documentation
  119. - add mkdir ${RPM_BUILD_ROOT} to %%install
  120. - install man-pages
  121. * Mon Mar 5 2007 Till Maas <opensource till name> - 2.4.0-1
  122. - Initial spec for fedora