gc-vl.spec 4.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. Summary: Garbage Collector for C and C++
  3. Summary(ja): C, C++ ガーベージコレクションライブラリ
  4. Name: gc
  5. Version: 8.2.2
  6. Release: 1%{?_dist_release}
  7. Group: system
  8. Vendor: Project Vine
  9. Distribution: Vine Linux
  10. Packager: inagaki
  11. License: BSD
  12. URL: https://www.hboehm.info/gc/
  13. Source: https://www.hboehm.info/gc/gc_source/%{name}-%{version}.tar.gz
  14. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  15. BuildRequires: libatomic_ops-devel
  16. #Patch1: gc-6.4-opendl.patch
  17. %description
  18. The Boehm-Demers-Weiser conservative garbage collector can be used as a garbage
  19. collecting replacement for C malloc or C++ new.
  20. %package devel
  21. Summary: Libraries and header files for gc development
  22. Summary(ja): gc の開発用ライブラリおよびヘッダファイル
  23. Group: programming
  24. Requires: %{name} = %{version}-%{release}
  25. %description devel
  26. Libraries and header files for gc development.
  27. ## to build compat32 for x86_64 architecture support
  28. %package -n compat32-%{name}
  29. Summary: Garbage Collector for C and C++
  30. Group: system,legacy
  31. Requires: %{name} = %{version}-%{release}
  32. %description -n compat32-%{name}
  33. The Boehm-Demers-Weiser conservative garbage collector can be used as a garbage
  34. collecting replacement for C malloc or C++ new.
  35. %package -n compat32-%{name}-devel
  36. Summary: Libraries and header files for gc development
  37. Group: programming,legacy
  38. Requires: compat32-%{name} = %{version}-%{release}
  39. Requires: %{name}-devel = %{version}-%{release}
  40. %description -n compat32-%{name}-devel
  41. Libraries and header files for gc development.
  42. %debug_package
  43. %prep
  44. %setup -q
  45. %build
  46. %configure \
  47. --enable-cplusplus \
  48. --disable-static \
  49. --disable-dependency-tracking \
  50. --enable-large-config \
  51. --enable-threads=posix
  52. make %{?_smp_mflags}
  53. %install
  54. rm -rf $RPM_BUILD_ROOT
  55. make DESTDIR=$RPM_BUILD_ROOT install
  56. mkdir -p $RPM_BUILD_ROOT%{_mandir}/man3
  57. install -m644 doc/gc.man $RPM_BUILD_ROOT%{_mandir}/man3/gc.3
  58. ## Unpackaged files
  59. rm -rf $RPM_BUILD_ROOT%{_datadir}/gc
  60. rm -f $RPM_BUILD_ROOT%{_libdir}/lib*.la
  61. rm -rf $RPM_BUILD_ROOT%{_docdir}/gc
  62. mv -f README.QUICK LICENSE
  63. %check
  64. make check
  65. %clean
  66. rm -rf $RPM_BUILD_ROOT
  67. %files
  68. %defattr(-,root,root)
  69. %license LICENSE
  70. %doc ChangeLog doc/README*
  71. %{_libdir}/lib*.so.*
  72. %files devel
  73. %defattr(-,root,root)
  74. %doc doc/*.md
  75. %dir %{_includedir}/gc
  76. %{_includedir}/gc.h
  77. %{_includedir}/gc_cpp.h
  78. %{_includedir}/gc/*
  79. %{_libdir}/lib*.so
  80. %{_libdir}/pkgconfig/*.pc
  81. %{_mandir}/man?/*
  82. ## to build compat32 for x86_64 architecture support
  83. %if %{build_compat32}
  84. %files -n compat32-%{name}
  85. %defattr(-,root,root)
  86. %{_libdir}/lib*.so.*
  87. %files -n compat32-%{name}-devel
  88. %defattr(-,root,root)
  89. %{_libdir}/lib*.so
  90. %endif
  91. %changelog
  92. * Fri Nov 18 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.2.2-1
  93. - new upstream release.
  94. - dropped ldconfig scriptlets.
  95. * Tue Sep 10 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 8.0.4-1
  96. - updated to 8.0.4.
  97. * Fri Jul 1 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.4.4-1
  98. - updated to 7.4.4.
  99. * Sun Jan 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.2f-1
  100. - update to 7.2f
  101. * Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.2e-1
  102. - new upstream release
  103. * Sun Oct 03 2010 Shu KONNO <owa@bg.wakwak.com> 7.1-3
  104. - rebuilt with rpm-4.8.1 for pkg-config
  105. * Sun Jul 05 2009 NAKAMURA Kenta <kenta@vinelinux.org> 7.1-2
  106. - removed unneccesary %if !%{build_compat32} case condition
  107. * Wed Jun 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.1-1
  108. - new upstream release
  109. * Wed Apr 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.0-2
  110. - spec in utf-8
  111. - remove static library
  112. - add --enable-large-config --enable-threads=posix
  113. * Wed Apr 30 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.0-1
  114. - new upstream release
  115. * Sat Feb 10 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.8-0vl1
  116. - new upstream release
  117. * Wed Jul 19 2006 Shu KONNO <owa@bg.wakwak.com> 6.6-0vl2
  118. - added compat32-* packages for x86_64 architecture support
  119. * Thu Feb 09 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 6.6-0vl1
  120. - new upstream release
  121. * Tue May 03 2005 Satoshi MACHINO <machino@vinelinux.org> 6.4-0vl1
  122. - new upstream release
  123. -- updated patch1
  124. * Sun Jan 18 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 6.2-0vl1
  125. - initial build for Vine Linux