gdk-pixbuf2-vl.spec 9.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336
  1. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  2. %define _unpackaged_files_terminate_build 1
  3. # biarch support
  4. %define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
  5. %define _query_suffix %{nil}
  6. %if %{build_compat32}
  7. %define _query_suffix -32
  8. %endif
  9. Name: gdk-pixbuf2
  10. Summary: An image loading library
  11. Version: 2.42.9
  12. Release: 1%{?_dist_release}
  13. Group: system
  14. Vendor: Project Vine
  15. Distribution: Vine Linux
  16. License: LGPLv2+
  17. URL: http://www.gtk.org
  18. %global shortver %(echo %{version} | cut -d . -f 1,2)
  19. Source: https://download.gnome.org/sources/gdk-pixbuf/%{shortver}/gdk-pixbuf-%{version}.tar.xz
  20. BuildRequires: meson
  21. BuildRequires: glib2-devel >= 2.36.0
  22. BuildRequires: libpng-devel
  23. BuildRequires: libjpeg-turbo-devel
  24. BuildRequires: libtiff-devel
  25. BuildRequires: gobject-introspection-devel
  26. BuildRequires: python3-docutils
  27. BuildConflicts: jasper-devel
  28. # gdk-pixbuf does a configure time check which uses the GIO mime
  29. # layer; we need to actually have the mime type database.
  30. BuildRequires: shared-mime-info
  31. BuildRequires: gtk-doc
  32. ## BuildRequires: libtool >= 2.2.10
  33. BuildRequires: libtool
  34. BuildRequires: gettext
  35. # We also need MIME information at runtime
  36. Requires: shared-mime-info
  37. # gdk-pixbuf was included in gtk2 until 2.21.2
  38. Conflicts: gtk2 <= 2.21.2
  39. # https://bugzilla.gnome.org/show_bug.cgi?id=624712
  40. Patch0: 0001-Fix-linking-when-libpng-loader-is-builtin.patch
  41. %description
  42. gdk-pixbuf is an image loading library that can be extended by loadable
  43. modules for new image formats. It is used by toolkits such as GTK+ or
  44. clutter.
  45. %package devel
  46. Summary: Development files for gdk-pixbuf
  47. Group: programming
  48. Requires: %{name} = %{version}-%{release}
  49. Requires: glib2-devel
  50. Requires: gobject-introspection-devel
  51. Requires: libpng-devel
  52. # gdk-pixbuf was included in gtk2 until 2.21.2
  53. Conflicts: gtk2-devel <= 2.21.2
  54. %description devel
  55. This package contains the libraries and header files that are needed
  56. for writing applications that are using gdk-pixbuf.
  57. %if %{build_compat32}
  58. #######################################################################
  59. # compat32
  60. %package -n compat32-%{name}
  61. Summary: An image loading library
  62. Group: system,legacy
  63. Requires(post): compat32-glib2
  64. # gdk-pixbuf was included in gtk2 until 2.21.2
  65. Conflicts: compat32-gtk2 <= 2.21.2
  66. %description -n compat32-%{name}
  67. gdk-pixbuf is an image loading library that can be extended by loadable
  68. modules for new image formats. It is used by toolkits such as GTK+ or
  69. clutter.
  70. %package -n compat32-%{name}-devel
  71. Summary: Development files for gdk-pixbuf
  72. Group: programming,legacy
  73. Requires: compat32-%{name} = %{version}-%{release}
  74. Requires: %{name} = %{version}-%{release}
  75. Requires: compat32-libpng-devel
  76. # gdk-pixbuf was included in gtk2 until 2.21.2
  77. Conflicts: compat32-gtk2-devel <= 2.21.2
  78. %description -n compat32-%{name}-devel
  79. This package contains the libraries and header files that are needed
  80. for writing applications that are using gdk-pixbuf.
  81. %endif
  82. %debug_package
  83. %prep
  84. %setup -q -n gdk-pixbuf-%{version}
  85. ## %patch0 -p1 -b .libpng-linking
  86. %build
  87. %meson \
  88. -Dbuiltin_loaders=png \
  89. -Dinstalled_tests=false \
  90. -Dgtk_doc=false
  91. %meson_build
  92. %install
  93. %meson_install
  94. touch %{buildroot}%{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
  95. %if %{build_compat32}
  96. cp %{buildroot}%{_bindir}/gdk-pixbuf-query-loaders \
  97. %{buildroot}%{_bindir}/gdk-pixbuf-query-loaders%{_query_suffix}
  98. %endif
  99. %find_lang gdk-pixbuf
  100. %transfiletriggerin -- %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
  101. gdk-pixbuf-query-loaders --update-cache || : > /dev/null 2>&1
  102. %transfiletriggerpostun -- %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
  103. gdk-pixbuf-query-loaders --update-cache || : > /dev/null 2>&1
  104. %if %{build_compat32}
  105. %transfiletriggerin -n compat32-%{name} -- %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
  106. gdk-pixbuf-query-loaders%{_query_suffix} --update-cache || : > /dev/null 2>&1
  107. %transfiletriggerpostun -n compat32-%{name} -- %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
  108. gdk-pixbuf-query-loaders%{_query_suffix} --update-cache || : > /dev/null 2>&1
  109. %endif
  110. %files -f gdk-pixbuf.lang
  111. %defattr(-,root,root,-)
  112. %license COPYING
  113. %doc NEWS README.md
  114. %{_bindir}/gdk-pixbuf-pixdata
  115. %{_bindir}/gdk-pixbuf-thumbnailer
  116. %{_libdir}/libgdk_pixbuf-2.0.so.*
  117. %{_libdir}/girepository-1.0
  118. %dir %{_libdir}/gdk-pixbuf-2.0
  119. %dir %{_libdir}/gdk-pixbuf-2.0/2.10.0
  120. %dir %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
  121. %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.so
  122. %ghost %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
  123. %{_bindir}/gdk-pixbuf-query-loaders
  124. %{_mandir}/man1/gdk-pixbuf-query-loaders.1.gz
  125. %{_datadir}/thumbnailers/gdk-pixbuf-thumbnailer.thumbnailer
  126. %files devel
  127. %defattr(-,root,root,-)
  128. %{_includedir}/gdk-pixbuf-2.0
  129. %{_libdir}/libgdk_pixbuf-2.0.so
  130. %{_libdir}/pkgconfig/gdk-pixbuf-2.0.pc
  131. %{_bindir}/gdk-pixbuf-csource
  132. #{_datadir}/gtk-doc/html/*
  133. %{_datadir}/gir-1.0
  134. %{_mandir}/man1/gdk-pixbuf-csource.1.gz
  135. %if %{build_compat32}
  136. %files -n compat32-%{name}
  137. %defattr(-,root,root,-)
  138. %{_libdir}/libgdk_pixbuf-2.0.so.*
  139. %dir %{_libdir}/gdk-pixbuf-2.0
  140. %dir %{_libdir}/gdk-pixbuf-2.0/2.10.0
  141. %dir %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders
  142. %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders/*.so
  143. %ghost %{_libdir}/gdk-pixbuf-2.0/2.10.0/loaders.cache
  144. %{_bindir}/gdk-pixbuf-query-loaders%{_query_suffix}
  145. %files -n compat32-%{name}-devel
  146. %defattr(-,root,root,-)
  147. %{_libdir}/libgdk_pixbuf-2.0.so
  148. %endif
  149. %changelog
  150. * Thu Aug 11 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.42.9-1
  151. - new upstream release.
  152. * Sun Apr 11 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.42.6-1
  153. - new upstream release.
  154. * Sat Apr 03 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.42.4-1
  155. - new upstream release.
  156. - dropped ldconfig scriptlets.
  157. * Mon Mar 08 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.42.2-1
  158. - new upstream release.
  159. - updated %%post{,un} and trigger scripts.
  160. * Sat May 09 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.40.0-1
  161. - new upstream release.
  162. * Sat Jan 06 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.36.11-1
  163. - new upstream release.
  164. - disabled JPEG2000: jasper is too buggy and not fully implemented.
  165. * Thu Jul 14 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.34.0-1
  166. - new upstream release
  167. * Sat Dec 19 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.3-1
  168. - new upstream release
  169. * Fri Nov 13 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.2-1
  170. - new upstream release
  171. * Sat Oct 10 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.32.1-1
  172. - new upstream release
  173. * Sun Aug 30 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.31.6-1
  174. - new upstream release
  175. * Thu May 14 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.31.4-1
  176. - new upstream release
  177. * Sat Mar 28 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.31.3-1
  178. - new upstream release
  179. * Mon Nov 24 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.31.2-1
  180. - new upstream release
  181. * Sun Oct 26 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.31.1-1
  182. - new upstream release
  183. * Sun Jul 13 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.8-2
  184. - rebuild with libpng-1.6.12
  185. * Fri Jun 06 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.8-1
  186. - new upstream release
  187. * Fri Mar 28 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.7-1
  188. - new upstream release
  189. * Sat Feb 08 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.4-1
  190. - new upstream release
  191. * Sat Jan 25 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.3-1
  192. - new upstream release
  193. * Tue Dec 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
  194. - new upstream release
  195. * Sun Nov 24 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
  196. - new upstream release
  197. * Sat Oct 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
  198. - new upstream release
  199. * Sun Jun 09 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.2-1
  200. - new upstream release
  201. * Wed Apr 17 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.28.1-1
  202. - new upstream release
  203. * Sat Nov 10 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.5-1
  204. - new upstream release
  205. * Wed Sep 26 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.4-1
  206. - new upstream release
  207. * Fri Aug 17 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.2-1
  208. - new upstream release
  209. * Sun Apr 22 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.26.1-1
  210. - new upstream release
  211. * Fri Dec 23 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.1-1
  212. - new upstream release
  213. - add configure option (--with-x11)
  214. * Sat Sep 03 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.24.0-1
  215. - new upstream release
  216. * Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.23.5-1
  217. - new upstream release
  218. * Sat Nov 20 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.1-1
  219. - new upstream release
  220. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.22.0-1
  221. - new upstream release
  222. - add configure option (--enable-introspection=yes)
  223. - drop Patch0
  224. * Sat Oct 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.3-1
  225. - initial build for Vine Linux
  226. * Mon Jul 19 2010 Bastien Nocera <bnocera@redhat.com> 2.21.6-3
  227. - Require libpng for linking
  228. * Thu Jul 15 2010 Colin Walters <walters@verbum.org> - 2.21.6-2
  229. - Rebuild with new gobject-introspection
  230. * Mon Jul 12 2010 Matthias Clasen <mclasen@redhat.com> - 2.21.6-1
  231. - Update to 2.21.6
  232. * Fri Jul 2 2010 Colin Walters <walters@verbum.org> - 2.21.5-4
  233. - Also Require shared-mime-info for same reason
  234. * Fri Jul 2 2010 Colin Walters <walters@verbum.org> - 2.21.5-3
  235. - BR shared-mime-info; see comment above it
  236. * Tue Jun 29 2010 Colin Walters <walters@pocket> - 2.21.5-2
  237. - Changes to support snapshot builds
  238. * Mon Jun 28 2010 Matthias Clasen <mclasen@redhat.com> 2.21.5-1
  239. - Update to 2.21.5
  240. * Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.4-2
  241. - Rename to gdk-pixbuf2 to avoid conflict with the
  242. existing gdk-pixbuf package
  243. * Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.4-1
  244. - Update to 2.21.4
  245. - Incorporate package review feedback
  246. * Sat Jun 26 2010 Matthias Clasen <mclasen@redhat.com> 2.21.3-1
  247. - Initial packaging