123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398399400401402403404405406407408409410411412413414415416417418419420421422423424425426427428429430431432433434435436437438439440441442443444445446447448449450451452453454455456457458459460461462463464465466467468469470471472473474475476477478479480481482483484485486487488489490491492493494495496497498499500501502503504505506507508509510511512513514515516517518519520521522523524525526527528529530531532533534535536537538539540541542543544545546547548549550551552553554555556557558559560561562563564565566567568569570571572573574575576577578579580581582583584585586587588589590591592593594595596597598599600601602603604605606607608609610611612613614615616617618619620621622623624625626627628629630631632633634635636637638639640641642643644645646647648649650651652653654655656657658659660661662663664665666667668669670671672673674675676677678679680681682683684685686687688689690691692693694695696697698699700701702703704705706707708709710711712713714715716717718719720721722723724725726727728729730731732733734735736737738739740741742743744745746747748749750751752753754755756757758759760761762763764765766767768769770771772773774775776777778779780781782783784 |
- %global glib2_version 2.56.0
- %global gtk3_version 3.22.4
- %global json_glib_version 1.2.0
- %global packagekit_version 1.1.1
- %global appstream_glib_version 0.7.14-3
- %global libsoup_version 2.52.0
- %global gsettings_desktop_schemas_version 3.12.0
- %global gnome_desktop_version 3.18.0
- %global fwupd_version 1.0.7
- %global flatpak_version 0.9.4
- Summary: A software center for GNOME
- Name: gnome-software
- Version: 3.36.1
- Release: 2%{?_dist_release}
- Group: admin-tools,desktop-gnome
- Vendor: Project Vine
- Distribution: Vine Linux
- License: GPLv2+
- URL: https://wiki.gnome.org/Apps/Software
- %global shortver %(echo %{version} | sed -e 's/\.[0-9]*$//')
- Source0: https://download.gnome.org/sources/gnome-software/%{shortver}/%{name}-%{version}.tar.xz
- # /usr/share/pixmaps/backgrounds/Vine/vinelinux7-7-1920x1200.jpg from vine-backgrounds
- Source1: vine.jpg
- BuildRequires: gcc
- BuildRequires: gettext
- BuildRequires: libxslt
- BuildRequires: docbook-style-xsl
- BuildRequires: desktop-file-utils
- #BuildRequires: fwupd-devel >= %{fwupd_version}
- BuildRequires: glib2-devel >= %{glib2_version}
- BuildRequires: gnome-desktop3-devel
- BuildRequires: gnome-online-accounts-devel
- BuildRequires: gsettings-desktop-schemas-devel >= %{gsettings_desktop_schemas_version}
- BuildRequires: gspell-devel
- BuildRequires: gtk3-devel >= %{gtk3_version}
- BuildRequires: gtk-doc
- BuildRequires: json-glib-devel >= %{json_glib_version}
- BuildRequires: libappstream-glib-devel >= %{appstream_glib_version}
- BuildRequires: libsoup-devel
- BuildRequires: libxmlb-devel
- BuildRequires: meson
- BuildRequires: PackageKit-devel >= %{packagekit_version}
- BuildRequires: polkit-devel
- BuildRequires: libsecret-devel
- BuildRequires: flatpak-devel >= %{flatpak_version}
- BuildRequires: ostree-devel
- #BuildRequires: rpm-ostree-devel
- BuildRequires: libgudev-devel
- #BuildRequires: valgrind-devel
- Requires: appstream-data
- Requires: flatpak%{?_isa} >= %{flatpak_version}
- Requires: flatpak-libs%{?_isa} >= %{flatpak_version}
- #Requires: fwupd%{?_isa} >= %{fwupd_version}
- Requires: glib2%{?_isa} >= %{glib2_version}
- Requires: gnome-desktop3%{?_isa} >= %{gnome_desktop_version}
- # gnome-menus is needed for app folder .directory entries
- Requires: gnome-menus%{?_isa}
- Requires: gsettings-desktop-schemas%{?_isa} >= %{gsettings_desktop_schemas_version}
- Requires: gtk3%{?_isa} >= %{gtk3_version}
- Requires: json-glib%{?_isa} >= %{json_glib_version}
- Requires: iso-codes
- Requires: libappstream-glib%{?_isa} >= %{appstream_glib_version}
- # librsvg2 is needed for gdk-pixbuf svg loader
- Requires: librsvg2%{?_isa}
- Requires: libsoup%{?_isa} >= %{libsoup_version}
- Requires: PackageKit%{?_isa} >= %{packagekit_version}
- # this is not a library version
- %define gs_plugin_version 13
- %description
- gnome-software is an application that makes it easy to add, remove
- and update software in the GNOME desktop.
- %package devel
- Summary: Headers for building external gnome-software plugins
- Group: programming
- Requires: %{name}%{?_isa} = %{version}-%{release}
- %description devel
- These development files are for building gnome-software plugins outside
- the source tree. Most users do not need this subpackage installed.
- %prep
- %autosetup -p1
- %build
- %meson \
- -Dsnap=false \
- -Dgudev=true \
- -Dpackagekit=true \
- -Dexternal_appstream=true \
- %if 0
- -Drpm_ostree=true \
- %else
- -Drpm_ostree=false \
- %endif
- -Dmalcontent=false \
- -Dtests=false \
- -Dubuntuone=false \
- -Dubuntu_reviews=false \
- -Dfwupd=false \
- -Dvalgrind=false
- %meson_build
- %install
- %meson_install
- # make the software center load faster
- desktop-file-edit %{buildroot}%{_datadir}/applications/org.gnome.Software.desktop \
- --set-key=X-AppInstall-Package --set-value=%{name}
- %if 0
- # set up for Fedora
- cat >> %{buildroot}%{_datadir}/glib-2.0/schemas/org.gnome.software-fedora.gschema.override << FOE
- [org.gnome.software]
- official-repos = [ 'fedora', 'fedora-debuginfo', 'fedora-source', 'koji-override-0', 'koji-override-1', 'rawhide', 'rawhide-debuginfo', 'rawhide-source', 'updates', 'updates-debuginfo', 'updates-source', 'updates-testing', 'updates-testing-debuginfo', 'updates-testing-source', 'fedora-modular', 'fedora-modular-debuginfo', 'fedora-modular-source', 'rawhide-modular', 'rawhide-modular-debuginfo', 'rawhide-modular-source' ]
- FOE
- %endif
- # Install upgrade background image
- mkdir -p %{buildroot}%{_datadir}/gnome-software/backgrounds
- cp -a %{SOURCE1} %{buildroot}%{_datadir}/gnome-software/backgrounds/
- rm -rf %{buildroot}%{_docdir}/gnome-software
- %find_lang %name --with-gnome
- %check
- desktop-file-validate %{buildroot}%{_datadir}/applications/*.desktop
- %post
- if [ $1 -eq 1 ]; then
- glib-compile-schemas /usr/share/glib-2.0/schemas ||:
- update-desktop-database -q > /dev/null || :
- fi
- %postun
- if [ $1 -eq 0 ]; then
- glib-compile-schemas /usr/share/glib-2.0/schemas ||:
- update-desktop-database -q > /dev/null || :
- fi
- %files -f %{name}.lang
- %doc AUTHORS README.md
- %license COPYING
- %{_bindir}/gnome-software
- %{_datadir}/applications/gnome-software-local-file.desktop
- %{_datadir}/applications/org.gnome.Software.desktop
- %{_mandir}/man1/gnome-software.1.gz
- %{_datadir}/icons/hicolor/*/apps/*
- %{_datadir}/icons/hicolor/scalable/status/software-installed-symbolic.svg
- %dir %{_datadir}/gnome-software
- %{_datadir}/gnome-software/*.png
- %{_datadir}/gnome-software/backgrounds/
- %{_datadir}/gnome-software/featured-*.svg
- %{_datadir}/gnome-software/featured-*.jpg
- %{_datadir}/metainfo/org.gnome.Software.appdata.xml
- %{_datadir}/metainfo/org.gnome.Software.Plugin.Flatpak.metainfo.xml
- %if 0
- %{_datadir}/metainfo/org.gnome.Software.Plugin.Fwupd.metainfo.xml
- %endif
- %{_datadir}/metainfo/org.gnome.Software.Plugin.Odrs.metainfo.xml
- %{_datadir}/polkit-1/actions/org.gnome.software.external-appstream.policy
- %dir %{_libdir}/gs-plugins-%{gs_plugin_version}
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_appstream.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_desktop-categories.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_desktop-menu-path.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_dpkg.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_dummy.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_fedora-pkgdb-collections.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_flatpak.so
- %if 0
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_fwupd.so
- %endif
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_external-appstream.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_fedora-langpacks.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_generic-updates.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_hardcoded-blacklist.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_hardcoded-popular.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_icons.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_key-colors-metadata.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_key-colors.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_modalias.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_odrs.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_os-release.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-history.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-local.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-offline.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-proxy.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-refine-repos.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-refine.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-refresh.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-upgrade.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit-url-to-app.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_packagekit.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_provenance-license.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_provenance.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_repos.so
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_rewrite-resource.so
- %if 0
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_rpm-ostree.so
- %endif
- %{_libdir}/gs-plugins-%{gs_plugin_version}/libgs_plugin_systemd-updates.so
- %{_sysconfdir}/xdg/autostart/gnome-software-service.desktop
- %{_datadir}/app-info/xmls/org.gnome.Software.Featured.xml
- %{_datadir}/dbus-1/services/org.freedesktop.PackageKit.service
- %{_datadir}/dbus-1/services/org.gnome.Software.service
- %{_datadir}/gnome-shell/search-providers/org.gnome.Software-search-provider.ini
- %{_datadir}/glib-2.0/schemas/org.gnome.software.gschema.xml
- %if 0
- %{_datadir}/glib-2.0/schemas/org.gnome.software-fedora.gschema.override
- %endif
- %{_libexecdir}/gnome-software-cmd
- %{_libexecdir}/gnome-software-install-appstream
- %{_libexecdir}/gnome-software-restarter
- %files devel
- %{_libdir}/pkgconfig/gnome-software.pc
- %dir %{_includedir}/gnome-software
- %{_includedir}/gnome-software/*.h
- %{_datadir}/gtk-doc/html/gnome-software
- %changelog
- * Fri Aug 14 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.36.1-2
- - added R:appstream-data.
- * Tue Aug 04 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.36.1-1
- - new upstream release.
- * Mon Sep 23 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.30.6-5
- - initial build for Vine Linux.
- * Tue May 07 2019 Kalev Lember <klember@redhat.com> - 3.30.6-4
- - Fix distro upgrade progress bar to actually work
- * Sun Apr 28 2019 Kalev Lember <klember@redhat.com> - 3.30.6-3
- - Add artwork for F30 upgrades
- * Mon Feb 25 2019 Kalev Lember <klember@redhat.com> - 3.30.6-2
- - Backport various fixes to error messages to avoid the dreaded
- "Unable to update '(null)'" error
- * Tue Dec 18 2018 Kalev Lember <klember@redhat.com> - 3.30.6-1
- - Update to 3.30.6
- * Wed Oct 24 2018 Kalev Lember <klember@redhat.com> - 3.30.5-1
- - Update to 3.30.5
- * Thu Oct 18 2018 Kalev Lember <klember@redhat.com> - 3.30.3-1
- - Update to 3.30.3
- * Fri Oct 05 2018 Kalev Lember <klember@redhat.com> - 3.30.2-1
- - Update to 3.30.2
- * Wed Sep 26 2018 Kalev Lember <klember@redhat.com> - 3.30.1-2
- - Add modular repos to official repos list
- * Tue Sep 25 2018 Kalev Lember <klember@redhat.com> - 3.30.1-1
- - Update to 3.30.1
- * Thu Sep 06 2018 Kalev Lember <klember@redhat.com> - 3.30.0-1
- - Update to 3.30.0
- * Tue Aug 28 2018 Richard Hughes <rhughes@redhat.com> - 3.29.92-1
- - Update to 3.29.92
- * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.29.1-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
- * Wed May 09 2018 Kalev Lember <klember@redhat.com> - 3.29.1-1
- - Update to 3.29.1
- * Mon Apr 09 2018 Kalev Lember <klember@redhat.com> - 3.28.1-1
- - Update to 3.28.1
- * Thu Mar 29 2018 Kalev Lember <klember@redhat.com> - 3.28.0-5
- - Fix empty OS Updates showing up
- - Make rpm-ostree update triggering work
- * Thu Mar 15 2018 Kalev Lember <klember@redhat.com> - 3.28.0-4
- - Fix opening results from gnome-shell search provider
- * Wed Mar 14 2018 Kalev Lember <klember@redhat.com> - 3.28.0-3
- - Fix crash on initial run with no network (#1554986)
- * Tue Mar 13 2018 Kalev Lember <klember@redhat.com> - 3.28.0-2
- - Backport an upstream patch to fix shell extensions app ID
- * Mon Mar 12 2018 Kalev Lember <klember@redhat.com> - 3.28.0-1
- - Update to 3.28.0
- * Sun Mar 11 2018 Kalev Lember <klember@redhat.com> - 3.27.92-3
- - Rebuilt for gspell 1.8
- * Wed Mar 07 2018 Kalev Lember <klember@redhat.com> - 3.27.92-2
- - Move org.gnome.Software.Featured.xml from -editor to main package
- * Mon Mar 05 2018 Kalev Lember <klember@redhat.com> - 3.27.92-1
- - Update to 3.27.92
- * Sun Mar 04 2018 Neal Gompa <ngompa13@gmail.com> - 3.27.90-4
- - Drop obsolete snapd-login-service requirement for snap plugin subpackage
- * Mon Feb 19 2018 Adam Williamson <awilliam@redhat.com> - 3.27.90-3
- - Backport fix for RHBZ #1546893 from upstream git
- * Mon Feb 19 2018 Kalev Lember <klember@redhat.com> - 3.27.90-2
- - Re-enable rpm-ostree plugin
- * Thu Feb 15 2018 Kalev Lember <klember@redhat.com> - 3.27.90-1
- - Update to 3.27.90
- - Temporarily disable the rpm-ostree plugin
- * Tue Feb 13 2018 Björn Esser <besser82@fedoraproject.org> - 3.27.4-4
- - Rebuild against newer gnome-desktop3 package
- * Thu Feb 08 2018 Kalev Lember <klember@redhat.com> - 3.27.4-3
- - Add fedora-workstation-repositories to nonfree-sources schema defaults
- * Wed Feb 07 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.27.4-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
- * Mon Jan 08 2018 Kalev Lember <klember@redhat.com> - 3.27.4-1
- - Update to 3.27.4
- - Drop unused --without packagekit option
- * Fri Jan 05 2018 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 3.27.3-2
- - Remove obsolete scriptlets
- * Sat Dec 16 2017 Kalev Lember <klember@redhat.com> - 3.27.3-1
- - Update to 3.27.3
- * Mon Nov 13 2017 Kalev Lember <klember@redhat.com> - 3.27.2-1
- - Update to 3.27.2
- * Thu Nov 09 2017 Kalev Lember <klember@redhat.com> - 3.26.2-1
- - Update to 3.26.2
- - Re-enable fwupd support
- * Tue Oct 31 2017 Kalev Lember <klember@redhat.com> - 3.26.1-5
- - Enable the rpm-ostree plugin
- * Wed Oct 25 2017 Kalev Lember <klember@redhat.com> - 3.26.1-4
- - Fix "too many results returned" error after distro upgrades (#1496489)
- * Tue Oct 10 2017 Kalev Lember <klember@redhat.com> - 3.26.1-3
- - Backport a flatpakref installation fix
- * Mon Oct 09 2017 Richard Hughes <rhughes@redhat.com> - 3.26.1-2
- - Disable fwupd support until we get a 3.27.1 tarball
- * Sun Oct 08 2017 Kalev Lember <klember@redhat.com> - 3.26.1-1
- - Update to 3.26.1
- * Mon Sep 11 2017 Kalev Lember <klember@redhat.com> - 3.26.0-1
- - Update to 3.26.0
- * Sun Aug 27 2017 Kalev Lember <klember@redhat.com> - 3.25.91-1
- - Update to 3.25.91
- * Tue Aug 15 2017 Kalev Lember <klember@redhat.com> - 3.25.90-1
- - Update to 3.25.90
- * Fri Aug 11 2017 Igor Gnatenko <ignatenko@redhat.com> - 3.25.4-6
- - Rebuilt after RPM update (№ 3)
- * Thu Aug 10 2017 Igor Gnatenko <ignatenko@redhat.com> - 3.25.4-5
- - Rebuilt for RPM soname bump
- * Thu Aug 10 2017 Igor Gnatenko <ignatenko@redhat.com> - 3.25.4-4
- - Rebuilt for RPM soname bump
- * Wed Aug 02 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.25.4-3
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
- * Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.25.4-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
- * Fri Jul 21 2017 Kalev Lember <klember@redhat.com> - 3.25.4-1
- - Update to 3.25.4
- * Tue Jul 18 2017 Kalev Lember <klember@redhat.com> - 3.25.3-6
- - Drop a meson workaround now that meson is fixed
- * Wed Jun 28 2017 Neal Gompa <ngompa13@gmail.com> - 3.25.3-5
- - Actually properly enable snap subpackage after removing conditional
- * Wed Jun 28 2017 Neal Gompa <ngompa13@gmail.com> - 3.25.3-4
- - Remove unnecessary arch-specific conditional for snap subpackage
- * Tue Jun 27 2017 Neal Gompa <ngompa13@gmail.com> - 3.25.3-3
- - Ensure snap subpackage is installed if snapd is installed
- * Fri Jun 23 2017 Richard Hughes <rhughes@redhat.com> - 3.24.3-2
- - Enable the snap subpackage
- * Fri Jun 23 2017 Kalev Lember <klember@redhat.com> - 3.25.3-1
- - Update to 3.25.3
- - Switch to the meson build system
- - Add an -editor subpackage with new banner editor
- * Mon May 15 2017 Richard Hughes <rhughes@redhat.com> - 3.24.3-1
- - Update to 3.23.3
- - Fix a common crash when installing flatpakrepo files
- - Ensure we show the banner when upgrades are available
- * Tue May 09 2017 Kalev Lember <klember@redhat.com> - 3.24.2-1
- - Update to 3.24.2
- * Tue Apr 25 2017 Adam Williamson <awilliam@redhat.com> - 3.24.1-2
- - Backport crasher fix from upstream (RHBZ #1444669 / BGO #781217)
- * Tue Apr 11 2017 Kalev Lember <klember@redhat.com> - 3.24.1-1
- - Update to 3.24.1
- * Tue Mar 21 2017 Kalev Lember <klember@redhat.com> - 3.24.0-1
- - Update to 3.24.0
- * Thu Mar 16 2017 Kalev Lember <klember@redhat.com> - 3.23.92-1
- - Update to 3.23.92
- * Mon Feb 27 2017 Richard Hughes <rhughes@redhat.com> - 3.23.91-1
- - Update to 3.23.91
- * Mon Feb 13 2017 Richard Hughes <rhughes@redhat.com> - 3.23.90-1
- - Update to 3.23.90
- * Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 3.23.3-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
- * Thu Dec 15 2016 Richard Hughes <rhughes@redhat.com> - 3.23.3-1
- - Update to 3.23.3
- * Wed Nov 23 2016 Kalev Lember <klember@redhat.com> - 3.23.2-1
- - Update to 3.23.2
- * Tue Nov 08 2016 Kalev Lember <klember@redhat.com> - 3.22.2-1
- - Update to 3.22.2
- * Wed Oct 12 2016 Kalev Lember <klember@redhat.com> - 3.22.1-1
- - Update to 3.22.1
- * Mon Sep 19 2016 Kalev Lember <klember@redhat.com> - 3.22.0-1
- - Update to 3.22.0
- * Wed Sep 14 2016 Kalev Lember <klember@redhat.com> - 3.21.92-1
- - Update to 3.21.92
- - Don't set group tags
- * Thu Sep 01 2016 Kalev Lember <klember@redhat.com> - 3.21.91-1
- - Update to 3.21.91
- * Wed Aug 17 2016 Kalev Lember <klember@redhat.com> - 3.21.90-2
- - Rebuilt for fixed libappstream-glib headers
- * Wed Aug 17 2016 Kalev Lember <klember@redhat.com> - 3.21.90-1
- - Update to 3.21.90
- - Tighten -devel subpackage dependencies
- * Thu Jul 28 2016 Richard Hughes <rhughes@redhat.com> - 3.21.4-2
- - Allow building without PackageKit for the atomic workstation.
- * Mon Jul 18 2016 Richard Hughes <rhughes@redhat.com> - 3.21.4-1
- - Update to 3.21.4
- * Thu May 26 2016 Kalev Lember <klember@redhat.com> - 3.21.2-2
- - Build with flatpak support
- * Mon May 23 2016 Richard Hughes <rhughes@redhat.com> - 3.21.2-1
- - Update to 3.21.2
- * Tue May 10 2016 Kalev Lember <klember@redhat.com> - 3.21.1-2
- - Require PackageKit 1.1.1 for system upgrade support
- * Mon Apr 25 2016 Richard Hughes <rhughes@redhat.com> - 3.21.1-1
- - Update to 3.21.1
- * Mon Apr 25 2016 Richard Hughes <rhughes@redhat.com> - 3.20.2-1
- - Update to 3.20.1
- - Allow popular and featured apps to match any plugin
- - Do not make the ODRS plugin depend on xdg-app
- - Fix many of the os-upgrade issues and implement the latest mockups
- - Make all the plugins more threadsafe
- - Return all update descriptions newer than the installed version
- - Show some non-fatal error messages if installing fails
- - Use a background PackageKit transaction when downloading upgrades
- * Wed Apr 13 2016 Kalev Lember <klember@redhat.com> - 3.20.1-1
- - Update to 3.20.1
- * Fri Apr 01 2016 Richard Hughes <rhughes@redhat.com> - 3.20.1-2
- - Set the list of official sources
- - Compile with xdg-app support
- * Tue Mar 22 2016 Kalev Lember <klember@redhat.com> - 3.20.0-1
- - Update to 3.20.0
- * Mon Mar 14 2016 Richard Hughes <rhughes@redhat.com> - 3.19.92-1
- - Update to 3.19.92
- * Thu Mar 03 2016 Kalev Lember <klember@redhat.com> - 3.19.91-2
- - Set minimum required json-glib version
- * Mon Feb 29 2016 Richard Hughes <rhughes@redhat.com> - 3.19.91-1
- - Update to 3.19.91
- * Mon Feb 15 2016 Richard Hughes <rhughes@redhat.com> - 3.19.90-1
- - Update to 3.19.90
- * Wed Feb 03 2016 Fedora Release Engineering <releng@fedoraproject.org> - 3.19.4-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
- * Fri Jan 15 2016 Richard Hughes <rhughes@redhat.com> - 3.19.4-1
- - Update to 3.19.4
- * Thu Dec 03 2015 Kalev Lember <klember@redhat.com> - 3.18.3-2
- - Require librsvg2 for the gdk-pixbuf svg loader
- * Thu Nov 05 2015 Richard Hughes <rhughes@redhat.com> - 3.18.3-1
- - Update to 3.18.3
- - Use the correct user agent string when downloading firmware
- - Fix a crash in the limba plugin
- - Fix installing web applications
- * Mon Oct 26 2015 Kalev Lember <klember@redhat.com> - 3.18.2-2
- - Fix apps reappearing as installed a few seconds after removal (#1275163)
- * Thu Oct 15 2015 Kalev Lember <klember@redhat.com> - 3.18.2-1
- - Update to 3.18.2
- * Tue Oct 13 2015 Kalev Lember <klember@redhat.com> - 3.18.1-1
- - Update to 3.18.1
- * Wed Oct 07 2015 Kalev Lember <klember@redhat.com> - 3.18.0-2
- - Backport two crasher fixes from upstream
- * Mon Sep 21 2015 Kalev Lember <klember@redhat.com> - 3.18.0-1
- - Update to 3.18.0
- * Tue Sep 15 2015 Kalev Lember <klember@redhat.com> - 3.17.92-2
- - Update dependency versions
- * Tue Sep 15 2015 Richard Hughes <rhughes@redhat.com> - 3.17.92-1
- - Update to 3.17.92
- * Thu Sep 10 2015 Richard Hughes <rhughes@redhat.com> - 3.17.91-2
- - Fix firmware updates
- * Thu Sep 03 2015 Kalev Lember <klember@redhat.com> - 3.17.91-1
- - Update to 3.17.91
- * Wed Aug 19 2015 Kalev Lember <klember@redhat.com> - 3.17.90-1
- - Update to 3.17.90
- * Wed Aug 12 2015 Richard Hughes <rhughes@redhat.com> - 3.17.3-1
- - Update to 3.17.3
- * Wed Jul 22 2015 David King <amigadave@amigadave.com> - 3.17.2-3
- - Bump for new gnome-desktop3
- * Wed Jun 17 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.17.2-2
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
- * Fri Jun 05 2015 Kalev Lember <kalevlember@gmail.com> - 3.17.2-1
- - Update to 3.17.2
- * Mon May 25 2015 Kalev Lember <kalevlember@gmail.com> - 3.17.1-1
- - Update to 3.17.1
- * Fri May 15 2015 Kalev Lember <kalevlember@gmail.com> - 3.16.2-2
- - Fix a crash under Wayland (#1221968)
- * Mon May 11 2015 Kalev Lember <kalevlember@gmail.com> - 3.16.2-1
- - Update to 3.16.2
- * Tue Apr 14 2015 Kalev Lember <kalevlember@gmail.com> - 3.16.1-1
- - Update to 3.16.1
- * Mon Mar 23 2015 Kalev Lember <kalevlember@gmail.com> - 3.16.0-1
- - Update to 3.16.0
- * Mon Mar 16 2015 Kalev Lember <kalevlember@gmail.com> - 3.15.92-1
- - Update to 3.15.92
- - Use license macro for the COPYING file
- - Add a patch to adapt to gnome-terminal desktop file rename
- * Mon Mar 02 2015 Kalev Lember <kalevlember@gmail.com> - 3.15.91-1
- - Update to 3.15.91
- * Sat Feb 21 2015 Kalev Lember <kalevlember@gmail.com> - 3.15.90-3
- - Export DisplayName property on the packagekit session service
- * Thu Feb 19 2015 Kalev Lember <kalevlember@gmail.com> - 3.15.90-2
- - Backport a crash fix
- * Tue Feb 17 2015 Richard Hughes <rhughes@redhat.com> - 3.15.90-1
- - Update to 3.15.90
- * Mon Jan 19 2015 Richard Hughes <rhughes@redhat.com> - 3.15.4-1
- - Update to 3.15.4
- * Tue Nov 25 2014 Kalev Lember <kalevlember@gmail.com> - 3.15.2-1
- - Update to 3.15.2
- * Thu Nov 13 2014 Richard Hughes <rhughes@redhat.com> - 3.14.2-3
- - Fix non-Fedora build
- * Tue Nov 11 2014 Richard Hughes <rhughes@redhat.com> - 3.14.2-2
- - Backport a patch to fix compilation
- * Mon Nov 10 2014 Kalev Lember <kalevlember@gmail.com> - 3.14.2-1
- - Update to 3.14.2
- * Sat Nov 08 2014 Kalev Lember <kalevlember@gmail.com> - 3.14.1-3
- - Update the list of system apps
- * Sat Nov 01 2014 David King <amigadave@amigadave.com> - 3.14.1-2
- - Rebuild for new libappstream-glib (#1156494)
- * Mon Oct 13 2014 Kalev Lember <kalevlember@gmail.com> - 3.14.1-1
- - Update to 3.14.1
- * Thu Oct 09 2014 Kalev Lember <kalevlember@gmail.com> - 3.14.0-2
- - Depend on gnome-menus for app folder directory entries
- * Mon Sep 22 2014 Kalev Lember <kalevlember@gmail.com> - 3.14.0-1
- - Update to 3.14.0
- * Wed Sep 17 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.92-2
- - Set minimum required dependency versions (#1136343)
- * Tue Sep 16 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.92-1
- - Update to 3.13.92
- - Replace gnome-system-log with gnome-logs in the system apps list
- * Tue Sep 02 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.91-1
- - Update to 3.13.91
- * Tue Aug 19 2014 Richard Hughes <rhughes@redhat.com> - 3.13.90-1
- - Update to 3.13.90
- * Sat Aug 16 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.13.5-0.2.git5c89189
- - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
- * Mon Aug 11 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.5-0.1.git5c89189
- - Update to 3.13.5 git snapshot
- - Ship HighContrast icons
- * Sun Aug 03 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.4-2
- - Replace Epiphany with Firefox in the system apps list
- * Wed Jul 23 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.4-1
- - Update to 3.13.4
- * Wed Jun 25 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.3-1
- - Update to 3.13.3
- * Thu Jun 12 2014 Richard Hughes <rhughes@redhat.com> - 3.13.3-0.2.git7491627
- - Depend on the newly-created appstream-data package and stop shipping
- the metadata here.
- * Sat Jun 07 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.3-0.1.git7491627
- - Update to 3.13.3 git snapshot
- * Wed May 28 2014 Richard Hughes <rhughes@redhat.com> - 3.13.2-2
- - Rebuild with new metadata.
- * Wed May 28 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.2-1
- - Update to 3.13.2
- * Thu May 15 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.1-4
- - Depend on gsettings-desktop-schemas
- * Mon May 12 2014 Richard Hughes <rhughes@redhat.com> - 3.13.1-3
- - Update the metadata and use appstream-util to install the metadata.
- * Wed May 07 2014 Kalev Lember <kalevlember@gmail.com> - 3.13.1-2
- - Drop gnome-icon-theme dependency
- * Mon Apr 28 2014 Richard Hughes <rhughes@redhat.com> - 3.13.1-1
- - Update to 3.13.1
- * Fri Apr 11 2014 Kalev Lember <kalevlember@gmail.com> - 3.12.1-2
- - Rebuild with new metadata.
- * Fri Apr 11 2014 Richard Hughes <rhughes@redhat.com> - 3.12.1-1
- - Update to 3.12.1
- * Mon Mar 24 2014 Richard Hughes <rhughes@redhat.com> - 3.12.0-1
- - Update to 3.12.0
- * Thu Mar 20 2014 Richard Hughes <rhughes@redhat.com> - 3.11.92-1
- - Update to 3.11.92
- * Tue Mar 18 2014 Richard Hughes <rhughes@redhat.com> - 3.11.91-2
- - Rebuild with new metadata.
- * Sat Mar 08 2014 Richard Hughes <rhughes@redhat.com> - 3.11.91-1
- - Update to 3.11.91
- * Tue Feb 18 2014 Richard Hughes <rhughes@redhat.com> - 3.11.90-1
- - Update to 3.11.90
- * Mon Feb 03 2014 Richard Hughes <rhughes@redhat.com> - 3.11.5-2
- - Require epiphany-runtime rather than the full application
- * Mon Feb 03 2014 Richard Hughes <rhughes@redhat.com> - 3.11.5-1
- - Update to 3.11.5
- * Thu Jan 30 2014 Richard Hughes <rhughes@redhat.com> - 3.11.4-3
- - Rebuild for libpackagekit-glib soname bump
- * Wed Jan 22 2014 Richard Hughes <rhughes@redhat.com> - 3.11.4-2
- - Rebuild with metadata that has the correct screenshot url.
- * Thu Jan 16 2014 Richard Hughes <rhughes@redhat.com> - 3.11.4-1
- - Update to 3.11.4
- * Tue Dec 17 2013 Richard Hughes <rhughes@redhat.com> - 3.11.3-1
- - Update to 3.11.3
- * Tue Nov 19 2013 Richard Hughes <rhughes@redhat.com> - 3.11.2-1
- - Update to 3.11.2
- * Tue Oct 29 2013 Richard Hughes <rhughes@redhat.com> - 3.11.1-1
- - Update to 3.11.1
- - Add a gnome shell search provider
- - Add a module to submit the user rating to the fedora-tagger web service
- - Add support for 'missing' codecs that we know exist but we can't install
- - Add support for epiphany web applications
- - Handle offline installation sensibly
- - Save the user rating if the user clicks the rating stars
- - Show a modal error message if install or remove actions failed
- - Show a star rating on the application details page
- - Show font screenshots
- - Show more detailed version numbers when required
- - Show screenshots to each application
- * Wed Sep 25 2013 Richard Hughes <richard@hughsie.com> 3.10.0-1
- - New upstream release.
- - New metadata for fedora, updates and updates-testing
- - Add a plugin to query the PackageKit prepared-update file directly
- - Do not clear the offline-update trigger if rebooting succeeded
- - Do not load incompatible projects when parsing AppStream data
- - Lots of updated translations
- - Show the window right away when starting
- * Fri Sep 13 2013 Richard Hughes <richard@hughsie.com> 3.9.3-1
- - New upstream release.
- - Lots of new and fixed UI and updated metadata for Fedora 20
- * Tue Sep 03 2013 Richard Hughes <richard@hughsie.com> 3.9.2-1
- - New upstream release.
- - Allow stock items in the AppStream XML
- - Extract the AppStream URL and description from the XML
- - Only present the window when the overview is complete
- - Return the subcategories sorted by name
- * Mon Sep 02 2013 Richard Hughes <richard@hughsie.com> 3.9.1-1
- - New upstream release which is a technical preview for the alpha.
- * Sun Sep 01 2013 Richard Hughes <richard@hughsie.com> 0.1-3
- - Use buildroot not RPM_BUILD_ROOT
- - Own all gnome-software directories
- - Drop gtk-update-icon-cache requires and the mime database functionality
- * Thu Aug 29 2013 Richard Hughes <richard@hughsie.com> 0.1-2
- - Add call to desktop-file-validate and fix other review comments.
- * Wed Aug 28 2013 Richard Hughes <richard@hughsie.com> 0.1-1
- - First release for Fedora package review
|