123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341 |
- # clean old caches when groff =< %{cache_clean_ver}
- # is uninstalled.
- %define cache_clean_ver 1.18.1.1-4%{?_dist_release}
- %global __requires_exclude perl\\(.*\\.pl\\)$
- Summary: A document formatting system.
- Summary(ja): GNU groff 日本語対応版
- Name: groff
- Version: 1.23.0
- Release: 1%{?_dist_release}
- Group: publishing
- Vendor: Project Vine
- Distribution: Vine Linux
- Packager: daisuke
- License: GPL-3.0-or-later AND GFDL-1.3-or-later AND BSD-4-Clause-UC AND MIT AND X11 AND LicenseRef-Fedora-Public-Domain
- URL: https://www.gnu.org/software/groff/
- Source0: https://ftp.gnu.org/gnu/groff/groff-%{version}.tar.gz
- # resolves: #530788
- Patch0: 0001-missing-groff-x11-info-message-when-gxditview-not-fo.patch
- Patch1: 0002-load-site-font-and-site-tmac-from-etc-groff.patch
- # resolves: #709413, #720058, #720057
- Patch2: 0003-various-security-fixes.patch
- # resolves: #987069
- Patch3: 0004-don-t-use-usr-bin-env-in-shebang.patch
- # allow to specify custom docdir
- Patch4: 0005-do-not-overwrite-docdir.patch
- # Revert upstream change of mapping special characters for UTF-8 devices
- # Debian commit: https://salsa.debian.org/debian/groff/-/commit/d5394c68d70e6c5199b01d2522e094c8fd52e64e
- Patch5: 0006-Revert-upstream-change-of-mapping-special-characters.patch
- Buildroot: %{_tmppath}/%{name}-%{version}-root
- BuildRequires: libXmu-devel
- BuildRequires: libXaw-devel
- BuildRequires: psutils, bison, imake, netpbm-progs, ghostscript
- BuildRequires: texinfo
- Requires(postun): findutils
- Obsoletes: groff-tools
- %description
- Groff is a document formatting system. Groff takes standard text and
- formatting commands as input and produces formatted output. The
- created documents can be shown on a display or printed on a printer.
- Groff's formatting commands allow you to specify font type and size, bold
- type, italic type, the number and size of columns on a page, and more.
- You should install groff if you want to use it as a document formatting
- system. Groff can also be used to format man pages. If you are going
- to use groff with the X Window System, you'll also need to install the
- groff-gxditview package.
- %description -l ja
- GNU roff (groff) 日本語対応版です。日本語で書かれたマニュアルを表示す
- るのに必要です.
- %package perl
- Summary: Parts of the groff formatting system that require Perl.
- Group: publishing
- Requires: %{name} = %{version}
- Requires: mktemp
- %description perl
- The groff-perl package contains the parts of the groff text processor
- package that require Perl. These include the afmtodit font processor
- for creating PostScript font files, the grog utility that can be used
- to automatically determine groff command-line options, and the
- troff-to-ps print filter.
- %package gxditview
- Summary: An X previewer for groff text processor output.
- Group: publishing
- Requires: %{name} = %{version}
- %description gxditview
- Gxditview displays the groff text processor's output on an X Window
- System display.
- If you are going to use groff as a text processor, you should install
- gxditview so that you preview your processed text files in X. You'll also
- need to install the groff package and the X Window System.
- %debug_package
- %prep
- %setup -q
- %autopatch -p1
- for file in NEWS src/devices/grolbp/grolbp.1.man doc/{groff.texi*,webpage.ms} \
- contrib/mm/*.man contrib/mom/examples/{README.txt,*.mom,mom.vim}
- do
- iconv -f iso-8859-1 -t utf-8 < "$file" > "${file}_"
- mv "${file}_" "$file"
- done
- %build
- export PAGE=A4
- export YACC='bison -y'
- %configure \
- --docdir=%{_pkgdocdir} \
- --with-appdefdir=%{_datadir}/X11/app-defaults \
- --with-grofferdir=%{_datadir}/%{name}/%{version}/groffer
- %make_build
- %install
- %make_install
- # some binaries need alias with 'g' or 'z' prefix
- for file in g{nroff,troff,tbl,pic,eqn,neqn,refer,lookbib,indxbib,soelim} zsoelim; do
- ln -s ${file#?} %{buildroot}%{_bindir}/${file}
- ln -s ${file#?}.1.gz %{buildroot}%{_mandir}/man1/${file}.1.gz
- done
- # fix absolute symlink to relative symlink
- rm -f %{buildroot}%{_pkgdocdir}/pdf/mom-pdf.pdf
- ln -s ../examples/mom/mom-pdf.pdf %{buildroot}%{_pkgdocdir}/pdf/mom-pdf.pdf
- # rename groff downloadable postscript fonts to meet Fedora Font Packaging guidelines,
- # as these files are more PS instructions, than general-purpose fonts (bz #477394)
- for file in $(find %{buildroot}%{_datadir}/%{name}/%{version}/font/devps -name "*.pfa"); do
- mv ${file} ${file}_
- done
- sed --in-place 's/\.pfa$/.pfa_/' %{buildroot}%{_datadir}/%{name}/%{version}/font/devps/download
- # perl dependent files in /usr/bin will be in separate package
- rm -f files-perl files-nonperl
- for file in %{buildroot}%{_bindir}/*; do
- # package selection
- if grep -q -m1 '^#!.*\<perl\>' $file; then
- output_file=files-perl
- else
- output_file=files-nonperl
- fi
- echo %{_bindir}/$(basename $file) >> $output_file
- # manpage availability
- manfile=%{buildroot}%{_mandir}/man1/$(basename $file).\*
- if [ -f $manfile -o -L $manfile ]; then
- echo %{_mandir}/man1/$(basename $file).\* >> $output_file
- fi
- done
- # install info
- install -d $RPM_BUILD_ROOT%{_infodir}
- install -m644 doc/groff.info* $RPM_BUILD_ROOT%{_infodir}
- # remove unnecessary files and fix privileges
- rm -f %{buildroot}%{_infodir}/dir
- # remove CreationDate from documentation
- pushd %{buildroot}%{_pkgdocdir}
- find -name "*.html" | xargs sed -i "/^<!-- CreationDate: /d"
- find -name "*.ps" | xargs sed -i "/^%%%%CreationDate: /d"
- popd
- %triggerpostun -- %{name} <= %{cache_clean_ver}
- find %{_var}/cache/man -type f -name "*.bz2" -exec %{__rm} -f {} \;
- %files -f files-nonperl
- %license COPYING FDL LICENSES
- %doc %{_pkgdocdir}/*
- %doc BUG-REPORT MORE.STUFF NEWS PROBLEMS
- %dir %{_sysconfdir}/groff/
- %dir %{_sysconfdir}/groff/site-font
- %dir %{_sysconfdir}/groff/site-tmac
- %config(noreplace) %{_sysconfdir}/groff/site-tmac/*
- %{_datadir}/groff/
- # manpages for binaries are covered by -f
- %{_mandir}/man1/grohtml.*
- %{_mandir}/man5/*
- %{_mandir}/man7/*
- %{_infodir}/groff.info*
- %exclude %{_bindir}/gxditview
- %exclude %{_bindir}/xtotroff
- %exclude %{_mandir}/man1/gxditview.*
- %exclude %{_mandir}/man1/xtotroff.*
- %files perl -f files-perl
- %files gxditview
- %{_bindir}/gxditview
- %{_bindir}/xtotroff
- %{_datadir}/X11/app-defaults/GXditview
- %{_datadir}/X11/app-defaults/GXditview-color
- %{_mandir}/man1/gxditview.*
- %{_mandir}/man1/xtotroff.*
- %changelog
- * Fri Jul 19 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.23.0-1
- - new upstream release.
- * Mon May 13 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.22.4-1
- - new upstream release.
- - dropped all patches.
- - imported patches from rawhide.
- * Thu Jul 07 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.21-3
- - rebuild with gcc-5.4.0
- * Sun Dec 29 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.21-2
- - rebuild with VineSeed environment
- * Thu Mar 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.21-1
- - new upstream release
- - drop all cjk patch
- - add patch2,3 to fix typo
- * Fri Apr 02 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.18.1.1-5
- - add %posttriggerun to clean old caches (<BTS:VineLinux:960>)
- * Tue Mar 23 2010 Kazutaka HARADA <kazutaka@vinelinux.org> 1.18.1.1-4
- - add Patch2 to fix minus/hyphen character width (<BTS:VineLinux:960>)
- - add BuildRequires: psutils, byacc, imake, netpbm-progs, ghostscript
- * Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18.1.1-3
- - remove gxditview from main package
- * Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18.1.1-2
- - rebuild with libXaw.so.7 (libXaw-1.0.5)
- * Sat May 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.18.1.1-1
- - rebuild with new versioning policy
- - update Debian patch
- * Sat Sep 22 2007 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.18.1.1-0vl1
- - rebuilt with new toolchain
- - updated source and Japanese patch based on Debian
- - added BuildRequires: XOrg-devel
- * Fri Sep 22 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 1.17.2-0vl7
- - rebuild to add gpg sign
- * Tue Apr 8 2003 Hiroaki Irokawa <irorin@terra.dti.ne.jp> 1.17.2-0vl6
- - rebuild
- * Mon Nov 25 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.17.2-0vl5
- - rebuilt with new toolchain
- * Wed Mar 06 2002 Toru Sagami <sagami@vinelinux.org> 1.17.2-0vl4
- - corrected zsoelim.1 symlink in %%{_mandir}
- * Mon Feb 11 2002 Satoshi MACHINO <machino@vinelinux.org> 1.17.2-0vl3
- - fixed symlink of *.tmac
- * Mon Jan 21 2002 Satoshi MACHINO <machino@vinelinux.org> 1.17.2-0vl2
- - build on VineSeed
- * Mon Jan 21 2002 Satoshi MACHINO <machino@vinelinux.org> 1.17.2-0vl1
- - updated groff-1.17.2
- -- security fixed of CAN-2002-0003
- -- changed japanese patch to debian patch
- -- modified spec file
- * Mon Sep 10 2001 Toru Sagami <sagami@vinelinux.org>
- - 1.16.1-0vl1: split perl components into separate subpackage
- * Tue Jul 17 2001 <sagami@vinelinux.org>
- - 1.16.1: version up to 1.16.1
- - add groff-1.16.1-japanese.patch originally taken from Kondara
- - use %%configure after autoconf, %%makeinstall
- * Tue Jan 23 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
- - 1.15_jp-7
- - built on egcs-1.1/libstdc++2_9-2.9.0
- - fixed: whether or not build system compress man pages
- * Tue Dec 26 2000 Tomoya TAKA <tomoya@olive.plala.or.jp> 1.15_jp-6
- - some fixes to handle man pages correctly
- * Sat Nov 11 2000 MACHINO, Satoshi <machino@vinelinux.org> 1.15_jp-5
- - build on gcc-2.95.3
- - partially used macros
- * Mon Aug 7 2000 Jun Nishii <jun@vinelinux.org>
- - 1.15_jp-4
- - follow up to RHL62 (1.15-8)
- * Thu Feb 24 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
- - 1.15_jp-3
- - modified ja patch, namely lib.h
- * Sun Jan 9 2000 Jun Nishii <jun@vinelinux.org>
- - groff-tmac-ja was lacked in Source entry(;_;) fixed!
- * Tue Jan 4 2000 Jun Nishii <jun@vinelinux.org>
- - build for Vine Linux 2.0 with ja patch
- * Wed Dec 29 1999 Bill Nottingham <notting@redhat.com>
- - update to 1.15
- * Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
- - auto rebuild in the new build environment (release 9)
- * Tue Feb 16 1999 Cristian Gafton <gafton@redhat.com>
- - glibc 2.1 patch for xditview (#992)
- * Thu Oct 22 1998 Bill Nottingham <notting@redhat.com>
- - build for Raw Hide
- * Thu Sep 10 1998 Cristian Gafton <gafton@redhat.com>
- - fix makefiles to work with bash2
- * Fri May 08 1998 Prospector System <bugs@redhat.com>
- - translations modified for de, fr, tr
- * Thu Apr 30 1998 Cristian Gafton <gafton@redhat.com>
- - use g++ for C++ code
- * Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
- - manhattan and buildroot
- * Mon Nov 3 1997 Michael Fulbright <msf@redhat.com>
- - made xdefaults file a config file
- * Thu Oct 23 1997 Erik Troan <ewt@redhat.com>
- - split perl components into separate subpackage
- * Tue Oct 21 1997 Michael Fulbright <msf@redhat.com>
- - updated to 1.11a
- - added safe troff-to-ps.fpi
- * Tue Oct 14 1997 Michael Fulbright <msf@redhat.com>
- - removed troff-to-ps.fpi for security reasons.
- * Fri Jun 13 1997 Erik Troan <ewt@redhat.com>
- - built against glibc
|