gtest-vl.spec 5.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183
  1. Summary: Google C++ testing framework
  2. Summary(ja): Google C++ テスティングフレームワーク
  3. Name: gtest
  4. Version: 1.14.0
  5. Release: 1%{?_dist_release}
  6. Vendor: Project Vine
  7. Distribution: Vine Linux
  8. License: BSD-3-Clause and Apache-2.0
  9. Group: programming
  10. URL: https://github.com/google/googletest
  11. Source0: https://github.com/google/googletest/archive/refs/tags/v%{version}.tar.gz
  12. BuildRequires: cmake
  13. BuildRequires: python3-devel
  14. BuildRequires: python3-rpm-macros
  15. %description
  16. Google's framework for writing C++ tests on a variety of platforms (GNU/Linux,
  17. Mac OS X, Windows, Windows CE, and Symbian). Based on the xUnit architecture.
  18. Supports automatic test discovery, a rich set of assertions, user-defined
  19. assertions, death tests, fatal and non-fatal failures, various options for
  20. running the tests, and XML test report generation.
  21. %package devel
  22. Summary: Development files for %{name}
  23. Summary(ja): %{name} の開発ファイル
  24. Group: programming
  25. Requires: %{name} = %{version}-%{release}
  26. %description devel
  27. This package contains development files for %{name}.
  28. %package -n gmock
  29. Summary: Google C++ Mocking Framework
  30. Group: programming
  31. Requires: %{name} = %{version}-%{release}
  32. %description -n gmock
  33. Inspired by jMock, EasyMock, and Hamcrest, and designed with C++s
  34. specifics in mind, Google C++ Mocking Framework (or Google Mock for
  35. short) is a library for writing and using C++ mock classes.
  36. Google Mock:
  37. o lets you create mock classes trivially using simple macros,
  38. o supports a rich set of matchers and actions,
  39. o handles unordered, partially ordered, or completely ordered
  40. expectations,
  41. o is extensible by users, and
  42. o works on Linux, Mac OS X, Windows, Windows Mobile, minGW, and
  43. Symbian.
  44. %package -n gmock-devel
  45. Summary: Development files for gmock
  46. Group: programming
  47. Requires: gmock = %{version}-%{release}
  48. %description -n gmock-devel
  49. This package contains development files for gmock.
  50. %prep
  51. %autosetup -p1 -n googletest-%{version}
  52. # Set the version correctly
  53. sed -e "s/set(GOOGLETEST_VERSION .*)/set(GOOGLETEST_VERSION %{version})/" -i CMakeLists.txt
  54. %build
  55. %cmake -DBUILD_SHARED_LIBS=ON \
  56. -DPYTHON_EXECUTABLE=%{__python3} \
  57. -Dgtest_build_tests=ON
  58. %cmake_build
  59. %install
  60. %cmake_install
  61. %check
  62. %ctest
  63. %files
  64. %defattr(-,root,root,-)
  65. %license LICENSE
  66. %{_libdir}/libgtest.so.%{version}
  67. %{_libdir}/libgtest_main.so.%{version}
  68. %files devel
  69. %defattr(-,root,root,-)
  70. %doc CONTRIBUTORS README.md
  71. %doc docs/
  72. %doc samples
  73. %{_includedir}/gtest/
  74. %{_libdir}/libgtest.so
  75. %{_libdir}/libgtest_main.so
  76. %{_libdir}/cmake/GTest/
  77. %{_libdir}/pkgconfig/gtest.pc
  78. %{_libdir}/pkgconfig/gtest_main.pc
  79. %files -n gmock
  80. %license LICENSE
  81. %{_libdir}/libgmock.so.%{version}
  82. %{_libdir}/libgmock_main.so.%{version}
  83. %files -n gmock-devel
  84. %doc CONTRIBUTORS README.md
  85. %doc docs/
  86. %{_includedir}/gmock/
  87. %{_libdir}/libgmock.so
  88. %{_libdir}/libgmock_main.so
  89. %{_libdir}/pkgconfig/gmock.pc
  90. %{_libdir}/pkgconfig/gmock_main.pc
  91. %changelog
  92. * Tue Apr 09 2024 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.14.0-1
  93. - new upstream release.
  94. * Wed Sep 11 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.8.1-1
  95. - new upstream release.
  96. - dropped Patch0.
  97. - imported patches from rawhide.
  98. * Sat Jul 2 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.7.0-2
  99. - rebuilt with new toolchain.
  100. * Tue Jul 01 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.7.0-1
  101. - new upstream release
  102. * Sun Apr 29 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.6.0-1
  103. - new upstream release
  104. - changed source archive type to xz
  105. - added Patch0 from Mandriva
  106. * Wed Sep 29 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.0-2
  107. - rebuilt with rpm-4.8.1 for pkg-config
  108. * Sun May 23 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.5.0-1
  109. - initial build for VineSeed
  110. * Sat Nov 14 2009 Debarshi Ray <rishi@fedoraproject.org> - 1.4.0-1
  111. - Version bump to 1.4.0.
  112. * New feature: the event listener API.
  113. * New feature: test shuffling.
  114. * New feature: the XML report format is closer to junitreport and can
  115. be parsed by Hudson now.
  116. * New feature: elapsed time for the tests is printed by default.
  117. * New feature: comes with a TR1 tuple implementation such that Boost
  118. is no longer needed for Combine().
  119. * New feature: EXPECT_DEATH_IF_SUPPORTED macro and friends.
  120. * New feature: the Xcode project can now produce static gtest libraries in
  121. addition to a framework.
  122. * Compatibility fixes for gcc and minGW.
  123. * Bug fixes and implementation clean-ups.
  124. * Fri Jul 24 2009 Release Engineering <rel-eng@fedoraproject.org> - 1.3.0-2.20090601svn257
  125. - Autorebuild for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  126. * Mon Jun 01 2009 Tom "spot" Callaway <tcallawa@redhat.com> - 1.3.0-1
  127. - Version bump to 1.3.0.
  128. * New feature: ability to use Google Test assertions in other testing
  129. frameworks.
  130. * New feature: ability to run disabled test via
  131. --gtest_also_run_disabled_tests.
  132. * New feature: the --help flag for printing the usage.
  133. * New feature: access to Google Test flag values in user code.
  134. * New feature: a script that packs Google Test into one .h and one .cc file
  135. for easy deployment.
  136. * New feature: support for distributing test functions to multiple machines
  137. (requires support from the test runner).
  138. * Bug fixes and implementation clean-ups.
  139. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.0.0-2
  140. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  141. * Sat Jul 05 2008 Debarshi Ray <rishi@fedoraproject.org> - 1.0.0-1
  142. - Initial build.