ipmitool-vl.spec 6.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178
  1. Name: ipmitool
  2. Summary: Utility for IPMI control
  3. Summary(ja): IPMIコントロールユーティリティ
  4. Version: 1.8.18
  5. Release: 1%{?_dist_release}
  6. Group: System Environment/Base
  7. Vendor: Project Vine
  8. Distribution: Vine Linux
  9. License: BSD
  10. URL: https://github.com/ipmitool/ipmitool
  11. %global tagname IPMITOOL_%(echo %{version} | tr . _)
  12. Source0: https://github.com/ipmitool/ipmitool/releases/download/%{tagname}/%{name}-%{version}.tar.bz2
  13. Source1: openipmi-ipmievd.sysconf
  14. Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
  15. BuildRequires: openssl-devel readline-devel ncurses-devel
  16. Requires(post): chkconfig
  17. Requires(preun): chkconfig
  18. Obsoletes: OpenIPMI-tools < 2.0.14-3
  19. Provides: OpenIPMI-tools = 2.0.14-3
  20. Patch1: 0001-CVE-2011-4339-OpenIPMI.patch
  21. # WARNING: THIS PATCH MUST BE USED FOR RAWHIDE (f26+) BRANCH
  22. Patch2: 0002-openssl.patch
  23. Patch3: 0003-ipmitool-1.8.11-set-kg-key.patch
  24. Patch4: 0004-slowswid.patch
  25. Patch5: 0005-sensor-id-length.patch
  26. Patch6: 0006-enable-usb.patch
  27. Patch7: 0007-check-input.patch
  28. Patch8: 0008-add-extern.patch
  29. Patch9: 0009-best-cipher.patch
  30. Patch10: 0010-pef-missing-newline.patch
  31. Patch11: 0011-expand-sensor-name-column.patch
  32. Patch12: 0012-CVE-2020-5208.patch
  33. %description
  34. This package contains a utility for interfacing with devices that support
  35. the Intelligent Platform Management Interface specification. IPMI is
  36. an open standard for machine health, inventory, and remote power control.
  37. This utility can communicate with IPMI-enabled devices through either a
  38. kernel driver such as OpenIPMI or over the RMCP LAN protocol defined in
  39. the IPMI specification. IPMIv2 adds support for encrypted LAN
  40. communications and remote Serial-over-LAN functionality.
  41. It provides commands for reading the Sensor Data Repository (SDR) and
  42. displaying sensor values, displaying the contents of the System Event
  43. Log (SEL), printing Field Replaceable Unit (FRU) information, reading and
  44. setting LAN configuration, and chassis power control.
  45. %prep
  46. %setup -q
  47. %autopatch -p1
  48. for f in AUTHORS ChangeLog; do
  49. iconv -f iso-8859-1 -t utf8 < ${f} > ${f}.utf8
  50. mv ${f}.utf8 ${f}
  51. done
  52. autoreconf -ivf
  53. %build
  54. # --disable-dependency-tracking speeds up the build
  55. # --enable-file-security adds some security checks
  56. # --disable-intf-free disables FreeIPMI support - we don't want to depend on
  57. # FreeIPMI libraries, FreeIPMI has its own ipmitoool-like utility.
  58. %configure --disable-dependency-tracking --enable-file-security --disable-intf-free
  59. make %{?_smp_mflags}
  60. %install
  61. rm -rf %{buildroot}
  62. make DESTDIR=%{buildroot} install
  63. install -Dpm 755 contrib/ipmievd.init.redhat %{buildroot}%{_initrddir}/ipmievd
  64. install -Dpm 644 %SOURCE1 %{buildroot}%{_sysconfdir}/sysconfig/ipmievd
  65. %clean
  66. rm -rf $RPM_BUILD_ROOT
  67. %post
  68. /sbin/chkconfig --add ipmievd
  69. %preun
  70. if [ $1 = 0 ]; then
  71. service ipmievd stop >/dev/null 2>&1
  72. /sbin/chkconfig --del ipmievd
  73. fi
  74. %postun
  75. if [ "$1" -ge "1" ]; then
  76. service ipmievd condrestart >/dev/null 2>&1 || :
  77. fi
  78. %files
  79. %defattr(-,root,root)
  80. %config(noreplace) %{_sysconfdir}/sysconfig/ipmievd
  81. %{_initrddir}/ipmievd
  82. %{_bindir}/*
  83. %{_sbindir}/*
  84. %{_mandir}/man*/*
  85. %doc %{_datadir}/doc/ipmitool
  86. %{_datadir}/ipmitool
  87. %changelog
  88. * Sun Mar 22 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.18-1
  89. - new upstream release.
  90. - replaced all patches.
  91. * Sun Aug 02 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.8.11-2
  92. - rebuild with readline-6.3
  93. * Mon Jul 30 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.8.11-1
  94. - initial build for Vine Linux
  95. * Thu Aug 18 2011 Jan Safranek <jsafrane@redhat.com> - 1.8.11-11
  96. - fixed delloem powermonitor on bigendian systems (#731718)
  97. - fixed memory leak in Serial-over-Lan module (#731977)
  98. * Wed Aug 10 2011 Jan Safranek <jsafrane@redhat.com> - 1.8.11-10
  99. - added -Y option for ipmitool to hide Kg key from cmdline (#698647)
  100. - added 'channel setkg' command to set Kg encryption key on remote machine
  101. (#726390)
  102. * Thu Aug 4 2011 Jan Safranek <jsafrane@redhat.com> - 1.8.11-10
  103. - updated 'delloem setled' command to indicate SES status and drive
  104. activities for a PCI-e SSD (#727314)
  105. * Mon Jul 25 2011 Jan Safranek <jsafrane@redhat.com> - 1.8.11-9
  106. - rebuilt for RHEL 6.2 Fastrack
  107. * Thu Jul 14 2011 Jan Safranek <jsafrane@redhat.com> - 1.8.11-8
  108. - fixed 'ipmi sol' sending wrong packets due to miscalculation of SOL
  109. payload size (#675975)
  110. * Mon Feb 7 2011 Jan Safranek <jsafrane@redhat.com> - 1.8.11-7
  111. - added 'delloem' command for Dell-specific IPMI extensions (#631649, #63793)
  112. * Wed Jun 2 2010 Jan Safranek <jsafrane@redhat.com> - 1.8.11-6
  113. - Changed ipmievd to use /var/run/ipmievd.pid file by default (#596809)
  114. * Wed Mar 3 2010 Jan Safranek <jsafrane@redhat.com> - 1.8.11-5
  115. - Fixed exit code of ipmievd initscript with wrong arguments (#562186)
  116. * Fri Dec 11 2009 Dennis Gregorovic <dgregor@redhat.com> - 1.8.11-4.1
  117. - Rebuilt for RHEL 6
  118. * Mon Nov 2 2009 Jan Safranek <jsafrane@redhat.com> 1.8.11-4
  119. - fix ipmievd initscript 'condrestart' action (#532188)
  120. * Fri Aug 21 2009 Tomas Mraz <tmraz@redhat.com> - 1.8.11-3
  121. - rebuilt with new openssl
  122. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.11-2
  123. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  124. * Thu Feb 26 2009 Jan Safranek <jsafrane@redhat.com> 1.8.11-1
  125. - updated to new version
  126. * Tue Feb 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.8.10-4
  127. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  128. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> 1.8.10-3
  129. - rebuild with new openssl
  130. * Tue Oct 14 2008 Jan Safranek <jsafrane@redhat.com> 1.8.10-2
  131. - fix issues found during package review:
  132. - clear Default-Start: line in the init script, the service should be
  133. disabled by default
  134. - added Obsoletes: OpenIPMI-tools
  135. - compile with --disable-dependency-tracking to speed things up
  136. - compile with --enable-file-security
  137. - compile with --disable-intf-free, don't depend on FreeIPMI libraries
  138. (FreeIPMI has its own ipmitool-like utility)
  139. * Mon Oct 13 2008 Jan Safranek <jsafrane@redhat.com> 1.8.10-1
  140. - package created, based on upstream .spec file