kdoc-vl.spec 4.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185
  1. %define DATE 20020415
  2. %define sourcedir stable/%{version}/distribution/tar/generic/source
  3. %define is_release 1
  4. %define beta %{nil}
  5. Version: 2.0a54
  6. %define rel 1%{?_dist_release}
  7. %if "%{beta}" != ""
  8. %define VER %{version}%{beta}
  9. %else
  10. %define VER %{version}
  11. %endif
  12. Name: kdoc
  13. Summary: KDOC -- C++ and IDL Source Documentation System
  14. %if %{is_release}
  15. Source: ftp://ftp.kde.org/pub/kde/%{sourcedir}/kdoc-%{VER}.tar.bz2
  16. %else
  17. Source: ftp://ftp.kde.org/pub/kde/%{sourcedir}/kdoc-%{DATE}.tar.bz2
  18. %endif
  19. Release: %{rel}
  20. Epoch: 1
  21. Group: Development/Tools
  22. License: GPL
  23. BuildRoot: %{_tmppath}/%{name}-%{version}-root
  24. BuildRequires: perl >= 5.6.1 autoconf automake15
  25. BuildRequires: qt-devel
  26. Requires: perl >= 5.6.1
  27. BuildArch: noarch
  28. %description
  29. Documentation tools for the K Desktop Environment.
  30. KDOC creates cross-referenced documentation for C++ and CORBA IDL libraries
  31. directly from the source. Documentation can be embedded in special doc
  32. comments in the source.
  33. %prep
  34. %if %{is_release}
  35. %setup -q -n %{name}-%{VER}
  36. %else
  37. %setup -q -n %{name}
  38. %endif
  39. # Workaround for legacy auto* tools
  40. [ -x /usr/bin/autoconf-2.5? ] && ln -s /usr/bin/autoconf-2.5? autoconf
  41. [ -x /usr/bin/autoheader-2.5? ] && ln -s /usr/bin/autoheader-2.5? autoheader
  42. [ -x /usr/bin/aclocal-1.5 ] && ln -s /usr/bin/aclocal-1.5 aclocal
  43. [ -x /usr/bin/automake-1.5 ] && ln -s /usr/bin/automake-1.5 automake
  44. export PATH=`pwd`:$PATH
  45. # End workaround
  46. make -f Makefile.cvs
  47. %build
  48. export KDEDIR=/usr
  49. . /etc/profile.d/qt.sh
  50. if [ -x /usr/bin/getconf ]; then
  51. CPUS=`getconf _NPROCESSORS_ONLN`
  52. fi
  53. if test "x$CPUS" = "x" -o "x$CPUS" = "x0"; then
  54. CPUS=1
  55. fi
  56. CXXFLAGS="$RPM_OPT_FLAGS -I%{_includedir}/kde" %configure
  57. make -j $CPUS CXXFLAGS="$RPM_OPT_FLAGS -DNO_DEBUG -DNDEBUG"
  58. %install
  59. rm -rf $RPM_BUILD_ROOT
  60. make DESTDIR="$RPM_BUILD_ROOT" install
  61. rm -rf docs
  62. cp -a $RPM_BUILD_ROOT/usr/share/doc/kdoc docs
  63. rm -rf $RPM_BUILD_ROOT%{_docdir}
  64. %clean
  65. rm -rf $RPM_BUILD_ROOT
  66. %files
  67. %defattr(-,root,root)
  68. %doc COPYING docs/*
  69. %{_bindir}/*
  70. %dir %{_datadir}/kdoc
  71. %{_datadir}/kdoc/*
  72. %{_mandir}/*/*
  73. %changelog
  74. * Sun May 10 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0a54-1
  75. - applied new versioning policy
  76. - added BuildRequires: qt-devel
  77. * Sun Oct 22 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.0a54-0vl2
  78. - changed Group to Development/Tools
  79. * Mon May 20 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.0a54-0vl1
  80. - Update to 2.0a54
  81. - Epoch: 1
  82. - change Summary and description
  83. * Sat Mar 16 2002 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.2-0vl1
  84. - Update to 2.2.2
  85. * Sun Oct 14 2001 AKIYAMA Kazuhito <akiyama@karen.servepics.com> 2.2.1-1vl1
  86. - Update to 2.2.1
  87. - Delete Epoch
  88. - Add BuildPrereq and Requires
  89. - Build for VineSeed
  90. * Mon Aug 6 2001 Bernhard Rosenkraenzer <bero@redhat.com> 2.2-1
  91. - 2.2 final
  92. * Wed Jun 27 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  93. - 2.2 beta 1
  94. * Wed Feb 21 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  95. - 2.1-respin
  96. * Tue Feb 20 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  97. - 2.1
  98. * Sun Feb 18 2001 Bernhard Rosenkraenzer <bero@redhat.com>
  99. - Update
  100. * Tue Nov 28 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  101. - 2.0.1
  102. * Wed Nov 1 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  103. - Update to current CVS, this should finally be able to generate the kdelibs
  104. docs
  105. * Fri Oct 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  106. - Update to KDE_2_0_BRANCH, now that the ".0 release" bugs are fixed.
  107. - Fix build on 6.x systems
  108. * Mon Oct 23 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  109. - 2.0 final
  110. * Wed Oct 4 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  111. - 2.0rc2
  112. - clean up spec file
  113. * Tue Jul 18 2000 Trond Eivind Glomsrxd <teg@redhat.com>
  114. - drop icon (glint is obsolete)
  115. - "License" replaces "Copyright"
  116. - use %%docdir
  117. - different releasenumber scheme, the old one can't be used
  118. for tools and makes fixing specfiles hard
  119. * Thu Jul 13 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  120. - SMPify
  121. - Don't hardcode QTDIR
  122. * Tue Jul 11 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  123. - new snapshot
  124. * Tue Jun 27 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  125. - Fix build if %%{_mandir} = /usr/man
  126. * Sun Jun 20 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  127. - new snapshot
  128. - FHSify
  129. * Mon Apr 3 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  130. - fix compatibility with perl 5.6.0
  131. * Sat Mar 18 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  132. - new snapshot
  133. - remove renaming to kdoc2 etc, move to /usr
  134. * Wed Mar 15 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  135. - New snapshot
  136. - Make gzipped man pages optional
  137. * Tue Feb 1 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  138. - handle compressed man pages
  139. - new snapshot
  140. * Wed Jan 12 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  141. - fix up the makekde2doc script (add missing semicolon)
  142. * Thu Jan 6 2000 Bernhard Rosenkraenzer <bero@redhat.com>
  143. - new snapshot
  144. - get ready for powertools 6.2
  145. - make it a noarch package; it's just perl scripts
  146. * Thu Dec 16 1999 Bernhard Rosenkraenzer <bero@redhat.de>
  147. - initial RPM