ldns-vl.spec 12 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270271272273274275276277278279280281282283284285286287288289290291292293294295296297298299300301302303304305306307308309310311312313314315316317318319320321322323324325326327328329330331332333334335336337338339340341342343344345346347348349350351352353354355356357358359360361362363364365366367368369370371372373374375376377378379380381382383384385386387388389390391392393394395396397398
  1. %{?!with_python3: %global with_python3 0}
  2. %{?!enable_gost: %global enable_gost 0}
  3. %{?!enable_dane: %global enable_dane 1}
  4. %if %{enable_gost}
  5. %define subdir_conf_opt --disable-rpath --disable-static
  6. %else
  7. %define subdir_conf_opt --disable-rpath --disable-static --disable-gost
  8. %endif
  9. Summary: Lowlevel DNS(SEC) library with API
  10. Summary(ja): 低レベルな DNS(SEC) ライブラリと API
  11. Name: ldns
  12. Version: 1.8.3
  13. Release: 1%{?_dist_release}
  14. Group: system
  15. Distribution: Vine Linux
  16. Vendor: Project Vine
  17. Packager: iwaim
  18. License: BSD
  19. URL: http://www.nlnetlabs.nl/%{name}/
  20. Source: https://www.nlnetlabs.nl/downloads/ldns/%{name}-%{version}.tar.gz
  21. BuildRequires: libtool, autoconf, automake, gcc-c++, doxygen,
  22. BuildRequires: perl, libpcap-devel
  23. %if %{enable_gost}
  24. BuildRequires: openssl-devel >= 1.0.0
  25. %else
  26. BuildRequires: openssl-devel
  27. %endif
  28. %if %{with_python3}
  29. BuildRequires: python3-rpm-macros
  30. BuildRequires: python3-devel, swig
  31. %endif
  32. Obsoletes: ldns-python < 1.7.1-2
  33. Requires: ca-certificates
  34. %description
  35. ldns is a library with the aim to simplify DNS programing in C. All
  36. lowlevel DNS/DNSSEC operations are supported. We also define a higher
  37. level API which allows a programmer to (for instance) create or sign
  38. packets.
  39. %package devel
  40. Summary: Development package that includes the ldns header files
  41. Group: programming
  42. Requires: %{name} = %{version}-%{release}
  43. %description devel
  44. The devel package contains the ldns library and the include files
  45. %if %{with_python3}
  46. %package -n python3-ldns
  47. Summary: Python3 extensions for ldns
  48. Group: programming
  49. Requires: %{name} = %{version}-%{release}
  50. %description -n python3-ldns
  51. Python3 extensions for ldns
  52. %endif
  53. %debug_package
  54. %prep
  55. %{?extra_version:%global pkgname %{name}-%{version}%{extra_version}}%{!?extra_version:%global pkgname %{name}-%{version}}
  56. %autosetup -cn %{pkgname} -N
  57. pushd %{pkgname}
  58. # fixup .pc file
  59. sed -i "s/@includedir@/@includedir@\/ldns/" packaging/libldns.pc.in
  60. autoreconf -ivf
  61. popd
  62. %build
  63. CFLAGS="%{optflags} -fPIC -fno-strict-aliasing"
  64. CXXFLAGS="%{optflags} -fPIC -fno-strict-aliasing"
  65. LDFLAGS="$RPM_LD_FLAGS -Wl,-z,now -pie"
  66. export CFLAGS CXXFLAGS LDFLAGS
  67. pushd %{pkgname}
  68. %configure --disable-rpath --disable-static \
  69. --enable-ecdsa \
  70. --enable-ed25519 --enable-ed448 \
  71. --with-ca-file=/etc/pki/tls/certs/ca-bundle.trust.crt \
  72. --with-ca-path=/etc/pki/tls/certs/ \
  73. --with-trust-anchor=%{_sharedstatedir}/unbound/root.key \
  74. --with-examples \
  75. --with-drill \
  76. %if !%{enable_gost}
  77. --disable-gost \
  78. %endif
  79. %if %{with_python3}
  80. --with-pyldns PYTHON=%{__python3}\
  81. %endif
  82. make %{?_smp_mflags}
  83. make %{?_smp_mflags} drill
  84. make %{?_smp_mflags} examples
  85. make %{?_smp_mflags} doc
  86. popd
  87. %install
  88. rm -rf %{buildroot}
  89. pushd %{pkgname}
  90. mkdir -p %{buildroot}%{_libdir}/pkgconfig
  91. make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install
  92. make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-drill
  93. make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-examples
  94. make DESTDIR=%{buildroot} INSTALL="%{__install} -p" install-doc
  95. %if %{with_python3}
  96. # remove execute perms from python files
  97. chmod a-x %{buildroot}%{python3_sitearch}/*py
  98. %endif
  99. # don't package building script in doc
  100. rm doc/doxyparse.pl
  101. #remove doc stubs
  102. rm -rf doc/.svn
  103. #remove double set of man pages
  104. rm -rf doc/man
  105. # remove .la files
  106. rm -rf %{buildroot}%{_libdir}/*.la %{buildroot}%{python3_sitearch}/*.la
  107. popd
  108. %clean
  109. rm -rf %{buildroot}
  110. %files
  111. %license %{pkgname}/LICENSE
  112. %doc %{pkgname}/README
  113. %{_libdir}/libldns*so.*
  114. %{_bindir}/drill
  115. %{_bindir}/ldnsd
  116. #%{_bindir}/ldns-*
  117. %{_bindir}/ldns-chaos
  118. %{_bindir}/ldns-compare-zones
  119. %{_bindir}/ldns-[d-z]*
  120. %{_mandir}/*/*
  121. %files devel
  122. %doc %{pkgname}/doc %{pkgname}/Changelog %{pkgname}/README
  123. %{_libdir}/libldns*so
  124. %{_bindir}/ldns-config
  125. %{_libdir}/pkgconfig/*.pc
  126. %dir %{_includedir}/ldns
  127. %{_includedir}/ldns/*.h
  128. %if %{with_python3}
  129. %files python3-ldns
  130. %defattr(-,root,root)
  131. %{python_sitearch}/*
  132. %endif
  133. %changelog
  134. * Tue Aug 16 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.3-1
  135. - new upstream release.
  136. * Fri Aug 12 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.2-1
  137. - new upstream release.
  138. * Fri Dec 03 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.1-1
  139. - new upstream release.
  140. * Fri Nov 26 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.8.0-1
  141. - new upstream release.
  142. - dropped Patch1.
  143. - dropped Patch2-4: fixed in upstream.
  144. * Sat Oct 16 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.1-2
  145. - rebuilt with openssl-3.0.0.
  146. - imported Patch1-4 from rawhide.
  147. - dropped ldconfig scriptlets.
  148. - dropped python support.
  149. * Sat Aug 24 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.1-1
  150. - updated to 1.7.1.
  151. * Sun Nov 04 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.7.0-2
  152. - rebuilt with openssl-1.1.1.
  153. * Mon Jan 30 2017 IWAI, Masaharu <iwaim.sub@gmail.com> 1.7.0-1
  154. - update to 1.7.0
  155. - add enable_dane option
  156. * Tue Mar 15 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.6.17-2
  157. - rebuilt with openssl-1.0.2g.
  158. * Mon Mar 9 2015 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.17-1
  159. - update to 1.6.17
  160. - drop 'fix compiler warnings and one uninitialized value' patch (Patch1000)
  161. - upstream merged
  162. * Tue Dec 31 2013 IWAI, Masaharu <iwaim.sub@gmail.com> 1.6.16-2
  163. - add 'fix compiler warnings and one uninitialized value' patch (Patch1000)
  164. - from Fedora ldns-1.6.16-6.fc20
  165. * Wed Dec 5 2012 IWAI, Masaharu <iwai@alib.jp> 1.6.16-1
  166. - new upstream release
  167. * Sun May 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 1.6.13-1
  168. - new upstream release
  169. - move python files to sitearch from sitelib
  170. * Wed Feb 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.6.10-2
  171. - rebuild with python-2.7.2
  172. * Sat Sep 3 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.10-1
  173. - new upstream release
  174. * Wed Mar 30 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.9-1
  175. - new upstream release
  176. * Wed Feb 23 2011 IWAI, Masaharu <iwai@alib.jp> 1.6.8-1
  177. - new upstream release
  178. * Sun Nov 14 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.7-1
  179. - new upstream release
  180. - add enable_gost flag: default disable
  181. - defined subdir_conf_opt rpm macro
  182. * Thu Sep 2 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.6-1
  183. - new upstream release
  184. * Fri Jul 23 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.5-1
  185. - new upstream release
  186. - drop unnecessary installfix patch (Patch1): upstream merged
  187. - drop unnecessary rpathfix patch (Patch2): upstream merged
  188. * Thu Jun 3 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-2vl6
  189. - rebuild with libpcap 1.1.1 on VineSeed
  190. * Wed May 5 2010 IWAI, Masaharu <iwai@alib.jp> 1.6.4-1
  191. - initial build for Vine Linux: based Fedora 1.6.4-2.fc13
  192. * Fri Jan 22 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-2
  193. - Fix missing _ldns.so causing ldns-python to not work
  194. - Patch for installing ldns-python files
  195. - Patch for rpath in ldns-python
  196. - Don't install .a file for ldns-python
  197. * Wed Jan 20 2010 Paul Wouters <paul@xelerance.com> - 1.6.4-1
  198. - Upgraded to 1.6.4.
  199. - Added ldns-python sub package
  200. * Fri Dec 04 2009 Paul Wouters <paul@xelerance.com> - 1.6.3-1
  201. - Upgraded to 1.6.3, which has minor bugfixes
  202. * Fri Nov 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.2-1
  203. - Upgraded to 1.6.2. This fixes various bugs.
  204. (upstream released mostly to default with sha2 for the imminent
  205. signed root, but we already enabled that in our builds)
  206. * Tue Aug 25 2009 Tomas Mraz <tmraz@redhat.com> - 1.6.1-3
  207. - rebuilt with new openssl
  208. * Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-2
  209. - Added openssl dependancy back in, since we get more functionality
  210. when using openssl. Especially in 'drill'.
  211. * Sun Aug 16 2009 Paul Wouters <paul@xelerance.com> - 1.6.1-1
  212. - Updated to 1.6.1
  213. * Fri Jul 24 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.6.0-5
  214. - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
  215. * Mon Jul 13 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-4
  216. - Fixed the ssl patch so it can now compile --without-ssl
  217. * Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-3
  218. - Added patch to compile with --without-ssl
  219. - Removed openssl dependancies
  220. - Recompiled with --without-ssl
  221. * Sat Jul 11 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-2
  222. - Updated to 1.6.0
  223. - (did not yet compile with --without-ssl due to compile failures)
  224. * Fri Jul 10 2009 Paul Wouters <paul@xelerance.com> - 1.6.0-1
  225. - Updated to 1.6.0
  226. - Compile without openssl
  227. * Thu Apr 16 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-4
  228. - Memory management bug when generating a sha256 key, see:
  229. https://bugzilla.redhat.com/show_bug.cgi?id=493953
  230. * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.5.1-2
  231. - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
  232. * Tue Feb 10 2009 Paul Wouters <paul@xelerance.com> - 1.5.1-1
  233. - Updated to new version, 1.5.0 had a bug preventing
  234. zone signing.
  235. * Mon Feb 9 2009 Paul Wouters <paul@xelerance.com> - 1.5.0-1
  236. - Updated to new version
  237. * Thu Feb 05 2009 Adam Tkac <atkac redhat com> - 1.4.0-3
  238. - fixed configure flags
  239. * Sat Jan 17 2009 Tomas Mraz <tmraz@redhat.com> - 1.4.0-2
  240. - rebuild with new openssl
  241. * Fri Nov 7 2008 Paul Wouters <paul@xelerance.com> - 1.4.0-1
  242. - Updated to 1.4.0
  243. * Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-3
  244. - enable SHA2 functionality
  245. * Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-2
  246. - re-tag (don't do builds while renaming local repo dirs)
  247. * Wed May 28 2008 Paul Wouters <paul@xelerance.com> - 1.3.0-1
  248. - Updated to latest release
  249. * Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.2.2-3
  250. - Autorebuild for GCC 4.3
  251. * Wed Dec 5 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-2
  252. - Rebuild for new libcrypto
  253. * Thu Nov 29 2007 Paul Wouters <paul@xelerance.com> - 1.2.2-1
  254. - Upgraded to 1.2.2. Removed no longer needed race workaround
  255. * Tue Nov 13 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-4
  256. - Try to fix racing ln -s statements in parallel builds
  257. * Fri Nov 9 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-3
  258. - Added patch for ldns-read-zone that does not put @. in RRDATA
  259. * Fri Oct 19 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-2
  260. - Use install -p to work around multilib conflicts for .h files
  261. * Wed Oct 10 2007 Paul Wouters <paul@xelerance.com> - 1.2.1-1
  262. - Updated to 1.2.1
  263. - Removed patches that got moved into upstream
  264. * Wed Aug 8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-11
  265. - Patch for ldns-key2ds to write to stdout
  266. - Again remove extra set of man pages from doc
  267. - own /usr/include/ldns (bug 233858)
  268. * Wed Aug 8 2007 Paul Wouters <paul@xelerance.com> 1.2.0-10
  269. - Added sha256 DS record patch to ldns-key2ds
  270. - Minor tweaks for proper doc/man page installation.
  271. - Workaround for parallel builds
  272. * Mon Aug 6 2007 Paul Wouters <paul@xelerance.com> 1.2.0-2
  273. - Own the /usr/include/ldns directory (bug #233858)
  274. - Removed obsoleted patch
  275. - Remove files form previous libtool run accidentally packages by upstream
  276. * Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-4
  277. - Commented out 1.1.0 make targets, put make 1.0.1 targets.
  278. * Mon Sep 11 2006 Paul Wouters <paul@xelerance.com> 1.0.1-3
  279. - Fixed changelog typo in date
  280. - Rebuild requested for PT_GNU_HASH support from gcc
  281. - Did not upgrade to 1.1.0 due to compile issues on x86_64
  282. * Fri Jan 6 2006 Paul Wouters <paul@xelerance.com> 1.0.1-1
  283. - Upgraded to 1.0.1. Removed temporary clean hack from spec file.
  284. * Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-8
  285. - Cannot use make clean because there are no Makefiles. Use hardcoded rm.
  286. * Sun Dec 18 2005 Paul Wouters <paul@xelerance.com> 1.0.0-7
  287. - Patched 'make clean' target to get rid of object files shipped with 1.0.0
  288. * Tue Dec 13 2005 Paul Wouters <paul@xelerance.com> 1.0.0-6
  289. - added a make clean for 2.3.3 since .o files were left behind upstream,
  290. causing failure on ppc platform
  291. * Sun Dec 11 2005 Tom "spot" Callaway <tcallawa@redhat.com> 1.0.0-5
  292. - minor cleanups
  293. * Wed Oct 5 2005 Paul Wouters <paul@xelerance.com> 0.70_1205
  294. - reworked for svn version
  295. * Sun Sep 25 2005 Paul Wouters <paul@xelerance.com> - 0.70
  296. - Initial version