libbluray-vl.spec 8.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215216217218219220221222223224225226227228229230231232233234235236237238239240241242243244245246247248249250251252253254255256257258259260261262263264265266267268269270
  1. %global snapshot 0
  2. %global tarball_date 20130427
  3. %global git_hash 2b002fe52e8c2506ed52bf56c8b517d350dbb281
  4. %global git_short %(echo '%{git_hash}' | cut -c -13)
  5. %global build_pdf_doc 0
  6. %if %{?_dist_release} >= "vl7"
  7. %define jvmver 1.7.0
  8. %else
  9. %define jvmver 1.6.0
  10. %endif
  11. Name: libbluray
  12. Version: 0.4.0
  13. %if %{snapshot}
  14. Release: 0.1.%{tarball_date}git%{git_short}%{?dist}
  15. %else
  16. Release: 1%{?_dist_release}
  17. %endif
  18. Summary: Library to access Blu-Ray disks for video playback
  19. Summary(ja): Blu-Ray ディスクにアクセスしてビデオ再生するためのライブラリ
  20. Group: System Environment/Libraries
  21. License: LGPLv2+
  22. URL: http://www.videolan.org/developers/libbluray.html
  23. %if %{snapshot}
  24. # Use the commands below to generate a tarball.
  25. # git clone git://git.videolan.org/libbluray.git
  26. # cd libbluray
  27. # git archive --format=tar %{git_hash} --prefix=libbluray/ | bzip2 > ../libbluray-$( date +%Y%m%d )git%{git_short}.tar.bz2
  28. Source0: %{name}-%{tarball_date}git%{git_short}.tar.bz2
  29. %else
  30. Source0: ftp://ftp.videolan.org/pub/videolan/%{name}/%{version}/%{name}-%{version}.tar.bz2
  31. %endif
  32. Patch0: libbluray-0.2.2-no_doxygen_timestamp.patch
  33. BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
  34. %if %{snapshot}
  35. BuildRequires: autoconf
  36. BuildRequires: automake
  37. BuildRequires: libtool
  38. %endif
  39. %ifnarch ppc ppc64
  40. BuildRequires: java-devel >= 1.6.0
  41. BuildRequires: jpackage-utils
  42. BuildRequires: ant
  43. %endif
  44. BuildRequires: libxml2-devel
  45. BuildRequires: doxygen
  46. BuildRequires: texlive
  47. BuildRequires: graphviz
  48. BuildRequires: freetype2-devel
  49. %description
  50. This package is aiming to provide a full portable free open source bluray
  51. library, which can be plugged into popular media players to allow full bluray
  52. navigation and playback on Linux. It will eventually be compatible with all
  53. current titles, and will be easily portable and embeddable in standard players
  54. such as mplayer and vlc.
  55. %description -l ja
  56. このパッケージは完全にポータブルでオープンソースな bluray ライブラリの提供を
  57. 目指しており、Linux 上でポピュラーなメディアプレーヤーに組み込んで bluray の
  58. ナビゲーションや再生を可能にするものです。現在入手可能な全タイトルとの互換性
  59. を目指し、移植性を高め、mplayer や vlc といった標準プレーヤーに組み込み可能に
  60. なるようにする予定です。
  61. %ifnarch ppc ppc64
  62. %package java
  63. Summary: BDJ support for %{name}
  64. Summary(ja): %{name} 用 BDJ サポート
  65. Group: Development/Libraries
  66. Requires: %{name}%{?_isa} = %{version}-%{release}
  67. Requires: java >= 1.6.0
  68. Requires: jpackage-utils
  69. %description java
  70. The %{name}-java package contains the jar file needed to add BDJ support to
  71. %{name}.
  72. %description java -l ja
  73. %{name}-java パッケージには、%{name} に BDJ サポートを追加する jar ファイルが
  74. 収録されています。
  75. %endif
  76. %package devel
  77. Summary: Development files for %{name}
  78. Summary(ja): %{name} 用開発ファイル
  79. Group: Development/Libraries
  80. Requires: %{name}%{?_isa} = %{version}-%{release}
  81. %description devel
  82. The %{name}-devel package contains libraries and header files for
  83. developing applications that use %{name}.
  84. %description devel -l ja
  85. %{name}-devel パッケージには、%{name} を使うアプリケーションの開発に
  86. 必要なライブラリとヘッダーファイルが収録されています。
  87. %prep
  88. %if %{snapshot}
  89. %setup -q -n %{name}
  90. %else
  91. %setup -q
  92. %endif
  93. %patch0 -p1 -b .no_timestamp
  94. %build
  95. %if %{snapshot}
  96. autoreconf -vif
  97. %endif
  98. export JDK_HOME="%{_jvmdir}/java-%{jvmver}"
  99. %configure --disable-static \
  100. %if %{build_pdf_doc}
  101. --enable-doxygen-pdf \
  102. %else
  103. --disable-doxygen-pdf \
  104. %endif
  105. --disable-doxygen-ps \
  106. --enable-doxygen-html \
  107. --enable-examples \
  108. %ifnarch ppc ppc64
  109. --enable-bdjava
  110. %endif
  111. # Fix rpath issue
  112. sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
  113. sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
  114. make %{?_smp_mflags}
  115. make doxygen-doc
  116. # Remove uneeded script
  117. rm -f doc/doxygen/html/installdox
  118. %install
  119. rm -rf %{buildroot}
  120. make install DESTDIR=%{buildroot}
  121. find %{buildroot} -name '*.la' -exec rm -f {} ';'
  122. # Install test utilities
  123. for i in clpi_dump index_dump mobj_dump mpls_dump sound_dump;
  124. do install -Dp -m 0755 src/examples/$i %{buildroot}%{_bindir}/$i; done;
  125. for i in bd_info bdsplice hdmv_test libbluray_test list_titles;
  126. do install -Dp -m 0755 src/examples/.libs/$i %{buildroot}%{_bindir}/$i; done;
  127. %ifnarch ppc ppc64
  128. install -Dp -m755 src/examples/.libs/bdj_test %{buildroot}%{_bindir}/bdj_test;
  129. %endif
  130. %clean
  131. rm -rf %{buildroot}
  132. %post -p /sbin/ldconfig
  133. %postun -p /sbin/ldconfig
  134. %files
  135. %defattr(-,root,root,-)
  136. %doc COPYING player_wrappers README.txt
  137. %{_libdir}/*.so.*
  138. %{_bindir}/*
  139. %ifnarch ppc ppc64
  140. %files java
  141. %defattr(-,root,root,-)
  142. %{_libdir}/libbluray/libbluray.jar
  143. %endif
  144. %files devel
  145. %defattr(-,root,root,-)
  146. %doc doc/doxygen/html
  147. %if %{build_pdf_doc}
  148. %doc doc/doxygen/libbluray.pdf
  149. %endif
  150. %{_includedir}/*
  151. %{_libdir}/*.so
  152. %{_libdir}/pkgconfig/libbluray.pc
  153. %changelog
  154. * Thu Oct 24 2013 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 0.4.0-1
  155. - initial build for Vine Linux
  156. * Fri Sep 20 2013 Xavier Bachelot <xavier@bachelot.org> 0.4.0-1
  157. - Update to 0.4.0.
  158. - Fix rpath issues with some test utilities.
  159. * Sat Aug 03 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-3
  160. - Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
  161. * Thu Feb 14 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.3-2
  162. - Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
  163. * Tue Aug 21 2012 Xavier Bachelot <xavier@bachelot.org> 0.2.3-1
  164. - Update to 0.2.3.
  165. * Thu Jul 19 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.2-3
  166. - Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
  167. * Tue Jun 12 2012 Xavier Bachelot <xavier@bachelot.org> 0.2.2-3
  168. - Don't build pdf doc, it breaks multilib (see RHBZ#835952).
  169. * Tue Jun 12 2012 Xavier Bachelot <xavier@bachelot.org> 0.2.2-2
  170. - Fix multilib conflict in doxygen docs (RHBZ#831401).
  171. * Tue Mar 20 2012 Xavier Bachelot <xavier@bachelot.org> 0.2.2-1
  172. - Update to 0.2.2.
  173. * Tue Mar 20 2012 Karsten Hopp <karsten@redhat.com> 0.2.1-4
  174. - ppc(64) has no java-1.7.0-open yet, disable java subpackage on both PPC archs
  175. * Thu Mar 15 2012 Rex Dieter <rdieter@fedoraproject.org> 0.2.1-3
  176. - make build non-fatal when using doxygen-1.8 (doesn't produce installdox anymore)
  177. * Wed Feb 01 2012 Xavier Bachelot <xavier@bachelot.org> 0.2.1-2
  178. - Rebuild for openjdk 7.
  179. * Fri Jan 13 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.1-1
  180. - Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
  181. * Thu Dec 01 2011 Xavier Bachelot <xavier@bachelot.org> 0.2.1-1
  182. - First upstream official release.
  183. - Fix BD-J build (missing files in upstream tarball).
  184. - Have subpackages require an arch-specific base package.
  185. * Sun Oct 23 2011 Xavier Bachelot <xavier@bachelot.org> 0.2-0.7.20111023gite037110f11e70
  186. - Update to latest snapshot.
  187. * Sat Jul 16 2011 Xavier Bachelot <xavier@bachelot.org> 0.2-0.6.20110710git51d7d60a96d06
  188. - Don't build java subpackage on ppc64, no java-1.6.0-devel package.
  189. * Sun Jul 10 2011 Xavier Bachelot <xavier@bachelot.org> 0.2-0.5.20110710git51d7d60a96d06
  190. - Update to latest snapshot.
  191. * Sat May 14 2011 Xavier Bachelot <xavier@bachelot.org> 0.2-0.4.20110514git46ee2766038e9
  192. - Update to latest snapshot.
  193. - Drop -static subpackage.
  194. * Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-0.3.20110126gitbbf11e43bd82e
  195. - Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
  196. * Wed Jan 26 2011 Xavier Bachelot <xavier@bachelot.org> 0.2-0.2.20110126gitbbf11e43bd82e
  197. - Update to latest snapshot.
  198. - Split the BDJ support to a -java subpackage.
  199. * Fri Jan 07 2011 Xavier Bachelot <xavier@bachelot.org> 0.2-0.1.20110107git0e5902ff9a6f1
  200. - Update to latest snapshot.
  201. - Add BR: libxml2-devel for metadata parser.
  202. - Add BR: graphviz for doc generation.
  203. * Thu Oct 28 2010 Xavier Bachelot <xavier@bachelot.org> 0.1-0.3.20101028gitc32862b77dea4
  204. - Update to latest snapshot.
  205. - Install BDJ jar.
  206. * Thu Oct 21 2010 Xavier Bachelot <xavier@bachelot.org> 0.1-0.2.20101021git144a204c02687
  207. - Fix release tag.
  208. - Update to latest snapshot.
  209. * Thu Aug 19 2010 Xavier Bachelot <xavier@bachelot.org> 0.1-0.1.20100819
  210. - Initial Fedora release.