mariadb-connector-odbc-vl.spec 7.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186187188189190191192193194195196197198199200201202203204205206207208209210211212213214215
  1. # For deep debugging we need to build binaries with extra debug info
  2. %bcond_with debug
  3. # Disable CMake in-source builds
  4. # This is a fix for the https://fedoraproject.org/wiki/Changes/CMake_to_do_out-of-source_builds
  5. # So the beaviour will be the same also in F31 nad F32
  6. %undefine __cmake_in_source_build
  7. Name: mariadb-connector-odbc
  8. Version: 3.1.15
  9. Release: 1%{?with_debug:.debug}%{?_dist_release}
  10. Summary: The MariaDB Native Client library (ODBC driver)
  11. Group: system
  12. Vendor: Project Vine
  13. Distribution: Vine Linux
  14. License: LGPLv2+
  15. # Online documentation can be found at: https://mariadb.com/kb/en/library/mariadb-connector-odbc/
  16. URL: https://mariadb.org/en/
  17. Source: https://archive.mariadb.org/connector-odbc-%{version}/%{name}-%{version}-src.tar.gz
  18. Patch1: libraries_include_path.patch
  19. BuildRequires: cmake unixODBC-devel gcc-c++
  20. BuildRequires: libmariadb-devel >= 3.0.6
  21. Obsoletes: mysql-connector-odbc < 8.0.0
  22. Provides: mysql-connector-odbc = 8.0.0
  23. %description
  24. MariaDB Connector/ODBC is a standardized, LGPL licensed database driver using
  25. the industry standard Open Database Connectivity (ODBC) API. It supports ODBC
  26. Standard 3.5, can be used as a drop-in replacement for MySQL Connector/ODBC,
  27. and it supports both Unicode and ANSI modes.
  28. %debug_package
  29. %prep
  30. %setup -q -n %{name}-%{version}-src
  31. %patch1 -p1
  32. %build
  33. %cmake . \
  34. -DCMAKE_BUILD_TYPE="%{?with_debug:Debug}%{!?with_debug:RelWithDebInfo}" \
  35. -DMARIADB_LINK_DYNAMIC="%{_libdir}/libmariadb.so" \
  36. \
  37. -DINSTALL_LAYOUT=RPM \
  38. -DINSTALL_LIBDIR="%{_lib}" \
  39. -DINSTALL_LIB_SUFFIX="%{_lib}" \
  40. -DINSTALL_DOCDIR="%{_defaultdocdir}/%{name}" \
  41. -DINSTALL_LICENSEDIR="%{_defaultlicensedir}/%{name}"
  42. # Override all optimization flags when making a debug build
  43. %if %{with debug}
  44. CFLAGS="$CFLAGS -O0 -g"; export CFLAGS
  45. CXXFLAGS="$CXXFLAGS -O0 -g"; export CXXFLAGS
  46. FFLAGS="$FFLAGS -O0 -g"; export FFLAGS
  47. FCFLAGS="$FCFLAGS -O0 -g"; export FCFLAGS
  48. %endif
  49. #cmake -B %_vpath_builddir -LAH
  50. %cmake_build
  51. %install
  52. %cmake_install
  53. rm -rf %{buildroot}%{_defaultdocdir}/%{name}
  54. rm -rf %{buildroot}%{_defaultlicensedir}/%{name}
  55. %files
  56. %license COPYING
  57. %doc README
  58. # This is unixODBC plugin. It resides directly in %%{_libdir} to be consistent with the rest of unixODBC plugins. Since it is plugin, it doesn´t need to be versioned.
  59. %{_libdir}/libmaodbc.so
  60. # Pkgconfig
  61. %{_libdir}/pkgconfig/libmaodbc.pc
  62. %changelog
  63. * Fri Oct 14 2022 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.15-1
  64. - new upstream release.
  65. * Sat Mar 13 2021 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 3.1.11-3
  66. - initial build for Vine Linux.
  67. * Tue Jan 26 2021 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.11-2
  68. - Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
  69. * Mon Dec 14 2020 Lukas Javorsky <ljavorsk@redhat.com> - 3.1.11-1
  70. - Rebase to 3.1.11
  71. - Add updates for paths in libraries_include_path.patch
  72. * Thu Aug 06 2020 Michal Schorm <mschorm@redhat.com> - 3.1.9-4
  73. - Force the CMake change regarding the in-source builds also to F31 and F32
  74. - %%cmake macro covers the %%{set_build_flags}, so they are not needed
  75. That also means, the debug build changes to the build flags must be done AFTER the
  76. %%cmake macro was used.
  77. - %%cmake macro also covers several other options which redudndant specification I removed in this commit
  78. - Default to %%cmake commands instead of %%make commands
  79. * Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.9-3
  80. - Second attempt - Rebuilt for
  81. https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
  82. * Tue Jul 28 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.9-2
  83. - Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
  84. * Thu Jul 02 2020 Lukas Javorsky <ljavorsk@redhat.com> - 3.1.9-1
  85. - Rebase to 3.1.9
  86. - Add patch add_docs_license_dir_option
  87. * Thu Apr 09 2020 Michal Schorm <mschorm@redhat.com> - 3.1.7-1
  88. - Rebase to 3.1.7
  89. * Wed Jan 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.6-2
  90. - Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
  91. * Thu Jan 23 2020 Lukas Javorsky <ljavorsk@redhat.com> - 3.1.6-1
  92. - Rebase to 3.1.6
  93. * Fri Nov 15 2019 Lukas Javorsky <ljavorsk@redhat.com> - 3.1.5-1
  94. - Rebase to 3.1.5
  95. * Tue Nov 12 2019 Michal Schorm <mschorm@redhat.com> - 3.1.4-2
  96. - Rebuild on top of new mariadb-connector-c
  97. * Mon Nov 04 2019 Michal Schorm <mschorm@redhat.com> - 3.1.4-1
  98. - Rebase to 3.1.4
  99. * Mon Aug 19 2019 Michal Schorm <mschorm@redhat.com> - 3.1.3-1
  100. - Rebase to 3.1.3
  101. * Wed Jul 31 2019 Michal Schorm <mschorm@redhat.com> - 3.1.2-1
  102. - Rebase to 3.1.2
  103. - Patch2 upstreamed
  104. * Thu Jul 25 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.1.1-5
  105. - Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
  106. * Fri Jul 19 2019 Michal Schorm <mschorm@redhat.com> - 3.1.1-4
  107. - Use macro for setting the compiler flags
  108. * Wed Jun 05 2019 Michal Schorm <mschorm@redhat.com> - 3.1.1-3
  109. - Added debug build switch
  110. - Added patch2: configurable doc and license dirs paths
  111. * Wed Jun 05 2019 Michal Schorm <mschorm@redhat.com> - 3.1.1-2
  112. - Patch solution found
  113. * Tue Jun 04 2019 Michal Schorm <mschorm@redhat.com> - 3.1.1-1
  114. - Rebase to 3.1.1
  115. * Tue Jun 04 2019 Michal Schorm <mschorm@redhat.com> - 3.0.9-1
  116. - Rebase to 3.0.9
  117. * Fri Feb 01 2019 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.8-3
  118. - Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
  119. * Wed Jan 23 2019 Björn Esser <besser82@fedoraproject.org> - 3.0.8-2
  120. - Append curdir to CMake invokation. (#1668512)
  121. * Sun Jan 06 2019 Michal Schorm <mschorm@redhat.com> - 3.0.8-1
  122. - Rebase to 3.0.8
  123. * Tue Nov 20 2018 Michal Schorm <mschorm@redhat.com> - 3.0.7-1
  124. - Rebase to 3.0.7
  125. * Fri Aug 03 2018 Michal Schorm <mschorm@redhat.com> - 3.0.6-1
  126. - Rebase to 3.0.6
  127. - Raise the minimal version of the connector-c required, because of a fixed bug
  128. which affected connector-odbc builds
  129. * Fri Jul 13 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.3-2
  130. - Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
  131. * Sat Feb 10 2018 Michal Schorm <mschorm@redhat.com> - 3.0.3-1
  132. - Rebase to 3.0.3 version
  133. - Use more macros
  134. * Thu Feb 08 2018 Fedora Release Engineering <releng@fedoraproject.org> - 3.0.2-2
  135. - Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
  136. * Tue Jan 30 2018 Michal Schorm <mschorm@redhat.com> - 3.0.2-1
  137. - Rebase to 3.0.2 version
  138. - Update ldconfig scriptlets
  139. - Remove Group tag
  140. * Thu Sep 07 2017 Augusto Caringi <acaringi@fedoraproject.org> - 3.0.1-2
  141. - Update to top of 3.0 branch from GitHub 860e7f8b754f (version supporting dynamic linking)
  142. - Source tarball composed from upstream GitHub, because the latest version solves the issues
  143. with dynamic linking.
  144. * Mon Sep 04 2017 Augusto Caringi <acaringi@fedoraproject.org> - 3.0.1-1
  145. - Update to version 3.0.1
  146. * Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.14-3
  147. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
  148. * Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.14-2
  149. - Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
  150. * Tue May 16 2017 Michal Schorm <mschorm@redhat.com> - 2.0.14-1
  151. - Update to version 2.0.14 and check, if blockers still apply. They do.
  152. - Upstream issue created
  153. * Fri Feb 10 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.0.12-2
  154. - Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
  155. * Wed Oct 19 2016 Michal Schorm <mschorm@redhat.com> - 2.0.12-1
  156. - Initial version for 2.0.12